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Document Conventions
In addition to the use of italics for names of documents, the font conventions that are used in
this document are summarized in the table below.

Links to other locations in the current document or to other PDF documents are colored like
this: Document Conventions.

In descriptions of command syntax, the following UNIX conventions are used: braces { }

enclose a choice of required items, square brackets [ ] enclose optional items, and the bar
symbol | separates items in a list from which one item must be chosen. Lines of command
syntax that wrap should be interpreted as a single command.

File name, path, and environment variable syntax is generally given with the UNIX conven-
tions. To obtain the Windows conventions, replace the forward slash / with the backslash \ in
path or directory names, and replace the $ at the beginning of an environment variable with a %
at each end. For example, $SCHRODINGER/maestro becomes %SCHRODINGER%\maestro.

Keyboard references are given in the Windows convention by default, with Mac equivalents in
parentheses, for example CTRL+H (H). Where Mac equivalents are not given, COMMAND
should be read in place of CTRL. The convention CTRL-H is not used. 

In this document, to type text means to type the required text in the specified location, and to
enter text means to type the required text, then press the ENTER key.

References to literature sources are given in square brackets, like this: [10]. 

Font Example Use

Sans serif Project Table Names of GUI features, such as panels, menus, 
menu items, buttons, and labels

Monospace $SCHRODINGER/maestro File names, directory names, commands, envi-
ronment variables, command input and output

Italic filename Text that the user must replace with a value

Sans serif 
uppercase

CTRL+H Keyboard keys
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Maestro User Manual
Chapter 1
Chapter 1: Maestro Overview
Maestro is the graphical user interface (GUI) for nearly all of Schrödinger’s computational
programs: BioLuminate, CombiGlide, ConfGen, Core Hopping, Desmond, Epik, Field-based
QSAR, Glide, Impact, Jaguar, Liaison, LigPrep, MacroModel, MCPRO+, Phase, Prime,
PrimeX, QikProp, QSite, SiteMap, Strike, and WaterMap. It contains tools for building,
displaying, and manipulating chemical structures; for organizing, loading and storing these
structures and associated data; and for setting up, submitting, monitoring, and visualizing the
results of calculations on these structures. Maestro’s Job Control facility manages jobs
submitted from Maestro and from the command line to both local and remote hosts. Maestro
can be run locally and submit jobs to any host that you have access to. 

The Maestro interface uses the OpenGL graphics tools, and can take advantage of hardware
graphics capabilities, including stereo viewing capabilities. Maestro runs on Linux, Mac and
Windows platforms. For information on Maestro requirements, software and hardware, see
Chapter 2 of the Installation Guide. For information on configuring stereo viewing, see
Section 4.7 on page 74.

This manual contains an introduction to the Maestro graphical user interface (GUI) and a
description of how to use Maestro’s settings, panels, and features to build, import, and manipu-
late molecular structures. No prior knowledge of Maestro is assumed. If you cannot find the
information you are looking for in this document, see the Maestro online help. For help with
preparing and starting computations, see the user manual for the related product. For help with
Job Control, see the Job Control Guide.

This chapter provides an overview of Maestro—the general interface design, Maestro projects,
Maestro workflow, and running jobs from Maestro.

1.1 General Interface Design

The Maestro interface is built on the Qt toolkit, and inherits many standard features from Qt.
The design follows most common interface conventions, but it has some characteristics that are
unique. The general operation of the Maestro interface is described in this section. Specific
features are described in the relevant sections or chapters. 
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1.1.1 Maestro Windows

Maestro is based on a main window, from which you can open a range of secondary windows
for the performance of various tasks. The main window is described in detail in Chapter 2.

Most of the windows that are opened from Maestro are amodal, and are called panels. More
than one panel can be open at any given time, and a panel need not be closed for an action to be
carried out. Some of the panels are docked by default into the main window. You can undock
them and place them wherever you want, and you can redock them, using the docking button.

If you do not want the panels to be docked, deselect Allow docking of panels under General →
Panels in the Preferences panel (see Section 14.1.6 on page 339). Panels can be closed with
CTRL+W or the close button on the title bar.

Maestro also has dialog boxes, most of which are modal: you must click OK to carry out the
action and you cannot open any of the panels while the dialog box is open. There are also some
dialog boxes that allow you to carry out limited operations in the Workspace or in a panel. 

1.1.2 Mouse Functions

Maestro supports common mouse functions: 

• The left button (button 1) is used for selecting: choosing menu items, clicking buttons and
selecting objects. This button is also used for resizing and moving panels. In the descrip-
tion of mouse actions, “click” always means left-click. 

• The right button (button 3) is used for opening a shortcut (context-sensitive) menu, where
these menus are available. 

• Shift-click is used to select a contiguous range of items in a list, and control-click is used
to select and deselect a single item in a list without affecting the selection of other items. 

• Dragging operations are supported. For instance, in the Workspace, dragging selects mul-
tiple objects. In the Project Table, dragging selected entries allows you to reposition the
entries; dragging a column heading moves the column; dragging on the boundary of a
row or column resizes the row or column.

• The scroll wheel is supported for scrolling vertically in tables, lists, and text areas. In
lists, scrolling is equivalent to using the UP ARROW and DOWN ARROW keys. In tables,
the table scrolls one line at a time, or, with the SHIFT key, one page at a time.

There are also specialized mouse functions in the Workspace, which are described in
Section 2.8 on page 31.
Schrödinger Software Release 2015-2 



Chapter 1: Maestro Overview
If the handedness on your mouse is set to “left”, the mouse functions are the opposite of those
described: the right button is used for picking, and the left button is used for shortcut menus. 

Maestro is designed for the use of a three-button mouse, but provides settings for a two-button
mouse and a trackpad, which are automatically detected and applied. 

You can customize the mouse button actions in the Customize Mouse Actions panel—see
Section 13.3 on page 321 for details.

1.1.3 Keyboard Shortcuts and Shortcut Menus

Maestro supports keyboard shortcuts in some of its panels, including the main window. These
shortcuts are documented with the relevant panel. The shortcut keys do not work if you have
NUM LOCK, CAPS LOCK, or SCROLL LOCK enabled.

The PAGE UP, PAGE DOWN, HOME, and END keys are supported in tables. 

The F1 key opens the help topic for the panel, and is equivalent to clicking the Help button.

Panels that are not docked into the Workspace can be closed with CTRL+W.

Maestro supports the use of shortcut menus, which are opened by right-clicking. A standard set
of menu items, along with the corresponding keyboard shortcuts, is available in any text input
area: Undo (CTRL+Z, Z), Redo (CTRL+SHIFT+Z, Z), Cut (CTRL+X, X), Copy
(CTRL+C, C), Paste (CTRL+V, V), Delete, and Select All (CTRL+A, A). 

1.1.4 File and Directory Selection

The Maestro dialog box that is used for selecting a file, a project, or a directory is a fairly stan-
dard file selector, but also has some custom features, some of which depend on the particular
task to be performed with the file. File selectors contain the following features:

• Path option menu—This option menu lists all the parents in the current path, as well as
recent locations (the path history). You can use this option menu to select the directory
whose contents are displayed in the area below. The latest directory choice is displayed as
the selected item in this menu.

• Navigation buttons—These buttons allow you to navigate through the history of the
directory choices made, navigate up to the parent directory, or create a new subdirectory
(folder) in the current directory.

• View buttons—These buttons allow you to switch between a list view and a view that
provides details on the files and directories listed. 
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• Standard directories—This area contains labeled icons for the standard locations for a
file. When you select one of these items, the path option menu is updated and the list of
files and folders is updated. 

• List of current directory contents—This area lists the files and directories (folders) in the
current choice of directory. To select multiple items, use shift-click and control-click. To
scroll to files or folders that begin with a particular character, press the key for that char-
acter. The first file or folder beginning with that character is selected (and anything else is
deselected). To sort the files, click in the heading of the column you want to sort by.

• File name text box—Displays the name of the file or files. Multiple items are listed in
quotes, separated by a space. You can type the file names in to this text box, with either an
absolute or a relative path, and press ENTER to perform the action. You can also type in a
path and press ENTER to change directories. 

This text box supports inline completion, and by default contains the last item selected.
To replace the text that is already there, simply type over it. When what you type does not
match anything in the current directory, the completion text disappears.

• Files of type option menu—Lists the valid file names with their extensions. Choosing an
item on this option menu limits the display of the directory contents to files of the speci-
fied type. 

Set the path to your home directory. This is $HOME on Linux (usually /home/username) 
and Mac (/Users/username), and %HOME% on Windows (usually the same as 
%USERPROFILE%).

Set the path to the a custom directory, which is created if it does not exist. See 
Section 14.1.2 on page 336 for information on customizing this location. The default is 
the Maestro startup directory.

Set the path to the Maestro current working directory. This is the startup directory unless 
you have set a preference for another directory, or changed the current working direc-
tory.

Windows only:

Set the path to My Computer.

Set the path to My Documents.

Set the path to the Desktop.

Set the path to My Network Places.
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If you choose Custom File Filter, a dialog box opens in which you can specify a filter for
the files that are displayed. The filter supports the common filename metacharacters and
expressions:

*  Match any string of zero or more characters

?  Match any single character

[chars]  Match any one of the enclosed characters

{string1,string2,...}  Match one of the enclosed strings in the comma-separated list

• Action buttons—Along with the standard Cancel and Help buttons, there is an action but-
ton for the action to be performed on the file. The most common action buttons are Save

and Open.

Directory selectors are similar, except that the File name text box is now a Directory text box,
and the Files of type option menu choice is Directories, and cannot be changed. 

Project selectors are the same as file selectors, with the Files of type option menu choice set to
select Maestro projects.

When you first open a dialog box to choose a file, project, or directory, the current working
directory is the directory (folder) whose contents are displayed. If you navigate to some other
location in the dialog box, the dialog box remembers this location and uses it the next time it is
opened in the current Maestro session. It is not subsequently affected by changes in the current
working directory.

1.2 Maestro Workflow 

The main Maestro workflow involves performing actions on the displayed structures, to
change the appearance of the structures or to change the content of the structures. In many
cases, you will want to change only a part of the structure, which involves selecting the atoms
that you want to change. (The workflow for a product, which is supported by Maestro panels,
involves setting up and running jobs.)

Maestro has two ways of performing an action on a structure or a part of a structure: 

• Choose an action first and then select the atoms to apply the action to.

Actions are usually chosen either from a toolbar button menu or by opening a panel and
selecting options. 
Maestro 10.2 User Manual 5



Chapter 1: Maestro Overview

6

• Select atoms first and then choose an action to perform on them. 

Actions can be performed by opening a panel, selecting options and clicking the Selec-
tion button, or by choosing an item from the selection shortcut menu. See Section 2.7 on
page 26 for more details on this shortcut menu. 

Maestro’s atom selection tools provide you with a range of options for selecting single atoms,
entire structural units, or complex combinations of atom sets. These tools are described in
detail in Chapter 6. 

1.3 Maestro Projects

When you use Maestro, you are always working in a project. A project is a collection of chem-
ical structures and their associated data. The structures and data are organized into entries,
each of which can consist of multiple molecules and their properties. The project is represented
in the Project Table, which displays an ordered list of entries and associated data. 

You can open the Project Table panel by choosing Project → Show Table, pressing CTRL+T, or
by clicking the Table button on the Project toolbar.

Figure 1.1. The Project Table panel.

If you do not specify a project when you start Maestro, Maestro creates a scratch project. You
can work in a scratch project, but you must save it in order to use it in future sessions. Scratch
projects are stored in a temporary location—see Section 14.1.2 on page 336 for more informa-
tion on this location.
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Entries are represented by rows in the Project Table. Each row contains the row number; the
entry’s Workspace inclusion state (the In column); the title; a set of buttons (in the Title
column) to open panels if there is auxiliary data associated with the entry such as surfaces,
trajectories, vibrations, hypotheses; the entry ID, and any properties associated with the entry. 

You control which entries are displayed in the Workspace from the Project Table. You can use
entries as input for most of the computational programs. You can select entries as input for the
ePlayer, which displays the selected structures in sequence. You can duplicate, combine,
rename, split, and sort entries; create properties for entries, import structures as entries, and
export entries in various formats. Although the Project Table does not have spreadsheet capa-
bilities, you can export properties to and import properties from a spreadsheet. 

When you draw molecules in the Workspace, they constitute a scratch entry until you choose
to save the structures as project entries. The scratch entry is not saved with the project unless
you explicitly add it to the project. However, you can use a scratch entry as input for some jobs,
and the results can be incorporated.

For products that have wizard-based interfaces (CombiGlide, Phase, and Prime), data is stored
inside the project, grouped as entities called “runs”. Output from each step is incorporated into
the next step and stored in the project, but not via the Project Table. The data in the runs can
include structural data, but do not make use of the Project Table directly. Instead, structures can
be copied to and from the Project Table at various points in the run. 

More information on projects is given in Chapter 9.

1.4 Access to Applications

Maestro provides panels for preparing and running jobs for most of Schrödinger’s applications.
Access to these applications are presented on the menu bar as two alternative menus, and also
in a panel that provides extra features for finding and selecting applications. The menus are:

• Tasks menu—This menu lists the main tasks that can be performed by Schrödinger appli-
cations. If you know what kind of task you want to perform, you can use this menu. It is
displayed by default on the menu bar in the main window. If the Applications menu is dis-
played, choose Task View from this menu to display the Tasks menu.

• Applications menu—This menu lists the available applications (products). If you are
familiar with the products, you can use this menu to find the panel you want to use. To
display this menu, choose Application View from the Tasks menu. 

Both of these menus are also displayed in tree form with search capabilities, in the Task Tree

and Application Tree panels. Like the menus, these panels are interchangeable and can be
switched from the panel itself. The Task Tree panel opens by default when Maestro is started,
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but you can open it by choosing Show Tree from either of the menus. A brief description of
how to use the panel is given in the lower section of the panel when it first opens. 

Figure 1.2. The Application Tree and Task Tree panels.

• To expand or collapse a submenu (node) in the tree, click on the + or – button. 

You can also expand and collapse the submenu by right-clicking on the name and choos-
ing Selected from the Expand or Collapse submenu, or expand a submenu and collapse
all others by choosing Expand → Only Selected. 

• To expand or collapse all submenus, right-click on any submenu and choose All from the
Expand or Collapse submenu, or click the Settings button and choose Expand All or Col-

lapse All.

• To display a description of a task or panel (leaf) in the lower section of the panel, click on
the task or panel.
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• To find a task or panel by searching the text of the menu, the name of the task or panel, or
its description, enter text in the search box at the top of the panel. Only the items that con-
tain matching text are shown in the tree. The tree is updated as you type. Click the clear
(X) button in the search box to clear the search text and redisplay the full tree.

• To open a panel, double click the task or panel name, or right-click on it and choose
Open. 

In addition to the Tasks and Applications menus, the panel shows the Tools menu and the
Scripts menu. This allows you to search more widely for the task that you are interested in.

Maestro has a large number of application panels. If your workflow only uses a few of them, or
only uses a few of them most of the time, you can designate “favorite” applications, and
display a tree that only contains the favorites. To mark an item as a favorite, right-click on it
and select Favorite. To show only the favorites in the tree, select Show Favorites Only on the
Settings button menu. The panel title is updated to reflect this choice. You can also restrict the
Tasks and Applications menus to only the designated favorites by selecting Show Favorites

Only on the menu. To show the full tree or menu, deselect this item.

The menus can also be customized—see Section 13.2 on page 318.

1.5 Running Jobs

When you have set the appropriate options in an applications panel, you use the Job toolbar to
start the job. This toolbar is described in all the application manuals. Briefly, you can click Run

to run a job with the current job settings, or click the Settings button to open the Job Settings
dialog box and set options for running the job. See Section 2.2 of the Job Control Guide for a
detailed description of the options in the Job Settings dialog box. When you have finished,
click Run to launch the job (and optionally open the Monitor panel), or click save to save the
settings for the next job. Note that most jobs that are run locally are automatically run at low
priority so that they do not significantly affect the performance of Maestro. Exceptions are
noted in this manual.

Maestro’s job launching and incorporation capabilities are designed to make it easy to manage
multiple structures and their passage though multiple computational programs, without having
to deal with the details of the file system. The running of jobs is handled by the Job Control
facility, which is described in detail in the Job Control Guide. 

Input files for the job are written to the launch directory, which is Maestro’s current working
directory. This directory can be changed by choosing Project → Change Directory and navi-
gating to the new directory in the Change Directory dialog box, or by entering the command cd
path in the Commands text box (command input area) in the main window. You can also set
preferences for this directory—see Section 14.1.2 on page 336.
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Once a job is launched, the Monitor panel can be used to display job progress, which can also
be summarized on the status bar. You can open the Monitor panel from the Tasks menu or the
Applications menu, or have it open automatically on starting a job by setting a preference in the
Preferences panel. You may cease or resume monitoring at any time, and you can monitor any
currently running job. If a job finishes while it is being monitored, its output is incorporated
into the current project, according to the settings used to launch the job. If a job that is not
currently being monitored finishes successfully, you must select it in the Monitor panel and
click Monitor to incorporate the results. Multiple structures are incorporated as entry groups. 

Two other tools offer quick access to information on running jobs: the status button on the Job
toolbar in the application panel, which you click to show a small job status window, and the
Jobs button on the status bar in the main window. 

For the programs that do not incorporate results, the output files are placed in the launch direc-
tory. 

For information on Job Control and incorporation, see the Job Control Guide.

1.6 Citing Maestro in Publications

The use of this product should be acknowledged in publications as:

Maestro, version 10.2, Schrödinger, LLC, New York, NY, 2015. 
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Chapter 2: The Maestro Main Window
This chapter describes how to start and end a Maestro session, and gives a detailed description
of the main window and its functions. 

2.1 Starting Maestro 

The mechanism for starting Maestro is different for Linux, Windows, and Mac hosts. This
mechanism is described for each of these host types in the following subsections. 

When Maestro starts, it reads resource files that define your preferences from your user
profiles directory. For information on the location of this directory and on setting preferences,
see Chapter 13. Any resource files that it does not find in this location it reads from the
resource subdirectory in the Schrödinger software installation, maestro-vversion/data/
res, where version is the 5-digit Maestro version number. The resource files and preferences
are saved in your user profiles directory when you quit Maestro.

If you are starting a new release of Maestro for the first time, the preferences and resource files
are copied from the location for the previous release. Your preferences are therefore preserved
for the new version of Maestro. However, layout settings are not copied, because changes to
the panels might make some controls hidden with the saved layout. If you see warnings on
startup, it is likely that a customization is no longer valid, due to definitions changing between
releases. For more information on defining resources, see Section 13.5 on page 324. 

Maestro has the concept of a startup directory, which on Linux is the directory from which
Maestro was started. On Windows and Mac, the startup directory is set to the Schrodinger
folder in your documents folder. The startup directory is used for Maestro’s current working
directory, subject to a preference (see Section 14.1.2 on page 336). To change the current
working directory, you can choose Project → Change Directory and navigate to the new direc-
tory in the Change Directory dialog box.

If Maestro fails to start, the Diagnostics panel opens, with instructions about what to do about
the failure. More information on this panel is given in Section 7.10.1 of the Installation Guide.

2.1.1 Starting Maestro on a Windows Host

To start Maestro, double-click the Maestro icon on the desktop, or use the Start menu. Maestro
is in the Schrödinger submenu. This submenu can also be used to open the release notes and
the documentation index in your browser. 
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To start Maestro with a specific project, double-click the zipped project. Zipped projects have a
.prjzip extension, and are read-only. To replace the zipped project, you must first save it,
then zip it, then copy it over the old project. Zipped projects can also be linked to a web page:
clicking on the link to the project in your browser opens the project in Maestro.

You can import a Maestro, PDB, SD or MOL2 file into a Maestro session by double-clicking
on the file icon. For Maestro files, if there is an existing Maestro session open, the file is
imported into this session (or the most recently used session if there is more than one). 

2.1.2 Starting Maestro on a Mac Host

To start Maestro, click the Maestro icon on the dock. If there is no Maestro icon on the dock,
you can put one there from Finder by choosing Go → Applications and opening the
SchrodingerSuite2015-2 folder. Icons for all the Maestro profiles (and other graphical applica-
tions) are available there, and you can drag them to the dock. 

You can also start Maestro from the command line, by opening a terminal window and using
the instructions given below for Linux and the bash shell.

2.1.3 Starting Maestro on a Linux Host

Before starting Maestro, you must set the SCHRODINGER environment variable to point to the
installation directory, by entering the following command in a terminal window:

You might also need to set the DISPLAY environment variable, if it is not set automatically
when you log in. To determine if you need to set this variable, enter the command:

echo $DISPLAY 

If the response is a blank line, set the variable by entering the following command: 

For local display, you should omit display-machine-name.

After you set the environment variables, you can start Maestro using the command:

$SCHRODINGER/maestro [options] [filename] 

csh/tcsh:  setenv SCHRODINGER installation-directory 

bash/ksh:  export SCHRODINGER=installation-directory 

csh/tcsh:  setenv DISPLAY display-machine-name:0.0

bash/ksh:  export DISPLAY=display-machine-name:0.0 
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For a description of the options for the maestro command, run the command with the -h
option. The optional filename specifies a file to be imported into the project, in any format that
Maestro recognizes by its extension. 

2.1.4 Choosing a Profile

Much of the Maestro interface can be configured or customized, through the use of prefer-
ences, toolbar, menu, and mouse customization, installation of scripts, and use of macros and
shortcuts. These configuration and customization options are stored in your user profiles direc-
tory. See Chapter 13 for more information on customization and the user profiles directory. 

To allow the use of more than one set of customizations, Maestro supports the concept of
profiles. A profile is a named collection of customizations and preferences that can be applied
when you start Maestro. The profiles are stored in the user profiles directory, each in its own
folder (subdirectory). Profile names are case-sensitive, and can include spaces and other non-
alphanumeric characters. The main standard profiles are provided in the distribution:

• Maestro—for general use of Maestro.
• BioLuminate—a customization for the BioLuminate product.
• MaterialsScience—a customization for the Materials Science suite.
• Elements—a simplified Maestro interface designed for medicinal chemistry.

Some other standard profiles are available that perform different customizations, to simulate
the behavior of Maestro 9.1, to simplify the interface for new users, and to emphasize small
molecule features. These profiles are very similar to the main Maestro profile, except that they
may have fewer menu items, or some rearrangements of the toolbars. There is no custom
online help for these profiles, as there is for the main standard profiles, so you may find that
documented features are not available in these profiles.

When you start Maestro without specifying a profile1, the Choose Profile dialog box opens by
default. In this dialog box you can choose the profile, by selecting it from the list. To start
Maestro with the chosen profile, click Start or press ENTER, or double-click on the profile you
want to use.

1. Starting Maestro with a particular profile can be done from the command line or by using the icon for the pro-
file. 
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Figure 2.1. The Choose Profile dialog box.

You can set the default profile by clicking in the Default column. If you bypass this dialog box
by clearing the Show this dialog at startup option, the default profile is used to start Maestro.
To return to displaying this dialog box, choose Maestro → Customize → Profiles, and select
Show the Choose Profile dialog box at startup in the Customize Profiles panel. More informa-
tion on customizing profiles is given in Section 13.4 on page 323.

All descriptions in this manual are given for the Maestro profile.

2.2 The Main Window

The Maestro main window is shown in Figure 2.2. The following main window components
are always visible: 

• Title bar—displays the project name and the current working directory if the relevant
preference is set—see Section 14.1.4 on page 338.

• Auto-Help bar—automatically displays context-sensitive help

• Main menu bar—provides access to panels

• Workspace—displays molecular structures and other 3D graphical objects, such as sur-
faces and Phase hypotheses. Information on a single project entry can also be displayed in
the top left corner—see Section 14.5.2 on page 358. 
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Figure 2.2. The Maestro main window, showing all window components.

The following main window components can be displayed or hidden by choosing the compo-
nent from the Window menu. Your choice of which main window components are displayed is
persistent between Maestro sessions.

• Toolbars—contain buttons for many common tasks. See Section 2.4 on page 17 for an
overview of the toolbars and references to more detailed information.

• Status bar—displays information about a particular atom, about structures in the Work-
space, or about the contents of the Workspace and job status. See Section 2.5 on page 23.

• Clipping planes window—displays a small, top view of the Workspace that shows the
clipping planes and viewing volume indicators. Hidden by default. See Section 4.6 on
page 72.
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• Sequence viewer—shows sequences for proteins displayed in the Workspace. Hidden by
default. See Section 2.6 on page 25.

• Command input area—provides a place to enter Maestro commands. Hidden by
default. Command completion is supported for the keyword (but not the options).

When a distinction between components in the main window and those in other panels is
needed, the term main is applied to the main window components (e.g., main menu bar).

The toolbars are dockable: they can be moved to any side of the Workspace or dragged out of
the Workspace entirely.

You can expand the Workspace to occupy the full screen, by pressing CTRL+= or choosing
Workspace → Full Screen. All other components and panels are hidden. To return to the
previous display, press ESC. 

The following sections describe some of these main window components in more detail.

2.3 The Menu Bar

The menus on the main menu bar provide access to panels, allow you to enter commands, and
control the appearance and contents of the Workspace. The main menus are as follows: 

• Maestro—change directories, check for software updates, set preferences, customize
menus, toolbars, and mouse actions, display main window components, set up command
aliases and macros, interact with PyMOL, and quit Maestro. 

• Project—display Project Table and annotation; create, open, close, copy, delete, save,
back up, restore, and merge projects; import and export structures. For more information
on projects, see Chapter 9.

• Edit—undo actions, copy and paste structures or images, delete Workspace objects, select
atoms, find atoms, build and modify structures, and mark entries.

• View—change the view of the Workspace objects (rotate, translate, zoom, align) or the
view attributes (clipping, perspective, depth perception, fog), enter or exit stereo mode,
save or restore particular views, tile the Workspace. 

• Workspace—control the display of the contents of the Workspace, save Workspace
images and Workspace “scenes”. 

• Tools—group atoms; measure, align, superimpose, and minimize structures; assign struc-
tural features; and view and visualize data. 

• Applications—set up, submit, and monitor jobs for Schrödinger’s computational pro-
grams. Some products have a submenu from which you can choose a specific task. 
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• Tasks—Run various tasks. Alternative to Applications menus.

• Workflows—set up, submit, and monitor jobs for KNIME workflows.

• Scripts—manage, install, and run scripts. For details, see Section 15.1 on page 385.

• Window—close or reopen all panel, arrange panels in a cascade, save or load a panel lay-
out, raise individual or all open panels.

• Help—display various kinds of documentation, including online help, manuals, informa-
tion about Maestro and other Schrödinger products.

The functions of the items on the menus are described in detail in later chapters of this manual.
The menus and items as described here are the Maestro defaults. You can customize the menus
by adding or removing items, changing the names, keyboard shortcuts, and mnemonics—see
Section 13.2 on page 318. If you do, the descriptions of the locations given in this manual do
not, of course, apply to the changed items.

2.4 The Main Window Toolbars 

The main window has a number of toolbars, which allow you to perform many of the common
tasks. Each toolbar contains buttons for a particular kind of task. 

The toolbars contain three kinds of buttons for performing common tasks:

There are five types of items on button menus, and all four types can be on the same menu (see
Figure 2.3):

• Action—Perform an action immediately.

• Display—Open a panel or dialog box.

• Structural unit for picking—Choose Atoms, Bonds, Residues, Chains, Molecules, or
Entries, then click on an atom in the Workspace to perform the action on all the atoms in
that structural unit. The structural unit types are included as radio buttons on the menu,
and the button is highlighted to indicate that this is the action to be performed.

Action—Perform a simple task, like clearing the Workspace.

Display—Open or close a panel or open a dialog box, such as the Project
Table panel.

Menu—Display a button menu. These buttons have a triangle to the right of
the button, which displays the menu. Clicking the button performs the
default action, if it has one.
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Figure 2.3. Examples of button menus.

• Atom category for selection—Choose one of a list of categories of atom to apply the
action to all atoms of this type in the Workspace. The list of categories is the same as on
the Select button (though with slightly different wording)—see Section 6.2 on page 119.

• Other setting—Set a state, choose an attribute, or choose a parameter type and click on
atoms in the Workspace to act upon that parameter.

The toolbar buttons can be displayed as an icon, as text, or as both. The choice can be made for
each toolbar separately, by right clicking on the toolbar and choosing an option from the Style

submenu of the shortcut menu. You can also change the style for all toolbars in the Preferences

panel, under General → Appearance, where you can also change the font for the toolbar
buttons—see Section 14.1.4 on page 338.

The choice of buttons that appears on each toolbar can be customized, by choosing Maestro →
Customize → Toolbars, or choosing Customize from the toolbar shortcut menu. 

Figure 2.4. The Customize Toolbars panel.

The Customize Toolbars panel has a menu of toolbars at the top, a list of all available buttons
on the left, categorized by function, and a list of buttons that are on the selected toolbar on the

structural unit 
type

display
action

other setting:
parameter type
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right. You can choose buttons from any of the categories and add them to any toolbar. You can
also create your own toolbar, by clicking New, naming the toolbar, and adding the desired
buttons. A toolbar named Favorites has been included for you to customize; by default it has no
buttons.

As well as adding toolbars, you can delete toolbars, including the predefined toolbars. To do
so, choose the toolbar from the Toolbar option menu, and click Delete. As the customizations
are stored in your profile, you can always restore toolbars from the installation. 

To reset all toolbars to their defaults, click Reset All. 

The complete list of main window toolbars is:

• Manager toolbar—contains buttons for showing or hiding the other toolbars. You can
also show and hide toolbars with Window → Toolbar.

• Project toolbar—contains buttons for common project-related tasks. This toolbar is
described below.

• Edit toolbar—contains buttons for atom selection and editing structures, in addition to
the usual Undo/Redo, Cut, Copy, Paste, and Delete buttons. This toolbar is described
below.

• View toolbar—contains buttons for changing the view of the Workspace. See Section 4.1
on page 63.

• Workspace toolbar—contains buttons for common Workspace operations and for
scenes. This toolbar is described below.

• Style toolbar—contains buttons for setting the visual style of the contents of the Work-
space, including representation, color scheme, ribbons, atom display, surfaces. See
Section 7.6 on page 154.

• Saved Views toolbar—contains buttons for saving, restoring, and managing views. See
Section 4.3 on page 67.

• Display Atoms toolbar—contains buttons for displaying and undisplaying atoms. See
Section 7.5 on page 150.

• Representation toolbar—contains buttons for changing the molecular representation
and ribbons. See Section 7.1 on page 133.

• Labels toolbar—contains buttons for various annotations in the Workspace, including
atom labels, captions, highlights, and single-entry feedback. See Section 8.1 on page 161.

• Build toolbar—contains buttons for various structure-building tasks. See Section 5.1 on
page 79. 
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• Fragments toolbar—contains a small selection of molecular fragments for building. See
Section 5.1 on page 79.

• Find toolbar—contains tools for finding various structural objects in the Workspace. See
Section 2.10 on page 36.

• Proteins toolbar—contains buttons for various protein-related tasks. See Section 3.7 of
the PrimeX User Manual.

• Periodicity toolbar—contains buttons for display of periodic structures. Section 7.5.3 on
page 152.

• Favorites toolbar—contains no buttons by default, but is intended for you to customize.

The toolbar buttons for the default Project, Edit, and Workspace toolbars are described below.
Many of their features are described in later chapters.

2.4.1 The Project Toolbar

This toolbar contains buttons for the common project operations.

Open 
Open a project. Opens the Open Project project selector so you can select a project to open.
Menu equivalent: Project → Open.

Save As 
Save a project by a different name.
Menu equivalent: Project → Save As.

Import 
Import structures into the project as new entries. Opens the Import panel.
Menu equivalent: Project → Import Structures.

Export 
Export structures from the project to file. Opens the Export dialog box.
Menu equivalent: Project → Export Structures.

Table 
Open or close the Project Table panel.
Menu equivalent: Project → Show Table.

2D Viewer 
Display 2D structures of the selected entries in a grid. Opens the 2D Viewer panel.
Menu equivalent: Project → 2D Viewer.

Lig. Int. 
Display a simplified representation of ligand-receptor interactions. Opens the Ligand Interac-
tion Diagram panel.
Menu equivalent: Tools → Ligand Interaction Diagram.
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2.4.2 The Edit Toolbar

This toolbar contains buttons for atom selection and editing structures, in addition to the usual
buttons found on Edit toolbars.

Get PDB 
Retrieve a structure from the PDB and import it into the project. Opens the Get PDB File dia-
log box. 
Menu equivalent: Project → Get PDB.

Prep Wiz 
Prepare a protein for use in calculations. Opens the Protein Preparation Wizard panel.
Menu equivalent: Workflows → Protein Preparation Wizard.

Select 
Select atoms in the Workspace. Double-click to select all atoms.
This button has a menu from which you can choose the type of structural unit you want to 
select. If you select a structural unit from the menu, the icon changes to reflect that structural 
unit (A for atoms, R for residues, etc.). You can expand the selection to include entire residues 
within a specified distance by choosing one of the distance options, and you can include or 
exclude the picked object in the final selection.
You can choose Select to open the Atom Selection dialog box and specify atoms to select.
Menu equivalent: Edit → Select Atoms.

Undo/Redo 
Undo or redo the last action. The button icon and text changes, depending on the action.
Menu equivalent: Edit → Undo/Redo.

Cut 
Delete the selected atoms from the Workspace and place them on the clipboard, in Maestro 
format and in SMILES format. 
Menu equivalent: Edit → Cut.

Copy 
Copy the selected atoms and an image of the Workspace onto the clipboard. The selected 
atoms are stored in Maestro and SMILES format. The resolution of the image is the current 
screen resolution, so if you want a higher resolution, you should use the Save Image panel. 
Menu equivalent: Edit → Copy.
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Paste 
Paste a structure from the clipboard into the Workspace. The structure can be a SMILES 
string, a structure from ChemDraw or Isis Draw (Windows) or a set of atoms previously cut or 
copied from the Workspace.
SMILES strings are converted into 2D structures, and added to the project as a new entries, 
with the SMILES string as the title. No attempt is made at 3D conversion. To paste it in 3D, 
choose Edit →Paste Special → As 3D.
Atoms that were cut or copied from Maestro are placed at the coordinates at which they were 
cut or copied onto the clipboard, as a scratch entry. You can paste atoms from one Maestro ses-
sion into another session. 
Menu equivalent: Edit → Paste.

Delete 
Delete objects in the Workspace. The button menu has several sections: one for the current 
selection (DELETE), one for structural units to pick for deletion, one for other kinds of struc-
tural objects to delete, and one for markers and annotations. Double-click to delete the 
selected atoms.
Menu equivalent: Edit → Delete → Pick to Delete.

Build 
Show or hide the Build toolbar and Fragments toolbar, or open the Build panel from the menu. 
Menu equivalent: Edit → Build.

2D Sketcher 
Sketch to edit or create structures in 2D. Opens the 2D Sketcher panel. 
Menu equivalent: Edit → 2D Sketcher.

Add H 
Add hydrogen atoms to a structure that lacks them, to complete the valence. From the button 
menu you can choose the type of structural unit to pick for addition of hydrogens, open the 
Atom Selection dialog box to select the atoms, or choose a hydrogen treatment. Double-click 
to add hydrogens to the selected atoms.
Menu equivalent: Edit → Add Hydrogens.

Transform 
Transform (rotate or translate) selected atoms in the Workspace. From the button menu you 
can choose to display hydrogen bonds, contacts, and bond lengths while transforming, choose 
a structural unit to pick the atoms to transform, or open the Advanced Transformations panel 
for more control over the transformation. 
Menu equivalent: Edit → Transform.

Adjust 
Adjust the geometry of structures. From the button menu you can choose geometric parame-
ters to adjust: distances, angles, dihedrals or chirality; torsions, peptides, or side chains (rota-
mers); or choose to display hydrogen bonds and contacts while adjusting torsions.
Menu equivalent: Edit → Adjust.
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2.4.3 The Workspace Toolbar

This toolbar contains buttons for some common Workspace operations, and buttons for
creating and managing scenes. 

2.5 The Status Bar

The status bar displays information about the contents of the Workspace or about a particular
atom, depending on where the pointer pauses. If the pointer is not over an atom, information
about the contents of the Workspace is displayed, in the format

Atoms:sa/ma/na Entries:me/ne Res:nr Chn:nc Mol:nm Chg:n 

where the fields in the display have the following meanings:

Create Entry 
Create an entry in the current project using the contents of the Workspace. Opens a dialog box 
in which you can supply a title for the entry, and choose whether to create the entry from all 
atoms, the selected atoms, or the displayed atoms. If all the atoms in the new entry come from 
entries in the same entry group, the new entry is added to the same group, otherwise it is added 
to the ungrouped entries in the Project Table.
Menu equivalent: Workspace → Create Project Entry.

Clear 
Clear the Workspace. Excludes all entries in the Project Table, and deletes the contents of the 
scratch entry, if there is one.
Menu equivalent: Workspace → Clear.

Save Image 
Save an image of the Workspace to a file in TIFF, JPEG, or PNG format, in the Save Image 
panel.
Menu equivalent: Workspace → Save Image.

New Scene 
Create a new “scene”, which is a snapshot of part or all of the project, including the Work-
space content and display settings. Opens the New Scene dialog box, in which you can pro-
vide a description and choose which parts of the project to include in the scene.
Menu equivalent: Workspace → Scenes → New.

View Scenes 
Enter a mode in which you view scenes. The Scenes toolbar is displayed in a bar at the bot-
tom of the Workspace, and the selected scene is opened. While you are viewing scenes, no 
changes are made to the project.
Menu equivalent: Workspace → Scenes → View.
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If the pointer is over an atom, and the preference to show feedback on atoms is set, the status
bar displays the chain, residue number, element, PDB atom name, formal charge, and a user-
selected property, in the format 

atom:chain:residue number :(element) PDB :charge:"userchoice"

where the fields in the display have the following meanings:

If you are picking an object in the Workspace and you have the preference set, the index of the
object is displayed at the beginning of the status bar, in the format Pick: index. For example,
if you are picking molecules, the molecule number is displayed. 

The preferences to show feedback and the user-selected property can be set under Feedback –

Atoms in the Preferences panel—see Section 14.5.1 on page 358. 

On the left of the status bar is a button that displays job status information. The text on the
button gives the number of jobs in the format Jobs: mj/nj, where mj is the number in the
project and nj is the total number. Clicking the button opens the Monitor panel. The tool tip for
the button displays information on the status of the first few jobs in the Monitor panel.

Atoms Number of atoms in the Workspace: sa is the number selected, ma is the number
displayed, na is the total

Entries Number of entries in the Workspace: me is the number displayed, ne is the total

Res Number of residues nr in the Workspace

Chn Number of chains nc in the Workspace

Mol Number of molecules nm in the Workspace

Chg Total charge n of the Workspace contents

atom Atom number in the Workspace

chain Chain name

residue Residue name

number Residue number and insertion code

element Element

PDB PDB atom name

charge Formal charge of the atom

userchoice Selected Project Table property
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2.6 The Sequence Viewer

The sequence viewer displays the sequence of the proteins that are included in the Workspace.
Each chain is displayed on a separate line. If a protein contains waters, ions, or ligands2, each
of these groups of molecules is displayed on a separate line. If the sequence is longer than a
single line, the entire set of lines is continued below the first set of lines (“wrapped”) by
default. (You can unset a preference if you want them to scroll horizontally instead.) The left
column of the sequence viewer displays a label for the sequence, in the format
row:pdbID_chainID, where row is the Project Table row number. The right column displays
the actual sequence as a list of single-letter codes, and also displays the secondary structure
assignment, if one is available.

The background colors of the sequences reflect the current coloring scheme for the alpha
carbon in the Workspace. Each residue in the sequence also has a tooltip that gives the residue
name, number, and insertion code.

If the protein has a secondary structure assignment, the assignment is displayed above the
sequence, using the following symbols:

• Helices are displayed as tubes, colored red
• Strands are displayed as arrows, colored cyan
• Loops are displayed as a gray line.

You can select residues in the sequence and perform actions on these residues. 

• To select a single residue, click the residue. 

• To add single residues to the selection or remove single residues from the selection, con-
trol-click the residues. 

• To select a range of residues, click the first and shift-click the last, or drag over the resi-
dues. If the sequence viewer is wrapped, you can drag over multiple rows to select resi-
dues in more than one row (but only in the sequence in which you started dragging). 

• To change the selection of a contiguous set of residues, hold down the CTRL key and drag
over the set of residues. The unselected residues are selected, and the selected residues
are deselected. This can be used to extend the selection or add a discontinuous sequence
fragment to the selection, for example.

The selected residues are highlighted in reverse video (as colored letters on a black back-
ground), and are marked in yellow in the Workspace. 

2. These entities are defined by the corresponding ASL expressions. “Ligands” are defined by ligand detection set-
tings; “ions” are a small set of ionic species commonly found in or used with proteins.
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The sequence viewer and the Workspace are synchronized: selection of atoms in the Work-
space selects the corresponding residues in the sequence viewer, and selection of residues in
the sequence viewer selects them in the Workspace. Likewise, changing the color scheme in
the Workspace changes the color scheme in the sequence viewer, and vice versa. Structural
changes, such as mutating a residue, are also reflected in the sequence viewer. 

To zoom in on a residue in the Workspace without selecting it, middle-click the residue in the
sequence viewer.

The sequence viewer has a shortcut menu (right-click and hold), which you can use to perform
various actions on the sequences or the display. If you do not have any residues selected in the
sequence viewer, the sequence viewer shortcut menu is displayed. The items on this menu are
described in Table 2.5. If you have residues selected, the selection shortcut menu is displayed
(see Table 2.2). In this context there is one extra item on the Color Scheme submenu: Proximity.
If you choose this item, the residues within a given distance of the selected residues are colored
orange, and the selected residues are colored red. All others are colored gray. To remove this
color scheme, deselect the residues and choose None from the Color Scheme submenu. The
distance is specified in the Sequence Viewer - Preferences dialog box, which you open from
the sequence viewer shortcut menu. 

2.7 Shortcut Menus

Some of the main window components have shortcut menus, which you open by right-clicking
and holding over the component. 

The status bar, the toolbars, and the command input area have two common items, Hide, which
hides the component, and Help, which displays the relevant help topic. These are the only items
for the status bar.

The toolbars have a Customize item to open the Customize Toolbars panel for customization—
see Section 2.4 on page 17. The toolbars other than the Manager toolbar have a Style item,
from which you can select the arrangement and appearance of the icon and the text for the
buttons. 

The command input area has a standard set of text input items, which are described in
Section 1.1.3 on page 3. 

The Workspace has three shortcut menus: one for the Workspace itself (the Workspace shortcut
menu), one for the atoms in the current selection (the selection shortcut menu), and one for
bonds (the bond shortcut menu). The selection shortcut menu is also available from the
sequence viewer. These shortcut menus have common items for tiling when used in the Work-
space. The items on these menus are described in Table 2.1, Table 2.2, Table 2.3, and
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Table 2.4. The selection shortcut menu items that are only on the Workspace or the sequence
viewer shortcut menus are noted in the table. 

The sequence viewer has a shortcut menu for the sequence label area, which is described in
Table 2.5. This is in addition to the selection shortcut menu, which is displayed when you
right-click on a sequence.

When you right-click and hold in the Workspace:

• On an unselected atom, the atom becomes the selection and the selection shortcut menu is
displayed. 

• On a selected atom, the selection shortcut menu is displayed. 

• On a bond, the two atoms in the bond become the selection and the bond shortcut menu is
displayed. 

• On empty space, if there is an atom selection, the selection shortcut menu is displayed,
otherwise the Workspace shortcut menu is displayed.    

Table 2.1. Workspace shortcut menu items.

Menu Item Action

Background Color Set the Workspace background color to black, white, gray, or blue. 

Workspace 
Feedback 

Set up entry properties to be shown at the top left of the Workspace (“feed-
back”). Opens the Preferences panel at the Feedback – Entry section.

Save Image Open the Save Image panel to save an image of the Workspace in TIFF, 
JPEG, or PNG format. 

Save View Save the current view of the Workspace (orientation, location, and zoom). 

Restore View Restore the last saved view of the Workspace (orientation, location, and 
zoom). 

Manage Views Open the Manage Views panel to work with the saved Workspace views. 

Fit to Workspace Fit the displayed structure to the Workspace and reset the center of rotation. 

Create Project Entry Create a Project Table entry from the Workspace. 

Clear Workspace Clear the Workspace. 

Delete Delete labels, measurements, or adjustments. 

Highlights Add or change highlights on the Workspace structures.

Caption Add captions to the Workspace, delete captions or edit captions.

Help Open the Shortcut Menus help topic.
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Table 2.2. Selection shortcut menu items.

Menu Item Action 

Background Color Set the Workspace background color to black, white, gray, or blue. 

Workspace 
Feedback 

Set up entry properties to be shown at the top left of the Workspace (“feed-
back”). Opens the Preferences panel at the Feedback – Entry section.

Invert Selection Select the unselected atoms and deselect the selected atoms. 

Expand Selection Expand the selection to include atoms or residues within a specified distance, 
or to select only these atoms. (Workspace)

Select Matching 
Atoms By

Select all atoms that match any of the currently selected atoms by Color, Rep-
resentation, or Element (which you choose from the submenu). For example, 
if the selection has red and green atoms, all red and green atoms are selected.

Representation Set the molecular representation to wire frame, ball and stick, CPK, tube, or 
thin tube. 

Color Scheme Apply the color scheme from the submenu to the selected atoms. 

Labels Apply the label from the submenu to the selected atoms. 

Highlights Add a highlight of a particular type with the default settings or manage high-
lights. (Workspace)

Display Display the entire molecules or residues containing the selected atoms. This 
action is useful if part of the molecule or residue was previously undisplayed. 
Also, display residues within a given distance of the selected atoms.

Display Only Display only the selected atoms. (Workspace)

Undisplay Undisplay the selected atoms. 

Delete Delete the selected atoms. 

Switch Alternate 
Positions 

For atoms with partial occupancy, switch between the alternate positions. 
(Workspace)

Display Alternate 
Positions 

For atoms with partial occupancy, display all positions. The alternate positions 
are displayed as ghosts. (Workspace)

Set Element Change the selected atoms to atoms of the element chosen from the submenu. 
(Workspace)

Insert Gap Insert a gap to the left of the selected residue. Opens a dialog box in which you 
can specify the number of residues to insert. (Sequence viewer) 

Mutate Residue Change the residues that contain the selected atoms (or the selected residues) 
to the type chosen from the submenu. 

Rotamers Open the Rotamers dialog box to select one of the standard rotamers for the 
selected residues.
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Create Project Entry Create a project entry. Opens the Create Project Entry dialog box, in which 
you can provide a title for the entry, and choose whether to use the selected 
atoms, the displayed atoms, or all atoms. (Workspace)

Exclude Entries Exclude the entries that contain the selected atoms from the Workspace. 

Select Project 
Entries

Select the entries that contain the selected atoms in the Project Table. The sub-
menu allows you to choose whether to add the entries to the current Project 
Table selection, or to replace the selection. 

Fit to Workspace Fit the displayed structure to the Workspace and reset the center of rotation. 

Clip Clip the display to the selected atoms. Moves the clipping planes. (Workspace)

Center Electron 
Density 

Center the displayed electron density map on the centroid of the selected 
atoms. Used for PrimeX. (Workspace)

Transform Perform a local transformation. (Workspace)

Align Centers of 
Mass 

Translate the entries so that the centers of mass of the selected atoms in each 
entry coincide. (Workspace)

Help Open the Shortcut Menus help topic.

Table 2.3. Bond shortcut menu items.

Menu Item Action

Order Set the bond order to zero, one, two, or three. 

Measure Measure the bond length and display it. The measurement is added to the list in the 
Measurements panel. 

Adjust Adjust the bond length or the dihedral angle around this bond. 

Delete Delete the bond. 

Table 2.4. Tiling items on shortcut menus.

Menu Item Action

Apply Zoom to All Tiles Apply the zoom value from the current tile to all tiles. 

Apply View to All Tiles Apply the view (rotation, translation, zoom) from the current tile to all 
tiles.

Reset Tile Reset the view of the current tile to its initial value. 

Pick Tiles to Move Turn on or off picking to move tiles. When enabled, picking selects tiles 
which can then be moved to a new location. The location is marked with a 
vertical line between tiles as you move the mouse to the desired location.

Table 2.2. Selection shortcut menu items. (Continued)

Menu Item Action 
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Table 2.5. Sequence viewer shortcut menu items.

Menu Item Action 

Hide Hides the sequence viewer. To redisplay it, use the Window menu. 

Color Scheme Colors the sequence with the scheme selected from the submenu. Choose from 
None, Color by Chain, Residue Type, Residue Property, Secondary Structure, 
Template ID, or Proximity (sequence viewer only). 

Font Size Sets the font size for the sequence viewer. Choose Small, Medium, Large, or 
Huge from the submenu. 

View SSA Shows or hides the secondary structure assignment for the sequence. 

Show Displayed 
Residues Only 

Shows only the residues that are displayed in the Workspace.

Display Non-pro-
tein Molecules 

Display non-protein molecules in the sequence viewer. Three lines are used, for 
ligands, waters, and ions.

Align by Residue 
Number 

Aligns the sequences in the sequence viewer by residue number. (Does not affect 
the alignment of the structures.) This command enables gaps to be displayed in 
the sequence viewer.

Exclude Entry Excludes the entry containing this chain from the Workspace. The chain is 
removed from the sequence viewer. If the entry contains multiple chains, all the 
chains in the entry are removed from the sequence viewer. 

Wrap Sequences Wraps the sequence display so that long sequences are displayed across multiple 
lines with vertical scrolling rather than on a single line with horizontal scrolling.

Legend Opens the Sequence Viewer Legend dialog box, which explains the sequence 
color schemes. 

Preferences Opens the Sequence Viewer - Preferences dialog box, in which you can set the 
proximity cutoff. 

Save Image Opens the Save Sequence Viewer Image file selector, in which you can save an 
image of the sequence viewer to a file. The image format is determined by the 
extension that you choose. 

Export 
Sequences 

Exports the sequences in the Sequence Viewer to a FASTA file. Opens a file 
selector to specify the location and the file name.

Help Opens the Sequence Viewer help topic.
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2.8 Mouse Functions

The Workspace has special uses for the middle and right mouse buttons. These are used on
their own and in combination with the SHIFT and CTRL keys to perform common operations
such as rotation, translation, centering, and zooming. The table below summarizes the standard
actions for a 3-button mouse with scroll wheel.

Table 2.6. Mapping of Workspace operations to mouse actions.

Mouse Button Keyboard Motion Action

Left click, drag Select

Left drag Quick Torsion adjustment and adjust-
ment of distance, angle, dihedral 

Left SHIFT click, drag Toggle the selection

Middle drag Rotate about X and Y axes

Middle SHIFT drag vertically Rotate about X axis

Middle SHIFT drag horizontally Rotate about Y axis

Middle CTRL drag horizontally Rotate about Z axis

Middle SHIFT + CTRL drag horizontally Zoom

Right click Spot-center on selection
Toggle selection

Right click and hold Display shortcut menu

Right drag Translate in the X-Y plane

Right SHIFT drag vertically Translate along the X axis

Right SHIFT drag horizontally Translate along the Y axis

Right CTRL drag horizontally Translate along the Z axis

Middle & Right drag horizontally Zoom

Wheel scroll Zoom 
In any adjust mode, do adjustment

Wheel CTRL scroll Adjust isovalue of electron density 
map (PrimeX)
In clipping planes window, move clip-
ping planes in opposite directions

Wheel SHIFT scroll In clipping planes window, move clip-
ping planes in the same direction
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Section 4.2 on page 64 has more detailed information on changing the Workspace view. Mouse
and trackpad functions can be customized—see Section 13.3 on page 321 for information

2.9 Shortcut Keys

Some frequently used operations in the main window have been assigned shortcut key combi-
nations. The default shortcuts, their functions, and their menu equivalents are listed in
Table 2.7. Shortcut keys in the Project Table panel and the Plot panel are listed in the chapters
that describe those panels. In addition to the shortcut keys listed below, there are a set of keys
that can be used in either the Workspace or the Project Table. Most of these keys are for actions
in the Project Table—see Section 9.4.6 on page 192 for more information. You can customize
the shortcut keys in the Customize Menus panel—see Section 13.2 on page 318 for details. 

If Num Lock, Caps Lock, or Scroll Lock is enabled, the shortcut keys do not work. Some
shortcut keys might not work on non-English keyboards: for example, CTRL+= (full screen) on
German keyboards in the German locale or ` (pick to select) on French keyboards in the French
locale. If this is the case, you can customize the shortcut keys for these functions.

Table 2.7. Default shortcut keys in the Maestro main window.

Keys Action Equivalent Menu Choice

B Pick bonds in the Workspace

CTRL+SHIFT+Z 
(Z)

Select the next defined adjustment of the 
current type for adjustment.

Edit → Adjust → Next Adjust-
ment

CTRL+SHIFT+A 
(A)

Select the previous defined adjustment of 
the current type for adjustment.

Edit → Adjust → Previous 
Adjustment

U Clean up the geometry of the Workspace 
structure or selected atoms.

Edit → Build → Clean Up 
Geometry 

CTRL+C (C) Copy the Workspace contents onto the clip-
board. Includes atoms, SMILES, and image 
at screen resolution.

Edit → Copy 

CTRL+X (X) Cut the atom selection (delete the selected 
atoms and put them on the clipboard)

Edit → Cut 

DEL Delete the selected atoms Edit → Delete 

CTRL+F (F) Show or hide the Find toolbar Edit → Find 

X Mark or clear mark for the current entry, 
creating the Mark property if necessary.

Edit → Mark Target Entry 

CTRL+V (V) Paste atoms into the scratch entry Edit → Paste 
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CTRL+SHIFT+V 
(V)

Paste atoms into the scratch entry so that the 
centroid is at the picked location.

Edit → Paste Special → By 
Placing 

A Pick atoms in the Workspace for the current 
action. 

Edit → Pick → Atoms 

C Pick chains in the Workspace for the current 
action. 

Edit → Pick → Chains 

E Pick entries in the Workspace for the current 
action.

Edit → Pick → Entries 

M Pick molecules in the Workspace for the 
current action.

Edit → Pick → Molecules 

R Pick residues in the Workspace for the cur-
rent action. 

Edit → Pick → Residues 

CTRL+A (A) Select all atoms Edit → Select Atoms → All 

CTRL+U (U) Clear the atom selection Edit → Select Atoms → None 

N Select the next residue in the structure from 
the currently selected residue.

Edit → Select Atoms → Next 
Residue 

` Select atoms by picking. Edit → Select Atoms → Pick to 
Select 

P Select the previous residue in the structure 
from the currently selected residue.

Edit → Select Atoms → Previ-
ous Residue 

1, 2, ... , 0 Select atoms in previously saved atom set 1, 
2, ... , 10.

Edit → Select Atoms → 
Restore → Atom Set n 

CTRL+1 (1), 
CTRL+2 (2), ... 
CTRL+0 (0)

Save the selected atoms as atom set 1, 2, ... , 
10.

Edit → Select Atoms → Save 
→ Atom Set n 

* Cycle through number of stars assigned to 
the target entry, in increasing order.

Edit → Star Target Entry 

CTRL+G (G) Enter and exit local transformation mode Edit → Transform → Pick to 
Transform 

CTRL+Z (Z) Undo/Redo the last command. Edit → Undo/Redo

CTRL+H (H) Display the default help topic Help → Online Help 

CTRL+, (,) Open the Preferences panel Maestro → Preferences 

CTRL+Q (Q) Quit Maestro Maestro → Quit 

Table 2.7. Default shortcut keys in the Maestro main window. (Continued)

Keys Action Equivalent Menu Choice
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CTRL+W (W) Close the project. Project → Close 

CTRL+E (E) Open the Entry List panel Project → Entry List 

CTRL+I (I) Open the Import panel Project → Import Structures 

CTRL+N (N) Create a new project Project → New Project 

CTRL+O (O) Open an existing project Project → Open Project 

CTRL+T (T) Open the Project Table panel Project → Project Table 

CTRL+R (R) Open the Task Tree panel Tasks → Show Tree 

CTRL+M (M) Minimize the selected atoms (or all atoms, if 
there is no selection)

Tools → Minimize → Selected 
Atoms

CTRL+SHIFT+M 
(M)

Minimize the ligand. Tools → Minimize → Ligand 

D Turn on and off enhancement of depth view 
with ambient spherical occlusion.

View → Enhanced Depth View

L Fit the ligand to the Workspace. If there is 
more than one ligand-sized molecule, cycle 
through them with repeated use of L.

View → Fit to Workspace → 
Ligand 

Z Fit the selected atoms or all atoms to the 
Workspace

View → Fit to Workspace → 
Selected Atoms 

G Move clipping planes further apart View → Move Clipping Planes 
→ Apart 

– Move clipping planes back (away from 
user)

View → Move Clipping Planes 
→ Back

= Move clipping planes forward (toward user) View → Move Clipping Planes 
→ Forward

F Move clipping planes closer together View → Move Clipping Planes 
→ Together 

; Rotate the view in the positive x direction 
by the keyboard rotation increment.

View → Rotate → +X 

/ Rotate the view in the negative x direction 
by the keyboard rotation increment.

View → Rotate → -X 

. Rotate the view in the positive y direction 
by the keyboard rotation increment.

View → Rotate → +Y 

Table 2.7. Default shortcut keys in the Maestro main window. (Continued)

Keys Action Equivalent Menu Choice
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, Rotate the view in the negative y direction 
by the keyboard rotation increment.

View → Rotate → -Y 

] Rotate the view in the positive z direction by 
the keyboard rotation increment.

View → Rotate → +Z 

[ Rotate the view in the negative z direction 
by the keyboard rotation increment.

View → Rotate → -Z 

: Translate the view in the positive x direction 
by the keyboard translation increment.

View → Translate → +X 

? Translate the view in the negative x direc-
tion by the keyboard translation increment.

View → Translate → -X 

> Translate the view in the positive y direction 
by the keyboard translation increment.

View → Translate → +Y 

< Translate the view in the negative y direc-
tion by the keyboard translation increment.

View → Translate → -Y 

} Translate the view in the positive z direction 
by the keyboard translation increment.

View → Translate → +Z 

{ Translate the view in the negative z direc-
tion by the keyboard translation increment.

View → Translate → -Z 

Y Enter and exit rotation mode, in which the 
use of the mouse for picking is suspended 
and mouse actions perform rotation of the 
view.

View → Transform Mode → 
Rotation 

CTRL+S (S) Enter and exit stereo viewing mode View → Stereo 

CTRL+L (L) Tile the Workspace by entry View → Tile → Tile Workspace 

CTRL+SHIFT+L 
(L)

Switch between transforming all tiles and 
transforming a single tile

View → Tile → Transform All 
Tiles 

K Zoom in. Same as one click on the scroll
wheel.

View → Zoom In 

J Zoom out. Same as one click on the scroll
wheel.

View → Zoom Out 

CTRL+SHIFT+I 
(I)

Show or hide the Command Input Area. Window → Command Input 
Area 

CTRL+D (D) Open the Command Script Editor panel Window → Command Script 
Editor 

Table 2.7. Default shortcut keys in the Maestro main window. (Continued)

Keys Action Equivalent Menu Choice
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2.10 Finding Objects in the Workspace

If you want to find an atom, residue, or other group of atoms in the Workspace, you can do so
with the Find toolbar, which you display by pressing CTRL+F (F), choosing Edit → Find, or
choosing Windows → Toolbars → Find. 

To search for a particular kind of object, choose the object from the Find option menu. For each
of the menu choices, the toolbar is configured so you can define the object (atoms) to search
for. When you have defined the object, press ENTER to run the search, or click N or P. 

• Residue number—Enter the residue number in the text box. You can also specify the
chain name and insertion code, e.g. A:15B, but these are optional. If the chain name is not
specified, all the residues with the specified residue number (and insertion code if speci-
fied) are found. If the insertion code is not specified, all the residues with the specified
residue number (and PDB chain name if specified) are found.

• Atom number—Enter the atom number in the text box. Since atom numbers are unique,
this search finds only one atom. Press ENTER to find the atom.

• SMARTS—Enter the SMARTS expression into the text box, or select atoms in the Work-
space and click Get from Selection to generate the SMARTS expression for those atoms.
(You can set preferences for some of the notational elements in the generated SMARTS
pattern—see Section 14.15 on page 382.) You can copy a SMARTS pattern from another
location and paste it in with CTRL+V. 

CTRL+SHIFT+N 
(N)

Create a project entry from the structures in 
the Workspace

Workspace → Create Project 
Entry 

CTRL+= (=) Enter full screen mode (Workspace occupies 
full screen)

Workspace → Full Screen 

CTRL+> (>) Open and display the next scene. Workspace → Scene → Next 
Scene 

CTRL+< (<) Open and display the previous scene. Workspace → Scene → 
Previous Scene 

S Display or undisplay entry information in 
the Workspace (subject to a preference).

Workspace → Single-Entry 
Feedback 

CTRL+Y (Y) Apply the Workspace style. Workspace → Style → Apply 
Style 

Table 2.7. Default shortcut keys in the Maestro main window. (Continued)

Keys Action Equivalent Menu Choice
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• Residue type—Choose a residue type from the option menu. This menu includes only the
residues that are present in the Workspace. 

• Secondary structure—Choose a secondary structure element from the option menu, from
Helix, Loop, or Strand.

• Element—Enter a standard element symbol in the text box, e.g. Cl. 

• PDB atom name—Enter a standard PDB atom name in the text box, e.g. CA. Spaces are
significant, as 'CA ' and ' CA ' are not the same. 

• Specified atoms—Enter an ASL expression in the text box, or click Select to open the
Atom Selection dialog box and make an atom selection. This tool can be used to find
objects that are not on the menu. For example, to find molecule number 3, enter mol.num
3 in the text box. 

When you do the search, all instances of the object that match are located. The number of
matched objects and the index of the current matched object is shown in a text area. You can
step through the instances with the N (next) and P (previous) buttons. The instance of the
object that you step to becomes the Workspace selection. If you want to fit the object to the
Workspace, select Fit. 

If there is only one match, the N and P buttons are disabled after the match is found. In this
case, if you want to find the match again, click in the text box and press ENTER. These buttons
are always disabled for Atom number, so you must press ENTER to find an atom by number.

If you have a single residue selected, you can step through the residues in sequence by pressing
the N or P keys. If you reach the end of the chain, the next residue found is the lowest residue
in the next chain or the highest residue in the previous chain.

2.11 Undoing Workspace Operations

Single operations in the Workspace can be undone by choosing Undo action from the Edit
menu. This item is dynamic: its name includes a description of the last undoable action, and
changes to Redo after it has been used. Selecting Redo action reimplements the action that was
undone. This menu item is mapped to the Undo/Redo button on the toolbar. 

To undo the last operation, do one of the following:

• Click the Undo/Redo button on the toolbar. 

• Choose Undo action from the Edit menu. 
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• Press CTRL+Z.

If you want to be able to undo more than one operation, you can define an Undo block. The
Undo block groups a sequence of commands so that the effect of the entire sequence can be
reversed. This is particularly useful for risky or complicated procedures.

To define an Undo block:

1. Enter beginundoblock in the Command Input Area.

2. Perform the sequence of operations that you want to be able to undo.

3. Enter endundoblock in the Command Input Area.

To undo the operations in an Undo block:

• Choose Undo action from the Edit menu, press CTRL+Z, or click the Undo/Redo button in
the toolbar.

As for a single action, the Undo option for a block changes to Redo once you have used it.

Maestro can perform certain actions (such as job monitoring) from within undo blocks. These
actions might prevent the entire sequence of operations from being undone.

2.12 Running Maestro Commands

Maestro uses a command language for performing most of its operations. You can use this
language in Maestro, by entering commands in the Commands text box, also known as the
Command Input Area. To display this tool, choose Window → Command Input Area, or type
CTRL+SHIFT+I. The commands are given in the Maestro Command Reference Manual.

The Commands text box has access to the command history, which you can navigate with the
UP ARROW and DOWN ARROW keys. When you start typing a command, a completion list is
shown below the text box, and you can choose the desired command from this list.

2.13 Ending a Maestro Session

To end a Maestro session, choose Quit from the Maestro menu, or type CTRL+Q. The Quit

Maestro panel opens, offering the opportunity to cancel the quit operation. If you do not want
the Quit Maestro panel to open, select Do not show again, or deselect Warn when quitting
Maestro in the Preferences panel, under General – Quitting Maestro.

If you continue with quitting Maestro, several other actions may take place that depend on
preferences set under General – Quitting Maestro in the Preferences panel. See Section 14.1.7
on page 339 for a description of these preferences.
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Figure 2.5. The Quit Maestro panel.

If you are working in a scratch project and have not saved the project, you are prompted to do
so, if you have the preference Warn before closing a scratch project set, under Project – Closing

projects in the Preferences panel. If this preference is not set, the scratch project is discarded. 

To quit Maestro quickly, press CTRL+Q ENTER (Q ENTER).
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Chapter 3: Importing and Exporting Structures and 
Data
The primary place for reading and writing data from Maestro is a project. When you open a
project, the structures and data from that project are read into Maestro. As you modify struc-
tures and data they are automatically saved in the project (unless you have set a preference not
to do so). Projects are described in detail in Chapter 9. In addition to reading and writing to
projects, Maestro can also read and write structural information in a variety of formats,
including its own native Maestro format, MacroModel, Jaguar, PDB, MDL SD, Sybyl Mol2,
and MCPRO zmat format. Structural information can also be obtained from the input and
output files of a wide variety of quantum chemical programs. 

Obtaining structures from a file in Maestro is called importing rather than reading because the
structures are imported into the current project. Any structures that do not exist as entries in the
current project are external to the project, and therefore must be imported. Similarly, the term
exporting is used instead of writing because a file is created for use outside the current project. 

Data that is associated with structures can also be imported and exported independently to
spreadsheet files. This capability enables properties that are created by Schrödinger software to
be read by a spreadsheet program, manipulated, and re-imported into the project. 

3.1 Importing Structures

The main means of importing structures is by using the Import panel. You can import data from
files in Maestro, MacroModel, PDB, Sybyl Mol2, MDL SD, and a range of other formats. If
the files contain multiple structures, such as the output of a conformational search, you can
select the structures to import. 

If you want to import structures from a file you have recently imported from, with the current
import settings, you can simply choose Project → Import Recent Structures → filename. 

When importing structures, Maestro places each structure into a separate, new entry in the
current project. For Maestro files, molecular representation information can be imported along
with a structure. In addition, Maestro adds two properties to the structures on import: the full
path to the file from which the structures were imported (Source Path), and the file name
without the path (Source File). If these properties already exist in the imported structures, they
are overwritten.

You can undo the import operation, but the changes made to the Project Table remain.
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Figure 3.1. The Import panel.

To open the Import panel, do one of the following:

• Choose Project → Import Structures in the main window.
• Press CTRL+I (I) with the pointer in the main window.
• Choose Table → Import → Structures in the Project Table panel.
• Click the Import button on the Project toolbar in the main window or the Project Table

panel.
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3.1.1 Selecting Files

Selecting a file type: Before you choose files, you must specify the file type by choosing a file
format from the Files of type option menu. The menu options are described below.

Common

Import one of the common file types, including Maestro, PDB, and SD. See the descriptions
below for these file types. 

Maestro

Import from Maestro structure files, which have a .mae extension (.mae.gz or .maegz if they
are compressed). Properties are imported as well as structures.

PDB

Import PDB files, which have either a .pdb, a .pdb.gz (for compressed files), or a .ent
extension. (See also Section 3.1.6 on page 48.)

The PDB ID is used for the structure title, and the title from the PDB file is stored in a new
property, PDB TITLE. 

Where multiple sets of coordinates (alternate positions) exist for atoms in a single PDB entry,
Maestro reads all sets by default. You can read the coordinates for the first set only by dese-
lecting Read alternate locations in the Import Options dialog box. Properties are imported as
well as structures. 

Note: PDB structures that have varying number of atoms in different MODELs cannot be
imported.

Mol2

Import Sybyl Mol2 files, which have a .mol2 extension.

SD

Import MDL SD files, which have an .sd or.sdf extension for multiple structure files, an
.sdfgz or .sdf.gz extension for compressed multiple structure files, or a .mol extension for
files with a single structure. Properties are imported as well as structures. If you want to choose
a property from the SD file to use for the Title property in the Maestro project, you can do so in
the Import Options dialog box. The default is the SD molecule name. 
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SMILES

Import SMILES strings from a text file with a .smi extension or a compressed text file with a
.smigz or a .smi.gz extension. The text file must have one SMILES string per line, with an
optional title separated by a blank. The structures created on import are 2D structures with
hydrogens, so you must convert them to 3D structures before using them in applications. 

Jaguar Input 

Import from Jaguar input files, which have .in extensions. 

ReagentPrep

Import ReagentPrep structure files, which have .bld extensions. These are special files labeled
with grow bonds for use in CombiGlide.

MacroModel

Import from MacroModel input or output structure files, which have .dat or .out extensions.
Properties are imported as well as structures.

Jaguar Output

Import from Jaguar output structure files, which have .out extensions. Properties are imported
as well as structures.

MCPRO Input 

Import from MCPRO+ input files, which have .zmat extensions. 

Desmond 

Import Desmond composite model system files, which have a .cms extension if uncompressed,
or a.cms.gz, or .cmsgz extension if compressed.

Glide Pose Viewer

Import Glide pose viewer files, which are Maestro files that have the receptor as the first entry,
followed by a set of docked ligands. These files have a _pv.mae extension if uncompressed,
and _pv.mae.gz or _pv.maegz if compressed. There 

Other formats: 

Import structures from a range of other programs or formats, including BioGraf, GAMESS
output, Gaussian, Mopac, XYZ (MYZ is a synonym for multiple structures in XYZ format),
CCF, CIF, mmCIF, and FHI-aims. The format conversion is performed with the use of the
program Babel. The list of formats provided here is a subset of the formats that Babel can
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convert. If you want to import structures in formats not listed here using Babel, you can use
Jaguar to read the files. See Section 11.1.2 of the Jaguar User Manual for more information,
including the full list of file types read by Babel. 

On Linux hosts you can use Babel from the command line to convert structures to a format that
Maestro can import directly. To do so, you must first set the environment variable BABEL_DIR:

To obtain usage information, enter the babel command without arguments:

$SCHRODINGER/mmshare-vversion/bin/platform/babel

Here, version is the 5-digit mmshare version number, and platform indicates the platform on
which you are running, e.g. linux-x86.

Any

Import a file of any type. The file type is determined from the extension of the selected file or
the file name you enter in the Selection text box. If the extension is not unique, Maestro does
not import the file. The formats for which Maestro recognizes the extension are Maestro, Mol
and Mol2, PDB, SD, XYZ (or MYZ), Mopac Cartesian and Internal, and Spartan. This option
is useful if you want to locate any of these kinds of structure files. 

Filtering the file list: To filter the list of files according to your own requirements, choose
Custom File Filter from the Files of type option menu. The Custom File Filter dialog box opens,
in which you can enter the filter. The filter can include metacharacters for filename expansion:
* for zero or more characters; ? for a single character, and square brackets for specific charac-
ters or a range of characters, e.g. [a-e]. 

Selecting a directory: To specify the directory from which to import, you can enter it in the
File name text box, or navigate to it using the standard locations, the navigation buttons, or the
option menu at the top of the panel. The path displayed in the option menu and the lists are
then updated for the chosen directory. 

Selecting a file: To select a file, you can type its name (and path) in the File name text box, or
select it from the list. 

If you type the name of the file in the File name text box, you must include the correct exten-
sion. In the list of files, only files with the correct extension are displayed.

If the file does not appear in the list, check that you have chosen the correct file type from the
Files of type option menu, or select All from this option menu to view all files. 

csh/tcsh: setenv BABEL_DIR $SCHRODINGER/mmshare-vversion/data/babel

bash/ksh: export BABEL_DIR=$SCHRODINGER/mmshare-vversion/data/babel
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Selecting multiple files: You can import structures from more than one file at a time. To select
multiple input files, use the SHIFT and CTRL keys in combination with mouse clicks to select
as many files as you wish in the Files list, or click All Files to select all files in the Files list.

3.1.2 Selecting Import Settings

Once you have selected the files to import structures from, you must choose which structures
to import and how to display them. The options for these tasks are hidden by default, and can
be displayed by clicking Options. In addition to the options shown in the panel, there are some
options that can be set as preferences in the Preferences panel—see Section 14.2.4 on
page 343. These options are also described below. 

Selecting structures to import: Maestro can import multiple structures from multiple files. If
you do not want to import all structures from each file, deselect Import all structures. You can
then enter the index of the first structure in the Start text box, and the total number of structures
to import in the Total text box. You can import to the end of the file by selecting End instead of
specifying the total number. These settings are applied to all files: they cannot be set for each
file in a multiple file selection. To import different numbers of structures from a set of files,
select each file in turn and set the number of structures to import. 

If you want to import only the first structure from a Desmond CMS file, select For Desmond
files, import only first structure.

Importing associated data: If the structure file has other data associated with it, the data can
be imported into the project and associated with the relevant entries, by selecting Import asso-

ciated data files. The mapping of the data to the entries is done in a file with the suffix .smap.
This option is selected by default.

Reading alternate positions from PDB files: If the PDB file contains alternate positions, you
can read them by selecting For PDB files, read alternate locations. If this option is not selected,
the coordinates for the atoms with the highest occupancy are read, and the rest are ignored. You
can display alternate positions from the Workspace menu. 

Creating titles for SD structures: SD files often do not have a title property, so you must
choose one to display in the project from the options under For SD files, create titles from. The
default is SD molecule name. To specify an alternative property for the title, select SD property

and enter the property name in the text box. 

Creating groups: Structures can be added to the Project Table as single entries or as groups.
You can control how the entries are grouped on import by selecting an item from the Create
groups for option menu. By default, groups are created for files with multiple structures. The
groups are named after the file, minus the extension. You can also create a single group for all
structures from all imported files, and provide a name in the Group name text box.
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Mapping Maestro and SD properties: To map properties in an input Maestro file to different
properties in the project, select For Maestro files, modify property mapping. This allows resolu-
tion of property types as well as creation of a single project property from multiple sources.
The Map Properties dialog box opens when you click Open. In this dialog box you can select a
property from the project for each property in the input file (in the first structure). You can also
save and load property mappings, so you can use different mappings for different files or proj-
ects. Mapping of properties in SD files can be done similarly by setting a preference under
Project – Importing Structures in the Preferences panel—see Section 14.2.4 on page 343. 

At the same time, you can select the properties to import, using the check boxes in the Import

column of the Map Properties dialog box. Properties that are not imported cannot be mapped.

Selecting structures to display: When you import structures from a file, you can set options
to control which structures to display, and whether the structures already in the Workspace are
cleared or not. If Replace Workspace is selected (the default setting), Maestro automatically
clears existing structures from the Workspace. To import new structures without removing the
Workspace contents, deselect Replace Workspace. 

Other display options are available under Project – Importing Structures in the Preferences

panel—see Section 14.2.4 on page 343. Some of these are described below.

• To specify which structures are to be included in the Workspace, choose one of the
options from the Include in Workspace option menu: No Imported Structures, First
Imported Structure, or All Imported Structures. The default is First Imported Structure. If
you choose No Imported Structures and Replace Workspace is selected, the Workspace is
cleared.

• Structures that are imported are not necessarily centered on the coordinate origin, and
might not be visible even though displayed. To ensure that the view is centered on the
structures and zoomed to display all atoms upon import, select Fit to Workspace following

import. (This setting is persistent between Maestro sessions.) 

Opening the Protein Preparation Wizard: If you are importing a PDB file, you can select
Open Protein Preparation Wizard after importing PDB file under Project – Importing Structures
in the Preferences panel, to open the Protein Preparation Wizard panel automatically when the
structure is imported. You can then prepare the protein for use in various applications. 

Setting up pose viewing: If a pose viewer file is imported, you can perform the setup in the
Project Table automatically by selecting For pose viewer files, turn on pose viewing under
Project – Importing Structures in the Preferences panel. You can then immediately start
viewing poses—see Section 6.1 of the Glide User Manual for more information. This option is
selected by default.
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3.1.3 Interacting with the Import Process

If the import takes more than a few seconds, or there are errors on import, the Import Progress
dialog box opens. The dialog box shows which file is being read and how many structures have
been read. It also shows whether there have been any errors or warnings on import, and shows
the related messages in a text area. You can show or hide these messages by clicking the
Details button. You can also copy and paste the messages into another application with the
usual key strokes.

You can suspend import by clicking the Pause button. This allows you to examine any
messages that were generated, and choose whether to continue with the import or cancel it. The
button changes to Resume, so you can continue the import.

If you cancel the import, the structures imported successfully are kept. If you want to delete
these structures, click the Undo button or choose Edit → Undo in the main window.

When the import finishes, the dialog box remains open if there were any errors or warnings, or
if the messages area is displayed. The Cancel button changes to OK so that you can dismiss the
dialog box when you have finished examining the messages. 

3.1.4 Importing Structures from Another Project

You can import entries from another project, by choosing Project → Import from Project. A
project selector opens, in which you can select the desired project. When you have selected the
project, the Import entries dialog box opens. This dialog box lists the title and the PDB ID for
the entries, which you can select for import. When you click OK, the entries are imported,
along with all their properties and auxiliary data. The entries are selected, and the inclusion of
entries is governed by the options in the Import panel.

3.1.5 Importing Structures by Dragging onto the Workspace

You can import structures into Maestro by dragging one or more files from your window
manager’s file explorer onto the Maestro Workspace. The structures are imported in the same
way as using the Import panel, except that the first structure in the first file is added to the
Workspace, and the imported structures are added to the selection in the Project Table. Drag-
and-drop is supported for Maestro, SD, MOL2, XYZ, and PDB formats.

3.1.6 Importing Structures from the PDB Database

In addition to importing PDB files, you can import structures directly from the PDB database
or from a local copy of the PDB database. To do so, you can use the Get PDB File dialog box,
which you open from the Project menu. This dialog box runs the getpdb utility, which is
described in Section 2.3 of the General Utilities manual, and which you can use directly from
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the command line under Unix to extract a structure or a chain into a PDB file. 

Figure 3.2. The Get PDB File dialog box.

To import a PDB file:

1. Choose Project → Get PDB or click the Get PDB toolbar button. 

2. Enter the PDB ID in the PDB ID text box.

The ID can be in lower case or upper case.

3. If you want to download only a single chain, enter the name in the Chain name text box.

4. Select Auto, Retrieve from local installation or Download from Web.

Auto tries the local installation first, then downloads from the web as a fallback.

5. Click Download.

The structure is copied to your current directory as a PDB file and imported into Maestro, then
the dialog box closes. If you choose to retrieve the file from a local installation, the installation
used is the first found in the following list of locations:

• $SCHRODINGER_PDB 
• $SCHRODINGER_THIRDPARTY/database/pdb 
• $SCHRODINGER/thirdparty/database/pdb 

3.1.7 Error Reporting for PDB Files

When Maestro imports structures from PDB files, it attempts to place bonds according to a set
of standard residue templates, the CONECT records of the PDB file, and geometry. A few
amino acids require that choices be made as to where to place the double bonds and formal
charges. Schrödinger’s conventions for these choices are given in Table 3.1.
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If the placement of bonds or identification of atoms fails, the regions of the structure in which
problems were identified are assigned an atom property (i_m_pdb_convert_problem) that
records the type of error. This property can be used to color the structure by the conversion
status, with the PDB Conversion Status color scheme. The color scheme is given in Table 3.2.
This scheme is not used by default, but you can set a preference to color the structure by
conversion status on import in the Preferences panel—see Section 14.2.4 on page 343.  

Table 3.1. Placement of double bonds and formal charges for imported amino acids.

Amino Acid Pair Double Bond  Formal Charge

ARN/ARG between CZ and NH1 for ARG, +1 formal charge on NH1

ASP/ASH between CG and OD1 for ASP, -1 formal charge on OD2

GLU/GLH between CD and OE1 for GLU, -1 formal charge on OE2

Table 3.2. Coloring scheme for structures imported from PDB files.

Color Description

orange Non-standard residues connected by geometry and/or CONECT records. Unless 
duplicate CONECT records are specified, only single bonds are assigned, so you will 
need to add multiple bonds.

red Standard residue, but the input PDB file had missing atoms. 

blue A standard residue that has some atom names unknown to the standard connection 
template. The unrecognized atom names were connected by geometry. 

cyan An adjacent residue is listed in the SEQRES records but is entirely missing from the 
ATOM records, indicating a gap in the structure.

green A residue with alternate positions for the atoms, indicating partial occupancies. By 
default, all sets of positions are read and stored in the entry. The first set is the set that 
is displayed by default. 

gray Standard residues connected by standard templates. Confidence in bond orders 
assigned to these residues is high. 
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Maestro imports PDB files by running the utility pdbconvert, which is described in
Section 1.3 of the General Utilities manual. The conversion creates a temporary Maestro file,
and imports the structures from this file. Maestro displays warnings to indicate the status of the
PDB conversion, which are listed in Table 3.3. The atom property is stored in the project, and
can be used to select residues in the Atom Selection dialog box. 

3.1.8 Entry Names for Imported Structures

The names of project entries are not required to be unique. Maestro creates entry names that
are unique within the file imported by appending the index of the structure in the file to the file
base name. Thus, if you import structure 5 from file mystruct.mae, the entry name would be
mystruct.5. If valid entry names already exist, Maestro does not overwrite them. 

3.1.9 Reading Jaguar Input Files

Jaguar maintains its own input files, which include calculation options in addition to the
molecular geometry, and may also include molecular orbitals. Therefore, Jaguar has a separate
file reading mechanism. When you read input files through Jaguar, the structures are displayed
in the Workspace and Maestro-formatted files are created. 

To read input files through Jaguar, choose a task from the Jaguar submenu of the Applications
menu, then click Read in the Jaguar panel. The Jaguar Read file selector is displayed. Navi-
gate to the directory containing the file, and select the file. Choose the file type from the File

Format option menu, and change the Read as setting if necessary. Click OK to read the file.

For more information, see the Jaguar User Manual. 

Table 3.3. PDB conversion warning messages.

Status Message and Explanation

OK No message. Conversion appears successful.

WARNING “Problems found while converting file.” A temporary PDB output file was gener-
ated successfully, but the assignments were not all successful. 

ERROR “Could not convert file to formatname format.” The conversion failed, usually 
because the temporary output file could not be created. There may be a permis-
sions problem, or the disk may be full. Another reason for failure is the attempt to 
convert a file that has varying number of atoms in different MODELs.
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3.2 Exporting Structures

Using the Export dialog box, you can write out structure files in Maestro, PDB, Sybyl Mol2,
MDL SD, and SMILES formats, and in various other formats available through the program
Babel. You can use the Workspace contents or selected project entries as input, and you can
append structures to an existing file and retain additional information when the file format
allows it. When exporting project entries, Maestro provides options for exporting each selected
entry to its own file, or placing all selected entries in the same file.

Project data is automatically saved, unless you are running in a non-automatic synchronization
mode. The structures from a project are saved in a Maestro-formatted file, along with other
data. If you want to save just the structures and their associated data, or if you want to save
structures in other file formats, you can export the structures. 

Figure 3.3. The Export dialog box.
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To open the Export dialog box, do one of the following:

• Click the Export button in the main window or in the Project Table panel. 

• Choose Project → Export Structures in the main window.
• Choose Table → Export → Structures in the Project Table panel.
• Choose Export Structures from the entry group shortcut menu.

The Export dialog box is laid out in a similar fashion to the Import dialog box, as a standard file
selector, with an Options button to display or hide the options for making export settings. The
options are displayed by default.

When you have made all the necessary selections, click Export. A dialog box confirms that the
files were written. If a file by the specified name already exists, the Exporting-Overwrite?

dialog box is displayed and you must choose an action. 

3.2.1 Selecting a File

By default, structures are exported to a single file, which you can select as described below. It
is also possible to export structures to multiple files. 

Selecting a file format: To create a file, you must specify the file format. By default, the file
type is determined by extension, which means that you can enter the file name with its exten-
sion in the File name text box. You are warned if the extension is invalid. Otherwise, you can
select the type of file you wish to write from the types given in the Files of type option menu,
which include Maestro, PDB, Mol2, SD, MacroModel, and a range of file types converted by
Babel. The file extension in most cases is determined by the file type. Maestro, PDB, and SD
files can be exported as compressed (gzipped) files. Default file extensions for the files in the
first section of the menu can be set under General → File extensions in the Preferences panel.
Properties from the Project Table are exported as well as structures to Maestro and SD files,
and any relevant properties are exported to PDB files. SMILES files are exported as plain text
files with the extension .smi. The SMILES string for each structure is written on a separate
line, followed by the title (if it exists), from which it is separated by a space. 

Selecting a directory: To specify the directory to export to, you can enter it in the File name

text box, or navigate to it using the standard locations, the navigation buttons, or the option
menu at the top of the panel. The path displayed in the option menu and the lists are then
updated for the chosen directory. 

Selecting a file: If the file exists, you can select it from the list of files or enter its name in the
File name text box. If you want to export to a new file, enter the name in the File name text
box, including an absolute or relative path if you want.
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3.2.2 Selecting Export Settings

Once you have selected the file to export structures to, you can make choices about which
structures to export and how to export them. You can display the options for these choices by
clicking Options. 

Appending or overwriting files: To append a structure to an existing file, select Append. If
the file exists and you do not select Append, it is overwritten. 

Maestro file format: If you want to export a Maestro file for use in an earlier release, you can
select Use v1 format (Suite 2012) when writing Maestro files. The v2 format reduces the size of
the Maestro file by removing redundant space and information, so it cannot be used in earlier
releases. 

PDB file records: When writing a PDB file, you can include the SEQRES, HELIX, SHEET,
TURN, and SSBOND records in the file by selecting Write SEQRES, HELIX, SHEET, TURN,

and SSBOND information. You can write out duplicate CONECT records to store information
on the bond order, by selecting Write multiple bonds as duplicate CONECT records. If you
deselect this option, only one record is written per bond, regardless of bond order. 

You can also ensure that the atoms are written out in ascending order of residue number, by
selecting Reorder by residue number. This option ensures that all the atoms from a given
residue are in a contiguous block in the PDB file. It is useful if atoms have been added to the
structure, as added atoms are placed at the end of the atom list and are not next to other atoms
from the same residue.

SD file format: If you are saving an SD file, you have the choice of writing it in V3000 format
by selecting Use V3000 format when writing SD files. This is a a free-format version that allows
the writing of structures with more than 999 atoms. The default is to use the V2000 format for
SD files, which is fixed-format.

The property names in the SD file can be written out with names as they appear in the Project
Table (the display name), by selecting Use display names when writing SD files. The default is
to write the internal names, which have prefixes that indicate the type and origin of the prop-
erty and spaces replaced with underscores. When an SD file from another source is imported,
the property names do not have type and origin information. The name in the SD file is used as
the display name, and an internal name is constructed that adds the type and origin prefixes, for
internal use in Maestro. If you are exporting a file for use in other applications, you should
select this option, particularly if you are transferring data between Maestro and other applica-
tions using SD files and want to maintain consistent naming.
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Specifying the source of the structures: You can save structures directly from the Workspace
or write files containing structures from one or more project entries. To write out the contents
of the Workspace to a file, choose Workspace (all atoms) from the Structure source to be

exported option menu. This is equivalent to writing the included entries. If you only want the
displayed atoms to be written to a file, choose Workspace (Displayed atoms only). The atoms
are written as a single structure, even if there are multiple entries in the Workspace. To write
out the entries that are selected in the Project Table, choose Project Table (selected entries). If
there are no selected entries in the Project Table, Workspace is selected by default.

Specifying the properties to export: You can export all properties from the Project Table, the
properties that are shown in the Project Table, or the properties that you select, by choosing All,
Shown, or Selected from the Properties to be exported option menu. To change the shown
properties, choose Property → Show in the Project Table panel. To select properties for export,
choose Select from the option menu, then click the Select button. A property selector opens, in
which you can choose the properties. The property selection is stored in the project for later
use and as a user preference. Initially, the selection is set to the shown properties.

The properties are written in the order in which they appear in the Project Table. You can
change the order of the properties in the Reorder Properties dialog box (see Section 9.11.15 on
page 246).

Exporting to single or multiple files: You can export entries to a single, multi-structure file,
to multiple files each of which contains a single entry, or to multiple files each of which
contains all the entries from a single entry group. From the Files option menu, choose Export

all entries to the same file, Export each entry to a different file, or Export each entry group to a

different file. If you export to one of the Babel-supported formats, you can only export a single
structure to each file, so you must choose Export all entries to a different file. The exception is
XYZ (or MYZ) format, which supports multiple structures in a single file. 

3.2.3 Exporting Multiple Files

If you want to save each entry or each entry group to a separate file, you must specify how to
name the files by choosing one of the naming schemes from the File Names Are option menu.
The naming schemes are described below. 

Note: Because entry names, entry titles, and group titles are not unique, choosing any option
that involves the names or titles does not guarantee that the file name is unique. You
must make sure that these names or titles are unique. Otherwise, Maestro will offer to
either overwrite a previously created file with the same name or to skip writing the file,
and in either case not all the entries will be exported.
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File name + entry name 
File name + group title

If you choose File name + entry name or File name + group title, you must select a file or type
in a file stem. The entry name or group title and the file suffix are appended to the file stem. If
you choose a file name, the suffix is the suffix of that file name. For example, if you are
exporting the entries combination-3, combination-4, and combination-5 as separate files,
and you select the file structure.maegz, the new files are named

structure_combination-3.maegz
structure_combination-4.maegz
structure_combination-5.maegz

If you typed in the file stem HIV, the following files would be written, with the default exten-
sion .mae (or the extension for the selected file type):

HIV_combination-3.mae
HIV_combination-4.mae
HIV_combination-5.mae

File name + entry ID 
File name + group ID

If you choose File name + entry ID or File name + group ID, you must select a file or type in a
file stem. The entry ID or group ID and the file suffix are appended to the file stem. If you
choose a file name, the suffix is the suffix of that file name. For example, if you are exporting
the entries with IDs 3, 4, and 5 to separate files, and you select the file structure.mae, the
new files are named

structure3.mae
structure4.mae
structure5.mae

File name + automatic number 

If you select File name + automatic number, you must specify a filename. The files are given
the same name and extension as the selected file, but numbers are added in sequence to the
base file name. For the example above, with the file structure.mae, the new files are named

structure_1.mae
structure_2.mae
structure_3.mae
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Just entry names 

If you choose Just entry names, the file name is constructed from the entry name, and the File

name option menu becomes unavailable. You can choose the file type from the Files of type
option menu as usual. For the above example, the new files are named

combination-3.mae
combination-4.mae
combination-5.mae

and a dialog box confirms that the files were written to the desired directory.

Just entry titles 
Just group titles

If you choose Just entry titles or Just group titles, the file name is constructed from the entry
title or group title, with special characters and blanks replaced with underscores (_). For two
entries with titles “Acetic acid” and “Methyl salicylate”, the new files are named

Acetic_acid.mae
Methyl_salicylate.mae

The File name option menu is unavailable in this case. You can choose the file type from the
Files of type option menu as usual.

3.3 Exporting Data to a Spreadsheet

The Project Table does not have full spreadsheet capabilities, but you can export data to a
spreadsheet file, manipulate it in a spreadsheet program, then re-import it into Maestro.
Exporting data to a spreadsheet file is done from the Export Spreadsheet panel. The data that
you can export are the properties in the Project Table. To export data, you must first open
Project Table panel, which you can do by choosing Project → Show Table in the main window
or clicking the Open/Close project table button on the toolbar.

When the Project Table panel is displayed, choose Table → Export → Spreadsheet. The Export

Spreadsheet panel is displayed. The layout of this panel is similar to that of the Export and
Import panels, with standard file navigation and selection tools, and an Options button for
showing and hiding the settings. 

Selecting a directory: To specify the directory to export to, you can enter it in the File name

text box, or navigate to it using the standard locations, the navigation buttons, or the option
menu at the top of the panel. The path displayed in the option menu and the lists are then
updated for the chosen directory. 
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Selecting a file: If the file exists, you can select it from the list or enter its name in the File

name text box. If you want to export to a new file, enter the name in the File name text box.
You can specify an absolute or relative path in the File name text box in addition to the file
name. Existing files will be overwritten. 

The selection of entries, properties and delimiter is made in the settings section, which you
show or hide by clicking Options.

Selecting entries to export data from: The Entries option menu allows you to choose
different classes of entries to export data from: All, Shown, Selected, and Included. The default
is All. For more information on showing, selecting, and including entries, see Section 9.5 on
page 197 and Section 9.6 on page 203.

Selecting properties to export: You can choose whether to export all properties, the shown
properties, or your choice of properties by selecting All, Shown, or Selected from the Proper-

ties option menu. The row number and the inclusion state are not exported. All other properties
can be exported, including the Booleans represented in the Title column for the auxiliary data.
To limit the range of properties exported, you can hide columns by using the Properties

shortcut menu in the Project Table panel (right-click in the column heading), then export only
the shown properties. Alternatively, you can choose the properties to export, by choosing
Selected from the Properties option menu, clicking Select, and selecting the properties in the
property selector that opens. The property selection is stored in the project for later use and as
a user preference. Initially, the selection is set to the shown properties. 

The entry title is always in the first column in the exported file. 

Selecting a delimiter: You can choose from the two standard delimiters, a comma and a tab
character, or choose other, then enter your own delimiter in the text box. 

Once you have made your selection, click Save in the Export Spreadsheet panel.

3.4 Importing Data From a Spreadsheet

Once you have exported data from Maestro and manipulated it in a spreadsheet, you can re-
import the data into Maestro. You can also import data that did not originate from Maestro.
Importing data from a spreadsheet file is done from the Import Spreadsheet dialog box, and the
data is added to entries in the Project Table. The data that you import must therefore match
entries in the project. For data that you exported from Maestro, matching should be no
problem, but for data that did not originate from Maestro, you must ensure that there is a
proper match to the entries in the Project Table. 
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To import data, you must first open the Project Table panel, which you can do by choosing
Show Table from the Project menu in the main window, or clicking the Open/Close project
table button in the toolbar.

When the Project Table panel is displayed, choose Table → Import → Spreadsheet. The Import

Spreadsheet panel is displayed. Like the Export and Import panels, this panel is a standard file
selector, with options added. To select a file to import data from, you can navigate to it with the
file selection tools, or enter its name in the File name text box. 

When the properties are imported, you can add them to the selected entries or to all entries, by
selecting an Import properties for option.

If you want to add values only where the project does not have values, deselect Overwrite
existing data. Otherwise, existing values are replaced with values from the spreadsheet and new
values are added.

When you have selected the file and set any options, click Open. The Choose Import Key

dialog box opens. In this dialog box, you determine how the rows of the spreadsheet are
mapped to the entries in the Project Table, and select the delimiter. The File key column lists
the properties in the spreadsheet file. The values of the key that you choose in this column are
matched to the values of the property that you choose in the Match to property in Project Table

column. You must choose a property from each column—for example, if both the spreadsheet
and the Project Table have a Title property, you can match the rows by title. If the file key value
for a given row in the spreadsheet matches more than one entry, the properties for that row are
copied to all entries; if several file key values match a single entry, the row for the last file key
value that matches is used to import data. 

Figure 3.4. The Choose Import Key dialog box.
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By default, the Entry ID property is selected in the Match to property in Project Table column
and also in the File key column if the file contains the entry ID as a property. These defaults
allow you to easily import data for entries whose properties were exported: the imported data is
associated with the correct entries because the entry ID is unique. 

To continue, choose the delimiter that is used in the spreadsheet file, then click OK. If all the
properties in the spreadsheet already exist in the Project Table, they are imported immediately.

If any properties do not exist in the Project Table, the New Property dialog box opens. This
dialog box lists the property name, the property type (Boolean, Integer, Real, or String), and
number of decimal places for real properties. To change the property type, select the properties
in the table (use shift-click and control-click for multiple properties), choose the property type
from the Type option menu, and click Set. For real properties, you can set the number of
decimal places to display in the Decimal places text box before clicking Set. The default preci-
sion is set as a preference—see Section 14.3.1 on page 345 for more information. When you
click OK, the properties are imported with the specified types. 

Figure 3.5. The New Property dialog box.

3.5 Exporting Structures and Data to a Canvas Project

You can export the selected entries in the Project Table panel with their properties directly to a
Canvas project, and open the Canvas GUI with that project loaded. To do so, choose Table →
Export → To Canvas in the Project table panel, or right-click in the selected entries and choose
Export to Canvas. The Export to Canvas dialog box opens, and offers the following choices for
how the structures are exported:

• New Canvas project—Create a new Canvas project with these structures and properties.

• Existing Canvas projects—Add the structures to an existing project, either by appending
the structures, or replacing existing structures. 
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Figure 3.6. The Export to Canvas dialog box.

When you click OK in this dialog box, a file selector opens so that you can navigate to a loca-
tion and name the new Canvas project or choose the existing Canvas project. Once the project
is created or updated, the Canvas GUI is started with the specified project already loaded.

3.6 Exporting Data from a Table

You can export data from any table in Maestro, either in CSV or HTML format. To do so,
right-click in the table and choose the format from the Export Table Data submenu. A file
selector opens in which you can navigate to a directory and enter the file name. The table must
have some data in it to export. The file that is written includes the column headings as well as
the data. The HTML file contains just the table.

3.7 Copying and Pasting Structures

You can import structures by pasting them into the Workspace. The structure must be a
SMILES string that was previously copied to the clipboard (not the paste buffer on Linux). On
Windows, you can copy a structure in ChemDraw or ISIS/Draw and paste it into the Work-
space.

A new project entry is created for the structure, with the SMILES string as the title. The struc-
ture retains any stereo (R/S or E/Z) properties it has. You can paste the structure in 2D, by
choosing Edit → Paste or pressing CTRL+V. SMILES strings are converted to 2D structures,
which are then placed with the centroid at the coordinate origin. If the coordinate origin is
outside the viewing area, you will not see the structure when you paste it and you will have to
click Fit to Workspace to see the structure. 

If you want to paste the structure at another location, choose Edit → Paste Special → By

Placing, or press CTRL+SHIFT+V, then click in the Workspace where you want the centroid of
the structure to be located. The cursor changes to a plain arrow for this operation, because you
are picking a point rather than atoms. 
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If you want to use the structure for modeling, you must convert it to a 3D structure, by using
LigPrep for example. The structure retains stereo (R/S or E/Z) properties, which can be used
by LigPrep to ensure the correct stereochemistry. A minimized 3D structure can be generated
when you paste the structure, by choosing Edit → Paste Special → As 3D. This feature uses
tools from LigPrep but does not allow any of the flexibility that is available in LigPrep.

You can also copy atoms from a structure in Maestro with Edit → Copy or CTRL+C (C), and
paste them into the Workspace with Edit → Paste or Edit → Paste Special → By Placing. If
there is nothing in the Workspace, a new entry is created with a default title. If there is a single
entry in the Workspace when you paste, it is added to this entry. If there are multiple entries in
the Workspace when you paste, you are prompted to choose an entry to add the atoms to, or to
create a new entry. When you copy (or cut) the atoms, any bonds between the copied atoms and
the rest of the Workspace structure are broken and capped with hydrogen atoms. You can also
paste the copied structure into ChemDraw.

Another option is to copy atoms as a SMARTS pattern, by selecting atoms in the Workspace
and choosing Edit → Copy as SMARTS. The SMARTS pattern can then be pasted anywhere
that accepts SMARTS as input—into text boxes in other panels in Maestro, for example. You
can set preferences for some of the notational elements in the SMARTS pattern—see
Section 14.15 on page 382.
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Chapter 4: Viewing the Workspace
The view of the objects in the Workspace can be changed in a variety of ways, and you can
save the view for later use. This chapter describes the different views that are available, how
you can change them, and how you can manage them. It also describes viewing effects such as
tiling, stereo viewing, perspective, and fog. 

4.1 The View Toolbar

The View toolbar provides tools for changing the view of the Workspace. These buttons are
described briefly below, and in more detail in later sections. See Section 2.4 on page 17 for
general information on toolbars.

Fit 
Fit the selected atoms (or all atoms, if there is no selection) to the Workspace.
Menu equivalent: View → Fit to Workspace → Selected atoms.

Fog 
Turn fogging on or off, or select automatic fogging when the Workspace has more than 40 
atoms.
Menu equivalent: View → Fog → On/Off/Automatic.

Enhance 
Enhance depth cues.
Menu equivalent: View → Fog → Enhance Depth Cues.

Rotate X 
Rotate the Workspace around the x axis by 90 degrees.
Menu equivalent: View → Rotate X 90.

Rotate Y 
Rotate the Workspace around the y axis by 90 degrees.
Menu equivalent: View → Rotate Y 90.

Tile 
Arrange the Workspace entries in a rectangular grid of “tiles”. From the button menu you can 
choose to move tiles, transform tiles separately or together, choose how to tile the entries.
Menu equivalent: View → Tile.

Reset 
Reset the rotation, translation, and zoom of the Workspace to the default state (coordinate x 
and y axes in the plane of the screen, z axis perpendicular to the screen).
Menu equivalent: View → Reset.
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4.2 Changing the View

The view that is presented in the Workspace can be regarded as the image that you see through
a video camera. Changing the view is like moving the camera to a new location or a new angle,
or zooming in or out. Changing the view does not change the coordinates of any of the objects
in the Workspace, it merely changes the camera angle, location, and zoom. However, you can
apply the current view to change the coordinates of the Workspace objects by choosing Edit →
Update Coordinates.

The view is stored as a coordinate system, with an origin (location), an orientation (angle), and
a scale factor (zoom). The coordinate system in Maestro is oriented so that the positive z axis
points out of the screen, the x axis is the horizontal axis, and the y axis is the vertical axis. The
default view is the coordinate system and scaling of the structures in the Workspace.

Changing the view is done with a “global transformation” of the coordinate system: a transla-
tion, a rotation, or a zoom. Rotation, translation, and zoom actions are assigned to combina-
tions of mouse buttons with the SHIFT and CTRL keys. The default assignments for a 3-button
mouse with a scroll wheel are given in Table 4.1. For information on the mappings for this and
other mouse or trackpad configurations, open the Customize Mouse Actions panel (Maestro →
Customize → Mouse Actions). You should take care that you do not click instead of drag,
because clicking might have a particular action associated with it in the context in which you
are working, and change the structure. The following sections give more details on doing
global transformations. 

Table 4.1. Mapping of Workspace operations to mouse actions.

Operation Action

Rotate about the x- and y-axes Drag with middle mouse button

Rotate about the x-axis only Drag vertically with SHIFT and middle mouse button

Rotate about the y-axis only Drag horizontally with SHIFT and middle mouse button

Rotate about the z-axis Drag horizontally with CTRL and middle mouse button

Spot-center on an atom Right-click

Translate in the x-y plane Drag with right mouse button

Translate along the y-axis Drag vertically with SHIFT and right mouse button

Translate along the x-axis Drag horizontally with SHIFT and right mouse button

Translate about the z-axis Drag horizontally with CTRL and right mouse button

Zoom Drag horizontally with middle and right mouse buttons or with 
SHIFT+CTRL and middle mouse button; use the scroll wheel; 
use the pinch gesture.
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4.2.1 Translating the View

Translations can be carried out with the right mouse button, as described in Table 4.1.

You can perform translations in increments along the x, y, and z axes with the keyboard keys
and the corresponding items under View → Translate. The keys are described in Table 2.7 on
page 32.

You can also do a translation by “spot-centering”, an action that places the coordinate origin of
the view on a particular atom, which then appears at the center of the Workspace. As a conse-
quence, subsequent rotations of the view are performed about this atom. This action is done by
right-clicking on the atom. 

In addition to the mouse controls, a number of global transformations are available from the
View menu and the main toolbar. 

4.2.2 Rotating the View

In addition to the rotations that can be performed with the middle mouse button, there are a
number of other actions that perform a rotation. 

On the toolbar, there are two buttons for rotation by 90° about the x axis or the y axis: 

These buttons have corresponding menu items, View → Rotate → X 90 and View → Rotate →
Y 90. 

You can perform rotations in increments about the x, y, and z axes with the keyboard keys and
the corresponding items under View → Rotate. The keys are described in Table 2.7 on page 32.

Another rotation that you can perform is to align the view so that selected atoms are lying on
one of the Cartesian axes or planes. This action is performed in the Align Atoms panel, which
you open by choosing View → Align. 

To align two atoms to one of the Cartesian axes, select the axis, select Pick atoms, then pick the
two atoms. A purple cube is drawn around the first atom when you pick it, and the alignment is
performed when you pick the second atom. The view is rotated through the smallest possible
angle to perform the alignment.
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Figure 4.1. The Align Atoms panel.

To align three atoms to one of the Cartesian planes, select the plane, then use the picking tools
in the Pick atoms to align section to pick the three atoms. When the third atom is picked and a
check is performed to ensure that the plane is uniquely defined (i.e. the atoms are not
collinear), a blue-green plane is displayed in the Workspace, and the Align button becomes
available. Click this button to perform the alignment. The view is rotated through the minimum
angle required to bring the selected atoms into alignment with the chosen plane. If you do not
want to see the plane, deselect Markers.

When you have done the alignment, you can also change the coordinates of the structure to
those of the current view, by clicking Update Coordinates. The structure itself is then aligned
on the axis or plane, and not just the view of the structure.

4.2.3 Zooming In and Out

Zooming in and out can be done with the scroll wheel, with the middle and right mouse buttons
(held down together), with SHIFT+CTRL and the middle mouse button, or with the pinch
gesture on a trackpad. The keys K and J are assigned to zooming in and zooming out, in small
increments. Each press of one of these keys corresponds to one click of the scroll wheel, and
you can hold the keys down for continuous zoom. 

Another way of zooming is to use the Fit to Workspace button on the toolbar, which zooms in
or out so that the atom selection fills the Workspace (or all atoms, if there is no selection). 

You can perform a fit to the Workspace from the View menu. The Fit to Workspace submenu
offers the choices of Selected Atoms (shortcut Z), All, or Ligand (shortcut L). Choosing All
allows you to fit the entire structure to the Workspace without changing the selection.
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4.2.4 Restoring the Default View

To restore the view to the default view, in which the view axes are aligned with the coordinate
axes of the structure, click the Reset View button on the toolbar.

4.2.5 Setting the View Origin and Rotation Center

By default, the origin of the view coordinate system moves when you translate a structure, so
that rotation of the view has the same effect on the structures no matter where they are trans-
lated to. The origin is changed by spot-centering, which was described in Section 4.2.1 on
page 65. The origin is reset when you restore the default view, and it is also set when you do a
Fit to Workspace. 

If you want the center for rotation to stay at the same location regardless of how you translate
the structures, you can set a preference in the Preferences panel. Choose Maestro → Prefer-
ences to open the panel, then in the Workspace tab, select Keep center of rotation fixed while

translating. The rotation center is then decoupled from the translation origin, and remains at the
location of the view origin when you selected the option. If you want the center for rotation to
stay at the center of the Workspace, reset the view first, then select the option. 

If you want to display the center for rotation, select Display center of rotation in the Workspace
tab of the Preferences panel.

4.3 Saving, Restoring, and Managing Views

When you have set up the view of the Workspace for a particular purpose—for example, with a
particular view of a binding pocket—you can save the view for future use. Views can be saved
with a name, restored, and even played through. The tools for working with views are available
from the View menu and the Saved Views toolbar, which you display by choosing Window →
Toolbars → Saved Views, or by clicking the Saved Views button on the Manager toolbar. The
toolbar buttons are described below. 

Save 
Save the current view of the Workspace (orientation, location, and zoom) as a saved view. 
Opens a dialog box in which you can name the view.
Menu equivalent: View → Save.

Previous 
Apply the previous view in the list of saved views to the Workspace. 
Menu equivalent: View → Restore View → Previous.
Maestro 10.2 User Manual 67



Chapter 4: Viewing the Workspace

68
The Manage Views panel contains tools for all view operations. You can open this panel by
choosing View → Manage Views, or clicking the Manage views button on the Views toolbar.

Figure 4.2. The Manage Views panel.

To save a named view, choose View → Save View or click the Save view button on the Views

toolbar: 

Next 
Apply the next view in the list of saved views to the Workspace. 
Menu equivalent: View → Restore View → Next.

View 1 
Apply the first saved view to the Workspace. The other four numbered buttons apply the spec-
ified view number. These buttons are always assigned to the first five views listed in the Man-
age Views panel. Buttons that do not have a corresponding view are not available.
Menu equivalent: View → Restore View → ViewN.

Manage 
Manage the saved views. Opens the Manage Views panel, in which you can select views to 
show, play through views, record movies of the views, import and export views, save and 
delete views, and animate view changes. 
Menu equivalent: View → Manage Views.
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The Save View dialog box opens, in which you can enter a name for the view. The default
name is viewN. If you want to save views with the default name rather than explicitly naming
them, you can select Use default name under When saving views in the Manage Views panel.
The Save View dialog box is no longer displayed, unless you select Prompt for name. 

The translation, rotation, and zoom are stored in the named view, and the new view is saved in
the project. Once the view is saved, it is listed on the Restore View submenu of the View menu
and entered into the table in the Manage Views panel. If it is in the top five views in this table,
it is associated with a button on the Views toolbar. 

Named views store information only about the state of the “camera”—the location, angle, and
zoom. They do not store any information about the content of the Workspace. This means that
you can, for example, set up a view of a protein, then at some later point, display the protein
from the same angle with a ligand in the binding pocket. 

To restore a saved view, use one of the following methods:

• Choose View → Restore View → view-name 
• Click the button for the view on the View toolbar (if it has one)
• Select the view in the Manage Views panel and click Restore 

In addition to restoring a single view, you can step through a sequence of views manually, or
play through a sequence of views with a given display time for each view, and you can export a
movie of the sequence of views.

The views that are played can be selected by checking the check box in the Play column of the
Views table. Only the checked views are played with the play controls. These controls also
apply to saving a movie of the views. 

To step through views manually, click the Previous view or Next view button on the Saved

Views toolbar, or in the Manage Views panel. You can also use the View → Restore View

submenu items to step to the previous or next view.

To play through the views continuously, use the controls in the Manage Views panel. 

If you want the view changes to be smooth rather than instantaneous, select View animation in
the Animation section, and set the duration of the animation. If the distances the structures
move are large, you can control when the animation is used by selecting Limit animation

distance and entering the distance above which animation is turned off in the Maximum

distance text box. 
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The animation time can be coordinated with the length of time each view is displayed to
produce a continuous movement. The view time is set in the Pause Time column of the Views
table. If you want to set the pause time for multiple views, select them in the table, enter a
value in the Set pause times to text box, and click Set. 

To save a movie in MPEG format with the chosen play list and duration settings, click Record

Movie, and navigate to a location and name the movie file. The movie does not record anima-
tion of view changes.

To delete views, select them in the Views table and click Delete.

Since views are saved in the project, they are not automatically available when you close the
project. To transfer views between projects, you can import and export them, by using the
Import and Export buttons. These buttons open file selectors, in which you can navigate to a
location and name the view file. 

4.4 Tiling the Workspace

Sometimes you want to see several structures or surfaces in the Workspace separated from
each other, rather than superimposed. This can be done by tiling the Workspace contents,
which rearranges the objects in a grid pattern in the Workspace. There are three ways that you
can tile the Workspace, or tiling modes, which can be selected from the Tile submenu of the
View menu or the Tile button menu on the View toolbar.

• Tile by Entry—This is the default mode, in which each entry in the Workspace occupies a
separate tile, except for fixed entries, which are displayed in every tile.

• Tile by Entry Groups—In this mode, all entries that are in the same entry group are dis-
played in the same tile. This mode allows you, for example, to display several proteins
with their ligands in the Workspace, and use the ePlayer to step through ligands for a
given receptor.

• Tile by Surface—In this mode, each surface that is displayed in the Workspace is placed
in a separate tile, along with the corresponding structure. Surfaces for fixed entries are
displayed in every tile, and entries that are displayed in the Workspace that do not have
surfaces are displayed in their own tiles, at the end of the grid (i.e. they are treated as hav-
ing a single surface that is null). This mode allows you to display multiple surfaces for a
single entry in separate tiles, such as molecular orbitals or SiteMap surfaces.

To perform the tiling, choose View → Tile → Tile Workspace, or click the Tile button on the
View toolbar. 
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The button is highlighted, to indicate that you are in tile mode. To undo the tiling, click the Tile

Entries button again. You can also enter and exit tile mode by choosing View → Tile →Tile
Workspace or pressing CTRL+L. Information on individual transformations is discarded when
you exit tile mode.

The tiles are initially arranged according to the order in which the entries were included in the
Workspace. There are two ways of rearranging the tiles. The first is to exclude an entry and
then include it again. This entry is placed at the end of the grid of tiles. The second is to move
individual tiles. To move tiles, first choose Pick Tiles to Move from the Tile button menu or
from the Tile submenu of the View menu. Then click on a tile to select it for moving, and click
on the desired new location. As you move the pointer, the location where the selected tile will
go if you click in the current tile is marked by a purple line. The tiles between the initial loca-
tion and the final location are moved to fill the space left by moving the selected tile, and the
selected tile is placed in the new location. When you have finished moving tiles, deselect Pick
Tiles to Move.

Each tile is a mini-Workspace, in which you can perform all the operations that are available
when the Workspace is not tiled. Transformations (rotation, translation, zoom) can be
performed on all tiles simultaneously, or on individual tiles. To perform simultaneous transfor-
mations, select Transform All Tiles from the Tile entries button menu (or the Tile submenu of the
View menu). This option is selected by default. If you deselect this option, you can transform
individual tiles. Clicking in a tile selects the tile, which is marked by a thicker border. To trans-
form an individual tile, start the transformation operation when the pointer is in the tile. You
can drag outside the tile to finish the transformation operation, but to start another operation on
the same tile, you must move the pointer back into the tile. 

To reset the view in each tile to the initial view, choose Reset All Tiles from the Tile button
menu (or View → Tile → Reset All Tiles). To reset the view in an individual tile, right-click in
the tile and choose Reset Tile from the shortcut menu.

To apply the view or zoom for an individual tile to all tiles, right-click in the tile and choose
Apply View to All Tiles or Apply Zoom to All Tiles from the shortcut menu.

When the Workspace is tiled, you can save an image that shows the tiled Workspace.

Some actions do not behave the same in tile mode as out of tile mode.

• Adding atoms in Draw or Place mode by clicking in an empty part of the Workspace adds
the atoms to the scratch entry. If the scratch entry is not in the tile you clicked in, the
atoms will not appear in that tile, but rather in the scratch entry tile. If you draw or place
atoms by clicking first on an existing atom, the behavior is normal: atoms are added to the
structure that you clicked on.
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• Saving a view only saves the current global transformation, and does not preserve
changes made in individual tiles. Consequently, restoring a view applies the same view to
each tile, and does not preserve changes made in individual tiles.

4.5 Using the Full Screen

If you want to make use of the full size of your monitor to view the Workspace, you can enter
full-screen mode, by choosing Workspace → Full Screen, or pressing CTRL+=. In this mode,
the only components of the main window that are visible by default are the Workspace, the
menu bar, and the Auto-Help bar. You can use the Window menu to display the toolbars, open
hidden panels, and perform other window-related actions.

To exit full-screen mode, press ESC. 

Another way to make use of your monitor is to simply maximize the main window instead of
entering full screen mode. The main window components that you have displayed occupy
some space, but you can undisplay many of these components if you want the extra space.

4.6 Clipping

How much you can see of the structures that are in the Workspace depends on whether you
have zoomed in or out, and also on where the structure is “clipped”. Clipping is used to limit
the parts of a structure that are displayed in the Workspace, by defining clipping planes perpen-
dicular to the z axis (or parallel to the screen) and displaying only the parts of the graphical
image that are between these planes. Anything that is in front of or behind these planes is not
displayed. Clipping is useful when working with large structures containing many atoms, in
which it can be hard to see certain atoms and even harder to pick those atoms.

The part of the structure that is displayed in the Workspace is indicated in the clipping planes
window. This window is located in the lower-right corner of the Workspace. By default, it is
not displayed. You can display it by choosing Window → Clipping Planes.

The display in the clipping planes window consists of the following features:

• Top view of structures: A representation of the structures in the Workspace, drawn in
the wire frame representation. The view of the structures is from the top, that is, from the
positive y direction looking down to the negative y direction. The back of the structure is
in the upper part of this window while the front is in the lower part of this window.

Zooming in and out on the structures in the top view is controlled by a preference. If you
select Zoom clipping planes with Workspace under Workspace → Clipping Planes in the
Preferences panel (see Section 14.4.8 on page 351), the top view zooms in and out as you
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zoom in and out in the Workspace. If you deselect this option, the top view stays the
same, regardless of what happens in the Workspace. Translation in x and z moves the dis-
played structures. 

• Clipping planes: These are horizontal lines that mark the planes where the graphical
image is clipped. The lower line marks the plane that is closest to the viewer, and the
upper line marks the plane furthest from the viewer. 

The planes can be moved by dragging the horizontal lines. To move both planes in the
same direction, hold down the CTRL key and drag one of the planes or use the scroll
wheel. To move both planes in opposite directions, hold down the SHIFT key and drag
one of the planes or use the scroll wheel. You can use the keyboard to move the planes
closer together (F), further apart (G), towards you (=), or away from you (-), in small
increments. These actions are also available from View → Move Clipping Planes.

The clipping planes are adjusted if you select Adjust clipping planes when focusing on a

substructure under Workspace → Clipping Planes in the Preferences panel (see
Section 14.4.8 on page 351) and you do one of the following:

• Select part of a structure and perform a fit-to-Workspace.
• Perform a fit-to-ligand.
• Middle-click a residue in the sequence viewer to zoom in on it.
• Select a residue in the residues table of the Density Fit panel (PrimeX)
• Select a rotamer in the Residues table of the Rotamers dialog box.
• Find a residue with the Find toolbar.

• Viewing volume indicator: This is a green box that represents the viewing volume. As
you zoom in on the structure, the box shrinks. If you have perspective enabled, the view-
ing volume box is trapezoidal, with the small side at the bottom.

Clipping can be applied to fit objects in the Workspace, by choosing To All Atoms, To Selected

Atoms, or To Ligand from the Move Clipping Planes submenu of the View menu. This feature
can be used to reset the clipping without changing the zoom. 

Clipping can be applied selectively, as well as to all graphical objects. To choose what clipping
is applied to, right-click in the clipping planes window and make your choice from the shortcut
menu that is displayed. The choices are:

• All—Apply clipping to all objects (structures and surfaces). Clipping planes are drawn as
horizontal orange lines, and can be adjusted by dragging.

• Surfaces—Apply clipping to surfaces but not to structures. There are four clipping
planes: front, back, left, and right. These planes are drawn as horizontal and vertical pur-
ple lines, and can be adjusted by dragging.
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• Surfaces to selected atoms—Apply clipping to the surfaces using a cube centered on the
selected atoms. For example, you might select just the ligand in a ligand-receptor com-
plex, and the surface will be clipped to a cube that contains the ligand. The outline of the
cube is displayed in cyan. You can resize the cube by dragging horizontally.

• Selected atoms—Apply clipping only to the selected atoms. For example, you could
select the receptor in a complex, and leave the ligand unclipped. Clipping planes are
drawn as horizontal cyan lines, and can be adjusted by dragging.

4.7 3D Viewing

Maestro provides several tools to enhance the 3D appearance of complex structures. These
tools include stereo viewing, perspective, fogging distant atoms, and depth cues. They are
described in the sections that follow. Most of the tools are in the 3D and Fog tabs of the
Appearance panel, which you can open by choosing View → 3D Options or View → Fog →
Settings.

4.7.1 Stereo Viewing

Maestro provides two kinds of stereo viewing method: software stereo and hardware stereo.
Software stereo can be run on any computer, and can be run across a network or with remote
display software, such as NX or Remote Desktop. It usually involves displaying both images
on the screen simultaneously, and relies on focusing or simple devices to view the stereo effect.
Hardware stereo requires some special equipment—a specialized monitor or graphics card, or
both, and 3D glasses. It can usually only be viewed locally. 

Two software stereo methods are available. In the first, two images are displayed simultane-
ously on separate parts of the screen, and the stereo effect relies on focusing your eyes so that
the images appear to merge into a single image. Two variants of this method are available:
“wall-eyed”, in which the left eye looks at the left image and the right eye looks at the right
image (focusing at a very long distance); and cross-eyed, in which the left eye looks at the right
image and the right eye looks at the left image (focusing at a very short distance). Neither of
these variants needs any special hardware, though a device for screening out one image for
each eye may be useful. The default variant is wall-eyed. 

The second software stereo method is anaglyph stereo, in which the images are superimposed
and are drawn with color filters, red and blue-green. To view the stereo effect, you need a pair
of glasses with the appropriate color filter for each eye. The images have full color, but the red
colors are not as true as when you do not view in stereo. 
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Figure 4.3. The Stereo tab in the Appearance panel.

For hardware stereo, Maestro supports both quad-buffered hardware stereo and horizontally
interlaced stereo. Details of the hardware and software requirements can be found in the Instal-
lation Guide. 

In quad-buffered stereo, the left and right images are displayed alternately on the screen. To
reduce flickering, a monitor with a sufficiently high refresh rate is needed (better than 100 Hz). 

In horizontally interlaced stereo, the left and right images are displayed on consecutive lines on
the screen. The resolution is therefore not as high as for quad-buffered stereo, and text can be
difficult to read. If the interlacing also alternates between left and right images each time the
screen is refreshed (field-sequential interlacing), the synchronization with the glasses may be
inverted. This can be fixed as described below.

To set the stereo viewing options, choose View → 3D Options in the main window and select
the Stereo tab. To select a stereo viewing method, choose Wall-eyed, Cross-eyed, Interlaced, or
Hardware from the Method option menu. To view the Workspace in stereo, select Display in

stereo in the panel, or choose View → Stereo or press CTRL+S in the main window. These
actions also turn off stereo viewing.

If you are using hardware stereo and the synchronization is inverted, select Swap stereo

images. (This option also swaps cross-eyed and wall-eyed software stereo.)
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If you are using the cross-eyed or wall-eyed method and the displayed stereo pairs are more
than 2.5 inches from each other, adjust the Size factor, Separation factor, and Eye separation
controls to bring the structures closer. This will make stereo viewing easier.

With any stereo method, you can adjust the eye separation and the alignment depth. Adjusting
the eye separation changes the amount that the stereo image appears to extend into and out of
the screen—the stereo depth—and adjusting the alignment depth makes the stereo image
appear to move into or out of the screen. Decreasing the eye separation factor can help for
interlaced stereo on some monitors. 

The stereo method and stereo settings (size and separation) persist across Maestro sessions:
they are saved in prefer.cmd in your profile directory. 

4.7.2 Using Perspective

The Perspective feature enhances 3D graphical representation by scaling objects in the Work-
space in proportion to their distance from the viewing plane (“camera”). Perspective is enabled
by default. You can turn it on and off by choosing View → Perspective.

Figure 4.4. The Perspective tab in the Appearance panel.

The perspective controls are in the Perspective subtab of the 3D tab. You can adjust the scaling
using the Perspective scale slider. A larger value gives a stronger impression of depth (“depth
cue”). The green lines in the Clipping Planes window move to reflect the viewing volume
available at a given value on the Perspective scale.
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4.7.3 Using Fogging

The Fog feature changes atom colors in the displayed structure so that they fade toward that of
the background as atom coordinates grow increasingly negative in the z direction. This feature
is particularly useful for depth-cueing when viewing large structures, such as proteins, and
when using the Wire molecular representation. 

Figure 4.5. The Fog tab in the Appearance panel.

The fog controls are in the Fog tab of the Appearance panel. To enable fogging, select On or
Automatic from the Display fog option menu. You can independently apply fogging to atom
labels using the Display fog on atom labels option. You can also turn fogging on or off from the
Fog submenu of the View menu or from the Fog button menu on the Workspace toolbar.

Automatic fogging means that fogging is turned on when a molecule is bigger than a given
number of atoms. Below this threshold, fogging is turned off. The threshold is 40 atoms, and
can be set with the Maestro command displayopt fogcutoff=number. 

The default method for fogging employs linear fall-off for the brightness of the displayed
structural elements. To exaggerate the fogging effect, you can select either the Exponential
method or Exponential squared method. When you are displaying a structure in perspective,
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you should use linear fall-off. The Automatic method uses linear fall-off with the start and end
points determined by the background color.

The points at which fogging begins and ends can be controlled with the Linear start and Linear

end sliders. Adjusting Linear start moves the boundary at which fogging starts between the
front (0.0) and the back (1.0) of the displayed structure. Adjusting Linear end moves the fog
boundary that is behind the structure further back, to a maximum of twice the depth of the
displayed portion of the structure. By adjusting these boundaries you can control the amount
by which the structure appears to fade into the background.

For exponential and exponential squared fogging methods, the Density slider allows you to
change the contrast of the colors used in fogging. Higher density makes closer portions of the
structure appear brighter and more distant ones fade more quickly into the background. 

Fog options are preserved between Maestro sessions.

4.7.4 Depth Cues

When you are viewing in stereo or in perspective and you zoom in on a structure, the structure
can appear to “flatten”. This happens because the entire depth of the structure remains in the
field of view when you zoom in: it is not clipped at all, and the depth cues (eye separation or
perspective scale) are not preserved. You can preserve depth cues by selecting the Adjust clip-

ping to preserve depth cues option. When you do this, the front part of the structure is clipped
as you zoom in, so that you see only the parts of the structure that are “in front of you”, not the
parts that are “behind you”. 

The Alignment depth slider can be used to shift objects in or out of the screen, in order to
change their relative size (depth scaling) or clipping.

The depth cues are affected by the location of the clipping planes: the closer they are to the
structure, the better the depth cues. To move the clipping planes in to fit the displayed struc-
ture, click Enhance Depth Cues in the 3D tab, choose View → Fog → Enhance Depth Cues,
press D in the Workspace, or click the Enhance button on the Workspace toolbar. 

You can also enhance the perception of depth with the use of ambient occlusion. This feature is
available for atom representations, and is set in the Atoms tab of the Molecular Representation

panel. See Section 7.3.1 on page 141 for details. 
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Maestro provides a variety of tools for building and modifying structures. The Build toolbar
and Fragments toolbar provide basic tools for building and modifying structures. In the Build
panel, you can create molecular structures from a wide variety of predefined fragments and
modify structures and properties of atoms and residues. The 2D Sketcher panel allows you to
draw structures in 2D. Other panels enable you to add hydrogen atoms, adjust the geometry,
connect or fuse molecules, and define centroids of groups of atoms. You can also set prefer-
ences for the behavior when certain building tasks are performed in the Preferences panel. 

Some of the operations for building and modifying structures involve selection of atoms in the
Workspace. For information on selecting atoms, see Chapter 6.

5.1 The Build and Fragments Toolbars

The Build and Fragments toolbars provides quick access to tools for building, drawing, and
modifying structures. To display these toolbars, choose Window → Toolbars → Build or
Window → Toolbars → Fragments, or click the relevant button on the Manager toolbar.

The Build buttons are described below, and their use is described in detail later. For a descrip-
tion of the types of toolbar buttons, see Section 2.4 on page 17.  

Draw structures 
Enter Draw mode to draw structures freehand in the Workspace. Each click in the Workspace 
places an atom and connects it to the previous atom. The menu offers a choice of common ele-
ments for drawing (default C), and access to a periodic table for choosing other elements.

Delete 
Delete objects in the Workspace. The button menu has several sections: one for the current 
selection (DELETE), one for structural units to pick for deletion, one for other kinds of struc-
tural objects to delete, and one for markers and annotations. Double-click to delete the 
selected atoms.
Menu equivalent: Edit → Delete → Pick to Delete.

Set element 
Change the element for the atoms you pick in the Workspace to the element that is selected on 
the menu. The menu offers a choice of common elements (default C), and access to a periodic 
table for choosing other elements. 

Increment bond order 
Increment the order of the bonds you pick in the Workspace by one, to a maximum of 3. 
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The set of fragment buttons on the Fragments toolbar provides a limited selection of structural
fragments. These fragments can be added to the Workspace in Place mode (see Section 5.3.1
on page 84 for details). The intention is that you build with these fragments to create the basic
molecular framework, then change the element to introduce heteroatoms. A few specialized
fragments with heteroatoms are provided, such as a planar amine fragment, which is useful for
building amides. The fragment names are displayed in tool tips. A much larger set of fragments
is available from the Build panel, which you can open by clicking the Fragments button:

The ring fragments can be attached by connection to an atom, which you do by picking an
atom, or by fusion with a bond, which you do by picking a bond. The picking cursor is labeled
A|B to indicate that either an atom or a bond must be picked. 

Decrement bond order 
Decrement the order of the bonds you pick in the Workspace by one, to a minimum of 0. Zero-
order bonds are displayed with dashed lines (or tube segments).

Increment formal charge 
Increment the formal charge of the atoms you pick in the Workspace by one unit.

Decrement formal charge 
Decrement the formal charge of the atoms you pick in the Workspace by one unit.

Invert chirality or flip ring substituents 
Invert the chirality at a chiral center, or swap the substituents on an aliphatic ring atom, by 
picking the chiral center or the ring atom. Double-click to invert the chirality of all atoms.

Move 
Choose a direction for moving atoms, then click the atom to be moved. Moves in the XY plane 
are made by clicking the new location. Moves in the Z direction are made in 0.5 Å increments. 

Clean up geometry 
Cleans up the geometry of the structure or the selected atoms in the Workspace by performing 
a short force-field minimization.You can choose the minimizer from the button menu: Built-in 
for the built-in minimizer using the OPLS_2005 force field, and UFF for the universal force 
field minimizer, which covers more elements.

Sculpt 
Select and move atoms, followed by a short force-field minimization of the atoms in the same 
residue (or molecule). Atoms in residues within 5 Å are constrained, and the rest are frozen. 
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In addition to the organic fragments, there is a button for placing metal centers, from which
you can choose a metal center type, and place it in the Workspace. 

The metal centers are also available in the Build panel. Once a metal center is placed, you must
set the element for the metal center, as the metal is undefined (a dummy atom). By default, the
attached ligand at each coordination site is hydrogen, but you can change it or replace it with a
fragment or a metal ligand.

5.2 The Build Panel

The Build panel consists of three tabs. The primary building tools are contained in the Frag-

ments tab. The Fragments tab contains several fragment libraries from which you can select a
fragment and add it to the Workspace, either by positioning it manually or by using predefined
grow rules. The other two tabs, Atom Properties and Residue Properties, contain tools for
changing the properties of atoms or residues. The use of these tabs is described in the following
sections.

To open the Build panel with a particular tab displayed, choose Edit → Build → tab, or choose
the tab from the Build toolbar button menu on the Edit toolbar (if shown). 

You can also open the Build panel at the Fragments tab with the Fragments button on the Frag-
ments toolbar.

Hydroxyl Methyl Cyclobutadienyl 

Planar amine Cyclopropyl Phenyl 

Sulfonyl Cyclobutyl Cycloheptyl 

Carbonyl Cyclopentyl 
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5.3 Building a Structure From Fragments

Whenever possible, you should use fragments to build structures. Building from fragments
ensures the correct geometry within each fragment, and thereby reduces the work needed to
minimize the structure. In addition to the small set of fragments on the Fragments toolbar, the
following fragment libraries are available in the Fragments tab of the Build panel:

Figure 5.1. The Fragments tab of the Build panel, showing the Organic library.

• Organic • Amino acids

• Rings • Nonstandard amino acids

• N-heterocycles • Modified amino acids

• O-heterocycles • Protein capping groups

• S-heterocycles • Protein ions & solvents

• Mixed heterocycles • Deoxyribonucleic acids

• Carbohydrate furanose • Ribonucleic acids

• Carbohydrate pyranose • Double-stranded A DNA

• L carbohydrate furanose • Double-stranded B DNA

• L carbohydrate pyranose • Double-stranded A RNA

• Metal centers • Double-stranded B RNA

• Metal ligands • Diverse fragments
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These libraries are described briefly below. 

• Organic—This library contains the common organic functional groups, a selection of
simple ring structures, some common ions such as hydroxide, sulfate, nitrate, ammonium,
and a hydrogen molecule. 

• Rings—This library contains some more complex ring structures than those in the
organic fragments library, including some fused ring structures, a basic steroid structure,
porphyrin and phthalocyanine, buckminsterfullerene, and dodecaborane.

• Heterocycles—The four heterocycle fragment libraries provide a range of ring structures
that contain nitrogen, oxygen, and sulfur atoms.

• Furanose and pyranose structures—Sugars can assume cyclized forms that include
either five or six members. The five-membered ring form is called the furanose form, and
the six-membered version is called the pyranose form. The natural state of most sugars is
the pyranose form, but some derivatives assume a furanose form. Maestro provides both
options in both D and L forms.

• Metal centers and ligands—These libraries contain common ligands used in inorganic
chemistry and metal centers with various coordination numbers, but with the specific
metal undefined. To change the metal type, retype the center once it is placed in the
Workspace.

• Amino acids—The Amino acids library contains the 22 naturally-occurring amino acids.
The Nonstandard amino acids library includes the D forms of the 22 naturally-occurring
amino acids and various other residues. The Modified amino acids library includes the five
residues MSE (selenomethionine), ASQ (phosphoaspartate), TPO (phosphothreonine),
PTR (phosphotyrosine), and SEP (phosphoserine).

• Protein capping groups—This library contains some common molecules used to cap
peptides.

• Protein ions & solvents—This library contains common solvents and solvent ions found
in protein structures, and is primarily intended for placement of these species in PrimeX.
These fragments cannot be used for growing because they do not have designated grow
bonds.

• Nucleic acids—The Deoxyribonucleic acids library contains Adenosine, Cytosine, Gua-
nine, and Thymine, while the Ribonucleic acids library contains Adenosine, Cytosine,
Guanine, and Uracil. The double-stranded DNA libraries contain deoxyribonucleic and
ribonucleic acid base pairs in the A and B helix formations.

• Double-stranded DNA and RNA—These four libraries provide the fragments for build-
ing DNA and RNA in the A and B helix conformations. 
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• Diverse fragments—This is a collection of chemically diverse fragments with chains of
various lengths attached to the main functional group. It is useful for examining structure-
activity relationships. It is intended for use with MCPRO+ for free-energy perturbation
calculations of relative ligand binding energies.

To select a fragment library, choose the library from the Fragments option menu. The area
below this menu contains a grid of buttons that you use to select fragments. Each button
displays either the name of the fragment, an abbreviation for the fragment name, or the frag-
ment structure. If a structure is displayed, the name of the fragment is given in the Balloon help
for the button.

If the particular fragment you want to use is not in the supplied libraries, you can build it from
other fragments, or select a fragment with a geometry similar to the one you want to use, then
replace atoms with those of different elements from the Atom Properties tab.

The fragment libraries and grow rules are read and interpreted at run time. If you are interested
in creating your own fragments or fragment libraries, please write to help@schrodinger.com to
obtain the appropriate instructions.

5.3.1 Building Structures Using Place Mode

You can use Place mode to create multiple molecular structures in the Workspace, to assemble
structures from multiple fragments, and to change a fragment into another fragment within a
structure. Place mode is the mode in force when you use the Fragments toolbar to build struc-
tures. To enter Place mode when using the Build panel, select Place in the Fragments tab.

To create multiple structures in the Workspace in Place mode, select a fragment from the build
toolbar or choose a library from the Fragments option menu in the Build panel and select a
fragment, then click in the Workspace. Repeat this process, clicking in a different place in the
Workspace for each new fragment you want to place. The fragments are placed in a predefined
orientation at the location you select, and are completed with hydrogen atoms to form mole-
cules. If you now want to join these structures to form a single molecule, you can use the tools
in the Connect/Fuse panel. See Section 5.8 on page 97 for details.

When you build a structure from fragments, a new project entry is automatically created, with
the default title StructureN. You can edit the title of the entry to change it. If the Workspace
contains a single entry when you start building, placing a fragment that is not connected to the
structure in the Workspace, adds the new fragment to the Workspace entry. This means that
placing multiple fragments will put all these fragments into a single project entry. If there are
two or more project entries in the Workspace, you are prompted to choose an entry to add the
fragment to, or to create a new entry. Each new fragment you place in these circumstances will
produce a prompt, so it is best to start placing fragments in an empty Workspace or one with
only one entry.
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You can build a single structure from multiple fragments in Place mode. Once you have placed
the first fragment, you can join a second fragment to it by selecting the fragment and clicking
in the Workspace on the atom that you want the new fragment to replace. If you click on a
terminal atom, the fragment replaces the terminal atom. If you click on a non-terminal atom,
that atom and its attached hydrogen atoms are replaced by the new fragment. For example,
clicking on a secondary amine nitrogen with a methyl fragment gives a disubstituted methyl
center, and clicking on a disubstituted methyl carbon with an amine fragment produces a
secondary amine center. 

If you are using the build toolbar to add a ring to a structure, you must ensure that you are in
connection mode (A cursor label) rather than fusion mode (B cursor label). Clicking on the ring
button switches between the modes. 

You can also mutate one residue into another in a protein. When you select Amino acids or
Modified amino acids from the Fragments menu in the Build panel, a Mutate button appears
beside the Define grow bond picking tools. To mutate a residue, select Mutate, select the new
residue from the list and pick an atom in the residue you want to mutate. The new residue
replaces the old residue. A quicker way of mutating a residue is to right-click on an atom in the
residue and choose the new residue from the Mutate Residue submenu of the shortcut menu
that is displayed.

Figure 5.2. The Fragments tab of the Build panel, showing the Mutate option.
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5.3.2 Building Structures Using Grow Mode

In Grow mode you can take advantage of the predefined “grow” rules that dictate where and
how fragments are connected to build structures. To enter Grow mode, select Grow in the Frag-

ments tab of the Build panel. This mode is only available from the Build panel.

To create a structure in Grow mode, click the fragments in the fragment library that you want
to assemble in the Workspace. At each click, the selected fragment is added to the structure,
and a green arrow marks the location of the grow bond—the bond that will be replaced when
the next fragment is added.

To grow a structure from a location other than that indicated by the current grow bond, you can
choose a new grow bond using one of the following methods:

• Choose Atom from the Pick option menu of the Define Grow Bond section, and pick two
atoms in the order that defines the grow direction.

• Choose Bond from the Pick option menu of the Define Grow Bond section, and pick a
bond. The grow direction arrow points to the atom closest to where you click.

• Choose backward from the Grow Direction option menu. The grow bond moves to the
opposite end of the molecule.

In addition to the fragments, the Fragments tab of the Build panel contains controls for setting
the joining geometry, and, where applicable, secondary structure and helix geometry. The
Joining Geometry option menu provides context-sensitive options for attaching new fragments
to the existing structure. For example, under the Deoxyribonucleic acid fragment type, the
joining geometry options are Standard Helix and User Defined. 

If you choose to define your own joining geometry, you must specify values for the torsions
that define applicable secondary and tertiary structures. When you select the User Defined

option and click on the name of the fragment, a dialog box prompting you to enter the angle
value is displayed.

If you are growing a structure with amino acid fragments, and you choose user defined from
the Secondary structure option menu, you are prompted for the phi angle and then the psi
angle. When growing in the N→C direction, the phi angle is applied to the new residue, but the
psi angle is applied to the residue that the new residue is attached to. This is because the N–C
bond is replaced when you grow the next residue; the new residue always has psi set to 180°.

By default, Maestro automatically fits the structure to the Workspace after each grow opera-
tion. You can turn this behavior off in the Builder tab of the Preferences panel (see
Section 14.12 on page 371). 
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When growing residues (amino acids, DNA/RNA, sugars—any fragment that has a residue
name), the residue number is incremented or decremented from the number of the residue that
you grow from, depending on the direction of growth, and the new residue is assigned the same
chain name. For other fragments (that don’t have a residue name), the added fragment inherits
the chain name and residue number of the residue it was attached to by the grow operation. 

5.4 Building a Structure From Atoms

The Build toolbar contains tools for drawing structures in the Workspace atom by atom (Draw
mode), and the Atom Properties tab and the toolbar contain tools for retyping atoms within a
structure. Maestro does not automatically correct geometries of structures created in Draw
mode. You can adjust the geometry after building the structure from the Adjust panel. You
should also minimize the energy of the completed structure.

When using Draw mode to create a structure, only a few elements—H, C, N, O, P, S, Si, Al, Cl,
and F—are available by default on the button menu. You can use other elements by choosing
Other from the button menu and selecting the element from the periodic table in the element
selector that opens. 

Figure 5.3. The element selector.

Alternatively, you can use one of the common elements to draw the structure, and then change
the desired atoms—see Section 5.6. Maestro allows you to violate the valency of an atom in
Draw mode so that you can change it to an atom of some other element.

The basic operations of Draw mode are described below.
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• To begin drawing with the currently selected element, click the Draw button.

The Draw structures button appears indented, indicating that you are in Draw mode. The
default element is carbon. 

• To place an atom, click in the Workspace. 

The atom appears as an asterisk enclosed in a purple cube. The cube marks the “active”
atom, which means that it is automatically bonded to the atom that is placed next. Each
subsequent click in the Workspace places another atom and bonds it to the previous atom
with a single bond. To finish drawing, click the active atom. The cube vanishes. 

• To start drawing from another location in the structure, deactivate the active atom by
clicking on it, then click on the atom that you want to start drawing from. This atom
becomes the active atom. 

• To connect the active atom to an existing atom, click the existing atom. 

• To create a multiple bond between the active atom and an adjacent atom, click the adja-
cent atom. Another bond is added between the two atoms. 

• To change the element that you are drawing with, choose the element from the Draw but-
ton menu, or choose Other and select it in the element selector. The next new atom you
place will be an atom of the new element. If you connect existing atoms of a different ele-
ment, the element of the existing atom is not changed: thus, it does not matter which ele-
ment is selected when you draw a bond between two existing atoms.

The atoms that you draw are placed in the xy plane (the plane of the screen). If you want to
create a 3D structure, you can rotate the structure in the Workspace with the middle mouse
button, then continue drawing atoms. Rotation does not change the active atom or exit Draw
mode. You can also move atoms that you have placed using the Move button menu. 

To move an atom in the xy plane, choose X-Y from the button menu, click the atom you want to
move, then click the new location. If the atom is in a ring, only the atom is moved. If the atom
is not in a ring, the atom and its attached atoms are moved. To move an atom in the z direction,
choose +Z or -Z from the menu, and click the atom to be moved. The atom is moved 0.5 Å in
the chosen direction. 
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5.5 Building a Structure in 2D

Draw mode (Section 5.4) allows you to build a structure in 3D by drawing in the Workspace.
Maestro offers another tool, for sketching structures in 2D. The structures can be saved as
project entries, either with 2D coordinates, or converted to 3D with LigPrep. 2D structures can
be sketched in the 2D Workspace panel, which you open by choosing Edit → 2D Sketcher, or
clicking the Sketcher button on the Edit toolbar.

The 2D Sketcher dialog box has a menu bar at the top, a drawing area, a toolbar to the left of
the drawing area, and options for creating a project entry below the drawing area. 

Figure 5.4. The 2D Sketcher panel.
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5.5.1 The 2D Sketcher Menu Bar

The menu bar has three menus: File, Edit, and View. The File menu has a single item, Save
Screenshot, which saves an image of the drawing area in a file. The image can be saved in
PNG, JPG, or BMP format. The shortcut key is CTRL+ALT+P (P). 

The Edit menu has the usual Undo (CTRL+Z, Z) and Redo, Copy (CTRL+C, C) and Paste

(CTRL+V, V) items. Copy copies the selected atoms or the entire structure to the clipboard as
a SMILES string. Paste places the SMILES string in the center of the display area as a 2D
structure. Select All (CTRL+A, A) and Deselect (CTRL+D, D) select all atoms and clear the
selection. Cleanup cleans up the structure (2D coordinates) and normalizes the orientation and
arrangement of groups.

The two remaining items on the Edit menu allow you to get structures from other sources:

• Input SMILES String (CTRL+S, S) allows you to add a structure to the center of the
drawing area by specifying its SMILES string in a dialog box. 

• Common or IUPAC Name Search (CTRL+P, P) allows you to run a PubChem query (on
the web) on the common name or IUPAC name of a structure that you provide in a dialog
box. The first result is added as a 2D structure to the center of the drawing area.

The View menu has items for flipping the structure, zooming in or out, changing the back-
ground, and labeling or coloring atoms. Flip Vertical (CTRL+ALT+F, F) flips the structure
from top to bottom, and Flip Horizontal (CTRL+ALT+H, H) flips the structure from left to
right. Fit to Screen (CTRL+F, F) zooms in or out so that the structure fills the visible part of
the drawing area. If you prefer to see the structure in white on a black background, like on a
blackboard, choose Blackboard View (CTRL+I, I). Finally, choose User defined fragments to
show or hide the User-defined fragments toolbar.

You can label chiral atoms with R or S by choosing Stereochemistry Labels (CTRL+L, L),
and you can color atoms other than carbon by choosing Color Heteroatoms (CTRL+T, T). N
is blue, O is red, S is yellow, and so on. 

5.5.2 The 2D Sketcher Toolbar

The toolbar has three sets of buttons. The first set of buttons is for performing actions, which
are described below. The second set is a collection of rings that you can add to the structure.
The third set is a collection of elements, which you can use to change atoms to a chosen
element. The selection of the element can also be done by typing the element symbol (case
insensitive). 
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Undo 
Undo the last action. Can be performed multiple times.

Redo 
Redo the last action that was undone. Can be performed multiple times.

Lasso 
Select atoms by drawing around them (“lassoing”). The selected atoms can be moved, rotated, 
deleted, copied.

Move 
Move (translate) the selected atoms or the entire structure. Drag in the drawing area to move 
the structure. Drag the selection to move the selected atoms. (This is the default action for 
dragging a selection, so you do not need to click this button before dragging it.) You can also 
move the structure by dragging with the right mouse button.

Rotate 
Rotate the selected atoms or the entire structure. Drag in the drawing area to rotate the struc-
ture. The angle through which the structure has been rotated is displayed near the center of 
rotation while you are rotating it. If rotation does not seem to be working properly, check 
whether you have other structures in the drawing area that are not visible. You can also rotate 
the structure by dragging with the middle mouse button.

Cleanup 
Clean up the structure (2D coordinates) and normalize orientation and arrangement of groups. 
If you have atoms selected, only those atoms are cleaned up.

Draw 
Draw a single bond. Click on an atom to draw a bond to a new (carbon) atom, click on a bond 
to add another bond between two atoms.

Erase 
Delete atoms or bonds. Clicking on a carbon atom deletes it; clicking on a non-carbon atom 
changes it back to carbon, then clicking again deletes it. Clicking on a bond removes one 
bond.

Wedge Bond 
Draw a wedge bond. Clicking on an atom draws a wedge bond to a new (carbon) atom; click-
ing on a single bond converts it to a wedge bond.

Dashed Bond 
Draw a dashed bond. Clicking on an atom draws a dashed bond to a new (carbon) atom; click-
ing on a single bond converts it to a dashed bond.

Increase Charge 
Increase the formal charge on an atom by 1.

Decrease Charge 
Decrease the formal charge on an atom by 1.
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5.5.3 Sketching Molecules

To start drawing, click the Draw button. 

Drawing creates a carbon-atom framework. You can change the element with the element
buttons, either during drawing or after you have finished drawing, or by typing the element
symbol while the pointer is over an atom.

The first atom is placed by clicking in the drawing area. It is shown as CH4. After placing the
first atom, you can draw in several ways:

• Click on an atom to place a new atom and draw a bond to it from the clicked atom. The
bond is placed in a default orientation with respect to existing bonds.

• Drag from an atom in a particular direction, to place a new atom and draw a bond from
the clicked atom to the new atom in the chosen direction.

• Drag from an atom to another atom to create a bond between the two atoms.

• Hold down shift and drag from an atom to add a linear chain to that atom.

• Click on a bond to increase its bond order.

The “active” atom—the one to which a new bond will be attached—is indicated by a gray
filled circle. Likewise, the active bond is indicated by a thicker gray line. The active atom or
bond changes as you move the pointer over the atoms or bonds.

You can also start your drawing with a ring: click on the ring in the toolbar then click in the
drawing area to place the ring.

To draw bonds with a given stereochemistry, click the Wedge Bond or Dashed Bond button,

and draw in the drawing area. Clicking on a bond changes its stereochemistry; clicking on an
atom adds a new atom with the selected orientation.

To add rings to your system, click on one of the ring buttons, then click in the drawing area.
When you move the pointer into the drawing area, the ring is shown in blue. As you move the
pointer in the drawing area, the ring “snaps” to positions that show a potential attachment of
the ring to the structure. Clicking when the ring is in one of these positions places the ring at
that position, and its color changes to black. You can do the same with the fragments on the
User-defined fragments toolbar. 
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To add a functional group, pause the pointer over the atom you want to add the group to, then
type – followed by its name, and press ENTER, e.g. -et to add an ethyl group. Many common
functional groups are recognized: the list is given in Table 5.1 with the corresponding
SMARTS patterns; the names are case-insensitive. You can also replace an atom with a func-
tional group, by omitting the initial –. 

To change the element, you can do one of the following:

• Pause the pointer over the atom, then type the element symbol.
• Click the button for the desired element on the toolbar, then click an atom in the structure.
• Type the element symbol, then click an atom in the structure.

The last two of these choices allow you to click on multiple atoms to change the element; the
first operates only on the active atom.

To assign a formal charge, click the Increase Charge button or the Decrease Charge button,

then click on an atom. The formal charge is given next to the atom, and any hydrogens are also
shown that are needed to complete the valence for the atom; or a red underline is shown to indi-
cate that the valence is not satisfied. You can also pause the pointer over an atom and type in
the formal charge. Any combination of numbers, +, and – is accepted.

Table 5.1. Functional group names and SMARTS patterns for use in editing 2D structures.

Name SMARTS Name SMARTS Name SMARTS

me C ph C(C=C1)=C-C=C1 coo- C(=O)[O-]

et CC bz CC(C=C1)=C-C=C1 no2 [N+](=O)[O-]

pr CCC chex C(CC1)CCC1 so2 S(=O)=O

ipr C(C)C cp C(C=C1)C=C1 so2n S(=O)(=O)N

nbu CCCC ome OC so3 S(=O)(=O)[O-]

ibu CC(C)C oet OCC po3 P(=O)([O-])[O-]

sbu C(C)CC cooh C(=O)O con C(=O)N

tbu C(C)(C)C coome C(=O)OC nco NC=O

nhex CCCCCC cooet C(=O)OCC cn C#N
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To move a group, first select the group by drawing around it with the Lasso tool:

If you want to translate it, just drag it to the new location. The pointer must be over the group
when you start to drag it. If you want to rotate it, click the Rotate button,

then drag it to the new orientation. As for translation, the pointer must be over the group when
you start to drag it. The angle is displayed as you drag.

To adjust the view, you can zoom in or out with the scroll wheel or pinch gesture, pan (trans-
late) with the right mouse button, and rotate with the middle mouse button.

5.5.4 Saving Templates for Building

You can save structures as templates that you can use to build other structures. These templates
are displayed on the User-defined fragments toolbar, which you display by choosing View →
User defined fragments. When you have drawn a structure that you want to add to the toolbar,
press CTRL () and drag the structure to the toolbar. A new button is added with the structure
displayed on it. To remove a structure from the toolbar, click on the button and press DELETE

or BACKSPACE. You can use these fragments in the same way as the ones on the main toolbar.

5.5.5 Saving Structures

You can save a structure as a project entry in several ways, with the buttons at the bottom of the
panel:

• Replace Workspace—Replace the Workspace with the sketched structure, as a scratch
entry. 

• Create New Entry—Create a project entry from the structure in the drawing area. A
default title is assigned to the entry. Hydrogens are added to the structure; it is converted
to 3D if Convert to 3D is selected. 

• Update Entry—Update the project entry from which the structure was taken with the
updated structure in the drawing area. Hydrogens are added to the structure; it is con-
verted to 3D if Convert to 3D is selected. 

If you have a LigPrep license, you can convert it to 3D by selecting Convert to 3D; otherwise it
is added as a 2D structure, and you must convert it to 3D if you want to use it for calculations.
Hydrogens are always added when saving a structure as a project entry.
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To save an image of the structure in PNG, JPEG, or BMP format, press CTRL+ALT+P. A dialog
box opens with controls for the size of the image and an option for saving with a transparent
background. When you click OK, a file selector opens, in which you can navigate to the loca-
tion and name the file. The image type is determined by the file extension. 

5.6 Changing Elements

Whether you build a molecule in Place mode, Grow mode, or Draw mode, the range of
elements available to you by default is limited. Even with access to the whole range of
elements, it is often more efficient to quickly sketch a structure as a carbon skeleton and then
change the elements to the desired ones afterwards. You do not have to complete the structure
before you make the change, you only have to place an atom at the desired location. 

Changing an atom from one element to another can be done from the Build toolbar, the Selec-

tion shortcut menu, or from the Atom Properties tab. 

Figure 5.5. The Atom Properties tab showing tools for the Element property.
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From the Set Element button menu on the Build toolbar you can choose H, C, N, O, P, S, F, Cl,
Br, I, Al, or Si, then click on an atom in the Workspace to change it to the selected element. 

To change to other elements, you can choose Other on the button menu and select an element
in the element selector (see Figure 5.3 on page 87). The element is listed in parentheses after
Other on the button menu, to indicate that it is the current element. 

To use the shortcut menu, select the atoms to change, then right-click in the Workspace and
choose Set Element, then choose the element. The same range of elements is available as on
the toolbar button, and also the Other item for choosing other elements.

To use the Atom Properties tab in the Build panel, first choose Element from the Property

option menu. A periodic table is displayed, from which you can select an element, then click
on an atom in the Workspace to change it to that element. You do not need to select Set

Element: this is done automatically when you click on an element in the periodic table.
However, you can select Set Element if it is unselected and you want to use the currently
selected element. 

5.7 Changing the Bond Order and Formal Charge

After creating a structure, you may wish to change some of the bond orders or formal charges.
You can make these changes with the tools on the Build toolbar (as shown below) or by right-
clicking a bond and choosing the appropriate item from the shortcut menu.

• To increase the bond order, click the + Bond Order toolbar button

then click the bonds whose order you want to increase. Each click increments the bond
order by one, up to a maximum of three. You can also increase the bond order in Draw
mode by drawing another bond between the two atoms. 

• To decrease the bond order, click the - Bond Order toolbar button

then click the bonds whose order you want to decrease. Each click decrements the bond
order by one, to a minimum of 0. Zero-order bonds are displayed with dashed lines in
wire representation and tube segments in tube representation.
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When you change the bond order, the valence states of the atoms can be violated. Maestro
gives no warning of this violation, so it is up to you to ensure that your structure is valid.

• To increase the formal charge, click the + Formal Chg toolbar button

then click the atoms whose formal charge you want to increase. You can only increase the
formal charge one atom at a time. However, the formal charge is also set when you
change the MacroModel atom type.

• To decrease the formal charge, click the - Formal Chg toolbar button

then click the atoms whose formal charge you want to decrease. Like increasing the for-
mal charge, you can only decrease the formal charge one atom at a time, and the formal
charge is set when you change the MacroModel atom type.

5.8 Connecting or Fusing Structures

To build some structures, it is sometimes convenient to connect or to fuse two existing struc-
tures. Connecting two structures creates a new bond between two selected atoms, with deletion
of appropriate hydrogens. An example is the creation of bipyridyl from two pyridine rings, by
connecting the 2-carbon on one ring with the 5-carbon on the other, and deleting the hydrogen
atoms. Fusing two structures deletes atoms. An example is the fusion of two benzene rings, in
which two carbon and two hydrogen atoms are deleted from one ring, and bonds formed to the
other ring with deletion of two hydrogen atoms, to form naphthalene.

Fusion of rings can be accomplished when building structures using the Build toolbar. Each
ring fragment can be fused onto the existing structure by clicking a bond. 

You can connect structures with draw mode, by clicking on the two atoms you want to connect.
However, no adjustment of the geometry is made when you do so.

More general tools for fusing and connecting structures are available from the Connect and

Fuse panel, which you open from the Edit menu. The panel is docked into the Workspace by
default, but you can move it out. In the connection and fusion operations, an attempt is made to
create structures with reasonable geometries, and a check is made that valency is not violated.
This is in contrast to Draw mode, which does not evaluate bonding or geometry. 
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Figure 5.6. The Connect & Fuse panel.

For both connect and fuse operations, you must first select atom pairs to be joined. The atoms
you select must not be hydrogen atoms. You can select as many pairs as you like. The first
atoms in all selected pairs must all come from the same molecule, and the second atoms in the
pairs must come from the same molecule. The molecule for the set of first atoms set need not
be different from the molecule for the set of second atoms. If you select a pair of atoms in the
same molecule, a new bond is drawn between the atoms.

To select atoms for a connect or fuse operation, ensure that Pick to define atom pairs is selected
and click on the Workspace atoms to define the pairs. Atom numbers of the selected pairs
appear in the Connect or fuse atoms list. Also, if Show Markers is selected, each pair is marked
with a dashed green line. For the pair that is selected in the list, the green line is flanked by
solid yellow lines. The lines disappear once the connect or fuse operation is completed.

When fusing structures, the order in which you select the atom pair is important. The first atom
selected is replaced by the second atom selected. For example, when fusing an amino nitrogen
and an ethyl carbon, selecting the nitrogen first results in its deletion, followed by attachment
of the remaining atoms of the amine to the ethyl carbon. Selecting the ethyl carbon first results
in deletion of the carbon and retention of the nitrogen.

To delete an atom pair from the Connect or Fuse Atoms list, select the pair in the list and then
click Delete. To clear the atom pair list, click Delete All.

When you have selected all the pairs of atoms that you want to connect or fuse, click the appro-
priate button—Connect or Fuse.

If you are performing a connection or fusion between structures belonging to different project
entries (the source entries), the result must belong to a single entry. When you click Connect or
Fuse, the Choose Entry dialog box opens, and you must specify the entry with which the new
structure should be associated. Subsequent actions depend on which entry you choose:
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• If you choose one of the two source entries, the other entry is deleted.

• If you choose an existing entry other than the two source entries, the new structure is
added to the existing entry and the source entries are deleted.

When you draw a bond between two entries, a new entry is created automatically, and you can
name the new entry in the Create Bond dialog box. If one of the entries is a scratch entry and
the other is a project entry, the scratch entry atoms are added to the project entry and the
scratch entry is deleted. If both entries are scratch entries, they are merged into one of the
scratch entries and the other is deleted. 

You can undo a connect or fuse operation, and the changes to the entries are also undone. 

5.9 Adjusting the Geometry

Before you use a structure for a calculation, you might want to adjust the geometry, especially
if you used Draw mode, or if the Grow mode orientation was incorrect. Maestro provides tools
on the Edit toolbar for the most common adjustments, on the Adjust button menu. 

More flexibility is provided in the Adjust panel, which you open from the Adjust submenu of
the Edit menu in the main window. The tools that are available on the Adjust button menu are
also available from the Adjust submenu of the Edit menu.

5.9.1 Adjusting Distances, Angles, and Dihedral Angles

You can change distances, angles, and dihedral angles, either directly in the Workspace or by
using the tools in the Adjust panel, as described below. If you are making a sequence of adjust-
ments of the same type, you can easily recall the previous or next adjustment. 

5.9.1.1 Using the Workspace Tools

The basic process for adjusting parameters directly in the Workspace is the same for distances,
angles, dihedral angles, and chirality. This description uses distances as an example:

1. Choose Distance from the Adjust button menu on the Edit toolbar:

2. In the Workspace, click on two atoms to define the distance.

A purple cube is drawn around the first atom, to indicate that it has been selected. For
angles and dihedrals, a cube is drawn around each subsequent atom.
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When you click the last atom, the distance is highlighted with two yellow solid lines, a
purple dotted line, and an arrow indicating the direction of adjustment. Angles are high-
lighted in green and orange, and dihedrals are highlighted in red and turquoise.

3. With the left mouse button, drag to the right to increase the distance or to the left to
decrease it. Alternatively, use the scroll wheel or the pinch gesture to adjust the distance.

You can choose bond lengths or dihedrals for adjustment by right-clicking on a bond in the
Workspace and choosing Distance or Dihedral from the Adjust submenu on the shortcut menu.

For a faster adjustment of a dihedral, choose Quick Torsion from the Adjust button menu, click
on a bond, then drag with the left mouse button. The fragment that is rotated has an arrow
pointing to it on the end of the bond nearest the moving fragment. By default the smaller frag-
ment is rotated around the selected bond. To change the fragment that is rotated, click the bond
again. Quick Torsion is selected by default, so if you have not previously selected some other
adjustment, you only need to click on the Adjust button, then perform the adjustment. 

If you want to display interactions such as hydrogen bonds and contacts while adjusting struc-
tures, you can select Display Interactions from the Adjust button menu. The interactions that are
displayed can be set as preferences—see Section 14.8.2 on page 365 for more information. 

5.9.1.2 From the Adjust Panel

The tools for adjusting bond lengths, bond angles, and dihedral angles are similar, so the
description given here is generic.

Figure 5.7. The Adjust panel, showing the Dihedral tab.
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To define the geometric parameter that you want to adjust, choose Atoms or Bonds from the
Pick option menu in the Define atoms for operation section, and pick the atoms or bonds. For a
bond length, you must pick two atoms or one bond; for a bond angle, you must pick three
atoms or two bonds; for a dihedral angle you must pick four atoms or one bond—the bond
about which the rotation is performed. When you pick this bond, the groups attached to the
atom nearest the point you click are the ones that are moved.

In addition to the standard picking tools just described, you can also specify dihedrals in
proteins using standard names (psi, phi, omega, etc.). Click Select in the Dihedral tab and
select dihedrals by the residues in each entry (or chain), or by standard names.

The atom numbers of the selected atoms are listed in the table in the center of the tab. The last
atom that you pick is the “target atom”—the atom that is moved in the adjustment process. You
must also decide which of the attached atoms to move along with the target atom. You can
choose from All attached atoms, All attached terminal atoms, or Only single atom. If the target
atom is part of a ring, the first option is unavailable. 

Once you have chosen the atoms for a particular adjustment, you can make the adjustment by
dragging with the left mouse button, by using the scroll wheel, or by entering a new value for
the geometric parameter in the Current column of the table. If you enter a new value, the value
is changed and the Workspace is updated when you press ENTER. You can make adjustments
using the table at any time, but you can only use the mouse immediately after picking. 

5.9.1.3 Repeating Adjustments

When adjusting a structure, you might want to switch between adjusting two or more parame-
ters. If the parameters are of the same type, you can select the previous or the next adjustment
by choosing Edit → Adjust → Previous Adjustment or Edit → Adjust → Next Adjustment, or use
CTRL+SHIFT+A (Z) and CTRL+SHIFT+Z (Z). If they are of different types, you can
select the adjustment type again, using the Edit menu or the Adjust button, and the last adjust-
ment of that type made is selected. You can also select the adjustment you want to change in
the Adjust panel, by selecting the table row in the tab for the adjustment type. 

5.9.2 Adjusting Peptide Linkages and Side Chains

The Adjust button menu on the main toolbar provides some tools for adjusting the geometry of
peptide linkages, and for selecting the most common rotamers for side chains. 

For peptide linkages, you can rotate the plane of the peptide linkage, rotate the carbonyl plane,
and convert between cis and trans linkages. 
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To perform peptide rotations:

1. Choose Rotate Peptide Plane or Rotate Carbonyl Plane from the Adjust button menu on
the Edit toolbar.

2. Click on an atom in the peptide group to select it.

The peptide group is marked with a rectangle.

3. Drag with the left mouse button to perform the rotation.

To convert between cis and trans:

1. Choose Convert Cis/Trans from the Adjust button menu on the Edit toolbar.

2. Click on one of the atoms in the peptide link. 

The geometry of the converted link is only approximate, and should be refined before use in
any application that depends on the accuracy of the geometry. 

To select a rotamer for one or more residue side chains:

1. Select the residues in the Workspace or the sequence viewer. 

2. Choose Rotamers from the Adjust button menu on the main toolbar.

The Rotamers dialog box opens. This dialog box has a list of the residues you selected in
the Workspace at the top and a list of rotamers for the residue that is selected from this list
below, with angles and a standard percentage population for each rotamer.

3. Select a residue from the table at the top of the dialog box.

The residue is highlighted in the table. The Workspace view zooms to that residue if Fit

selected residue to Workspace is selected.

4. Select a rotamer from the lower table. 

The side chain is rotated to the geometry of the selected rotamer. You can sort this table
by clicking on the column headings. 

Repeat steps 3 and 4 for each residue that you want to adjust. Note that no account is taken of
steric clashes when selecting rotamers; however the presence of clashes is indicated by a + sign
in the Clash column. If you decide that you prefer the original rotamer, you can select it in the
table or click Restore to Original Conformation. 

When using PrimeX, further options are available—see page 16 of the PrimeX User Manual.
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Figure 5.8. The Rotamers dialog box.

5.9.3 Adjusting the Stereochemistry

The simplest way of adjusting the stereochemistry at a chiral center is to use the toolbar button,

To invert the chirality, click this button, then pick the chiral center in the Workspace. The
groups to move are automatically selected, as the lowest-priority groups. You can also use this
button to exchange substituents on a single atom of an aliphatic ring. To invert the chirality at
all chiral centers, double-click this button. The structure is reflected in the xy plane to produce
its mirror image. This procedure can be used for any structure, including fused rings.

If you want more flexibility, you can use the picking tools in the Chirality tab of the Adjust

panel. You can invert the chirality of selected chiral centers or of all chiral centers. This tab
also has buttons for displaying the R and S labels for the configuration at chiral centers, and for
clearing the labels. If you click Label Chiral Centers, all other labels are cleared.
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To invert the chirality at a given chiral center, select the chiral atom, then select the two other
atoms that are connected to the chiral center that are to remain in place. After you have picked
the third atom, the two atoms that were not picked are interchanged, with their attached groups.

You can also choose Chirality from the Adjust button menu on the Edit toolbar, and select atoms
as described above.

To invert the chirality at all chiral centers, click All in the Invert chirality picking tools section.

These procedures do not apply to changing the chirality of atoms in fused ring systems at the
intersection of the rings, for which the chiralities of several centers are usually related in a low-
energy structure. 

To adjust the stereochemistry around a double bond (cis-trans isomers), choose Convert Cis/

Trans from the Adjust button menu, then click on a double bond. A rotation of 180º around the
double bond is performed, by adjusting the end that has the smallest number of attached atoms.
This is the same tool as for adjusting peptide linkages, but with a different target. 

5.9.4 Adjusting Groups of Atoms

Sometimes, you might want to adjust the position of a more general group of atoms—for
example, you might want to adjust the position of a ligand with respect to a receptor, or you
might want to move a functional group from one part of a molecule to another, by breaking the
bonds and re-attaching it in its new location. You can do this with the local transformation
tools, which are available from the Transform submenu of the Edit menu, the Advanced Trans-

formations panel, and the Transform button menu on the Edit toolbar.

To open the Advanced Transformations panel, choose Edit → Transform → Advanced, or
choose Advanced from the Transform button menu.

A local transformation is just like a global transformation (change of view), except that you are
moving an atom subset1 with respect to the other atoms in the Workspace. Local transforma-
tions use the same keyboard and mouse actions as global transformations.

1. The subset can in fact include all atoms in the Workspace, so that the rotation or translation actually changes the
coordinates of the entire contents of the Workspace.
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Figure 5.9. The Advanced Transformations panel.

To transform the selected atoms:

1. Select the atoms in the Workspace.

2. Right-click in the Workspace and choose Transform.

3. Rotate or translate the atoms with the right or middle mouse button.

To transform atoms by picking:

1. Enter local transformation mode by one of the following methods:

• Choose Edit → Transform → Pick to Transform.
• Select Local for Rotation/translation scope in the Advanced Transformations panel.
• Click the Transform toolbar button.

2. Choose a type of structure to pick:

• Choose Edit → Pick → type. 
• Choose from the Pick menu in the Atoms for Transformation section of the Advanced

Transformations panel.
• Select the type from the Transform button menu.

3. Pick the atoms in the Workspace.

You can drag to pick multiple structural objects, but you can only pick once—you cannot
add to the selection. 

4. Rotate or translate the atoms with the right or middle mouse button.

Various markers are available to help in the transformation process. These markers can be
turned on and off from the Transform button menu. If Show Markers is selected from this
button menu, the picked atoms are marked in yellow, and the rotation center is marked in
magenta. Display of the rotation center is governed by a preference—see Section 14.4.4 on
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page 350 for details. You can also display interactions such as hydrogen bonds, contacts, and
bond lengths while you are doing a local transformation. To do so, select Display Interactions
or Display Bond Lengths from the Transform button menu or the Transform submenu of the Edit

menu. Interactions are displayed between the moving atoms and the remaining atoms. The
interactions that are displayed can be set as preferences—see Section 14.8.2 on page 365 for
more information.

If you want to adjust the view while you are in a transformation, hold down the SPACEBAR
and change the view with the mouse buttons. This action temporarily exits local transformation
mode. You can also switch modes in the Advanced Transformations panel, by selecting Global

or Local under Rotation/translation scope, or by using the shortcut key CTRL+G.

More complex atom selection than a single pick can be done in the Atoms for transformation

section of the Advanced Transformations panel. However, the picking tools in this section still
only allow a single pick. If you have already selected the atoms you want to transform before-
hand, click the Atom Selections button and choose Workspace Selection. To select more than
one group, choose Select and use the Atom Selection dialog box. 

If you want to perform a rotation, a rotation center is required. By default, Maestro selects the
centroid of the atoms selected for transformation as the rotation center. If this is not satisfac-
tory, you must choose a rotation center, which you can do in the Advanced Transformations

panel. You can select a new center using the tools in the Center for transformation section.
Displaying atom number labels may be helpful for determining which atoms you would like to
specify as the rotation center.

When you begin a local transformation, Maestro automatically begins an undo block. As a
result, selecting Undo action from the Edit menu reverses all operations that occurred between
the time that the mouse button was pressed, and the time that it was released.

If you are transforming atoms for which some or all of them have alternate positions, you can
transform both alternates by selecting Include alternate positions in local transformations. To
transform only the displayed set of coordinates, deselect this option. This option is also avail-
able in the Preferences panel.
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5.9.5 Structure Sculpting

Maestro provides a special mode of local transformation called structure sculpting, which you
enter by choosing Structure Sculpting from the Tools menu, or clicking the Sculpt button on the
Build toolbar (also available from the Proteins toolbar). 

In this mode, the movement of atoms is followed by a short force-field minimization that
includes nearby atoms. Once you enter this mode, you can select atoms and drag them to a new
location (with the left mouse button). When you release the mouse button, the minimization
starts. The selected atoms are restrained. Atoms in the same residues (or molecule, if there are
no residue numbers) have no constraints placed on them; atoms in complete residues that are
within 5 Å of these residues are restrained, and all other atoms are frozen. The minimization
proceeds for a fixed number of cycles (500) or until there is no significant change (maximum
displacement of 0.005 Å). During the minimization you can continue to work on the structure.
The minimization stops if you exit the mode, for example by choosing some other action that
involves picking atoms, or change the content of the Workspace. If you select atoms and drag
them while the minimization is proceeding, it stops and a new minimization begins.

5.9.6 Cleaning Up the Geometry

Maestro provides two tools for cleaning up the structure in the Workspace: the Geometry
Symmetrizer, and the Geometry Cleanup utility. The Geometry Symmetrizer allows you to
symmetrize the geometry of the structure in the Workspace, subject to a given tolerance.

Figure 5.10. The Symmetrize Workspace panel.

To symmetrize the Workspace structure:

1. Choose Symmetrize Workspace from the Edit menu. 

The Symmetrize Workspace panel opens.

2. Click Find Point Group.

The point group found is displayed in the panel.

3. If this is not the desired point group, increase the tolerance and click Find Point Group. 
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4. When the desired point group is found, click Symmetrize. 

Structures that are built by drawing, or have been adjusted manually, can be far from the
minimum energy structure. To “clean up” the structure in the Workspace, the Geometry
Cleanup utility minimizes the energy of the structure or of the selected atoms using either the
built-in minimizer with the OPLS_2005 force field, or the Universal Force Field (UFF). The
choice of minimizer and force field can be set either from the Clean Up button menu or in the
Preferences panel (see Section 14.12 on page 371). 

Cleanup realigns atoms that are too crowded and corrects unphysical geometries. In general, it
corrects distortions that can cause jobs to fail, such as MacroModel or Jaguar jobs. Minimiza-
tion proceeds for 300 cycles or until the maximum atom displacement is less than 0.05 Å. By
default, when using the built-in minimizer, atoms within 5 Å of the selected atoms are
restrained with a moderate restraint, and atoms within 5 Å of these atoms are restrained with a
much tighter restraint. The rest of the atoms are frozen, but you can set a preference to freeze
all unselected atoms—see Section 14.12 on page 371.

To run this utility, choose Edit → Build → Clean Up Geometry, press U, or click the Clean Up

button on the Build toolbar. This job is not run at reduced priority, unlike most local jobs.

You can also use the built-in minimizer on the selected atoms by choosing Tools → Minimize

→ Selected Atoms or pressing CTRL+M (M), which minimizes for 1000 cycles or a
maximum displacement of 0.01 Å. If no atoms are selected, all atoms are minimized. To mini-
mize the ligand, choose Tools → Minimize → Ligand or press CTRL+SHIFT+M (M).

5.10 Adding and Treating Hydrogen Atoms

When building molecules or preparing proteins, you might want to apply a hydrogen treatment
that is compatible with the force field you intend to use in calculations on those structures. You
can also use a hydrogen treatment to add hydrogen atoms to a structure that is used for any
program that requires explicit hydrogen atoms, such as QikProp or Jaguar. Hydrogen treat-
ments can treat hydrogen atoms explicitly or implicitly, as part of another atom. To select and
apply a hydrogen treatment, you can use the controls in the Add Hydrogens - Advanced panel,
which you open by choosing Edit → Add Hydrogens → Advanced.
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Figure 5.11. The Add Hydrogens - Advanced panel.

To select a hydrogen treatment, choose an option from the Treatment option menu. A descrip-
tion of the treatment is displayed in the Description text box, including the force fields for
which the treatment is valid. This information is also given in Table 5.2. 

You can apply the selected treatment to the entire structure or to selected parts of the structure.
To apply the treatment to the entire structure click All in the Modify Hydrogen Treatment

section. To apply the treatment to selected atoms, use the picking tools in the Modify Hydrogen
Treatment section or click Select to open the Atom Selection dialog box and define the selected
atoms. If the structure already complies with the treatment you selected, no changes will be
made when you apply the treatment.

You can also apply the current hydrogen treatment to selected atoms, molecules, residues,
chains, or entries from the main toolbar or the Build panel toolbar. Select one of these structural
units from the Add H button menu, 

then pick atoms in the Workspace to apply the treatment. Double-click this button to apply the
treatment to all atoms in the Workspace. 

Each time you select a force field in the Potential section of a MacroModel or Impact energy
panel, the hydrogen treatment is automatically changed to comply with that force field, and the
hydrogen treatment for any atoms you subsequently draw in the Workspace will have the new
hydrogen treatment. If you attempt to start a MacroModel, Impact, or Jaguar job using an input
structure with an incompatible hydrogen treatment, the job fails.
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5.11 Changing Atom Properties

In addition to changing the element and the formal charge, you can change a variety of other
atom properties. The tools for making changes are in the Atom Properties tab. Each choice of
property from the Property option menu displays a set of tools that you can use to change the
property. Apart from the Element property, the properties are listed below with a description of
the tools. The last item on the option menu, Other, allows you to change the values for any
other atom property.

Before you change atom properties, it may be helpful to display atom labels. For atom labeling
information, see Section 8.2 on page 162.

5.11.1 Atom type (MacroModel) 

When you choose Atom type (MacroModel) from the Property option menu, a list of atom type
symbols with a brief description is displayed (see Figure 5.12). The atom type symbols repre-
sent atoms with specific properties, such as sp3 hybridization for a C atom with type symbol
C3, or a free radical for a C atom with type symbol CR. To retype an atom, choose the atom
type and click on the atoms in the Workspace that you want to change.

The use of atom types is provided primarily for MacroModel users, though Maestro always
assigns an atom type to each atom. For information on atom types, see Appendix B.

Table 5.2. Appropriate hydrogen treatments for Maestro-supported force fields.

Hydrogen Treatment 
Method M

M
3

M
M

2

A
M

B
E

R

A
M

B
E

R
94

M
M

F
F

M
M

F
F

S

O
P

L
S

-A
A

,
O

P
L

S
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00
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All-atom with No-Lp X X X X X X

All-atom with Osp3-Lp X

Csp3 United-atom with 
S-Lpa

X

Csp3 United-atom with 
No-Lpa

X

All atom with S-Lp X

Csp2/sp3 United atom 
with No-Lpa

X

a. In a united atom representation, hydrogen atoms are incorporated into the dimensions of the heavy 
atom to which they are attached. That is, they are implicit.
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Figure 5.12. The Atom Type (MacroModel) tools in the Atom Properties tab.

5.11.2 Partial Charge

To apply new partial charges to atoms of interest, enter new charges in the Partial Charge and
Solvation Charge text boxes, and use the picking tools to apply the partial charges to the atoms
of interest. Both of these charges are used in MacroModel calculations. The solvation charge is
used in MacroModel GB/SA solvation calculations. Generally, these two values should be the
same. Default values for these charges are supplied with MacroModel force fields. You can
also use partial charges from Jaguar electrostatic potential calculations, which are read by
default when the results Jaguar calculations are incorporated or imported.

5.11.3 PDB Atom Name

A PDB atom name is a combination of a chemical symbol and a connection indicator. The first
two characters contain the element symbol, right-justified; the third character is a remoteness
indicator (A=alpha, B=beta, G=gamma, and so on), and the fourth, if it is needed, is a numeric
branch designator. For instance, the name “_CA_” represents an alpha carbon, “_CB_” a beta
carbon, and “_HB_” a hydrogen on a beta carbon. In these descriptions, the underscore charac-
ters represent spaces, which are required for compliance with PDB semantics: “CA__” is a
calcium atom, and is different from “_CA_”.
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Figure 5.13. The PDB Atom Name tools in the Atom Properties tab.

Occasionally Maestro is not able to assign PDB names to all the atoms. To manually apply
missing PDB atom names, enter the desired name in the PDB atom name text box and use the
Apply PDB atom name picking tools to select the atoms to which you want to apply the name. 

For some purposes, such as for ligands in Prime induced fit calculations, it is useful to have
unique atom names within residues. To make the atom names unique, use the Set unique PDB

atom names within residues picking tools. The unique names are composed of the element
symbol, right justified in the first two characters, followed by a numeric index for that element.

5.11.4 Atom Name

You can assign one of three types of names to atoms in the Workspace: user-specified, canon-
ical, or unique. User-specified names can be any length. To assign a user-specified name, type
the name in the Atom name text box of the Set atom name section, and use the picking tools to
apply the name. You must display the atom name labels before you can see the new name.

A canonical atom name is an automatically assigned combination of atom property pairs:
Element & Atom Number or Residue Number & PDB Atom Name. To assign canonical names,
select the desired pair of properties from the Composition option menu, specify a separator
symbol in the Separator text box, and click Apply To All Atoms. You cannot selectively apply
canonical names.
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Figure 5.14. The Atom Name tools in the Atom Properties tab.

Unique names are generated using the element and atom number of each atom. If this naming
scheme produces atoms with identical names, Maestro adds numeric suffixes, followed by a
tilde (~) to distinguish the names. To apply unique names to all atoms, click Make Unique in
the Modify existing names section. As for canonical names, you cannot selectively apply
unique names. 

5.11.5 Grow Name

This name is the name used internally for a fragment when growing a structure. The intended
use of this property is labeling new fragments for a fragment library.

5.11.6 Isotope Number

To set the isotope number (atomic mass number) for selected atoms, choose Isotope number

from the Property option menu. You can specify the isotope in the text box, then apply it to
atoms with the picking tools. The isotope number is used in calculations of molecular weight. 

The isotope can be displayed in an atom label (see Section 8.2 on page 162) in two ways. If
you choose the Isotope number property to include in the atom label, it is displayed as atom-
isotope, e.g. C-13. If you choose the mass number property, only the atomic mass number is
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displayed. For hydrogen, you can set a preference to display the element label as H, D, or T,
depending on the isotope number—see Section 14.6 on page 360.

5.11.7 Other Properties

When you choose Other, the tools that are displayed allow you to change the properties for any
of the properties that do not have special editing tools. These tools consist of a Properties list,
which lists all the properties that have values for any of the atoms in the Workspace; an Atoms

table, which lists the atoms that you choose for making changes in the properties; Add and
Delete buttons, for adding and deleting properties, and Add atoms to edit their properties

picking tools, for adding atoms to the Atoms table.

Figure 5.15. The Other tools in the Atom Properties tab.

To edit one or more properties:

1. Select the desired properties in the Properties list. 

The properties are added as columns to the Atoms table. 

2. Use the Add atoms to edit their properties picking tools to select the atoms to edit. 

The atoms are listed in the Atoms table by atom number, and the property columns are
populated with the values. 
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3. Edit the table cells to change the property values:

• To change a property for a single atom, simply edit the table cell. 

• To set the value for multiple atoms, select the atom rows in the table, edit one of the
table cells, and press CTRL+ENTER to apply the change to the selected rows.
Selecting atoms in the table also selects them in the Workspace.

To delete property values for all atoms in the Workspace:

1. Choose the properties from the Properties list. 

2. Click Delete. 

The property values are removed from all atoms in the Workspace (not just those in the
table), and the property is removed from the Atoms table.

To add a property to the atoms that are selected in the Atoms table:

1. Click Add. 

The Add Property dialog box opens. 

2. Select the property type, name the property, and provide an initial value. 

3. Click OK. 

The property is added as a column to the Atoms table, and the values are added to the
selected atoms.

5.12 Changing Residue Properties

Residue properties can be changed in the Residue Properties tab. This tab is laid out in a
similar fashion to the Atom Properties tab, with a Property option menu and a set of tools
displayed for each choice. The residue properties and their tools are described below. In order
to view the results, you must first display the appropriate atom labels. 

Residue Number

To renumber more than one residue by incrementing the residue numbers, you can use the
Renumber Residues section. Enter the starting value in the Renumber From text box, then use
the picking tools to select the residues to renumber. The residue with the lowest number in the
selection is assigned the number in the text box. The residue numbers for the remaining resi-
dues are shifted by the same amount as that of the residue with the lowest number. Renum-
bering therefore preserves gaps in the residue numbering. If you want to eliminate gaps, select
the residues above the gap and renumber them.
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Figure 5.16. The Residue Number tools in the Residue Properties tab.

Renumbering a single residue is the same as assigning its number. To apply a specific residue
number to one or more residues, in the Apply residue number section enter the number you
want to apply in the Residue number text box, then use the picking tools to select the residues
to apply the number to. You can also reassign the residue number of single atoms whose
number is misassigned with these tools, by selecting Atoms from the Pick option menu, then
picking the atom to assign the specified residue number.

Residue Name

To name residues, enter the residue PDB name in the Residue PDB name text box, and use the
picking tools to select the residues to name. PDB residue names are three characters long and
are right-justified. For example, the residue name G3 must be entered with a leading space, as
“ G3”, whereas the residue name C19 should have no leading space, “C19”. 

Chain Name 

You can assign a single-letter name to chains. The definition of a chain is not restricted to the
items labeled Chain in the pick option menus: you can define a chain in any way that you like,
and assign it a name. To assign the name, enter a character in the Chain Name text box and use
the picking tools to select the chain. To remove a chain name, clear the Chain Name text box
and use the picking tools to select the chain.
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5.13 Defining Dummy Atoms

Dummy atoms are used by several of the computational programs for defining geometries and
geometric parameters. You can retype an atom to a dummy atom type using the MacroModel
Types atom property described earlier. You can also place a dummy atom at the centroid (mean
position) of a group of atoms, such as a ring. You can then change the dummy atom to a real
atom, and thus place real atoms at the centroid of some system of interest. 

The centroid capability is available in the Centroids panel, which you open from the Edit menu,
and is docked into the Workspace by default. To define a centroid, use the picking tools in the
Define atoms for centroid section. The atoms are listed in the Atoms to define centroid list. If
you have Markers selected, the atoms are marked with a salmon-colored star, and the atom that
is selected in the list is marked with a lavender-colored star. You can delete atoms from the list
by selecting the list item and clicking Delete. Once you have picked all the atoms, click Create

Centroid Atom. The To define another centroid, click Delete All before picking atoms for the
new centroid. 

Figure 5.17. The Centroids panel.

5.14 Deleting Atoms and Bonds

If you need to delete atoms from a structure, you can use the Delete submenu of the Edit menu
or the Delete button menu on the Edit toolbar or the Build toolbar.

These menus offer choices for the type of object to delete, and allow you to open the Atom

Selection dialog box to select atoms for deletion based on their properties. You can also select
atoms in the Workspace, then click the Delete button, press DEL, or use the shortcut menu to
delete them. 
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When you delete atoms, the terminal atoms that are attached to this atom can be deleted, or the
terminal atoms can be left in place. Terminal atoms are atoms that are bonded only to that
atom, such as hydrogen or a halogen. Deleting terminal atoms would not, for example, delete a
methyl group attached to the deleted atom. This action is controlled by an option that you can
set in the Builder tab of the Preferences panel. 

Another means of deleting atoms is to select them and choose Edit → Cut or press CTRL+X.
The atoms are removed from the structure and placed on the clipboard. You can then paste
these atoms into the Workspace later, as a scratch entry.

If you want to remove all atoms in the Workspace, choose Workspace → Clear or use the Clear
Workspace button, which is located on the main toolbar. This action does not delete the atoms
from the structure, it only removes them from the Workspace.

If you want to delete bonds, either to create new ones or to split a molecule into smaller pieces,
you can, you can right-click and hold on a bond in the Workspace and choose Delete from the
shortcut menu, or choose Bonds from the Delete button menu on the Edit toolbar or the Build
toolbar, then click on the bond to delete.

Zero-order bonds are a special type of bond that are used to define connectivity when a frag-
ment “belongs” to a molecule. Two fragments that are joined by a zero-order bond are consid-
ered to be a single molecule in Maestro. One instance where zero-order bonds are used is for a
metal atom in a complex, where for purposes of force-field calculations it must be treated as an
ion, but for purposes of connectivity it is considered part of the complex. You can delete zero-
order bonds in the same way as regular bonds, and you can delete all zero-order bonds by
choosing Zero Order Bonds from the Delete button menu.
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Chapter 6: Selecting Atoms
Maestro has a powerful set of tools for selecting atoms in a structure: toolbar buttons, picking
tools in panels, and the Atom Selection dialog box. These tools allow you to select atoms in two
ways:

• Select atoms first and apply an action to them
• Choose an action first and then select atoms for that action

6.1 Picking in the Workspace

One of the primary means of selecting atoms is to pick atoms in the Workspace. The tools with
which you can do so are described in later sections. To pick an atom, you click on the atom.
The atom is then selected. If you want to select multiple atoms, you can drag over the region
containing those atoms, and they are all selected. If you want to add atoms to the selection,
hold down SHIFT while you click or drag. To invert the selection of atoms (select the
unselected atoms, deselect the selected atoms), hold down CTRL while you click or drag. If
you click or drag in an empty part of the Workspace, the selection is cleared. Dragging over
ribbons when the associated atoms are not displayed selects the associated atoms inside the
rectangle. 

The Selection shortcut menu also has some items for selecting atoms. You can invert the selec-
tion, and you can extend the selection to atoms within a radius or atoms that match by color,
representation, or element. See Table 2.2 on page 28 for information on this shortcut menu.

6.2 Using the Toolbar Buttons

The small triangle in the lower right corner of a toolbar button indicates that the button
contains a menu. Many of these buttons allow you to choose a structural unit for selecting.
Choose Atoms, Bonds, Residues, Chains, Molecules, or Entries, then click on an atom in the
Workspace to perform the action on all the atoms in that structural unit. 

For example, to select atoms in residues with the Select button:

1. Choose Residues from the Select button menu:
Maestro 10.2 User Manual 119



Chapter 6: Selecting Atoms

120
The button changes to:

2. Click on an atom in a residue in the Workspace to select all the atoms in that residue.

The Select button is the primary means of selecting atoms in the Workspace prior to
performing an action. 

In addition to selecting atoms by picking, you can expand the selection to include atoms within
a given distance of the current selection. To include all atoms in residues that have any atoms
within the specified distance, select Expand Residues on the Select button menu. If this option
is not selected, only the atoms within the specified distance are added. To expand the selection,
choose the distance from the Select button menu, or choose Custom and enter the distance in
the dialog box that opens.

If you want to replace the selection with the atoms within a given distance of the selection,
select Exclude Selected from the Select atoms button menu. This is useful if, for example, the
ligand is selected, and you want to select the receptor residues that are within a given distance
of the ligand, but not include the ligand in the selection.

These tools are also available from the Expand Selection submenu of the Selection shortcut
menu (see Section 2.7 on page 26).

If you want to select all atoms in a particular category, you can choose the category from the
Select button menu. The available categories are:

• All—all atoms in the Workspace.
• Displayed Atoms—atoms that are displayed in the Workspace. 
• Protein—protein atoms (backbone and side chain).
• Protein Backbone—protein backbone atoms. 
• Protein Side Chains—protein side chain atoms. 
• Protein Near Ligand—protein residues within 5 Å of the ligand. 
• Ligands—ligand atoms, as defined in the Ligand Detection Settings dialog box. 
• Waters—all water molecule atoms.
• Ions— charged atoms and molecules that have less than 10 atoms.
• Metals—all elements to the left of B, Si, Ge, Sb, Po in the periodic table.
• Heavy Atoms—all non-hydrogen atoms.
• All Hydrogens—all hydrogen atoms. 
• Nonpolar Hydrogens— hydrogen atoms bonded to carbon. 
• Nonpolar Ligand Hydrogens— hydrogen atoms bonded to ligand carbon atoms. 
• Polar Hydrogens— hydrogen atoms bonded to atoms other than carbon. 
• Membrane—atoms in membrane molecules (POP, POPC, POPE, DPPC, DPMC).
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These categories are available on other toolbar buttons that allow you to pick atoms.

6.3 Using the Picking Tools

The picking tools are embedded in each panel in which you need to select atoms to apply an
operation. The picking tools in a panel can include one or more of the following:

• Pick option menu—Allows you to choose a structural unit for selecting atoms. The pick
option menu is described on page 123.

• Dihedral button—Opens the Dihedral Selection dialog box, in which you can select pro-
tein dihedral angles. 

• Markers option—Marks the selected atoms in the Workspace 

• Text box—Allows you to type in an ASL expression, and displays the ASL expression for
the current selection. ASL stands for Atom Specification Language, and is described in
detail in the Maestro Command Reference Manual. 

• Clear button—Clears the current selection. This button is displayed in the text box when
an expression is present.

• All button—Selects all atoms in the Workspace. This includes atoms that are not dis-
played.

• Atom Selections button—This button displays a list of common atom categories that can
be selected when you click it. Clicking one of the items acts on the corresponding atoms,
if the action is immediate, or adds the atoms to the selection, if the action is performed
later. It also has two buttons, to build or recall atom selections using ASL expressions. 

The atom categories that you can act on or add to the selection are: 

• Workspace Selection—atoms that are already selected in the Workspace.
• Displayed Atoms—atoms that are displayed in the Workspace. 
• Protein—protein atoms (backbone and side chain).
• Protein Backbone—protein backbone atoms. 
• Protein Side Chains—protein side chain atoms. 
• Protein Near Ligand—protein residues within 5 Å of the ligand. 
• Ligands—ligand atoms, as defined in the Ligand Detection Settings dialog box. 
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• Waters— all water molecule atoms.
• Ions— charged atoms and molecules that have less than 10 atoms.
• Metals—all elements to the left of B, Si, Ge, Sb, Po in the periodic table.
• Heavy Atoms—all non-hydrogen atoms.
• Hydrogens-All—all hydrogen atoms. 
• Hydrogens-Nonpolar— hydrogen atoms bonded to carbon. 
• Hydrogens-Nonpolar Ligand— hydrogen atoms bonded to ligand carbon atoms. 
• Hydrogens-Polar— hydrogen atoms bonded to atoms other than carbon. 
• Membrane—atoms in membrane molecules (POP, POPC, POPE, DPPC, DPMC).

These are the same as on the Select button menu (and other button menus), except for the
first item.

The two buttons are:

• Select—Opens the Atom Selection dialog box (see Section 6.5 on page 125)
• Previous—Performs the action on the most recent atom selection defined in the

Atom Selection dialog box (see Section 6.5 on page 125). 

The range of picking tools available in a panel varies according to the types of structural units
that are needed for the operation and whether picking causes immediate action or requires an
action to be specified later. The ASL text box and Clear button are included only when picking
merely defines a set of atoms for later use. For example, the Dihedral tab of the Adjust panel
has a Pick option menu and a Dihedral button, and the action is immediate. The Sets panel has
a full set of picking tools, and stores the atoms in a defined set that can be used later. When
picking for an action to be performed later, each picking action adds atoms to the ASL expres-
sion (with an implicit OR), which is (with an implicit OR) shown in the ASL text box. 

Figure 6.1. Examples of picking tools. Top: from the Sets panel; Center: from the Atom 
and Bond Coloring panel; Bottom: from the Adjust panel.
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6.3.1 The Pick Option Menu

With the Pick option menu, you can choose a structural unit (Atoms, Bonds, Residues, Chains,
Molecules, or Entries) and click on an atom or a bond in the Workspace to select all the atoms
in that structural unit. For instance, choose Atoms and click on an atom in the Workspace to
select just that atom. Choose Residues and click on an atom to select all the atoms in that
residue. Choose Bonds and click on a bond to select both atoms that define that bond. 

Figure 6.2. The Sets panel, showing the Pick option menu.

When you select a structural unit, the cursor in the Workspace appears as a box with a letter: A,
B, R, C, M, and E represent Atoms, Bonds, Residues, Chains, Molecules, and Entries, respec-
tively. Successive clicks add atoms to the selection.

If you want to know the index of structural unit that you are picking (for example, the molecule
number), you can set a preference to show the index in the status bar. When the pointer is over
an atom, the index of the structural unit is displayed as Pick: index at the beginning of the
status bar. See Section 14.5.1 on page 358 for details on the preference.

The number of structural units available in the menu depends on the operation. For instance,
when you define a dihedral angle, you can pick either four atoms or three bonds. The Pick

option menu for this operation therefore only contains Atoms and Bonds.

You do not need to select the Pick option before choosing an item from the Pick option menu; it
is automatically selected when you choose a menu item.
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6.3.2 The Dihedral Selection Dialog Box

For proteins, you can select the dihedrals by name in the Dihedral Selection dialog box, which
you open by clicking the Dihedral button in the picking tools.

Figure 6.3. The Dihedral Selection dialog box.

To select one or more dihedral angles:

1. Select one or more chains in the Entry (Chain) list.

The list of residues in the selected chains is displayed in the Residues list.

2. Select one or more residues in the Residues list.

3. Select the dihedrals in the Dihedrals list.

The dihedrals are selected for each selected residue, and the number of dihedrals is displayed
below the table. If Show markers is selected, the dihedrals are marked in the Workspace. 
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6.4 Using the Edit Menu

The Edit menu also has a set of tools for picking atoms, on the Pick and Select Atoms

submenus. You can choose the structural unit to pick from the Pick submenu, which also sets
the structural unit on the Select atoms toolbar button menu. To pick atoms, choose Edit →
Select Atoms → Pick to Select, which is the same as clicking the Select atoms toolbar button,
or pressing the ` key (backquote). 

In addition to selecting atoms by picking, the Select Atoms submenu has items to select all
atom (All), clear the selection (None), invert the selection (Invert), select the previous or next
residue (Previous/Next), or open the Atom Selection dialog box.

6.5 The Atom Selection Dialog Box

If you want to make atom selections based on more complex criteria, such as selecting all the
carbon atoms in a protein backbone, you can use the Atom Selection dialog box. The Atom

Selection dialog box allows you to select atoms by defining complicated ASL expressions
without the need to understand the ASL syntax.

Figure 6.4. The Atom Selection dialog box.
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To open the Atom Selection dialog box, choose Select from a button menu or click Select in the
picking tools of a panel. The Atom Selection dialog box is modal: you must dismiss it before
you can perform any other operations, with the exception of rotation and translation of struc-
tures and selecting atoms in the Workspace. 

When you close the Atom Selection dialog box, the ASL expression is automatically stored and
can be recalled with the Previous button on any set of picking tools.

To select atoms

1. Create an atom group by selecting a property and value (see Section 6.5.1 on page 126).

2. Click Add or Subtract to define the current selection (see Section 6.5.4 on page 127).

3. Create more atom groups as needed and click Add, Subtract, or Intersect to modify the
current selection (see Section 6.5.4 on page 127).

4. When you are satisfied with the current selection, click OK to apply the operation to the
selection. 

Some operations, such as deleting atoms, take effect immediately. Others merely define a set of
atoms to be used in a subsequent task, such as selecting atoms for creation of a surface. 

The features of the Atom Selection dialog box are described in the following sections.

6.5.1 Selecting Atoms by Property

You can create an atom group by selecting a property and a value for that property. These prop-
erties are grouped into a number of categories, each in their own tab: Atom, Residue, Molecule,
Chain, and Entry. For each category there is a list of properties shown on the left of the tab,
from which you can select one item. When you select an item, tools for that property are
displayed in the center of the tab. The three types of tools are:

• Text box. You can specify the allowed values for the property by using lists of numbers,
closed ranges (e.g. 12-42) and open ranges (e.g. >= 30). 

• List. You can choose one or more entries from the list by clicking, in combination with
the SHIFT and CTRL keys. Only items that are currently in the Workspace are displayed
in the list.

• Set of options, which can be nested. You can choose only one of the possible combina-
tions by selecting the options.

With text boxes and lists, you can also choose items by selecting atoms in the Workspace. For
example, if you choose the Element property in the Atom category, then select a carbon atom in
the Workspace, the “C” item in the list of elements is selected. 
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The current atom group is represented in two ways: the atoms are marked in purple in the
Workspace (if Show markers is selected) and the value in the Atoms Matching field indicates
how many atoms are matched by the current property specification.

6.5.2 Selecting Atoms by Connectivity 

You can create an atom group by specifying a substructure in the Substructure tab that defines
the connectivity of the atoms. This is a convenient way of selecting all instances of a particular
functional group, for example.

Maestro provides access to two substructure notations, SMARTS, and Maestro. The Maestro
substructure notation is described in Appendix C, and is similar to SMARTS. To select atoms
that match a particular substructure, type the pattern for the substructure in the text area. If you
select SMARTS notation, you can automatically generate the pattern from the Workspace
selection by clicking Get From Selection. You can make the selection in the Workspace while
the Atom Selection dialog box is open. A SMARTS pattern that matches the selection replaces
the content of the text area. If there are many atoms in the Workspace, it may take some time.
You can set preferences for some of the notational elements in the SMARTS pattern—see
Section 14.15 on page 382.

6.5.3 Selecting Atoms Using Previously Defined Sets or Selections

In the Sets tab, you can select atom sets that have been defined previously. Maestro provides a
list of predefined atom sets. You can also define your own sets, either directly in the Sets panel,
or by using the Atom Selection dialog box to select the atoms, then clicking Create Set. These
named sets are stored with the project and are available in the Sets tab. The sets are stored as
ASL expressions, unless you convert them to a list of atom or residue numbers. They can there-
fore be transferred from one structure to another. You can use the Sets panel to select atoms in
any of the sets you have created—see Section 10.4 on page 259 for details.

There are two other ways of recalling a previously defined atom selection. The first is to click
Previous (below the ASL text box), which recalls the atom selection defined the last time the
Atom Selection dialog box was used. The second is to click Selection, which uses the atoms
that are selected in the Workspace as the ASL expression. Both of these buttons replace the
current ASL expression: any existing expression is lost. You can add to these expressions, so
they are useful as a starting point for a more complex expression. 

6.5.4 Combining and Modifying Atom Selections

Once you have created an atom group, you can combine it with the current selection. The Add,
Subtract, and Intersect buttons combine the ASL expression for the atom group with the
existing ASL expression in the ASL text box (the current selection), as follows: 
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• The Add button includes the atom group in the current selection by performing a boolean
OR operation on the ASL expressions. 

• The Subtract button excludes the atom group from the current selection by performing a
boolean AND NOT operation on the ASL expressions. 

• The Intersect button restricts the selection to the atoms that are in both the atom group
and the current selection by performing a boolean AND operation on the ASL expres-
sions. 

Note: Intersect is not available for the first atom group that is defined.

In addition to combining ASL expressions to modify the current selection, you can use the
following buttons:

• All—select all atoms in the Workspace. Replaces the existing expression.

• Undo—undo the last operation

• Redo—redo the last operation

• Clear—clear the ASL expression 

• Invert—negate an entire expression

• Previous—recall the atom selection defined the last time the Atom Selection dialog box
was used. Replaces the existing expression.

• Selection—use the atoms that are selected in the Workspace as the ASL expression.
Replaces the existing expression.

• Atom Num—convert the ASL expression to list each atom explicitly by atom number

• Res Num—convert the ASL expression to list each residue explicitly by residue number

If Show Markers is selected, the atoms corresponding to the current selection (the expression in
the ASL text box) are highlighted with light blue markers in the Workspace.

6.5.5 Selecting Atoms by Proximity

Once you have made an initial selection, you can select atoms based on their distance from the
atoms defined by the current ASL expression (the source atoms) in the Proximity dialog box,
see Figure 6.5 on page 129. To open this dialog box, click Proximity.

You can specify the distance in angstroms or in terms of the number of bonds. If the boundary
for inclusion intersects a molecule or a residue, you can choose to include the entire molecule
or residue using the Fill buttons. 
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Figure 6.5. The Proximity dialog box.

You can either include or exclude the source atoms in the selection. For example, you might
want to include residues within a certain distance of a metal atom, but not include the atom
itself. The Update Markers button updates the markers for the proximity selection so that you
can view the selection in the workspace before accepting it.

6.5.6 Editing and Storing Expressions

You can undo multiple operations with repeated clicks on the Undo button. The Redo button
reverses undo operations, and can also be used multiple times. (These are the buttons in the
dialog box, not the toolbar button.)

You can also type ASL expressions directly into the ASL text box. The hand-edited expressions
are considered part of the last operation performed with the mouse and can be undone and
redone as part of that operation, but cannot be undone or redone separately.

The Create Set button opens a dialog box that enables you to name and store the existing ASL
expression for use as a set definition. The sets created in this manner are the same as sets
created with the Sets panel, and are listed in the Set tab. You can therefore create sets from the
Atom Selection dialog box, and use them for atom selection later. For more information on
creating and saving sets, see Section 10.4 on page 259.

6.5.7 Converting Expressions to Lists

ASL expressions are stored as formal expressions that can be applied in different contexts to
select different sets of atoms. If you want an expression that explicitly lists the atom numbers
or the residue numbers, you can convert the ASL expression in the ASL text box into a list of
atoms by clicking Atom Num, or into a list of residues by clicking Res Num. 
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6.5.8 Examples of Atom Selection

Below are some examples of the use of the Atom Selection dialog box. It is assumed that you
have the Atom Selection dialog box open. To apply your selection and dismiss the dialog box,
click OK. These examples assume that the protein and the ligand are in separate entries in the
Workspace.

To select all carbon atoms in the backbone of a protein:

1. In the Atom tab, select Element from the list of properties.

2. Select C from the list of elements.

3. Click Add to add the atom group to the ASL expression.

4. Select Backbone/Side Chain from the list of properties.

5. Select the Backbone option.

6. Click Intersect to restrict the current ASL expression to be applied only to protein back-
bone atoms.

If you want to continue to the next example, click Clear to clear the current ASL expression.

To select all side chains within 5.0 Å of a ligand in the active site of a ligand/receptor 
complex:

1. In the Entry tab, select the entry name for the ligand from the list of entries.

2. Click Add to make this entry name the current ASL expression.

3. Click Proximity to open the Proximity dialog box 

4. Enter 5.0 in the text box, click Residues in the Fill section, select Exclude source, then
click OK.

5. In the Residue tab, select the Backbone/Side Chain property.

6. Select the Sidechain option.

7. Click Intersect to restrict the current ASL expression to include only atoms in the protein
side chain.

8. If you want to continue to the next example, click Clear to clear the current ASL expres-
sion.
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To select a range of residues but exclude proline residues:

1. In the Residue tab, select Sequence from the property list.

2. Select the appropriate chain from the list of chains in the top scrolling list.

3. Select a range of residues in that chain from the lower scrolling list.

4. Click Add to make this residue range the current ASL expression.

5. Select the Residue Type property.

6. Select PRO from the list of residue types.

7. Click Subtract to exclude proline residues from the current ASL expression.

6.6 Storing the Workspace Selection

When you have made an atom selection, you can also store the selection in a memory location.
To do so, ensure that the pointer is in the Workspace, then press CTRL+numeral-key (for
example, CTRL+3), or choose Edit → Select Atoms → Save → Selection number. The selec-
tion is stored in the memory location corresponding to the numeral key or number. To retrieve
the selection, simply press the numeral key when the pointer is in the Workspace, or choose
Edit → Select Atoms → Restore → Atom Selection number. 

Selections are stored as an ASL expression that consists of the atom numbers relative to the
Workspace of the selected atoms. When you change the contents of the Workspace, the atom
numbers can change. If you retrieve a selection from memory after changing the Workspace
contents, the selection is applied to the current atom numbering, and might result in a selection
that is different from what you expected. However, if you replace the Workspace contents with
a conformer of the previous contents, for example, the stored atom selections should apply to
the corresponding atoms in the conformer.

For a more general storage facility, you can create atom sets in the Sets panel. See Section 10.4
on page 259 for more information. These stored selections are not the same as the named atom
sets, as they can only be defined and used in the Workspace. 
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Chapter 7: Changing the Appearance of Structures 
Maestro provides a wide selection of options for displaying structures. For example, you can
change the color of some or all of the atoms, change the molecular representation in which the
atoms are depicted, label atoms by their properties, or selectively undisplay certain atoms so
that you can better examine small subsections of a structure. 

7.1 The Representation Toolbar

Many of the features for changing the appearance of structures are available from the Repre-

sentation toolbar. The toolbar buttons are described in brief below, and their use is discussed in
the following sections.

Ribbon 
Show, hide, or color ribbons. From the button menu you can choose to display ribbons for all, 
selected, or displayed residues; delete ribbons; and display various combinations of atoms that 
are associated with the ribbons; and choose various coloring schemes for the ribbons. Click to 
pick residues for display of ribbons. Double-click to display ribbons for the selected atoms, or 
for all atoms if no atoms are selected.

Wire 
Draw bonds in wire frame representation. From the button menu you can select a structural 
unit to use when picking atoms to display in wire representation. Double-click to apply to the 
selected bonds, or to all bonds if there is no selection. 

CPK 
Draw atoms in CPK representation. From the button menu you can select a structural unit to 
use when picking atoms to display in CPK representation. Double-click to apply to the 
selected atoms, or to all atoms if there is no selection.

Ball & Stick 
Draw atoms and bonds in ball-and-stick representation. From the button menu you can select a 
structural unit to use when picking atoms to display in Ball & Stick representation. Double-
click to apply to the selected atoms, or to all atoms if there is no selection. 

Tube 
Draw bonds in tube representation. From the button menu you can select a structural unit to 
use when picking atoms to display in tube representation. Double-click to apply to the selected 
bonds, or to all bonds if there is no selection. 

Thin Tube 
Draw bonds in thin tube representation. From the button menu you can select a structural unit 
to use when picking atoms to display in tube representation. Double-click to apply to the 
selected bonds, or to all bonds if there is no selection.
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7.2 Changing Atom, Bond, and Background Color

Changing the color of a structure can help you to visualize its properties and its three dimen-
sional structure. The Atom and Bond Coloring panel allows you to apply a new color to all or
some of the Workspace atoms and bonds, or to use predefined or user-defined schemes to color
specific atom groups. You can also use the shortcuts available in the toolbar to change the atom
coloring. The default color is set in the Preferences panel—see Section 14.14.1 on page 378.

To open the Atom and Bond Coloring panel, choose Workspace → Atom and Bond Coloring. 

This panel is a dockable panel, that opens by default docked in the main window. To change
this behavior you can set preferences—see Section 14.1.6 on page 339.

Figure 7.1. The Atom and Bond Coloring panel, showing both tabs.

7.2.1 Applying a Single Color to Atoms and Bonds

To apply a single color to some or all atoms or bonds in the Workspace, you can use the tools in
the Atom Color or Bond Color tab. Select Constant color under Color atoms by or Color bonds
by, then select a color by clicking the color button in the Atom Color tab to open a standard
color selector, or clicking the color button in the Bond Color tab to display a color palette. Once
you have selected a color, use the picking tools or the selection button in the Apply constant
color section to apply the color to selected atoms or bonds. For a wider range of bond colors,

Color Scheme 
Color all atoms with a chosen color scheme. From the button menu you can choose the 
scheme, as defined in the Color Schemes tab of the Atom Coloring panel. The custom color 
schemes for carbon atoms and ligands are on a submenu. 

Color 
Color the picked residues with a constant color, which you can choose from the button menu. 
Double-click to apply the color to the selected atoms, or to all atoms if there is no selection.
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the color palette has an Advanced button, which opens the Choose Color dialog box, where you
can modify the palette and choose colors by RGB value.

You can also apply a color from the Color button menu on the Representation toolbar.

This button displays a menu from which you can choose from a selection of colors. The color
choice is persistent. You can then pick residues to apply the color, or double-click the button to
apply the color to all atoms. If the color you want to use is not on the menu, you can use the
Atom Color tab to select the color. The RGB value of the colors in the color palette is displayed
in a tool tip. For information on customizing the colors, see Section 13.5.2 on page 325.

7.2.2 Coloring Bonds by Atom Colors

If you want half-bonds to be colored by the atom color, select Atom color under Color bonds by

in the Bond Color tab. This option ties the bond color to the atom color, regardless of how the
atom is colored.

7.2.3 Using Color Schemes to Color Atoms

To apply coloring to some or all Workspace atoms using one of Maestro’s predefined color
schemes, or a custom color scheme, select Color Scheme under Color atoms by in the Atom

Color tab, then select the scheme from the option menu below this option. If you choose one of
the schemes with custom colors (for carbons or ligands), choose the color from the custom
color option menu (labeled Carbon color or Ligand color). Once you have selected a scheme,
use the picking tools to select the atoms you wish to color.

You can apply a color scheme to all atoms in the Workspace from the Color all atoms by

scheme button menu in the toolbar. 

When you click on the arrow to the right of the button, a menu is displayed from which you can
choose the scheme. The custom carbon and custom ligand schemes are in submenus. The color
scheme is applied when you make your menu choice. 

If you want to see a description of the color scheme, click Color Schemes, which opens the
Color Schemes panel. This panel allows you to view the description of the color scheme. For
details of the actual colors applied, click Edit in this panel. The Edit Color Schemes dialog box
lists the details of the colors and the criteria used to apply them. Use of this panel is described
below. The standard color schemes are described in Table 7.1. 
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Table 7.1. Standard color schemes

Scheme Description

Atom PDB B Factor 
(Temperature Factor) 

Apply a spectrum of colors to atoms depending on the PDB temperature 
factor (B factor).

Atom Partial Charge Apply a spectrum of colors to denote sign and magnitude of charge. 

Atom Type (MacroModel) Colors each atom type by the older MacroModel coloring scheme. 

Chain Name Color each chain with a unique color corresponding to its single-letter 
name. 

Density Fit Color atoms according to the value of the PrimeX density fit. 

Element Color atoms according to their atomic number. Light elements continue 
to have their standard Maestro colors, as in the Atom Type scheme. Other 
elements are divided into several groups, and each group has a unique 
color. For example, the first row of transition metals is turquoise. In this 
color scheme, atoms of the same element are always the same color, 
regardless of their formal charge or MacroModel atom type. This is the 
default coloring scheme.

Element (Light Carbons) Color atoms according to their atomic number, as in the Element scheme, 
except that carbon atoms are light gray, and hydrogens are cyan. 

Element (color Carbons) Color atoms according to their atomic number, as in the Element scheme, 
except that carbon atoms are colored with the stated color. These schemes 
appear under the heading Element (Custom Carbons).

Element (color Ligand) Color atoms according to their atomic number, as in the Element scheme, 
except that atoms in the ligand are colored with the stated color. These 
schemes appear under the heading Element (Custom Ligand).

Element (Entry Carbons) Color all atoms except carbon atoms according to their atomic number, as 
in the Element scheme, and colors carbon atoms by entry number, cycling 
through a list of 12 colors. 

Element (Chain Name 
Carbons)

Colors carbon atoms by chain name, using 26 colors for names A–Z and 
repeating for names 1–26, and colors other atoms by Element. 

Element (Molecule 
Number Carbons)

Colors carbon atoms by molecule number, cycling through a list of 12 
colors, and colors other atoms by Element. 

Entry Colors atoms according to the entry to which they belong. The scheme 
cycles through a list of 12 colors. 

Entry ID Colors atoms according to the entry ID of the entry to which they belong. 
The scheme uses a list of 12 colors, applying them by the value of the 
entry ID, modulo 12: thus, each entry whose remainder when the entry ID 
is divided by 12 has the same color. 
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Hydrophobicity Three schemes for hydrophobicity are available: Li-Tang-Wingreen 
(Phys. Rev. Lett. 1997, 79, 765), Kyte-Doolittle (J. Mol. Biol 1982 157, 
105), and Black-Mould (Anal. Biochem. 1991, 193, 72). All three 
schemes rely on the residue name to determine the appropriate property 
value for the color scheme. 

Molecule Number Color each molecule by number. The scheme cycles through a list of 12 
colors. 

Molecule Size Color atoms by molecule size, making it easier to locate ligands in a 
structure. 

PDB Conversion Status Color residues in structures imported from the PDB by the status of their 
conversion:
Gray  Standard residues, no conversion problems
Green  Residue with alternate position indicator
Blue  Standard residue with unknown atom names
Cyan Residue adjacent to gap
Red  Standard residue with missing atoms
Orange  Non-standard residue, bond orders may need correcting

Residue Charge Color amino acid residues according to charge. Positive charges are blue, 
negative charges are red.

Residue Property Color amino acid residues according to hydrophobicity, charge, and 
polarity.
gray GLY and atoms without PDB residue names
dark green Hydrophobic residues: ALA, CYS, ILE, LEU, MET, PHE, 

TRP, TYR, VAL, PRO   
cyan Polar uncharged: SER, THR, HIS, GLN, ASN
blue Positively charged: LYS, ARG 
red Negatively charged ASP, GLU 
purple Purines: G, A, I 
sienna Pyrimidines: C, T, U 

Residue Position Color amino acid residues by residue number. The first 10% (including 
the N-terminus) of the residues in a chain are dark blue, the last 10% (C-
terminus) are red and there is a color ramp between those ends. 

Residue Type Color amino acid residues by residue type. 

Residue Type (spectrum) Color amino acid residues by residue type, with finer distinctions 
between conservatively mutated and conserved residues. 

Secondary Structure Color residues according to protein secondary structure (strand, loop, 
helix). To assign secondary structure, choose Assign Secondary Structure 
from the Tools menu. 

Table 7.1. Standard color schemes (Continued)

Scheme Description
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7.2.4 Creating and Editing Color Schemes

If you want to adjust an existing color scheme, or create a new color scheme, click Color
Scheme in the Atom Color tab of the Atom and Bond Coloring panel. The Color Schemes panel
opens, in which you can You can edit an existing color scheme, copy an existing scheme to
edit, or create a new scheme from an atom property.

To examine or edit a color scheme, first select it in the color schemes list. The list is synchro-
nized with the Color scheme option menu in the Atom Color tab of the Atom and Bond Coloring
panel, so the scheme you chose in that panel is the default selection in the color scheme list.

Figure 7.2. The Color Schemes panel.

New color schemes can be created from atom properties for which schemes do not already
exist. To create a new scheme that is not based on an atom property, or is based on an atom
property for which a scheme already exists, you can copy the scheme, by selecting it in the list
and clicking Copy, and then edit it.

To edit a color scheme, select it in the list, and click Edit. The Edit Color Scheme dialog box
opens, and allows you to change the scheme. If the scheme is not a standard color scheme, you
can change the name in the Name text box. You can modify the description of the scheme in
the Description text box.
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Figure 7.3. The Edit Color Scheme dialog box.

Color schemes are defined in terms of rules, which are applied in order. The first rule has the
lowest priority, and can be superseded by any of the subsequent rules. Each rule is defined by
an ASL expression, and a color is assigned to that rule. The rules, their descriptions, and their
colors are listed in the Rules table.

• To add a new rule, click New. A new rule is added to the end of the table.

• To insert a rule after an existing rule, select the rule and click Copy. The copy is inserted
after the selected rule, and the selection is moved to the copy.

• To delete rules, select the rules and click Delete.

• To revert the rules for a standard scheme to their defaults, click Reset All. This button is
not available for custom color schemes.

• To change the color for a given rule, click the color cell, and choose a new color in the
Choose Color dialog box.

• To set the colors for multiple rules from a color ramp, select the rules, choose the color
ramp from the Color ramp option menu, and click Apply.

• To change the description for a rule, edit the table cell.
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• To change the ASL expression for a rule, do one of the following:

• Edit the ASL cell directly to change the expression
• Right-click and choose Element, then one of the common elements.
• Right-click and choose Residue Type, then one of the standard residues.
• Right-click and choose Select to set up the ASL expression in the Atom Selection

dialog box.

To preview the color scheme, you can apply it by using the tools in the Atom Color tab of the
Atom and Bond Coloring panel.

To create a new color scheme from an atom property, click New. The New Color Scheme dialog
box opens, and you can enter a name, select an atom property from the list, set the minimum
and maximum values of the property for the color scheme, the number of colors to use and
choose a color ramp. If you want some idea of the range of property values, include a molecule
in the Workspace that has a typical range, and click Update. The minimum and maximum
values for this molecule are entered into the Min and Max text boxes. When you have made
settings, click OK to create the new scheme.

Figure 7.4. The New Color Scheme dialog box.

New or edited color schemes are stored in your Maestro user resources directory. For informa-
tion on color scheme and color ramp files, see Section 13.5 on page 324. 

You can export and import color schemes, by clicking Export or Import in the Color Schemes
panel. These buttons open standard file selectors, in which you can browse to the appropriate
location for the color scheme file. 
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To delete a color scheme, select it in the color scheme list, and click Delete. You cannot delete
standard schemes, only custom schemes. To remove all custom schemes and revert to the stan-
dard schemes, click Reset All.

7.2.5 Setting the Background Color

The default background color of the main window is black, but the color can be changed to
adjust the contrast between the background and the Workspace atoms. To change the back-
ground color, choose Workspace → Appearance in the main window and select the Back-
ground tab. You can set the color by clicking the color button and choosing a color in the
standard color selector that opens, or you can use one of the five preset colors. The preset
colors are also available from the shortcut menus in the Workspace.

7.3 Changing Molecular Representations

The molecular representation is the way in which atoms, bonds, and protein chains are drawn
in the Workspace. Atoms can be drawn as points or as spheres, and bonds can be drawn as lines
(wires) or as tubes. Protein chains can be drawn as flat “ribbons” or as tubes, representing the
secondary and tertiary structure of the protein rather than the atoms. 

The basic choice of the type of representation can be done in the Molecular Representation

panel and the Ribbons panel, with corresponding toolbar items for the main actions. These
choices are described in the sections below. The details of the rendering of these objects, as
well as default choices of the type of representation and other settings, are made in the Molec-

ular Representation settings group in the Preferences panel,—see Section 14.14 on page 378. 

These panels are dockable panels, that open by default docked in the main window. To change
this behavior you can set preferences—see Section 14.1.6 on page 339.

7.3.1 Changing the Representation of Atoms And Bonds

In the Molecular Representation panel, you can change the representation of atoms and bonds.
These representations are not entirely independent: most of the options set both the atom repre-
sentation and the bond representation. 

To open the Molecular Representation panel, choose Workspace → Molecular Representation. 

At the top of the panel, you can set the representation for all atoms in the Workspace to one of
the five main representations: wire frame (lines), thin tubes, tubes, ball and stick, or CPK
(spheres). The buttons you use to set these representations are the same as on the Representa-
tion toolbar (see Section 7.1 on page 133). 
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Figure 7.5. The Molecular Representation panel.

Under Atom representation, you can choose between three options for the representation of
atoms, with the corresponding bond representation. The options are:

• None—no representation of atoms, with bonds represented as wires.

• Ball & Stick—represent atoms as spheres, and bonds as tubes.

• CPK—represent atoms as large spheres, using the van der Waals radii of the atoms for the
sphere radii. The bond representation is not changed if you set it with the Bond represen-

tation options; otherwise it reverts to wire.

To apply the atom representation, use the picking tools in the Apply current representation to

atoms section to select atoms to apply the representation. 

Under Bond representation, you can choose between four options for the representation of
bonds, with the corresponding atom representation. The options are:

• None—no representation of bonds. This option only sets the bond representation; the cur-
rent atom representation remains in effect.

• Wire—represent bonds as wires (lines), with no representation of atoms.

• Thin tube—represent bonds as thin tubes, with atoms represented by spheres the same
size as the tubes (i.e. caps to the tubes).

• Tube—represent bonds as tubes, with atoms represented by spheres the same size as the
tubes (i.e. caps to the tubes).

You can mix representations within a single molecule by picking. When you do so, the half of
each bond that is attached to each atom that is picked is represented with the chosen bond style.
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You can apply a molecular representation to atoms using the buttons on the Representation

toolbar.

Click the arrow next to any of the buttons to pick the structural unit to apply the representation
to. Double-click the button to apply the representation to the selected atoms, or to all atoms if
there is no selection. 

For atoms represented in CPK, the depth view can be enhanced using an approximate calcula-
tion of ambient occlusion, which takes into account the ambient lighting that is blocked by
nearby atoms. To enable the enhancement, select Enhanced depth view under Workspace –

Depth view in the Preferences panel or from the Workspace menu in the main window, or press
D when the pointer is in the Workspace. 

7.3.2 Rendering Proteins, DNA, and RNA as Ribbons

In the Ribbons panel you can display protein backbones as a ribbon diagram and DNA and
RNA as a ladder diagram. Displaying ribbons can simplify the analysis of secondary and
tertiary structures. You can choose from seven ribbon styles and nine color schemes, and apply
the ribbon style by picking or using the Atom Selection dialog box. You can mix representa-
tions within a single protein by picking. 

To open the Ribbons panel, choose Workspace → Ribbons.

Figure 7.6. The Ribbons panel, showing tools for color schemes.
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Ribbons are defined by a style and a color scheme. The choices of style are:

• Cartoon—display loops as thin tubes, sheets as arrows and helices as ribbons.
• Ribbon—thin, curved flat surface that follows the backbone.
• Tube—curved tube that follows the backbone.
• Thin Tube—thin curved tube that follows the backbone. 
• Curved Line—curved line that follows the backbone. 
• CA Trace—straight line that connects alpha carbon atoms. 
• CA Trace Tube—straight tube that connects alpha carbon atoms. 

The Color scheme option menu provides a range of properties which can be used to select the
color scheme, such as residue properties and secondary structure. Each of these has a
predefined set of colors that is applied to the ribbon.

With the exception of the CA Atom Color scheme, the color schemes are described in the Color

Scheme tab of the Atom Coloring panel (see Section 7.2.3 on page 135). In the CA Atom Color
scheme, the ribbon is colored with the current color of the alpha carbon atoms. Thus, if you
change the color of certain residues and reapply this color scheme, the section of the ribbon for
which you changed the residue color changes color to match. 

In the Ribbon or the Cartoon style, helices can be colored the same color on both sides of the
ribbon, or the inside can be colored gray. The choice between these two is made by setting a
preference in the Molecular Representation – Ribbons section of the Preferences panel (see
Section 14.14.2 on page 380).

Two of the color schemes have other choices that you can make. The controls for these choices
are displayed in the panel when you choose the color scheme—see Figure 7.6—and are
described below. 

• Constant color—Choose the color to use for coloring the ribbons. This option menu is
only available if you choose Constant color from the Color scheme option menu. 

• Residue position limits—These options allow you to set residue number limits for apply-
ing the Residue position color scheme, and are only available when that scheme is chosen
from the Color scheme option menu. Residues with residue numbers outside the range
are colored with the color for the end of the range. Insertion codes are ignored.

• Lower limit—Select this option to set the lower limit for coloring, and enter the low-
est residue number in the text box.

• Upper limit—Select this option to set the upper limit for coloring, and enter the high-
est residue number in the text box.
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To apply the chosen style and color scheme, you can use the picking tools in the Apply ribbons

to atoms section. You can apply the current scheme to all existing ribbons by clicking Update
All Ribbons. 

You can apply the color schemes and the display options using the Ribbons toolbar button. 

If you want to change the quality of the ribbons, the blending of ribbon colors, or the width or
thickness of the ribbons, strands, tubes, or ladders, click Preferences. The Preferences panel
opens at the Molecular Representation – Ribbons section. You can also control which of the
atoms that are associated with the ribbons are displayed when ribbons are created. See
Section 14.14.2 on page 380 for more information.

You can change the atom visibility with the usual display tools. In addition to these, the Show,
hide or color ribbons button menu offers a number of options for the display of ribbons and the
associated atoms:

• Show Ribbons for All Residues 
• Show Ribbons for Selected Residues 
• Show Ribbons for Displayed Residues 
• Select Atoms to Display Ribbons 
• Display Atoms 
• Undisplay Atoms 
• Display Side Chains Only 
• Delete Ribbons 

The first three items create the ribbons for the particular choice of residues, while the fourth
item opens the Atom Selection dialog box so you can choose residues for the ribbons. The next
three items display or undisplay atoms associated with the ribbons.

7.4 Changing Lighting, Materials, and Special Effects

The lighting effects and the materials that objects in the Workspace appear to be made of can
be changed in the Appearance panel, which you open by choosing Workspace → Appearance.
Special effects can also be added to enhance the appearance of objects in the Workspace. 

The Lighting tab of the Appearance panel contains controls for the lighting effects on objects in
the Workspace. There are two available light sources, light1 and light2, which you can control
independently. Maestro normally only uses one light source. To edit the parameters for one of
the light sources, select it in the list, and then select Use light if it is not selected. The controls
then become available.
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Figure 7.7. The Lighting tab in the Appearance panel.

The Light direction control allows you to pick the direction of the selected light, and also
displays the parameters that you set. To change the direction, click the desired location on the
red ball, or drag the yellow spot to the desired location. 

You can change three parameters of the lighting of objects in the Workspace. Each parameter
has a slider and a text box. 

• Ambient—Set the intensity of the ambient (nondirectional) light. This value affects the
shade of the object on the side away from the light source. A value of 100 means that
there are no shadows. 

• Diffuse—Set the intensity of diffuse (nondirectional) reflection from the object. and text
box. A value of zero means that there is no (or minimal) reflection from the object, and so
it appears to be dark. 

• Specular—Set the intensity of the specular reflection (“highlight”) of the object. The
highlight is essentially the image of the light source, diffused somewhat by the material
of the object. To change the character of the specular reflection, use the controls in the
Materials tab. 

You can restore the default values for a light source by clicking Restore Defaults.
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The Materials tab contains controls for the definition of the appearance of the objects in the
Workspace. You can set the appearance characteristics of different object types: atoms and
bonds, ribbons, surfaces, hypotheses, Phase QSAR objects. To make settings for one of these
object types, first choose the type from the Object type option menu, then make the settings. 

Figure 7.8. The Materials tab in the Appearance panel.

There are four preset material types, given in the Preset section: Metallic, Plastic, Rubber,
Wood. These material types correspond to particular settings of the five parameters in the
Custom section. 

The Custom section allows you to set the five properties of the material:

• Ambient—Intensity of the ambient (nondirectional) lighting
• Diffuse—Intensity of diffuse (nondirectional) reflection
• Specular—Intensity of specular reflection (the “highlight”)
• Emission—Intensity of nondirectional light emission from the object
• Shininess—Size and brightness of the highlight (specular reflection). Larger values pro-

duce a smaller and brighter highlight.

Each property has a slider and a text box. You can use either of these controls to set the prop-
erty value. Setting all five parameters has a performance cost, because there is a balance
between them. The Minimize performance cost option disables the Ambient and Diffuse
controls, and uses these properties to track color. This option is only present for OpenGL level
1.2, as the performance cost for 2.1 is negligible.
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The Environment map option menu provides a selection of environments (“pictures”) that are
shown as reflections on the surfaces of the objects in the Workspace. This menu is only present
when the OpenGL level is 2.1.

You can restore the default material values for an object by clicking Restore Defaults.

Some combinations of lighting and material are available from the Style toolbar—see
Section 7.6 on page 154.

Special effects can be added to structures in the Effects tab. There are four effects available,
which can be combined. These effects apply to the entire screen (Workspace). Other effects
can be added to specific objects, as highlights—see Section 8.5 on page 168. Some of the
screen effects are also available as preferences, though with limitations. 

Figure 7.9. The Effects tab in the Appearance panel.

• Antialiasing—smooth the edges of objects so they don't appear jagged. This effect does
not antialias semi-transparent objects. The Full-scene antialiasing preference
(Section 14.4.16 on page 355) does, but it does not antialias spheres and cylinders (balls
and sticks). For the smoothest edges, use both the preference and the screen effect.

• Ambient occlusion—enhance the perception of depth by taking into account the ambient
lighting blocked by nearby objects, pixel by pixel. The Enhanced depth view preference
(Section 14.4.12 on page 354) uses ambient occlusion based on atoms, and is only avail-
able for structures in CPK representation. This option is most useful for large structures
in CPK representation and with molecular surfaces.
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Figure 7.10. Use of ambient occlusion. From left to right: no effect, Enhanced depth view 
preference (atom based), Ambient occlusion screen effect (pixel-based).

You can set the intensity of the darkening effect with the Intensity slider and box. The
intensity is represented as a percentage, with 0 corresponding to no effect. You can also
change the range of the effect, with the Radius slider and box. Any screen object within
the specified radius of a pixel is considered to occlude the pixel. Thus, the smaller the
radius, the more local and “sharp” the effect. At a very small radius, the effect is like
outlines.

• Outlines—Add a thin outline to objects in the Workspace. You can set the width of the
outline (in pixels) in the Width text box, and you can set the color with the color button.

• Cartoon shading—Use cartoon shading, in which the color or shading is done in steps
rather than continuously. You can set the number of steps in the Steps text box.

This tab is not present if the OpenGL level is 1.2, as it requires features that are not present at
this OpenGL level.
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7.5 Displaying and Undisplaying Atoms

Maestro provides a range of tools for selectively displaying or undisplaying atoms. These tools
are available in the Display/Undisplay Atoms panel, on the Display toolbar, and on the Selection
shortcut menu. Maestro also provides tools for displaying atoms that are related by crystallo-
graphic symmetry and alternate positions for atoms.

7.5.1 The Display Atoms Toolbar

Many of the operations for displaying or undisplaying atoms are available from the Display

Atoms toolbar, and some of them are only available from the toolbar. The toolbar buttons are
described in brief below, and their use is described in the following sections. 

7.5.2 Selectively Displaying Atoms

You can display or undisplay (hide) atoms using the toolbar buttons or the Display/Undisplay

Atoms panel. These tools allow you to select the atoms that are displayed or are not displayed
in the Workspace. For example, you can hide from view all atoms, user-defined atom subsets,
or predefined subsets such as protein backbones, side chains, water molecules, or hydrogen
atoms. 

Display Sel 
Display only the selected atoms. This button has a menu from which you can choose a struc-
tural unit to use when picking atoms for display. Choose a structural unit, then click on an 
atom to display the atoms in that unit only. Double-click to display only the selected atoms, or 
all atoms if there is no selection. 

Display Only 
Display only the atoms in a particular category. From the button menu, you can select a cate-
gory of atoms to display, or open the Atom Selection dialog box to select atoms to display.

Also Display 
Add the atoms in a particular category to the display. From the button menu you can select a 
category of atoms to add to the display, or open the Atom Selection dialog box to select atoms 
to add to the display.

Undisplay 
Undisplay (hide) atoms in a particular category. From the button menu you can select a cate-
gory of atoms to undisplay, or open the Atom Selection dialog box to select atoms to undis-
play. 

Within 
Display residues within a specified distance of the currently displayed atoms. Entire residues 
that have any atoms within this distance of the displayed atoms are added to the display. From 
the button menu you can select a specific distance, or open a dialog box to enter a distance. 
Clicking the button performs the action.
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Displaying and undisplaying atoms is not the same as including or excluding entries from the
Workspace: it is merely changing the visibility of the atoms that are part of entries included in
the Workspace. The display state is stored with the project entry, so when you include it in the
Workspace later on, the same atoms are displayed or hidden. Undisplaying atoms is not the
same as deleting atoms, which removes them from the project entry.

To open the Display/Undisplay Atoms panel, choose Display/Undisplay Atoms from the Work-

space menu (see Figure 7.11).

Figure 7.11. The Display/Undisplay Atoms panel.

The Display/Undisplay Atoms panel is divided into sections for the following three operations. 

• Also Display—add the selected atoms to the atoms that are already displayed.
• Undisplay—do not display the selected atoms.
• Display Only—display only the selected atoms.

You can choose the atoms for the operation using the picking tools. You can also pick atoms to
display using the Display Sel button on the toolbar:

You can apply the display operation to a range of common atom groups using the Atom Selec-
tion button.

The common atom groups are also available from the toolbar on the Display Only, Also Display,
and Undisplay button menus:

You can also choose Select from these button menus to open the Atom Selection dialog box and
select the atoms to display or undisplay. If you already have a selection that includes atoms that
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are not displayed, you can add the molecules or residues that are included in this selection by
choosing Display → Molecules or Display → Residues from the selection shortcut menu.

As a special case of adding to the display, you can add atoms to the display that are within a
given distance of the displayed atoms, by using the Display residues within N Å of currently
displayed atoms toolbar button menu:

This button menu offers a selection of distances, and a Custom item that allows you to set the
distance in a dialog box. All atoms in residues that have any atom within the specified distance
are added to the display, except for nonpolar hydrogens. If you want nonpolar hydrogens to be
displayed as well, you can set a preference under Workspace – Display/undisplay atoms in the
Preferences panel. 

If you want to display atoms within a given distance of a selected set of atoms, rather than the
entire displayed set, you can choose the distance from the Display submenu of the Selection
shortcut menu. To display only the selected atoms and those within a given distance, choose
the distance from the Display Only submenu of the Selection shortcut menu. 

7.5.3 Displaying Periodic Structures

Structures that have periodic boundary conditions and crystal symmetry are usually only stored
as the asymmetric unit—the smallest structure that can be replicated with the space-group
symmetry operators to generate the entire crystal. By default, only the asymmetric unit is
displayed in Maestro, but you can display replicas and other information about the periodic
structures. The structures must have the unit cell parameters as entry properties. These proper-
ties are automatically added when you import a PDB structure.

Maestro can display atoms that are related by crystal symmetry—“crystal mates”—for struc-
tures whose unit cell parameters are available as entry properties. The crystal mates are the
nearest-neighbor replicas of the structure in the displayed entry. Display of crystal mates can
be limited to a certain radius of the displayed entry. All residues in the crystal mates that have
atoms within this radius of the displayed entry are displayed. 

• To display all crystal mates, choose All from the Crystal Mates submenu of the Work-

space menu. 

• To display crystal mates within one of four predetermined radii, choose Within radius
from the Crystal Mates submenu of the Workspace menu. 

• To turn off the display of crystal mates, choose None from the Crystal Mates submenu of
the Workspace menu. 
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Some protein structures have alternate positions for atoms—for example, when the structure
contained ligands bound at two different sites, or bound in different conformations. These are
represented as partial occupancies. Maestro reads the alternate positions and stores them as
entry properties. You can display the alternate positions of the atoms by choosing Workspace

→ Alternate Positions, or choosing Display Alternate Positions from the Selection shortcut
menu. The alternate positions are displayed as “ghost” atoms. If you want to make the alternate
positions the main positions, select the atoms, then choose Switch Alternate Positions from the
Selection shortcut menu. 

If you are editing a structure with alternate positions, you can set a preference for whether the
alternate positions are transformed along with the main positions—see Section 14.4.6 on
page 350 for more information.

If you have a crystal structure whose asymmetric unit consists of a small number of atoms (50
to 100), you can use the Periodicity toolbar to display the entire unit cell and multiple
surrounding unit cells, display cations surrounded by anions as polyhedrons, show bonding
information, and calculate properties of the unit cell. The toolbar is described below.

Unit cell 
Draw the unit cell boundaries or the lattice vectors, or both, in the Workspace. The choice of 
what to draw and the appearance can be set in the Preferences panel, under Workspace – 
Periodicity.

Show Atoms 
Choose options for which atoms are shown in the Workspace and how they are shown, from 
the button menu. You can show the symmetry-unique atoms of the unit cell (Symmetry 
Unique Atoms) or all atoms in the unit cell (All Atoms). When displaying all atoms, select 
Intact Molecules to extend connected fragments beyond the unit cell boundaries. If you only 
want to see atoms that are inside a single unit cell, you can select Keep Edge Atoms to display 
the same atom on both sides of the unit cell, if the atom is on a unit cell boundary. 

Calculate Bonds 
Show the connectivity of the structure, displayed as single bonds. Two atoms are considered 
connected if the distance between them is smaller than the sum of their covalent radii plus an 
offset. No account is taken of bond order in the display. Clicking the button or choosing Dis-
play Bonds from the button menu displays the connectivity. Choosing Update Bonds updates 
the connectivity by reapplying the distance criterion. Dynamic Bonds updates the connectivity 
after each change in the Workspace. To adjust the distance offset, choose Options.

Extents 
Display replicas of the unit cell along the lattice vectors. Choose Edit from the button menu to 
set the number of replicas in the positive and negative directions for each lattice vector, in the 
Edit Extents dialog box. The default is zero replicas. Choose Display Extents from the button 
menu to display the replicas. You must also choose All Atoms from the Show Atoms button 
menu to display the replicas.
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7.6 Display Styles

The previous sections in this chapter describe the tools that are available for changing the
appearance of the structures in the Workspace. It is often the case that you want to apply more
than one of these tools to your structure, and you prefer certain display attributes for all struc-
tures. You might also want to apply different display attributes to ligands and proteins. Maestro
provides tools for creating a display “style”, on the Style toolbar.

The Style toolbar allows you to create and apply visual styles for the Workspace contents. The
toolbar also provides easy access to the display of H-bonds and contacts, and generation and
display of molecular surfaces. The style settings made with this toolbar are designed to add
only those components specified, and leave any other style choices as they are. All style
settings are stored as preferences, so that they persist across Maestro sessions. 

The Workspace style is a set of choices for the molecular representation and color scheme of a
number of entities: the ligand, waters, ions, and default settings for all other atoms. It also
includes settings for the display of waters and hydrogens, and for creating receptor and ligand
surfaces. The ligand is detected automatically with settings made under Ligand Detection in the
Preferences panel—see Section 14.11 on page 369.

A brief description of the Style toolbar buttons is given below, and the use of the styles is elab-
orated in the following subsections. 

Polyhedrons 
Display polyhedrons for cations that are surrounded by 4 to 8 anions. An atom is considered as 
an anion if it is from Group 16 or Group 17 and has a zero or negative formal charge, or if it is 
N with a negative formal charge. An atom is considered a cation if it is not an anion and has a 
zero or positive formal charge, and has 4 – 8 bonded neighbors, all of which are anions. The 
color and opacity can be set in the Preferences panel, under Workspace – Periodicity.

Properties 
Calculate unit cell properties (density, volume, and molecular formula) and add these proper-
ties to the Project Table. Opens the Project Table panel, and scrolls to these properties.

Planes 
Display up to 4 crystal planes, specified by their Miller indices. Opens the Crystal Planes 
panel, which allows you to set the Miller indices, color, and opacity for each plane. If more 
than one unit cell is displayed in the Workspace, you can display replicas of each plane by set-
ting a range of displacements from the primary unit cell (Min and Max values), or move the 
planes parallel to the normal (Translation).

Apply 
Set and apply a defined style to the Workspace atoms. Click to apply the style, click on the 
arrow to display a menu for making style settings and ligand detection settings (preferences).
Menu equivalent: Workspace → Style → Apply Style.
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7.6.1 Applying the Workspace Style

The Workspace style is applied by clicking the Apply button: 

or by choosing Workspace → Style → Apply Style. If you change the contents of the Work-
space (add or remove atoms by any means: inclusion, building, deleting), the style is not auto-
matically applied to any new atoms. If you want to apply the style whenever new atoms are
added, click the Reapply button.

When this button is selected, the current style settings are applied to atoms that are added to the
Workspace, subject to the settings for applying the style. Selecting this button allows you to
keep the same style in effect as you change what is displayed in the Workspace. This button is
deselected when you close a project, subject to a preference (see Section 14.2.1 on page 340).

There is no “undo” operation for the application of the Workspace style.

Settings for color and representation are stored with entries, so the style for any entry you
include in the Workspace is changed when you apply the style. If you don’t want to change
these settings, ensure that Reapply When Workspace Changes is not selected. 

Reapply 
When the Workspace content changes, reapply the Workspace style, according to the options 
set in the Workspace Style Settings dialog box.
Menu equivalent: Workspace → Style → Reapply Style.

Surfaces 
Create molecular surfaces for the binding site (receptor, ligand, or both) by clicking this but-
ton; show or hide surfaces or open the Surface Table panel from the button menu. 
Menu equivalent: Workspace → Style → Create Binding Site Surfaces.

Fix 
Fix the receptor entry in the Workspace. 
Menu equivalent: Workspace → Style → Fix Receptor.

Rendering 
Set the priority for Workspace rendering, between best quality and best performance.
Menu equivalent: Workspace → Style → Rendering.

Material 
Select combinations of material and lighting to produce a particular appearance of molecular 
representations and surfaces. 
Menu equivalent: Workspace → Style → Material.
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The style settings do not include material and lighting effects, but you can choose from a few
preset styles from the Material button menu.

As well as applying a defined style, you can change the rendering, to optimize it for speed
when you change the structure or the view, or for quality, which can be a little slower, or a
balance between the two. You can make these choices from the Rendering button menu.

7.6.2 Defining the Workspace Style

The Workspace style consists of settings in three categories: molecular representation, color
scheme, display of hydrogens, and a collection of “general” settings, for hiding waters, fitting
to the ligand, and setting the scope of the style when the Workspace changes. The style is set
up in the Workspace Style Settings dialog box, which you open by choosing Workspace →
Style → Style Settings or choosing Settings from the Apply button menu. 

The General tab provides overall control of what changes when the style is applied or the
Workspace changes. 

Figure 7.12. The General tab of the Workspace Style Settings dialog box.
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To adjust the zoom to fit the ligand to the Workspace when the style is applied, select Fit to

ligand. The clipping settings are applied when zooming in on the ligand.

If you want to hide waters that are far from the ligand, choose the condition for undisplaying
waters from the Undisplay waters option menu. The three distance options are distances from
the ligand. The default is to undisplay all waters. 

You can also choose how the style is applied when the content of the Workspace changes.,
under When Workspace changes. If you do not want the style to be reapplied, ensure that
Apply settings to is not selected. If you want to reapply the style, select this option, and choose
one of the two options that determine the scope of the changes:

• Entire Workspace—Apply the style settings to all atoms in the Workspace.

• Ligand only—apply the style settings only to the ligand, and not to the rest of the Work-
space. This option is useful if you are stepping through ligands with a fixed receptor
(such as when viewing docked poses), and it makes the updating of the Workspace faster. 

In the Representation tab, you can choose the representation for the default atoms, the ligand,
waters, and ions, from Wire, Tube, Thin Tube, Ball & Stick, and CPK. You can also make
settings for the ribbon visibility, scheme, and style for the receptor. Other attributes are inher-
ited from the settings in the Molecular Representation panel (see Section 7.3 on page 141). The
default values are listed in Table 7.2.

Figure 7.13. The Representation tab of the Workspace Style Settings dialog box. 

If you want to see only those residues within a given distance of the ligand, select Display resi-
dues within N Å of the ligand and enter the distance in the text box. 
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You can choose whether or not the representation is changed when the Workspace style is
applied by selecting or deselecting Apply representations. Likewise, you can choose whether to
display ribbons by selecting or deselecting Display ribbons. The Apply representations option
applies to ribbons as well, so the Display ribbons option only determines whether ribbons are
included in the representation. 

In the Color tab, you can choose the color scheme to use for each of the four entities. The color
schemes are described in Table 7.1, and the defaults are listed in Table 7.2. The Optimize for
buttons make a particular selection of color schemes, optimized for a light background or a
dark background. You can choose whether or not the color schemes are changed when the
Workspace style is applied by selecting or deselecting Apply colors.

Figure 7.14. The Color tab of the Workspace Style Settings dialog box.

In the Hydrogens tab, you can choose which hydrogens to display for the receptor and for the
ligand. The choices are None, Polar only, and All. The default for the receptor is Polar only, and
for the ligand is All. 

Table 7.2. Default Workspace Style settings.

Atom type Representation Color Scheme

Default Wire Element 

Ligand Ball & Stick Element (Entry Carbons) 

Water Ball & Stick Element 

Ion CPK Element 
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Figure 7.15. The Hydrogens tab of the Workspace Style Settings dialog box.

In the Surfaces tab, you can choose whether to generate surfaces for the receptor (Create

receptor surface) or the ligand (Create ligand surface) or both when the Workspace style is
applied. This includes application when the Workspace changes, if you have the option set in
the General tab. The surfaces are generated according to the settings in the Create Binding Site

Surfaces dialog box. These two options create surfaces every time the style is applied, and
delete the previous surfaces and any related volumes. This might take some time. 

You can manually create surfaces as well—see Section 7.6.3 on page 159). The manually
created surfaces are stored independently.

7.6.3 Surfaces

Another feature of the Workspace style toolbar is the ability to create and display molecular
surfaces for the binding site. The surfaces can be set up manually by clicking the Create

Binding Site Surfaces button

or by choosing Workspace → Style → Create Binding Site Surfaces or Workspace → Surface
→ Create Binding Site Surfaces. In the Create Binding Site Surfaces dialog box, you can
choose whether to create surfaces for the ligand, the receptor, or both, by choosing the appro-
priate options. You can control of the extent of the receptor surface from the ligand, the trans-
parency and the grid spacing (surface quality), the surface style, and the color scheme. To
restore the default values, click Reset.
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Figure 7.16. The Create Binding Site Surfaces dialog box.

When you have created the surfaces, you can display or hide all of them from the Create

Binding Site Surfaces button menu:

If you want greater control over which surfaces are displayed and how they are displayed,
choose Manage from this button menu, or choose Workspace → Surface → Manage Surfaces,
to open the Manage Surfaces panel. This panel is described in detail in Section 12.4 on
page 307. See page 159 for information on automatic creation of surfaces. 
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Chapter 8: Labeling and Annotating the 
Workspace
Maestro has several ways that you can annotate the Workspace and its contents, by adding text
or highlights. Text can be added as atom labels, as captions, or as project entry information
(“feedback”). Highlighting of atoms can be done with changes in color intensity or contrast, or
by adding a silhouette, and can include text with an arrow pointing to the highlight. 

8.1 The Labels Toolbar

All of the annotation methods can be applied by using the Labels toolbar, which you can
display from the Manager toolbar, or by choosing Window → Toolbars → Labels. The toolbar
buttons are described in brief below, and their use is described in the following sections.

Label All 
Label all atoms (or target atoms) with the selected label. This button has a menu from which 
you can select and apply the label, set the current label composition, delete labels, and select 
an option to reapply the labels when the Workspace changes. The target atom is the first atom 
in an entry or the Cα atom of a residue if entry or residue properties are used in the label. All 
atoms are labeled if an atom property is used in the label. 

Pick to Label 
Pick atoms in the Workspace to apply a label. From the button menu you can:
– choose a structural unit to use when picking atoms for labeling
– open the Atom Selection dialog box to select atoms to label 
– compose labels in the Atom Labels panel
– reset label positions
– set label preferences
– delete labels 
Double-click to apply the label to the selected atoms, or to all atoms if there is no selection. 

HBonds 
Display hydrogen bonds as yellow dotted lines. This button has a menu from which you can 
choose to display H-bonds between entries (Inter) or within entries (Intra), or both (All); open 
the Preferences panel to make settings for H-bonds; and delete H-bond markers.

Measure 
Measure distances, angles, dihedrals or NMR coupling constants. From the button menu you 
can choose between distance, angle, dihedral, or 1H NMR coupling for measurement, open 
the Preferences panel to make settings for measurements, or delete measurements. 
Menu equivalent: Tools → Measurements → Pick to Measure.
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8.2 Labeling Atoms

Labels are useful tools for building, identifying, and analyzing molecular structures since they
can be used to display any combination of predefined information or user-specified text. For
instance, you might want to display atom numbers so that you can retype a specific atom, or to
pick atom pairs for superposition, inclusion in a set, or measurement.

Atom labels are persistent. The labels are stored as part of the entry, and are restored when an
entry is excluded from then included in the Workspace. However, labels that are dependent on
the numbering in the Workspace, such as Molecule Number, may change because they are rela-
tive to the Workspace, not the entry. 

User Text 
Change the user-defined text in the atom label on the picked atom. If the atom does not have a 
label, a label is added. A dialog box opens, to enter the text and choose whether to replace the 
entire label or replace the text in the label. 

Feedback 
Display information about a single entry, termed the “target” entry, in the top left corner of the 
Workspace. 
Menu equivalent: Workspace → Single-Entry Feedback.

Highlights 
Create, modify, delete, or apply highlights to atoms in the Workspace. Opens the Manage 
Highlights panel. 
Menu equivalent: Workspace → Highlights.

Quick Highlight 
Add a highlight to picked atoms with the current highlight settings.From the button menu you 
can choose a structural unit for picking to highlight; open the Atom Selection dialog box to 
select atoms to highlight; or open the Manage Highlights panel to make highlight settings. 

Add Caption 
Add a caption to the Workspace. Opens the New Caption dialog box, in which you can type in 
the text, and set the caption background, font, and text color. 
Menu equivalent: Workspace → Add Caption.

Show Cap 
Show or hide the Workspace captions. 

Increase Fonts 
Increase the size of all the Workspace fonts (atom labels, measurements, adjustments, cap-
tions, highlights, feedback).

Decrease Fonts 
Decrease the size of all the Workspace fonts (atom labels, measurements, adjustments, cap-
tions, highlights, feedback). 
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Labels can be set up and applied in the Atom Labels panel. To open the Atom Labels panel,
choose Workspace → Atom Labels or choose Composition from the Label All or the Pick to
Label button menu.

Labels can be constructed from a variety of atom, molecule, residue, chain, and entry proper-
ties, including element, charge, stereochemistry, atom and residue names and numbers, and
also user-defined atom and entry properties. By default, the Element and Atom number atom
properties are in the label.

Figure 8.1. The Atom Labels panel.

To add properties to the label composition, click Add, and select the properties in the Add Label

Fields dialog box. The Atom Properties and Entry Properties tabs have lists of properties that
you can select. You can filter and sort the entry properties. Click OK to add the selected proper-
ties to the label composition.

To remove properties from the label composition, select them in the Fields list, and click
Remove. To remove all properties, click Remove All. 

To show or hide properties in the label, but keep them in the list for easy access, check or clear
the check box for the properties. This allows you to keep the properties that you want to use
most often for labels available, but quickly change the displayed label. 
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Figure 8.2. The Add Label Fields dialog box, Atom Properties tab (left) and 
Entry Properties tab (right).

The properties are added to the label in the order they appear in the Fields list. You can change
this order by selecting properties in the list and dragging them to the desired position in the list.
The property values are separated by spaces in the label.

When you have finished composing the label, choose Add labels (replace) from the Pick to

option menu to begin adding labels. 

To select the atoms for the chosen labeling action, use the standard picking tools in the Label

atoms section. Labels are added to atoms that do not have labels, and existing labels are
replaced on atoms that already have labels. The labels are applied only at the time you perform
the labeling action, and do not change if you change the composition. If you want to update all
labels with the new composition, click Update Existing Labels. 

If you want to remove labels, you can do so by selecting atoms or you can remove all labels. To
select atoms to remove labels, choose Clear labels from the Pick to option menu, then use the
standard picking tools in the Label atoms section. To remove all labels, click Clear All Labels.
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To label atoms with your own text, click the User Text button on the Labels toolbar:

then pick the atom in the Workspace. The User Text dialog box opens, in which you can enter
the text, and choose whether to show only the text you entered (Only this text), or add the user
text to the label, replacing any existing user text (This text in label). You can also pick the atom
first, then click the button. User text is added to the Composition list, and can be turned on and
off like any other property in the label.

You can label atoms from the Labels toolbar. To apply labels for a single property from a
subset of the full range of properties (or the current label composition), choose the property (or
Current Composition) from the Label All button menu on the Labels toolbar:

The labels are applied to all atoms, if the property is an atom-level property. If it is a residue
property, the label is applied to the alpha carbon. If it is an entry property, it is applied to the
first atom in the entry.

This button menu also has a Reapply atom labels when Workspace changes option, which
reapplies the label that was selected from the button menu whenever the Workspace content
changes. You can also reapply the label manually by clicking the button. 

To apply the current labeling scheme by picking, use the Pick to Label button menu:

Double-click this button to apply the current labeling scheme to all atoms. From the button
menu you can choose Composition to open the Atom Labels panel with the Composition tab
displayed, you can choose Select to open the Atom Selection dialog box to select the atoms to
label, and you can choose Delete Labels to delete all labels. 

You can customize the appearance, formatting, position, and behavior of all labels in the Atom/

Bond label group in the Preferences panel. To open the Preferences panel at the Atom/Bond
label group, click Label Preferences in the Atom Labels panel or choose Label Preferences

from the Pick to Label button menu. See Section 14.6 on page 360 for more information. 

To reposition an individual label, drag the label to the desired location. To restore an individual
label to its default location, right-click on it and choose Reset Position. If you want to reset all
labels to their default positions, choose Reset Positions from the Pick to Label button menu. 
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8.3 Labeling Bonds

Like atoms, bonds can be labeled with bond properties. The bond property must be a property
of the entry, not something like a distance measurement. Bond properties are added to struc-
tures by some applications, and you can use these to label bonds.

Bond labels can be set up and applied in the Bond Labels panel. To open the Bond Labels
panel, choose Workspace → Bond Labels. The properties to include in the label can be selected
in the Fields list, which shows all bond properties in the project.

Figure 8.3. The Bond Labels panel.

When you have finished composing the label, you can apply the labels. There are two labeling
actions that are applied by selecting bonds, which you choose from the Pick to option menu:

• Add labels (replace)—Add labels to the selected bonds, replacing any existing labels.
• Add labels (append)—Add labels to the selected bonds, appending to any existing labels.

To select the bonds for the chosen labeling action, use the standard picking tools in the Label

bonds section. The labels are applied immediately. If you want to update all bond labels with
the new composition, click Update Existing Labels. 

If you want to remove the labels, you can do so by selecting bonds, or you can remove all
labels. To select bonds to remove labels, choose Clear labels from the Pick to option menu,
then use the standard picking tools in the Label bonds section. To remove all labels, click Clear

All Labels.
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Bond labels can be repositioned by dragging. To revert to the default position, right-click on
the label and choose Reset Position.

The formatting of the label (font, color, position) can be set as preferences—see Section 14.6
on page 360. Atom labels and bond labels share most of the preferences, but the bond label
color can be set independently.

8.4 Captions

Captions can be used to display any kind of text in the Workspace, in a text box. They are
stored as part of the project. 

To create a caption, either choose Workspace → Add Caption, or click the Add Caption button
on the Labels toolbar. 

The New Caption dialog box opens. Enter the caption text in the Workspace caption text area
(including any line breaks), choose the background style (transparent or automatic contrast to
the text), font attributes, and color, and click OK. The caption is displayed in the Workspace.
The gray border indicates that it is selected: it is not part of the caption. You can drag the
caption to the desired location.

The caption size is determined by the size of the text and the font. It does not change when you
zoom in and out. The shape of the caption is determined by where you place line breaks in the
text that you enter. 

If you want to change the text of a caption, double-click on the caption, or right-click on the
caption and choose Edit Caption. You can then make changes in the Edit Caption dialog box,
which has the same controls as the New Caption dialog box.

You can select one or more captions in the Workspace with shift-click and control-click.
Selected captions are displayed with a gray border. You can reposition the selected captions as
a group by dragging them. To delete them, you can press Delete, right-click and choose Delete

Selected Captions from the shortcut menu, or choose Captions from the Delete button menu on
the Edit toolbar.

To show or hide the captions, you can use the Show Cap button on the Label toolbar. 
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8.5 Highlights

Highlights are graphical annotations of a set of atoms in the Workspace, with optional text
annotation. The sets of atoms are defined by ASL expressions, so the highlight can be applied
to different entries that have a match to the ASL expression. 

There are three types of highlight:

• Silhouette—A colored border of a specified thickness is drawn around the atoms and
bonds. 

• Contrast—The brightness of the non-highlighted atoms is reduced. At 100% contrast,
these atoms are no longer visible.

• Saturation—The color saturation of the non-highlighted atoms is reduced. 

Each of these types of highlight can have associated text and an arrow pointing to the highlight.

Highlights can be created, edited, and deleted in the Manage Highlights panel, and are stored
with the project. To open the Manage Highlights panel, choose Workspace → Manage High-

lights, click the Highlights button on the Labels toolbar,

or choose Settings from the Quick Highlight button menu on the Labels toolbar. 

Figure 8.4. The Manage Highlights panel.
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8.5.1 Creating and Editing Highlights

To create a highlight, click New. A dialog box opens, in which you can name the highlight. The
highlight is listed in the table at the top of the Highlights tab, and the highlight is selected in the
table.

After you have created a highlight, you can choose a highlighting method from the Method

option menu in the Atoms tab, then use the Highlight atoms picking tools to pick the atoms to
highlight. 

Picking atoms in the Workspace creates a highlight that is specific to the entry whose atoms
you picked. If you want a highlight that can be applied to different entries, you should enter an
ASL expression in the text box, or compose the ASL expression in the Atom Selection dialog
box, by clicking Select. For example, you could use atom sets or SMARTS patterns to define a
particular functional group to highlight.

For silhouettes, you can choose the color and the transparency of the border in the Atoms tab.
These values are stored separately for each silhouette highlight. You can change the width of
the borders for all silhouettes in the Settings tab.

For contrast and saturation highlights, you can change the value of the contrast or the satura-
tion in the Settings tab. These values are stored globally and apply to all highlights of the given
type. 

If you want to create a highlight quickly, with the current settings in the Manage Highlights
panel, select a structural type from the Quick Highlight button menu, and pick atoms for the
highlight in the Workspace.

If you already have a highlight that you want to modify for another purpose, select it in the
table, and click Duplicate. A new row is added to the table with the duplicated highlight, and
the row is selected. The name of the duplicate has a suffix, -dupn, appended to the name of the
original. You can then start editing the duplicate to create a new highlight.

To edit any highlight, select it in the table. You can then change the name by editing the table
cell, or change any of the settings that define the highlight in the Atoms tab (and the Text and
Arrows tabs—see below).

To delete a highlight, select it in the table and click Delete.
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8.5.2 Adding Text and an Arrow to a Highlight

You can add text to the highlight in the Text tab. The text itself is entered in the text area, and is
laid out exactly as you type it, with line breaks. The font type, size, and style can be chosen
from option menus, and the color of the text can be chosen from a standard color selector, by
clicking Edit. You can choose whether to have a transparent background, which means that
anything that is behind the text will be visible through the text; or an opaque background,
whose color is chosen automatically to contrast with the text. 

Highlight text can be edited by double-clicking it in the Workspace, or right-clicking and
choosing Edit. The Edit Highlight Text dialog box opens, in which you can change the text,
background, and font. You can also edit it in the Manage Highlights panel, by choosing the
highlight in the table, then editing the text in the Text tab.

If you want to delete highlight text, select the text in the Workspace and press Delete, or choose
Highlight Text from the Delete button menu, or choose Delete Selected Highlight Text from the
highlight text shortcut menu. You can select multiple text boxes to delete, with shift-click and
control-click. 

If you have defined some text, you can also add an arrow from the text box in the Workspace to
a location relative to the structure, in the Arrow tab. To define the location of the arrow head,
use the Arrow head centroid picking tools. The head is placed at the centroid of the picked
atoms. The head of the arrow is defined as a point in 3D space, so it moves as you rotate or
translate the structure. You can keep the arrow in the plane of the screen (xy plane) by selecting
Flat in the General section of the Settings tab; selecting Pointing allows the arrow head to move
in the z direction as well. The text does not move with the structure, but you can relocate it by
dragging. If you want to move multiple text boxes simultaneously, you can select them with
shift-click and control-click, and drag them. 

When text is added to a highlight, you can choose whether to display the text only when there
are atoms highlighted in the Workspace for this particular highlight, or it can be always shown
when the highlight is selected for display. To make this choice, select or deselect Show only

when atoms are highlighted. If this option is deselected, you can create a highlight consisting
of text (and arrow) only, by not selecting atoms for the highlight. 

8.5.3 Displaying Highlights

By default, when you create highlights, they are displayed in the Workspace. If you want to
display or undisplay a highlight, you can click in the Show column of the highlights table. You
can also choose to display the text (and arrow) for the highlight only when the Workspace
contains atoms that match the ASL expression for the highlight, by selecting Show only when
atoms are highlighted in the Text tab for the highlight.
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8.6 Displaying Entry Properties

Properties for a single entry can be displayed in the Workspace if you have an entry included in
the Workspace that is uniquely defined by a set of conditions. This entry is called the “target
entry” and the conditions are:

• It is the only entry included in the Workspace
• It is the only entry included in the Workspace that is not fixed
• It is the only entry included in the Workspace that is selected

This display of properties for an entry is called feedback, or single-entry feedback. You can
choose the properties that are displayed in the Preferences panel, under Feedback – Entry (see
Section 14.5.2 on page 358). 

Feedback can be displayed or hidden by any of the following methods.

• Choosing Workspace → Single Entry Feedback.
• Pressing the S key when the focus is in the Workspace.
• Selecting Show single-entry feedback in Workspace in the Preferences panel, under

Feedback – Entry.
• Clicking the Feedback button on the Labels toolbar.

8.7 Other Objects

There are a few other objects that you can display in the Workspace, by choosing from the
Workspace menu:

• Dipole Moment—Display the dipole moment of the structure as an arrow in the Work-
space. If the structure has a dipole moment computed by a program (such as Jaguar), it is
used for the display, otherwise the dipole moment is computed from the partial charges of
the atoms (which can be Jaguar ESP charges if you calculated them). If no dipole moment
appears, you can choose Tools → Assign Partial Charges to compute the partial charges
from the OPLS_2005 force field. The arrow can be configured in the Preferences panel—
see Section 14.4.7 on page 351.

• Coordinate Axes—Display a set of coordinate axes in the lower left corner of the Work-
space. These axes show the orientation of the Workspace view, and rotate along with the
structures when you perform a rotation.
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When you use Maestro, you are always working within a project. Projects are made up of
entries, which can include multiple structures as well as properties of those structures. Project
entries and their properties are displayed in the Project Table. You can perform a variety of
operations on entries through the Project Table. By default, the Project Table panel is opened
automatically when you open a project. You can change this behavior in the Preferences panel.
To open the Project Table panel, choose Show Table from the Project menu, or click the Table

button on the Project toolbar.

The project data is stored in a directory whose base name has the extension .prj. This direc-
tory is created in Maestro’s current working directory. If you have not explicitly opened an
existing project or created a new project, a scratch project is created in a temporary directory.
You can specify this directory as a preference—see Section 14.1.2 on page 336 for more infor-
mation on setting the preference and the default location. 

This chapter discusses in some detail how to use the Maestro Project Facility. 

9.1 Project Operations

The Project menu of the main window enables you to perform operations on the project level.
To perform operations on entries in the current project, use the menus in the Project Table

panel. This section describes the operations that you can perform on projects. 

9.1.1 Creating and Opening Projects

When you start Maestro without specifying a project to open, a scratch project is created. You
can work with a scratch project, and perform nearly all the tasks that you can perform with a
named project. If you want to start a new project and save its data, you can create a new named
project by choosing Project → New. The main difference between a new project and a scratch
project is that the new project has a name and is automatically saved. When you choose New, a
project selector panel is displayed. This panel enables you to choose the location of the new
project, create a directory, and type in the project name.

To open a recently used project, choose Project → Recent Projects → project. 
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To open any project, choose Project → Open, or click the Open button on the Project toolbar. 

A project selector panel is displayed that enables you to select a project to open. The project
selector panels are described in more detail in Section 9.1.7 on page 177. On Windows, you
can open a project in a new Maestro session by double-clicking its icon. 

You can only have one project open at any time.

If you are opening a project from a previous release, the project might have to be converted to
the current release format. When you choose the project to open, the Convert Project dialog
box opens. This dialog box allows you to specify a name for the converted project (as the orig-
inal project is kept). Attempts at data extraction are made if errors occur during conversion.
You can also compress the structure data from older projects with Project → Compress Struc-
ture Data. This operation saves a lot of space, but can take some time with larger projects.

In addition to opening projects (with extension .prj), you can also open zipped projects (with
extension .prj.zip or .prjzip). These projects are uncompressed as temporary projects,
and must be saved as named projects in order to be kept. To create a zipped project, simply zip
the desired project directory, which has a .prj extension. You can open zipped projects
directly from a web page—the .prjzip extension is registered when Maestro is installed on
Windows; on Unix you have to register it.

9.1.2 Saving and Closing Projects

The data in a project is normally saved automatically when you make changes to the project.
Changes to entries that are made in the Project Table are saved automatically. The saving of
changes to entries that are displayed in the Workspace depends on the preferences you set in
the Preferences panel. By default these changes are saved automatically. 

Because the data in a named project is automatically saved you do not need to explicitly save
the project. When you have finished working in a project you need only close the project, by
choosing Close from the Project menu. If you want to work on a different project, you do not
need to close the old project before opening the new project. When you close a project without
opening a new project, a scratch project is created. 
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If you are working in a scratch project and decide you want to save it as a named project, or if
you want to save a named project with a different name, choose Save As from the Project menu
or click the Save As button on the Project toolbar.

A project selector panel is displayed that enables you to enter the name and choose the location
of the project, and if necessary, create a directory. The panel is described in Section 9.1.7 on
page 177. If you choose Close when you are working in a scratch project, you are prompted to
save the scratch project.

When a project is saved, all view transformations (translation, rotation, and zoom) are saved
with it and restored when the project is opened. In addition, all user-defined sets of atoms are
saved with the project and included when the project is copied or merged with another project.

If you want to make a copy of a project, you can do so in three ways, by choosing from the
Project menu:

• Save As—A copy is made of the project, and the copy becomes the current project. This
choice allows you to preserve the original project under its original name, and create a
new project to work in. 

Any jobs that you started in the original project are incorporated into the original, not the
new project. However, if the project was a scratch project and you save it as a named proj-
ect, jobs started from the scratch project are not incorporated. In that case, you must
import the results manually into the named project.

• Export Project—A copy is made of the project, and the current project continues to be the
current project. This choice allows you to make a backup of a project and continue to
work in the same project. You can select options to copy user-created files that are in the
project, to copy workflow data for Prime, Phase, and CombiGlide, to save the project in
compressed, or zipped, form (.prjzip), and to save the project in Maestro 9.3 project
format. You can also choose to copy only the selected or included entries into the copied
project. Plots are only copied if you copy all entries. 

• Publish—Create a web page (.htm or .html) that contains a relative link to a com-
pressed copy of the project, which is placed in a new folder. You can provide a summary
of the project, which is included in the web page. Because the link is a relative link, you
can copy the page and the folder to a suitable location for access on your web site, or
copy the link from the page to a suitable page on your web site and modify it suitably.

You can also copy a project with the UNIX cp -r command. A project is simply a directory
with various files stored in it for the administration of the project.
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9.1.3 Backing Up Projects

In addition to saving a copy of a project, you can make backups of projects to guard against
data loss. To do so, choose Project → Back Up. The Project Backup Description dialog box
opens, in which you can enter a short description of the backup. This description can be used to
identify the backup if a project has to be restored from backup. When you click OK, the backup
commences. The backup is stored in zip format, named with the time stamp as
YYYY.MM.DD-HH.MM.SS.prjzip. The backups for a project are written to the directory
project.backup, which is created in the same directory as project.prj. The backups are there-
fore outside the project itself, but in the same location as the project. You can specify an alter-
nate location in the Preferences panel—see Section 14.2.2 on page 341.

You can schedule automatic backups of projects, by making settings in the Preferences panel—
see Section 14.2.2 on page 341. You can also set preferences for the number of backups to
keep, and whether to issue a notification when the backup finishes. 

To revert to a saved backup, choose Restore from Backup from the Project menu. The Restore

Project from Backup dialog box opens, and presents a table of backups with the backup time
and description listed. Select the backup you want to restore, and click OK. The backup that
you restore overwrites the current project, so if you want to keep data from the current project
you should export it first.

You can also save the state of a project, which is a compressed copy of the project that is stored
inside the project directory. This is useful when you want to make changes that you might want
to revert later. To save the state, choose Project → Save State; to revert to this state, choose
Project → Revert to Saved State.

9.1.4 Recovering Projects

If a project is corrupted for some reason, Maestro tries to recover the data from the project
when it is opened. First, a warning dialog box is posted, indicating that Maestro cannot open
the project. When you click OK, the Recover Project dialog box opens. This dialog box offers
up to three options for project recovery

• Recover using the opening state—If the project had a compressed opening state, use this
to recover the project. Any information added to the project after it was last opened is
lost. This option is not available if the project did not have a compressed opening state.
The option applies to projects created from Maestro 9.7 or earlier.

• Recover using a previously generated backup—Use a zipped backup of the project to
recover the project. Any information added to the project after the backup was made is
lost. If you have made multiple backups, a dialog box is displayed, in which you can
choose the backup. See Section 9.1.3 for information on backing up projects.
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• Recover usable pieces—Recover as much data from the corrupted project as possible.
This option uses the utility project_extract, which is described in Section D.4 on
page 440.

The corrupted project is renamed from project.prj to project-corrupted.prj, and the
recovered version is named project.prj.

9.1.5 Deleting Projects

If you do not want to keep the current project you can remove it by choosing Delete from the
Project menu. You will be prompted to confirm the deletion of the project. When you delete a
project, any jobs associated with that project are killed and purged from the job database.

You can also delete the project from a terminal window by entering the command 

rm -rf project_name 

When you delete a project using rm, job files that were created using the project are not deleted
unless they are located within the project directory.

9.1.6 Undoing Project Operations

Changes made directly to the Project Table are saved immediately, regardless of your synchro-
nization preference. This preference affects only the changes made in the Workspace. (For
information on synchronization preferences, see Section 14.2.3 on page 343.) Some of these
changes can be undone with Edit → Undo, but you can only undo the last change made.

You can save the state of your project before performing operations that you might want to
undo. To save the state of the current project, choose Project → Save State. If the synchroniza-
tion mode you have selected is When approved by user, and you have modified entry structures
in the Workspace but have not synchronized the changes, you are prompted to do so. 

To revert to the saved state, choose Project → Revert to Saved State.

9.1.7 The Project Selector Panels

Many of the project operations—creating, opening, saving—involve selection of a project
location on disk. Each of these operations has a project selector panel. The project selector
panels are file selectors that are configured so that Maestro project directories (those with .prj
extensions) or zipped projects (those with .prjzip or .prj.zip extensions) are the only
visible items. These items appear in the current directory listing with a project icon. 

File selectors are described in detail in Section 1.1.4 on page 3.
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Only one instance of a given project can be open at a time. A project is locked if you or
someone else already has the project open. To indicate whether a project is in use, a lock icon
is placed on the icon for each locked project.

When you merge projects you can choose to include any user-created files by selecting Include

User Created Files. 

If you are creating a new project, you do not need to add the .prj extension, which Maestro
supplies if it is absent.

9.1.8 The Project Summary Panel

Projects can be large, diverse collections of data. To help you keep track of the project, Maestro
provides a Project Summary panel. This panel displays information about the current project,
including annotation of the project, information on jobs run from the project, and information
on runs saved from wizard-based panels. To open this panel, choose Summary from the Project
menu. The panel has three sections: Annotation, Project, and Jobs.

Annotation section: This section displays the project annotation. Because projects are
frequently modified, it may be helpful to annotate your project. The project creation date and
job history are automatically added to the project annotation.

You can edit the text in the annotation section, including the automatically generated text. The
standard mouse actions (highlight to copy, middle-click to paste) can be used to copy and paste
text. The main key strokes for editing text are:

• CTRL+W to cut the selection
• ALT+W to copy the selection
• CTRL+Y to paste the selection

These and other conventions are the same as those used by the Emacs editor. For more infor-
mation, visit the web site http://www.tcl.tk/man/tcl8.4/TkCmd/text.htm#M152.

Project section: This section displays statistics on the project, in two subsections, Entries and
Runs. The Entries subsection has a button to open the Project Table panel. The Runs subsection
displays information on jobs run for various products and has buttons to open product panels.

Jobs section: This section displays the jobs in the job database for the current project. Clicking
Refresh updates the display for all jobs, and is equivalent to clicking Monitor in the Monitor

panel. Clicking Delete deletes the selected jobs from the database. You can select jobs with the
usual click, shift-click and control-click key strokes.
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9.2 Adding Entries to a Project

Projects are made up of entries. Entries can contain multiple structures and their properties.
Each entry has an entry ID, an entry name, and a title. 

• The entry ID is used to identify entries internally and is guaranteed to be unique. It is also
used to select entries. It is assigned by Maestro and is noneditable. 

• The entry name can be used to identify entries in ASL expressions. It is guaranteed to
exist, and is assigned by Maestro if it does not exist, but is not guaranteed to be unique.
Entry names can be edited. 

• The title can be set or changed by the user but is otherwise not modified by Maestro. The
title is displayed in the Project Table by default, but the entry name is not. 

Entries can be grouped into entry groups for convenience. Each entry group has a title. 

You can add entries to a project by importing structures from a file, by creating entries from
structures you have built in the Workspace, or by merging entries from a different project. In
addition, you can create new entries by splitting or duplicating an existing entry, or by incorpo-
rating the results of a job into the project. 

9.2.1 Importing Structures From a File

One of the main ways of adding entries to a project is to import them from a file. Structures can
be imported from Maestro, MacroModel, PDB, Mol2, SD, and other files using the Import

panel. When Maestro imports structures from a file, the structures are copied, translated into
entries, and incorporated into the current project. You can also import structures from a
recently used file by choosing Project → Import Recent Structures → filename.

See Section 3.1 on page 41 for more information on importing structures.

9.2.2 Creating Entries From Workspace Structures

To save a scratch entry as a project entry—or to create a new entry from existing entries in the
Workspace—choose Create Project Entry from the Workspace menu or from the selection
shortcut menu, type CTRL+SHIFT+N (N), or use the Create Entry button on the Workspace

toolbar. 
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The Create Project Entry dialog box opens, in which you can type an entry title, and choose
whether to create the entry from the selected atoms, the displayed atoms, or all atoms in the
Workspace. 

If all the atoms in the new entry come from a single entry group, the new entry is placed in the
same group. Otherwise, it is added to the end of the ungrouped entries. 

A scratch entry is created, for example, when you draw a structure with the Draw tool. 

9.2.3 Pasting Structures Into the Workspace

You can paste structures into the Workspace from another application, provided they were
copied to the clipboard in SMILES or MDL format. A new entry is created for these structures.
For example, on Windows you can paste structures from ChemDraw and Isis Draw. See
Section 3.7 on page 61 for details.

9.2.4 Incorporating Entries From Job Output

When you use selected or included entries from a project as input for most kinds of jobs, you
have the option to incorporate the job results as entries in the Project Table. You can choose to
append the new entries, to replace the input entries with the new entries, or you can choose to
ignore the output and not incorporate them into the table at all. 

If the job results contain multiple structures, by default an entry group is created for them on
incorporation if one does not exist, with the group title set to the name of the file from which
the entries were incorporated, minus the extension. You can choose to append the entries indi-
vidually rather than as a group when you run the job from Maestro. See Section  on page 194
for more information on entry groups. 

For more information on incorporating job output into the project, see Section 2.9 of the Job
Control Guide.

9.2.5 Merging Entries From Another Project

You can merge the entries from a specified project into the current project. There is no facility
for merging a subset of entries. When the merge is performed, the entries are incorporated at
the end of the Project Table list in the current project, and are selected. Any conflicts between
group titles are resolved by adding a numerical suffix to the incoming group titles.

To copy the entries from a source project into the currently open project, choose Merge from
the Project menu. In the Merge From Project project selector, navigate to the desired source
project. If you want to include user-created files associated with the merge source project,
select Include user created files.
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9.3 Using Scenes

Maestro provides a way of storing multiple “snapshots” of a project or a subset of a project,
called scenes. Scenes are stored as mini-projects inside the main project, in zipped format
(.prjzip). Scenes include a set of entries, with associated data, and all aspects of the Work-
space state, such as the entries included, display options, measurements, and so on, so that you
can display the scene exactly as it was when you saved it. However, scenes do not include
scratch entries.Scenes do not include plots, job information, or run data from CombiGlide,
Prime, or Phase. They do not include information on panel layout or which panels are open, or
which components are visible in the main window. 

Scenes can be managed from the Manage Scenes panel, which you open by choosing Work-

space → Scenes → Manage.

Figure 9.1. The Manage Scenes panel.

To create a new scene, choose Workspace → Scenes → New, click New in the Manage Scenes
panel, or click the New Scene button on the Workspace toolbar. 

If there is a scratch entry in the Workspace, you are prompted to save it as a project entry; if
you do not, it is discarded. The New Scene dialog box opens, in which you can provide a text
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description of the scene, and choose which project entries to include in the scene. Once a scene
is saved, it is listed in the Scenes table of the Manage Scenes panel. The table row for the
scene includes a numerical index for the scene, a button to view the scene, a fingernail image
of the Workspace, and the description that you provided. You can edit the description by
double-clicking in the table cell. To reorder the rows, select them and drag them to the new
location in the table.

To delete scenes, select them in the table and click Delete or choose Delete from the shortcut
menu.

Because scenes are part of a project, you can display them without closing the current project.
When you display a scene, it behaves like a regular project. You can work within the scene just
as in a project, making changes and running jobs. The Maestro panels have access only to the
entries in the scene. Any changes you make are not saved by default, however. If you want to
save changes, select Warn before closing modified scenes. When you close a scene that has
changed, a dialog box is displayed in which you can replace the scene with the modified scene
(Replace), discard the changes and keep the original scene (Discard), or return to the scene
(Cancel). If this option is not selected, you can right-click in the scene row and choose
Replace. save the modified scene as a new scene and delete the original scene. You can also
create a new scene from the displayed scene, just as you can from a project. 

To display a scene, click the View column in the Scenes table of the Manage Scenes panel.
The scene is recalled and the Workspace structure is displayed as it was when the scene was
saved. The Scenes toolbar is displayed below the Workspace. This toolbar is a visual indication
that you are working in a scene, not the parent project.

The toolbar allows you to quickly step between scenes, by using the arrow buttons. You can
also use the UP ARROW and DOWN ARROW keys in the Manage Scenes panel to change
scenes. This is useful if you store a set of scenes that show different stages or aspects of a
project and want to use these scenes as a presentation. The scene changes are animated using
the preferences set in the Workspace tab of the Preferences panel. You can also use the toolbar
to exit the scene and return to the project. Only one scene can be displayed at a time. The
toolbar can also be displayed by choosing Workspace → Scenes → View, or clicking the View

Scenes button on the Workspace toolbar.

You can create a presentation from a set of scenes that contains only the scenes. The presenta-
tion is stored as a project that contains only the scenes. If you store it in zipped format (the
default), you can easily transfer it or send it by e-mail. To do so, click Export Presentation in
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the Manage Scenes panel. The Save Project panel opens, in which you can navigate to a loca-
tion and save the presentation. Because the scenes are read-only, you can make changes when
you show the presentation to others, and be assured that the presentation itself is not changed.

You can export the current scene as a project, by choosing Export as Project from the shortcut
menu. A file selector opens so that you can navigate to a location and name the project.

9.4 The Project Table Panel 

The Project Table panel provides access to a range of tools for managing the data in the project
and operating on that data. The panel contains a menu bar, several toolbars, the Project Table
itself, and a status bar. This section provides a brief description of the basic table operations,
the tools, and the use of the mouse and shortcut keys for performing various operations. 

Each project entry is represented by a row in the Project Table. Three columns of the Project
Table are always visible: the row number, the In column, which has an icon indicating whether
the entry is displayed in the Workspace, and the Title column, which contains buttons for auxil-
iary data as well as the title. The buttons are for display of Phase hypotheses (H), surfaces (S),
trajectories (T), and vibrational frequencies (V). The Stars column can be hidden. The
remainder of the columns appear in the scrolling section of the table, including the entry name
and the entry ID. The entry name can be displayed or undisplayed from the Property menu.

Figure 9.2. The Project Table panel.

Project entries have two states that represent how they are being used: the selection state and
the inclusion state. Selected entries are highlighted in the Project Table and are available for
operations such as copying, deleting, or use as input to a computational program. Selection of
entries is discussed in the next section. Included entries are displayed in the Workspace, and
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are available for manipulation, modification, and other actions that can be performed from the
Workspace. The selection and inclusion states are stored in the project, so they are restored
when you reopen the project.

The inclusion state is indicated in the In column. Excluded entries—entries that are not
displayed in the Workspace—are marked with an empty square. Included entries are marked
with a filled square. Fixed entries—entries whose display is not affected by the inclusion or
exclusion of other entries—are marked with a padlock icon. Fixed entries are not frozen: you
can perform operations on fixed entries in the Workspace, such as rotation and translation, or
adding or deleting atoms. To undisplay a fixed entry, you must exclude it from the Workspace.
The marker for an included entry is red for the target entry—a single entry for which informa-
tion can be displayed in the Workspace and which can be marked. 

9.4.1 The Project Table Toolbars 

There are four action toolbars: Project, Property, Find, and ePlayer, and in addition a Manager

toolbar that you can use to show or hide the toolbars. You can show or hide the toolbars by
choosing Table → Toolbars → toolbar. The Find toolbar and ePlayer toolbar are described in
later sections (Section 9.4.9 on page 196 and Section 9.7 on page 216). This section describes
the Project and Property toolbars. 

You can select the buttons that are shown on the toolbars by choosing Table → Customize →
Toolbars or by right-clicking in a toolbar and choosing Customize. 

9.4.1.1 Project Toolbar

The buttons on the Project toolbar are described briefly below. The use of these buttons is
discussed in other sections.

Import 
Import structures into the Project Table as new entries. Opens the Import panel. See 
Section 3.1 on page 41.

Export 
Export structures from the Project Table to file. Opens the Export dialog box. See Section 3.2 
on page 52.

2D Viewer
Display 2D structures in a grid. Opens the 2D Viewer panel. See Section 9.9.2 on page 221.

Plot 
Plot property values for the selected entries. Opens the Manage Plots panel. See Chapter 11.
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9.4.1.2 Property Toolbar

A description of the buttons on the Property toolbar is provided below. The use of these buttons
is discussed in other sections.

Sort 
Sort entries or entry groups, with optional group assignment and entry selection. Opens the 
Sort Project Table panel. See Section 9.6.12 on page 211.
You can sort by a single property from the shortcut menu for the property column header. 

Find/Replace 
Find and replace alphanumeric text in any column of the Project Table except for the row 
number. Opens the Find panel. See Section 9.4.9 on page 196.

Feedback 
Display information about a single entry, termed the “target” entry, in the top left corner of the 
Workspace. See Section 8.6 on page 171.

Color 
Color the rows in the Project Table for the selected entries. See Section  on page 194 and 
Section 9.11.14 on page 244

Calculator 
Perform calculations by combining properties of project entries. Opens the Project Table Cal-
culator panel. See Section 9.11.3.4 on page 231.

Columns 
Resize columns. Displays a menu from which you can choose an option for adjusting the col-
umn widths. See Section  on page 194.

Tree
Display a tree view of the properties in the Project Table. Opens the Property Tree panel, 
which is docked to the right of the properties in the table. See Section 9.11.12 on page 239.

Show
Show properties in the Project Table. 
See Section 9.9.2 on page 221.

2D Structure 
Display 2D structures in the Project Table as the third or fourth column, labeled 2D Structure. 
See Section 9.9.1 on page 220.

Show Family
Show only properties from the selected property family. Choose the family from the menu. 
See Section 3.1 on page 41.

Hide Family
Hide properties that are from the selected property family. Choose the family from the menu. 
See Section 3.2 on page 52.
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9.4.2 The Project Table Menus

The menus on the Project Table menu bar are described briefly below. The use of the menu
items is discussed later in this chapter.

• Table—find text, sort entries, plot properties, import and export structures and data, per-
form calculations on properties, and configure the Project Table. 

• Select—select all entries, none, invert your selection, make a random selection, or select
classes of entries using the Entry Selection dialog box and the Filter panel. 

• Entry—include or exclude entries from the Workspace, perform various operations on the
selected entries, group or ungroup entries, enter Pose Viewer mode. 

• Property—display and manipulate entry properties in the Project Table.

• Group—select, display, and delete entry groups.

• ePlayer—view entries in succession, stop, reverse and set the ePlayer options. 

9.4.3 The Project Status Bar

The status bar, located at the bottom of the panel, shows information about the project entries:
total number, number selected, and number included. It also shows information on the number
of groups and selected groups, and the number of properties in total and shown.

When the pointer is over a toolbar button, the display is replaced by information about that
button. 

9.4.4 Mouse Functions in the Project Table

The standard use of shift-click and control-click to select objects is supported in the Project
Table. Middle-click is supported as an alternative to control-click. This behavior applies to
selection of entries and inclusion of entries in the Workspace. Dragging to resize columns and
to move rows is also supported. You can drag a set of non-contiguous entries to reposition them
in the Project Table—see Section 9.6.11 on page 210 for more information. You can edit cells
by clicking in the cell and changing the text, then pressing ENTER or clicking elsewhere in the
Project Table. You can scroll vertically through the Project Table using the scroll wheel. 

A summary of project-based mouse functions is provided in Table 9.1.
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9.4.5 Project Table Shortcut Menus

In addition to the menus on the menu bar, the Project Table panel has shortcut menus, which
are displayed when you right-click and hold in the table. There are three main shortcut menus:
one for properties, one for entries, and one for entry groups.

• Property shortcut menu: This menu duplicates some items on the Property menu, and
has some additional items. It is displayed when you right-click and hold over a column
header, or click the arrow that is displayed in the header, and the actions are applied to the
property in the column. The items on this menu are described in Table 9.2.

Table 9.1. Mouse operations in the Project Table.

Task Mouse Operation

Change a Boolean property value. Click repeatedly in a cell to cycle through the possible 
values (On, Off, Clear). 

Display the Entry menu for an entry. Right-click anywhere in the entry. If the entry is not 
selected, it becomes the selected entry. The chosen action 
is applied to all selected entries.

Display a version of the Property menu 
for a property.

Right-click in the column header.

Edit the text or the value in a table cell. Click in the cell and edit the text or value. If the entry 
containing the cell is not selected, it is selected. The cur-
sor is placed at the end of the data by default, and the data 
is selected.

Include an entry, exclude all others. Click the In column of the entry.

Move selected entries. Drag the entries.

Paste text into a table cell. Middle-click.

Resize columns. Drag the boundary.

Select an entry, deselect all others. For an unselected entry, click anywhere in the row except 
the In column; for a selected entry, click the row number.

Select or include multiple entries. Click the first entry then shift-click the last entry.

Toggle the entry selection or inclusion 
state.

Control-click or middle-click the entry or the In column.

Scroll through the entries Use the wheel to scroll one entry at a time; hold down 
SHIFT and use the wheel to scroll a page at a time.
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Table 9.2. Property shortcut menu items.

Menu item Action

Hide Hide (undisplay) the property. Also available in the Entry List panel.

Sort Selected
Sort All 

Sort the table rows by the values of the property. There are four items, for sorting the 
selected rows or all rows, and in ascending (A-Z) or descending (Z-A) order. Also 
available in the Entry List panel.

Deselect 
Duplicate 
Values 

Deselect entries for which the value of the property is the same as that of another 
entry that is higher in the Project Table (lower row number) and in the same entry 
group. The effect is that only the entries with the first occurrence of any property 
value in the group are selected. This item is only available for string properties. 

Fit To Fit the column width to the width of the data, the header, or the larger of the two. The 
choice is made on the submenu (Header, Data, Header+Data). Also available in the 
Entry List panel.

Move To Move column to another location. The submenu contains First, Before, Left, Right, 
After, and Last, for moving columns within the scrolling area, and Fixed Area and 
Scrolling Area, for moving columns between the fixed and scrolling areas. Properties 
moved to the fixed area are placed at the end of the fixed area.

Reorder Reorder some or all properties. Opens the Reorder Properties dialog box, in which 
you can select the properties to move and their new location.

Edit Name/
Type

Change property names. Opens the Edit Property Name/Type panel, in which you 
can edit the visible name or the internal name of any property except those whose 
names are reserved.

Decimal 
Places

Set the decimal precision of real properties. Opens the Set Decimal Places dialog 
box, in which you can select properties, set the precision, and apply E notation. This 
item is present only if the column contains a real-valued property.

Change 
Case 

Change the case of a string-valued property. The submenu offers the choice of lower-
case (change all values to lower case), UPPERCASE (change all values to upper 
case), and Title Case (change first letter of each word to upper, rest to lower case). 
This item is present only if the property is a string property and changes are permit-
ted. You cannot change the case of these properties: Entry ID, Date Added, Date 
Modified, PDB format version, original cms file, source file, Job Name, ct type.

Copy Copy values from one property to another. Opens the Copy Property panel, in which 
you can specify the target and destination property. Properties can be copied for the 
selected entries or for all entries.

Clear Values Clear the values for the selected property. 

Delete Delete the selected property. 

Workspace 
Feedback 

Add or remove the property from the Workspace feedback. The submenu offers the 
choice of Add (add this property to the feedback), Replace (replace the feedback 
with this property), and Remove (remove this property from the feedback). Also 
available in the Entry List panel.
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• Entry shortcut menu: This menu duplicates the Entry menu, except for Mark Target

Entry and View Poses, and in addition has an Export submenu, which duplicates the
Export submenu on the Table menu. It is displayed when you right-click and hold over
any entry in the table. If the entry is part of the selection, the menu is displayed immedi-
ately. If the entry is not part of the selection, the entry is selected and all others deselected
before the menu is displayed. The items on this menu are described in Table 9.3. 

Table 9.3. Entry shortcut menu items.

Menu item Action

Include Only Include only the selected entries in the Workspace, and exclude all others that are 
not fixed.

Include Include the selected entries in the Workspace, without affecting the inclusion of 
others.

Exclude Exclude the selected entries from the Workspace.

Fix Fix the selected entries in the Workspace. Fixed entries must be explicitly 
excluded from the Workspace: they cannot be excluded by inclusion of other 
entries.

Unfix Change the inclusion status of fixed entries so that they are included but not fixed. 
The padlock icon is removed from the In column for these entries.

Lock Lock entries so that they cannot be changed or deleted. A padlock icon is dis-
played next to the row number.

Unlock Unlock entries so that they can be changed or deleted.

Stars Set the number of stars in the Stars property.

Delete Delete the selected entries, without confirmation. If you deleted entries uninten-
tionally, click the Undo button on the main toolbar.

Merge Merge the selected entries into a single entry. The name of the new entry is 
merge, and the title is the title of the first selected entry. The new entry goes 
immediately after the last selected entry.

Duplicate Duplicate the selected entries, and select the duplicates. Submenu with four 
actions:
In Place—place each duplicate after its original in the table.
Ungrouped—move the duplicates out of the group that the originals were in, if 

applicable. Entries that were moved out of a group appear at the end of the 
ungrouped entries; entries that were not grouped appear after their parents.

Into New Group— move the duplicates to a new entry group. A dialog box opens 
so you can name the group. 

Into Existing Group—move the duplicates into an existing group. A dialog box 
opens so you can select the group. 
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Split Split the selected entry into a set of entries. The source entry is not changed. The 
new entries inherit the title of the source entry. Submenu with three actions:
By Molecule—create one entry for each non-water molecule, and one for all 

water molecules. The entries are named by appending _moln to the entry name 
of the source entry, where n is an integer starting from 1.

By Chain—create one entry for each chain and one for all water molecules. The 
entries are named by appending the chain name to the source entry name. A 
Chain Name property is added to the entries to store the chain name.

Into Ligands, Water, Other—create one entry for each ligand-sized molecule, 
one for all water molecules, and one for all other atoms, such as receptor and 
cofactors. 

You can also set an option to copy properties to the new entries.

Copy Properties Copy the properties from the selected entry onto the clipboard, for pasting into 
one or more entries. The submenu offers the choice of All, to copy all properties, 
or Shown, to copy only the displayed properties.

Paste Properties Paste properties from the clipboard into the selected entries. The copied proper-
ties overwrite any existing properties of the same (internal) name. If a property 
does not exist (or is of a different type) a new property is created and values are 
added for the selected entries. If a property value is blank (null) in the copied 
property, it still overwrites values in the target entries.

Move to Row Move the selected entries in the table to start at a given row number. Opens a dia-
log box in which you can specify the row number, or choose First or Last.

Group Perform grouping operations on the selected entries. Submenu with four actions: 
New—Create an entry group from the selected entries. A dialog box is displayed, 

in which you can enter the title of the group.
Move To—Move the selected entries to a chosen group. A dialog box opens, in 

which you can select an existing group, no group, or create a new group.
By Entry Property—Create entry groups based on the properties of the entry. 

Opens the Group by Entry Property panel, in which you can name the groups, 
select the property, set conditions on the property, and create the groups.

Ungroup—Move the selected entries out of the group they are in. The entries are 
placed at the end of the ungrouped entries.

Color Color the rows in the Project Table for the selected entries. Submenu with three 
actions:
Constant Color—Color the rows for the selected entries with a chosen color. 

Opens a color selector so you can choose the color.
By Entry Property—Color the cells for a given property by the value of the prop-

erty. Opens the Color by Property dialog box.
Reset Colors—Reset the row colors of the selected entries to the defaults. 

Table 9.3. Entry shortcut menu items. (Continued)

Menu item Action
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• Entry group shortcut menu: This menu includes the Collapse and Expand items that
are on the Groups menu and a number of other items. It is displayed when you right-click
and hold over an entry group row. The items on this menu are described in Table 9.4.
There are four groups of items: for entry selection, for entry inclusion, for group manage-
ment, and for actions on group members. 

Export Export the selected entries. Submenu with three actions:
Structures—Export structures and properties. Opens the Export dialog box.
Spreadsheet—Export properties in CSV format. Opens the Export Spreadsheet 

panel.
To Canvas—Export structures and properties to Canvas. Opens Canvas with the 

structures imported into a new Canvas project. 

Table 9.4. Entry group shortcut menu items.

Menu item Action

Edit Title Edit the title of the group. Only displayed when the pointer is in the Title col-
umn. Not available in the Entry List panel (see Section 9.10 on page 224).

Duplicate Duplicate the group. The duplicate group is placed below the source group. 
Duplication makes copies of all the entries in the source group and places the 
copies in the new group.

Ungroup Move the entries out of the group, and delete the group. The entries are placed at 
the end of the ungrouped entries.

Delete Delete the group, and all the entries in it. A confirmation dialog is displayed 
when you choose this item.

Include All Include the entries in the group in the Workspace (with other included entries).

Include Only All Include in the Workspace only the entries in the group, and exclude all others. 
Does not affect fixed entries.

Include First Include the first entry in the group in the Workspace (with other included 
entries).

Exclude All Exclude the entries in the group from the Workspace.

Collapse or 
Expand 

Show or hide grouped entries. If the entries in the selected groups are visible, 
this item is Collapse, and the entries are hidden (the groups are collapsed). If the 
entries are not visible, this item is Expand, and the entries are shown (the groups 
are expanded). Each item has a submenu from which you can choose to collapse 
or expand all groups (All), or only the selected groups (Selected). The Expand 
submenu also has the item Only Selected, which allows you to expand only the 
selected groups and collapse all the others.

Table 9.3. Entry shortcut menu items. (Continued)

Menu item Action
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In addition to these shortcut menus, there are Surfaces and Hypotheses shortcut menus, which
are displayed when you right-click an S button or an H button in the Title column. The Surfaces
shortcut menu has two items, Hide All Surfaces, which undisplays all surfaces, and Display,
which is a submenu with choices for the object to display: Surfaces Only, Structure Only, and
Both. The Hypotheses shortcut menu provides tools for display of Phase hypotheses. This
shortcut menu is described in detail in Chapter 8 of the Phase User Manual. 

9.4.6 Use of the Keyboard in the Project Table

Some frequently used operations have been assigned shortcut key combinations. The shortcuts,
their functions, and their menu equivalents are listed in Table 9.5.

If you have Num Lock, Caps Lock, or Scroll Lock enabled, the shortcut keys do not work.

In addition to these shortcut keys that can be used in the Project Table, there is a range of keys
that can be used both in the Project Table and the Workspace for project navigation and opera-
tions. These keys are summarized in Table 9.6

ePlay Play through the entries in the group with the ePlayer.

View Poses Submenu that allows you to set up an entry group to display poses of a set of 
ligands in the context of a receptor, and calculate and display H-bonds and con-
tacts for the poses.

Export Structures Export the structures in the group. Opens the Export dialog box.

Table 9.5. Shortcut keys in the Project Table.

Keys Action Equivalent Menu Choices

CTRL+A (A) Select all entries Select → All 

CTRL+D (D) Duplicate entry in place Entry → Duplicate → In Place

CTRL+F (F) Find/Replace text Table → Find 

CTRL+I (I) Open Import panel Table → Import Structures 

CTRL+N (N) Include only selected entries Entry → Include Only 

CTRL+U (U) Deselect all entries Select → None 

CTRL+X (X) Exclude selected entries Entry → Exclude 

CTRL+Z (Z) Undo/Redo last command Edit → Undo/Redo in main window

Table 9.4. Entry group shortcut menu items. (Continued)

Menu item Action
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Table 9.6. Project Table navigation and operation keys

Key Description

UP ARROW Scroll the Project Table up one row.

DOWN ARROW Scroll the Project Table down one row.

RIGHT ARROW For each included entry, replace that entry in the Workspace with the
next selected entry in the Project Table.

LEFT ARROW For each included entry, replace that entry in the Workspace with the
previous selected entry in the Project Table.

HOME Scroll the Project Table to the top.

END Scroll the Project Table to the bottom.

PAGE UP Scroll the Project Table up one page.

PAGE DOWN Scroll the Project Table down one page.

SHIFT+PAGE UP Scroll the Project Table up to the previous selected entry, expanding 
groups as necessary.

SHIFT+PAGE DOWN Scroll the Project Table down to the next selected entry, expanding groups 
as necessary.

CTRL+PAGE UP Scroll the Project Table up to the previous included entry, expanding 
groups as necessary.

CTRL+PAGE DOWN Scroll the Project Table down to the next included entry, expanding groups 
as necessary.

SHIFT+UP ARROW Scroll the Project Table up by one group.

SHIFT+DOWN ARROW Scroll the Project Table down by one group.

CTRL+UP ARROW Scroll the Project Table up by one group, expand the group and collapse 
all other groups.

CTRL+DOWN ARROW Scroll the Project Table down by one group, expand the group and collapse 
all other groups.

CTRL+SHIFT+ 
UP ARROW 

Scroll the Project Table up by one group; expand the group and collapse 
all other groups; and change the selection to only the entries in the 
expanded group.

CTRL+SHIFT+ 
DOWN ARROW 

Scroll the Project Table down by one group; expand the group and col-
lapse all other groups; and change the selection to only the entries in the 
expanded group.

SHIFT+LEFT ARROW Include only the first selected entry in the next entry group.

SHIFT+RIGHT ARROW Include only the first selected entry in the previous entry group.

CTRL+LEFT ARROW Include the first selected entry (ePlayer Go to Start)
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9.4.7 Configuring the Project Table

The Project Table panel provides tools for controlling what is displayed in the table. Some of
these tools are also discussed later in this chapter. Many configuration options are available in
the Preferences panel—see Section 14.3 on page 345.

Grouping and ungrouping entries. You can group the selected entries by choosing Group

from the Entry menu. A new entry group is created at the end of the table, and the entries are
moved to the new location. You can display or hide the members of the group by clicking the In
column for the group. 

To ungroup an entry group, select the group and choose Ungroup from the Entry menu. The
group entries are placed at the end of the ungrouped entries, immediately above the first group. 

You can add the selected entries to an existing group by choosing Move to Group from the
Entry menu, and selecting the group in the dialog box that is displayed. You can move entries
out of a group by selecting them and choosing Move to Row from the Entry menu.

Displaying or hiding properties. You can display a subset of properties by choosing Property

→ Show → Select, then using the Show Property dialog box to select the properties to show or
hide. You can choose individual properties or a family of properties. Property families are the
properties generated by an application, such as QikProp, and are classified into primary and
secondary properties. You can restrict the display to a property family directly, by choosing the
family from the Show Only Family submenu of the Property menu. If you want to see only
those properties that have values for the selected entries, choose Property → Show → For

Selected Entries. See Section 9.11.12 on page 239 for more information. You can hide all
properties by choosing Property → Show → None. 

Displaying 2D structures. You can display 2D structures in the Project Table as the third or
fourth column, labeled 2D Structure. To do so, click the 2D structures toolbar button, or choose
Property → Show → Show 2D Structures. The size of the structures can be controlled by
changing the row height, which you do by dragging the row margin in the Row column. The
structures displayed are images that are generated when they are displayed. You can set prefer-

CTRL+RIGHT ARROW Include last selected entry (ePlayer Go to End)

X Mark or clear mark for the current entry. If the Mark property does not 
exist, create it and set the value for the entry to true (marked).

S Display or undisplay entry information in the Workspace. This option is 
subject to a preference for display of single-entry feedback.

Table 9.6. Project Table navigation and operation keys (Continued)

Key Description
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ences for the maximum structure size and for image generation in the 2D Structures tab of the
Preferences panel—see Section 14.10 on page 368.

Coloring by property values. You can color the cells of the Project Table by the values of the
properties in the cells. To so do, choose Color by Entry Property from the Entry menu, and
make settings in the Color By Property dialog box. See Section 9.11.14 on page 244 for more
information.

Coloring entries. You can color the selected rows in the Project Table by choosing items from
the Color submenu of the Entry menu or from the Color toolbar button. To apply a constant
color, choose Constant Color and select the color in the color chooser that opens. To color rows
by a property value, choose By Property Value, and make settings in the Color by Property

dialog box. See for more information. The color is stored in the project for the colored entries.
The property color and the selection color take precedence over the row color, but the row
color is always shown in the first column (Row). To reset the color to the default color for the
selected rows, choose Reset Colors.

Resizing columns. You can resize columns by dragging the border of the column. You can set
the width of the columns to the width of the widest data item (Fit to Data), the width of the
widest of the data and the heading (Fit to Header + Data), the width of the heading (Fit to
Header), or to a fixed width (Fixed Width), by choosing from the Columns button menu on the
toolbar, the Columns submenu of the Table menu, or the Adjust Width submenu of the Property

shortcut menu. The “fixed width” is 2 characters for Boolean properties, and a maximum of 8
characters for other properties. If you double-click the right border of the column it fits the
width to the column data.

Aligning column data. You can align the data in a column on the left boundary, the right
boundary, or the center of the column, by right-clicking and holding in the column header and
choosing the alignment mode from the Align submenu of the Property shortcut menu. 

Displaying the Entry Name. You can display the entry name in the scrolling area of the table
by choosing Show Entry Name from the Property menu. This option can also be set as a prefer-
ence in the Project tab of the Preferences panel. 

Setting the precision of real values. You can set the precision of real-valued properties in the
Set Precision dialog box, which you open from the Property menu. 

9.4.8 Navigating the Project Table

There are several means of navigating the Project Table rows. The UP ARROW and DOWN
ARROW keys scroll the rows. You can use the HOME and END keys to go to the top and
bottom of the table, and the PAGE UP and PAGE DOWN keys to move up and down the table a
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page at a time. The scroll wheel scrolls the table one row at a time, and in combination with the
SHIFT key, scrolls one page at a time. 

Special key bindings have been provided to traverse groups. To move to the top of the next or
previous group, use the SHIFT key in combination with the UP ARROW and DOWN ARROW
keys. To move to the top of the next or previous group, expand the group, and collapse all other
groups, use the CTRL key in combination with the UP ARROW and DOWN ARROW keys. 

These and other key bindings are summarized in Table 9.6.

9.4.9 Finding and Replacing Text in the Project Table

If you want to locate text or replace text in the Project Table, choose Find/Replace from the
Table menu, press CTRL+F, or click the Find/Replace toolbar button. 

The Find toolbar is displayed. By default it is located above the status bar at the bottom of the
panel, but you can drag its handle to place it wherever you want.

Enter the text you want to find in the Find text text box, and click Next or Previous to search
down or up. The Project Table scrolls to the found entry. The text is selected in the table cell
and highlighted in green. All other occurrences are highlighted in yellow. The highlighting
remains until you hide the toolbar. The number of matches is displayed on the status bar when
the search is first performed.

To find the next occurrence of the text, click Next or Previous again. The Project Table scrolls
to the next instance of the search string. The search wraps when it reaches either end of the
Project Table. 

You can choose to match the case of the search text exactly, by selecting Match case on the
Options button menu, or to match the search text as a whole word, by choosing Match whole

word only. For example matching “protein” as a whole word would not match “proteins”. 

By default, the entry that is found is not selected, so that searching for text does not change the
entry selection. If you want to select the found entries, select Select entries with matches on the
Options button menu. 

To replace text, enter the old text in the Find text box and the new text in the Replace with text
box, then start the search. When you have located the text, click Replace. The text is replaced
and the next occurrence of the search text is located. Clicking Replace instead of Next before
you have found the search text finds the first occurrence, but does not replace it. 
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To replace all occurrences of a piece of text with new text, enter the old text in the Find text box
and the new text in the Replace with text box, then click Replace All. The text is replaced, and a
dialog box is displayed that reports the number of occurrences replaced.

You can restrict the search range to selected rows by selecting Selected rows only on the
Options button menu. The selected rows are the entries that are selected in the Project Table,
which you can change in the Project Table itself. If you want to limit the range of properties,
select Selected properties only on the Options button menu, and choose the properties you want
to search in the Select Property dialog box. 

By default, the search includes entries in groups that are expanded (entries displayed), but not
in groups that are collapsed (entries not displayed). You can search all groups by selecting
Search in collapsed groups on the Options button menu.

9.5 Selecting Project Entries

Selection means choosing entry rows in the Project Table, which become the target for an
action. The rows are highlighted when they are selected. Selection differs from “inclusion,”
which is the display of the structures belonging to entries in the Workspace. Inclusion is
described on page 183. Selection is no different in principle from the selection of items in a list
in any graphical interface. In addition to the usual mouse operations, summarized in Table 9.1,
Maestro provides capabilities for selecting entries based on their properties. Selection can
include one or more entry groups. 

Once entries are selected, they can be operated on using the mouse or the tools in the Entry
menu. Selected entries can be renamed, duplicated, combined, split, deleted, exported, and
included in the Workspace, or a movie of the structures associated with entries can be made
with the ePlayer. Some operations on selected entries are mapped to shortcut keys, which are
described in Table 9.5 on page 192.

Selection states are persistent across Maestro sessions: entries that are selected when a project
is closed will still be selected the next time that project is opened. When new entries are
imported or incorporated into the Project Table, they are automatically selected.

9.5.1 The Select Menu

The Select menu provides tools for selecting entries. The first three items, All, None, and Invert,
select all entries, no entries (deselect all entries), and invert the selection (select the unselected
entries, and deselect the selected entries). Only, Add, and Deselect open the Entry Selection
dialog box, so that you can select entries by a combination of properties. By SMARTS allows
you to select entries that match a SMARTS pattern; From Groups allows you to select the same
selection criteria to multiple groups; Random allows you to randomly select a number or a
percentage of entries. These last three items all open dialog boxes to make the selection.
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The Filter submenu allows you to choose a named filter that is used to select entries, and to edit
named filters. Filters are defined in terms of Entry Selection Language (ESL) expressions, and
do not constitute a fixed set of entries. Whenever the filter is used, the ESL expression is
applied to the current contents of the Project Table. For more information on ESL, see the
Maestro Command Reference Manual.

9.5.2 Selecting Entries By Property

The Entry Selection dialog box (Figure 9.3) enables you to select entries in the Project Table
based on a combination of criteria for property values. Once you have defined a set of criteria
for selecting entries, you can store this set as a named filter, and use the filter directly from the
Select menu. You can open the Entry Selection dialog box from the Select menu by choosing
Only, Add, or Deselect. Only, Add, and Deselect. The Entry Selection dialog box is similar in
design to the Atom Selection dialog box. It allows you to select entries using GUI tools rather
than entering an ESL expression.

Figure 9.3. The Entry Selection dialog box.

At the top of the entry selection dialog box is a title bar, which defines the action to be taken
when you click OK. In the center are two tabs, Properties and Filters, that you use to define
property-based criteria for entry selection or choose named filters to combine with the entry
selection that is being created (the current entry selection). On the right are buttons for
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combining the criterion or named filter with the current entry selection. These tools become
available when you have selected a property and a condition for that property, or a named filter.
In the lower portion of the panel is an ESL text box that displays the current entry selection and
a set of buttons for editing the current entry selection.

To define a property criterion, choose a property from the list in the Properties tab, then select
a condition from the right side of the tab. The list can be restricted by choosing a subset,
filtered, or sorted. The available conditions depend on the property type. For some conditions,
you must enter a value or a range of values. The available conditions are:

• The property is defined. 

• For Boolean properties, the value is true or false.

• For numerical (real or integer) properties, the value lies in a given range, for example, >=
5.0 or 1 - 7. You can use any of the six operators ==, !=, <, >, <=, and >= to define the
range of property values.

• For string properties, the text matches a given string. “Match” means that the string given
is contained in the property value. The string can include the wildcard characters *, which
matches any number of characters, ?, which matches any single character, and #, which
matches any single digit.

In addition, the inclusion state and the selection state of the entry can be used as criteria. 

To combine this criterion with the current entry selection, click one of the buttons to the right
of the panel. 

• Add adds entries that meet the new criterion to the current entry selection, using a logical
OR operation on the ESL expressions. This is the default action, which is performed if
you press ENTER.

• Subtract excludes entries that meet the new criterion from the current entry selection,
using a logical AND NOT operation on the ESL expressions. If this is the first operation,
the default current entry selection is all. 

• Intersect limits the selection of entries to those in the current entry selection that also
meet the new criterion, using a logical AND operation on the ESL expressions. 

In addition to these three buttons, the Invert button at the bottom of the panel inverts the entire
current entry selection, using a logical NOT operation. All entries that were selected are
unselected, and all entries that were not selected are selected.

You can undo multiple operations with repeated clicks on the Undo button. The Redo button
reverses undo operations, and can also be used multiple times. You can also type ESL expres-
sions directly into the ESL text box. The hand-edited expressions are considered part of the last
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operation performed with the mouse and can be undone and redone as part of that operation,
but cannot be undone or redone separately.

Once you have defined the criteria for selecting entries, the current entry selection can be
stored as a named filter. To create a filter, click Create Filter. The New Filter dialog box opens,
in which you can provide a name for the filter. The newly created filter appears in the Filters

tab of the Entry Selection dialog box and on the Filter submenu of the Select menu. 

9.5.3 Selecting Entries By Matching a SMARTS Pattern

You can select entries that match one or more SMARTS patterns, in the Select by SMARTS

panel, which you open by choosing Select → By SMARTS. The search can be run on all entries
or on the selected entries. If it is run on all entries, the matches can be added to the selection or
they can replace the selection. These choices can be made with the Search option menu.
SMARTS patterns can be combined with logical operators, which are processed in sequential
order from the top, applying the logical operation at each step. You can highlight the atoms that
match the SMARTS expression in the selected entries by selecting Highlight atoms.

Figure 9.4. The Select by SMARTS panel.

To select entries that match a single SMARTS pattern:

1. Enter the SMARTS pattern in the text box at the top of the panel, or select atoms in the
Workspace and click Get from Workspace Selection.

2. Choose a search scope and action from the Search option menu.

3. Click Select.

To construct a complex search expression with several SMARTS patterns:

1. Enter the SMARTS pattern in the text box at the top of the panel, or select atoms in the
Workspace and click Get from Workspace Selection.
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2. Click AND, OR, or NOT.

Another section containing a SMARTS pattern text box and Get from Workspace Selec-
tion button is added above the logical operator buttons.

3. In this new section, enter the SMARTS pattern in the text box, or select atoms in the
Workspace and click Get from Workspace Selection.

4. To add another SMARTS pattern, repeat from step 2.

5. When all SMARTS patterns are entered, click Select.

To clear all the SMARTS patterns, click Reset. If you get the SMARTS pattern from the Work-
space selection, you can set preferences for some of the notational elements in the generated
SMARTS pattern—see Section 14.15 on page 382. 

9.5.4 Selecting Entries Using the Plot Panel

The Plot panel provides a means of graphically selecting entries and including them in the
Workspace. By plotting a property value against the entry name, for example, you can view the
properties and select the entries on the plot that you are interested in. See Section 11.1.5 on
page 291 for more information. 

9.5.5 Selecting Entries Using the 2D Viewer Panel

The 2D Viewer panel provides an alternative method for selecting entries on the basis of their
2D structures. The structures are presented in a grid, and you can synchronize the selection of
structures in the grid with the Project Table selection. You can also change the inclusion state
in this panel. See Section 9.9 on page 220 for more information.

9.5.6 Selecting Entries Randomly

You can make a random selection from the entries in the Project Table by using the Random

Selection dialog box, which you open by choosing Select → Random. The set of entries from
which the random selection is made can be based on the selected entries or groups, or all
entries or groups, and you can select a number of entries or a percentage of entries. For
percentages, the number of entries selected is rounded to the nearest integer. If you choose to
select from entry groups, the random selection is made from each group. Otherwise the random
selection is made from the entry selection without regard to groups. The number of entries or
groups from which selection is made is indicated next to the controls. 
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9.5.7 Selecting Entries in Groups

When you select an entry group, all the entries in the group are selected, and all other entries
are deselected. You can use shift-click and control-click to select multiple groups, and the
entries in these groups are selected. The group row is colored a light brown if all its entries are
selected, and white if none of its entries are selected.

You can make selections of a specified number or percentage of entries in one or more groups
by choosing Select → From Groups. In the Select from Groups dialog box, you can set the
number or percentage of entries to select, starting from the first or the last entry in the group.
The selection can be taken from the currently selected groups or from all groups. This feature
is useful if you have sorted the entries in the group by a property and want to select entries with
the highest or lowest values of the property. You can also make random selections—see
Section 9.5.6 on page 201.

The Group menu offers two selection items. If you select some but not all entries in one or
more groups, you can invert the selection inside each group that has selected entries by
choosing Invert Selection from the Group menu. The group rows for these groups are colored
light orange. You can also deselect all entries that are inside groups without affecting the selec-
tion of single entries by choosing Deselect All from the Group menu.

9.5.8 Selection Examples

There are generally multiple ways to perform each selection operation: from an option on the
Select menu, using the Entry Selection dialog box, using the mouse, and using ESL. A few
examples of the use of the Entry Selection dialog box are provided here.

To select a range of entries with the same base name:

1. Choose Only from the Select menu.

2. Select Entry name from the Properties list.

3. Select Matches in the conditions section and enter entry_name* in the text box, where
entry_name is the base name of the entries you want to select. 

4. Click Add, then click OK. 

To add entries from the Workspace to the current selection:

1. Choose Add from the Select menu.

2. Select Included State from the Properties list.

3. Select Included (or fixed) in the conditions section.

4. Click Add, then click OK. 
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9.6 Operating on Entries

The Entry menu provides tools to perform various operations on the selected table entries.
These operations are discussed in the following sections. The Entry menu items are the same as
the shortcut menu items, which are described in brief in Table 9.3.

9.6.1 Including, Excluding, and Fixing Entries

In addition to using mouse operations, you can include and exclude entries in the Workspace
by selecting the entries and choosing Include, Include Only, or Exclude from the Entry menu.
The last two of these menu items are mapped to the shortcut keys CTRL+N and CTRL+X. You
can also include and exclude entries by property value from a plot in the Plot XY panel. See
Section 11.1.5 on page 291 for more information on this feature. 

If you want to keep some entries in the Workspace while including and excluding other entries,
such as a receptor and a set of ligands, you can select the entries you want to keep in the Work-
space and choose Fix from the Entry menu or the shortcut menu, or press CTRL+F. These
entries remain in the Workspace until you explicitly exclude them, clear the Workspace, close
the project, or choose Unfix from the Entry menu or the shortcut menu. Unfix removes the
“lock” on the entries so that they are included in the Workspace but not fixed. 

To fix a receptor in the Workspace (defined as an entry with more than a ligand-sized number
of atoms), click the Fix button on the Style toolbar in the main window. Clicking again unfixes
the entry (or entries).

For entries that are in an entry group, the Group shortcut menu offers some inclusion options.
You can include all entries in the group by choosing Include All: the entries are added to the
Workspace. Similarly, you can exclude all entries in the group by choosing Exclude All. If you
want to include only the entries in the group, choose Include Only All. Finally, you can include
the first entry in the group by choosing Include First.

There are several ways of stepping through entries in the Workspace, that is, including the next
entry or the previous entry in the Project Table and excluding the current entry. If you have an
entry selection, and one of these entries is included in the Workspace, you can use the LEFT
ARROW and RIGHT ARROW keys to include the previous or the next selected entry in the
Workspace and exclude the current entry. If you have more than one entry included in the
Workspace, using the LEFT ARROW and RIGHT ARROW keys replaces each included entry in
the Workspace with the next selected entry in the Project Table. Thus, you can step through
multiple entries simultaneously to display them together in the Workspace. The other ways of
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stepping through entries are related, but have extra capabilities: the ePlayer (Section 9.7 on
page 216) and the pose viewing facility (Section 9.8 on page 220).

To exclude all entries from the Workspace, choose Workspace → Clear or click the Clear

button on the Workspace toolbar:

This action also removes fixed entries from the Workspace and clears the scratch entry.

If you include multiple entries in the Workspace in a single operation, there is a chance that
your computer does not have enough memory to store them all, particularly if they are proteins.
A warning dialog box opens if you include more than a designated number of entries in the
Workspace, and allows you to cancel the operation or to continue with the inclusion. You can
adjust the number of entries at which the warning is displayed in this dialog box. If you
continue, a progress dialog box is displayed if the inclusion takes more than a few seconds.
You can stop the include operation at the last entry included by clicking Stop or pressing ESC.
The entries already included remain in the Workspace. 

9.6.2 Renaming Entries

When importing entries from files, incorporating entries from jobs, merging entries with iden-
tical names, duplicating entries, or disassociating entries, Maestro automatically assigns new
entry names. You do not have to accept the automatically assigned names; you may rename the
entries using one of the methods described below.

To change the name of a single entry:

1. Double-click the entry name if the entry is not selected, or single-click the name if the
entry is selected.

2. Type in the new name. 

3. Press ENTER.

To rename multiple entries with the same name:

1. Select the entries to be renamed.

2. Click the entry name for one of the entries.

3. Type in the new name. 

4. Press CTRL+ENTER.
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9.6.3 Locking Entries

If you do not want entries to be changed or deleted, you can lock them by selecting them and
choosing Entry → Lock. A padlock icon is placed next to the row number. Locking entries
means that the structure and the properties as stored in the project cannot be changed or deleted
until you unlock them with Entry → Unlock (you are prompted to unlock the entry or discard
the changes if you try). You can also use the Entry shortcut menu to lock and unlock entries.

• Jobs run from a locked entry with Replace as the incorporation mode will not replace
structures or add properties, but can add surfaces. The job is marked as incorporated even
though the structure and properties are not updated. 

• You can edit the structure for a locked entry in the Workspace, but it will not be saved in
the project. If you exclude the structure from the Workspace, any changes are lost.

• Attempting to delete a locked entry will not delete structures or properties, but will delete
associated data.

• Locked entries can be sorted or moved around in the Project Table, because the position
in the Project Table (row number) is not a property of the entry.

9.6.4 Duplicating Entries

To duplicate entries, select the entries and choose an item from the Duplicate submenu of the
Entry menu. The possible choices are:

• In Place—Each duplicated entry is placed immediately below its source entry, and is
included in the source’s entry group if one exists. You can also use CTRL+D to duplicate
entries in place.

• Ungrouped—Each duplicated entry is placed at the end of the ungrouped entries, in
sequential order.

• Into New Group—The duplicated entries are placed into a new entry group. You can name
the group in a dialog box that is displayed.

• Into Existing Group—The duplicated entries are placed into an existing entry group. You
can select the group in a dialog box that is displayed.

To duplicate an entire entry group, right-click in the group row and choose Duplicate. 

The new entries retain the same title and entry name as the originals. The duplicates are
selected in the Project Table in place of the original entries, and any original entry that is
included in the Workspace is replaced in the Workspace by its duplicate. If modifications have
been made in the Workspace to any of the original entries, synchronization of the Workspace
with these entries is performed according to the synchronization preference (see Section 14.2.3
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on page 343). Any changes that were made to the Workspace that were not synchronized are
transferred to the duplicated entries.

9.6.5 Merging Multiple Entries

Maestro allows you to merge two or more selected entries, while leaving the original entries
unmodified. To merge entries, select the entries and choose Entry → Merge. When you merge
entries, Maestro places the new entry after the last entry that was included in the merge opera-
tion (inside an entry group, if this entry is in a group). The entries are placed in the new entry in
the order in which they appear in the Project Table. This order affects the atom and molecule
numbers in the merged entry. You can control the order of addition by moving the entries in the
Project Table before merging them.

Properties are also copied to the new entry. The properties of the entry with the most atoms (the
“lead” entry) are copied first, then the properties of other entries are added, in Project Table
order, to any blank cells. The title of the new entry is a concatenation of the titles of the source
entries, lead entry first, then the others in Project Table order. If more than three entries are
merged, the lead title is used with a suffix _mergedN, where N is the number of merged entries.
The entry name is likewise merged. Auxiliary data is not copied.

An alternative way of creating a new entry from several existing entries is to include them in
the Workspace, then create an entry from the Workspace. The order in which the entries appear
in the new entry is the order in which they were included in the Workspace. 

If you want to merge entries in the order of their entry IDs, enter the following command in the
Commands text box in the main window:

entrycombine order=entryid

9.6.6 Copying and Pasting Entry Properties

You can copy properties from a selected entry to the clipboard, and paste them into a selection
of other entries, either in the current project or another project.

To copy properties, use Entry → Copy Properties, and choose All to copy all properties, or
Shown to copy the properties that are shown in the Project Table.

To paste properties, select the entries you want to past the properties into, and choose Entry →
Paste Properties. The properties from the clipboard overwrite any existing properties of the
same (internal) name. If a property does not exist (or is of a different type) a new property is
created and values added for the selected entries. If a property value is empty in the source
entry, it overwrites values in the target entries with an empty value. 
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9.6.7 Splitting Entries

Entries that contain multiple molecules or chains can be split into entries that contain indi-
vidual molecules. For example, you can split a protein-ligand complex into separate entries for
the protein, the ligand, and the waters. To split an entry, select it and choose Entry → Split, then
By Molecule, By Chain, or Into Ligands, Water, Other. When an entry is split, the original entry
is kept, and a new entry is created for each molecule, chain, or other entity in the original entry. 

If the entry has zero-order bonds, splitting the entry does not break these bonds by default. You
can set a preference to determine whether zero-order bonds are considered when deciding
which atoms belong to the same molecule—see Section 14.12.1 on page 371 for details. You
can also delete the zero-order bonds before splitting, from the Delete button menu on the Edit
toolbar.

Some applications, such as the Protein Preparation Wizard, create zero-order bonds that are
broken by default, overriding this preference. If you have a metalloprotein, for example, the
Protein Preparation Wizard converts it into an ionic form, replacing any covalent bonds to the
metal with zero-order bonds. Splitting such a complex by molecule separates the metal from
the protein.

The new entries inherit the title of the original entry, with a suffix that indicates what kind of
structural unit is in the new entry. The entry names are also modified from the original by
adding a suffix. When you split by molecule, water molecules are collected in a single entry,
with the suffix _waters. The molecule entry names have the suffix _moln, where n indexes the
new entries; the title suffix is _moleculen. When you split by chain, the new titles have the
suffix _chainX, the entry names have the suffix _chain-name, and a Chain Name property is
created to store the chain name. When you split into ligands, water, and other, the entry name
suffixes are _ligandn, _waters, and _others (entry name) or _protein (entry title). 

If you want to copy the properties of the original entry to the new entries, choose Entry → Split,
and then select Copy Properties.

9.6.8 Grouping Entries

You can create groups of entries, and perform operations with the groups as a whole or restrict
operations to the members of a group. Entry groups are listed at the end of the Project Table,
and are identified by a group title and index. The number of entries in the group is given in
square brackets at the right of the Title column, and the entry group index is given in the title
column before the group title. The groups are stored as part of the project. Entry groups can be
created automatically when you import multiple structures, and use the file name (without the
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suffix) for the group title. They can also be created automatically when multiple structures are
incorporated as part of job output, and use the job name as the group title. 

You can create an entry group by selecting entries, then choosing Group → New from the Entry

menu or the Entry shortcut menu. A dialog box is displayed, in which you can enter the title of
the group. When you create the group, it is added at the end of the table, and the entries you
selected are moved inside the group. 

To reorder groups, select them in the table and drag them to the desired location.

Another means of grouping entries is to group them by the value of a particular property. If you
want to create a single group for a value or a range of values of a property, you can use the
Entry Selection dialog box to select the entries, then choose Create Group from the Entry menu
to create the group. If you want to create multiple groups, choose Entry → Group → By Entry
Property, which opens the Group By Entry Property panel. You can choose the property from
the Property list, which you can filter and sort, and group all entries or the selected entries. 

Figure 9.5. The Group By Entry Property panel.

• For string properties, a group is created for each unique string. 

• For Boolean properties, two groups are created, for TRUE and FALSE values of the prop-
erty. 

• For real and integer properties, the range of property values is divided into “bins” of a
specified size and entries are assigned to the bins on the basis of the property value. If you
choose a real or integer property, these controls for the range and the bin size are shown:
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• Step Size—Size of the bins used to divide the entries into groups. The bins include
the lower end of the range of values but exclude the upper end: thus a bin of size 2.0
for a real property starting at 2.0 would cover the range 2.0 ≤ value < 4.0.

• Align on value—Reference point for the lower end of each bin. The lower end of
each bin is set to this value plus (or minus) a multiple of the step size. For example,
if the reference point is 5 and the step size is 3, there will be bins covering the
ranges 2–4, 5–8, 9–11, and so on. If this option is deselected, the reference point is
the minimum of all values of the property in the entries that are to be grouped. This
option is on by default, with the value zero.

• Minimum—Lower limit for property values to be considered. Entries whose value of
the selected property is less than this limit will not be grouped.

• Maximum—Upper limit for property values to be considered. Entries whose value
of the selected property is greater than this limit will not be grouped.

To create the groups, click Group. You can enter an optional base name for the group, which is
used to construct the group title by adding the property name and information on the property
values in the group to the base name. 

If you want to change the group title, you can double-click on it and edit the text in the table
cell, or you can right-click on the title cell and choose Edit Title. 

9.6.9 Showing And Hiding Entries in Groups

The entries inside entry groups can be shown in the table (the group is expanded), or hidden
(the group is collapsed). You can expand or collapse a single group by clicking in the In

column. For multiple groups, you can show or hide the selected entry groups or all entry
groups from the Expand and Collapse submenus of the Group menu, or from the Group
shortcut menu, by choosing Selected or All. You can also expand the selected groups and
collapse all others by choosing Only Selected from the Expand submenu. The visibility of
entries in groups has no effect on their selection or inclusion state. 

9.6.10 Deleting Entries

You can delete entries from the Project Table by selecting the entries, then choosing Delete

from the Entry menu or pressing DELETE. You are prompted to confirm the deletion, but you
can choose not to be prompted in the confirmation dialog box. Entry deletion can be undone by
selecting Undo entrydelete from the Edit menu in the Maestro main window.

You can delete entry groups in the same way, by selecting the groups then choosing Delete

from the Entry menu or pressing DELETE. The entries are deleted from the groups immedi-
ately, then you are prompted for removal of the empty entry groups. You can delete all empty
groups by choosing Delete All Empty Groups from the Group menu.
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9.6.11 Moving Entries

Entries in the Project Table can be moved to another location in the table. Multiple entries can
be moved simultaneously, and entries need not be contiguous. To move entries, select them and
then drag them to the desired new location. The entries are placed after the first unselected
entry that precedes this location. For example, if you select entries 2, 4, and 6, and release the
mouse button on entry 3, these three entries are placed after entry 1, because entry 1 is the first
unselected entry that precedes entry 3. To move entries to the top of the table, drag them above
the top of the table; to move entries to the end of the table, drag them below the end of the
table. Dragging entries into an expanded entry group works in the same was as in the
ungrouped section of the table. Dragging entries to the heading row for the entry group places
them at the end of the group.

You can also move the rows that you have selected by choosing Move Rows from the Entry

menu. In the Move selected entries to row dialog box, you can specify the starting row number
for the first moved entry, or choose to move the rows to the beginning or the end of the table. 

Entries that are inside a group can be moved out of the group or moved to another group. To
move entries out of a group, select the entries, then choose Ungroup from the Entry menu to
place them at the end of the ungrouped entries, or drag them to the desired location. To move
entries to another group, select the entries, then drag them to the desired location in the new
group, or choose Move to Group from the Entry menu. The Move To Group dialog box is
displayed, in which you can select an existing group, select <no group> to ungroup the entries,
or select <new group> and create a new group. If you move all the entries out of a group, a
dialog box is displayed in which you can choose to delete or keep the empty group. 

Figure 9.6. The Move To Group dialog box.
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9.6.12 Sorting Entries and Entry Groups

You can sort project entries by property. For example, if you sort project entries in descending
order based on their inclusion state, entries included in the Workspace are placed at the top of
the list, and excluded entries are placed at the end. Sorting these entries in ascending order
places included entries at the end of the list.

Sorting entries respects the grouping of entries: the ungrouped entries are sorted, and the
entries within each group are sorted, but there is no change in the order of the groups or in the
group membership. If you want to sort groups, you can do so separately. 

The order in which string values are sorted can be changed with a preference. By default,
sequences of digits are treated as a single number, so that, for example, ligand10 follows
ligand9 rather than ligand1. If you want a standard dictionary sort, you can set a preference
under Project Table – Properties in the Preferences panel—see Section 14.3.1 on page 345.

To sort all entries by a single property, right-click and hold in the property header (or click the
arrow) and choose one of the Sort items from the shortcut menu. 

To sort selected entries, to sort entries by more than one property, or to sort entry groups, you
can use the Sort Project Table panel. In this panel you can choose as many sort keys as you
want, and specify the sort direction. The panel also offers grouping before sorting, sorting of
groups, and entry selection after sorting. These features are hidden by default. 

To open the Sort Project Table panel, choose Table → Sort or click the Sort toolbar button.

To sort entries: 

1. Select a property from the list on the left, and click the right-facing arrow button in the
center of the panel.

The property is added to the Sort entries table.

2. Click in the Direction column for the property to change the direction of the sort. 

3. To add another property, repeat Step 1 and Step 2.

4. To move a property up or down, select it and drag it to its new location.

5. Click Sort Selected or Sort All.

If you want to change the order of the entry groups, you can sort them by title or by the proper-
ties of their first entry. 
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Figure 9.7. The Sort Project Table panel, showing entry sorting tools only.

To sort entry groups by title:

1. Select Sort groups.

The controls for sorting groups are displayed below the option and the text of the option
changes to Sort groups by.

2. Select Group title.

3. Click Sort Selected or Sort All.

To sort entry groups by the properties of the first entry:

1. Select Sort groups.

The controls for sorting groups are displayed below the option and the text of the option
changes to Sort groups by.
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2. Select an option for the sort keys: 

• Properties of first entry, as sorted above—sort by the properties of the first entry
using the same sort keys as for sorting the entries.

• Properties of first entry, as shown below—sort by the properties of the first entry
using the sort keys specified in the table below.

3. Select the properties for sorting and add them to the relevant table, setting the sort order
and the sort direction, as necessary.

4. Click Sort All or Sort Selected. 

You can group entries before sorting by selecting Before sorting, group entries, then clicking
Options to set up the definition of the groups in the Group by Entry Property dialog box.

Figure 9.8. The Sort Project Table panel, showing all tools.
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Entries can be selected automatically from the top entries after sorting. The top entries are
those with the lowest row numbers, which corresponds to choosing the entries with the highest
or the lowest property values (depending on the sort direction), or in general it corresponds to
the order defined by the sort. You can select a specified number or percentage of entries, either
from all the project entries or from the entries in each group. You can select the top entry in
each group for each value of a chosen property, such as the title.

To select a given number of entries after sorting: 

1. Select After sorting, select top.

The controls for selecting entries are activated.

2. Select the Top N option.

3. Enter the number or percentage of entries to select in the text box.

The percentage is the percentage of the entries that were sorted.

4. Choose whether to select a number or percentage of entries, and whether to select them in
each group or in the entire sorted set of entries, from the option menu.

To select the top entry for each value of a property after sorting: 

1. Select After sorting, select entries.

The controls for selecting entries are displayed.

2. Select Unique entries in each group, by property.

3. Click the icon to the left of the text box and choose the property.

9.6.13 Ranking and Sorting Entries by Rank

There are occasions when you may want to sort entries by a rank that is calculated as the
optimum value of several properties, rather than sort them by properties independently. You
can calculate a rank by the Pareto method for two to four properties, and then sort entries by
this rank, in the Multivariate Ranking panel. 

To open this panel, choose Table → Multivariate Ranking.
Schrödinger Software Release 2015-2 



Chapter 9: Projects
Figure 9.9. The Multivariate Ranking panel.

To rank a set of entries by the optimal values of 2 to 4 properties:

1. Click Choose and choose the properties.

The table is populated with the property names and the default action, which is Maximize.
You can delete a property by right-clicking and choosing Delete.

2. If the best value of a property is the minimum, click in the Action column for that property
to change it from Maximum to Minimum.

3. Enter a property name for the rank in the Save as property text box.

4. If you want to sort the entries after ranking them, select Sort entries after ranking. Entries
within groups are sorted independently.

5. If you want to select the top-ranking entries after sorting, select After sorting, select

entries. More tools are displayed, which allow you to choose an option for selecting from
all entries or from each group, as a percentage or a number of entries, and enter the per-
centage or number in the text box.

6. Click Rank All to calculate the rank for all entries, or Rank Selected to calculate the rank
for the selected entries. The sorting and entry selection is done, if the options were
selected.

The rank value can be positive or negative. A large positive rank for an entry gives the number
of entries that have a lower rank. A negative rank for an entry means that for this entry there are
more entries with a higher rank than a lower rank. If the properties used in the ranking do not
exist for an entry that is ranked, no value is calculated for the rank property, and it is left empty. 
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9.6.14 Recording a Movie from Selected Entries

Maestro provides a facility for creating an MPEG movie (MPEG-1) from the selected entries
in the Project Table. To create the movie, select the entries, then choose Table → Record Movie.
The Record Movie file selector opens, in which you can name the movie. By default the movie
is recorded at 720×480 resolution with medium quality and a frame duration of 0.04 sec. If you
want to select another resolution, change the quality, change the frame duration or total dura-
tion, or add interpolated frames to smooth the movie, click Options, and make settings in the
Movie - Options dialog box. Adding interpolated frames increases the length of the movie: the
frame duration remains the same.

Figure 9.10. The Movie Options dialog box.

9.7 The ePlayer

The ePlayer allows you to view in succession the structures associated with selected entries.
By selecting entries to be included in the Workspace, and then selecting an entry to be used as
a reference, you can use the ePlayer to visualize structure relationships such as ligand-receptor
docking. You can also run a script on each entry as it is displayed. To use the ePlayer, you must
have a project open with at least one entry selected. The ePlayer can be operated from the
toolbar or from the ePlayer menu. The toolbar is hidden by default, but you can display it from
the ePlayer menu (Show Toolbar). The toolbar buttons are described below.
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The ePlayer menu has two additional items that are not represented on the toolbar:

• Next Group—Include only the first selected entry in the next entry group.
• Previous Group—Include only the first selected entry in the previous entry group.

9.7.1 ePlayer Modes

The ePlayer has two modes, Continuous mode and Step mode. In Step mode, you manually
advance the ePlayer to show each new entry structure. You can use the Next and Previous

buttons on the toolbar, the Next and Previous items on the ePlayer menu, or the RIGHT
ARROW and LEFT ARROW keys. 

To go to the beginning or the end of the entry list, use the Go to Start or Go to End toolbar
buttons or ePlayer menu items. 

Go to start 
Display the first selected structure. 

Previous 
Display the previous structure in the list of selected structures.You can also use the LEFT 
ARROW key to display the next structure, either in the Project Table or in the Workspace.

Play backward 
Display the selected structures in sequence, moving toward the first.

Stop 
Stop the ePlayer. You can also press ESC to stop play. 

Play forward 
Display the selected structures in sequence, moving toward the last.

Next 
Display the next structure in the list of selected structures. You can also use the RIGHT 
ARROW key to display the next structure, either in the Project Table or in the Workspace.

Go to end 
Display the last selected structure.

Loop 
Choose an option for repeating the display of the structures. Single direction displays struc-
tures in a single direction, then repeats. Oscillate reverses direction each time the beginning or 
end of the list is reached.
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In Continuous mode the ePlayer automatically displays all selected entry structures in
sequence. You can play through the structures once, or you can loop over the series by
repeating the sequence of structures in the same direction, or by reversing the direction. You
can stop play by pressing ESC. These options can be selected from the Loop submenu of the
ePlayer menu or the Loop button menu on the toolbar. 

If you choose None, the ePlayer displays the selected structures once in the direction you
choose and stops.

If you choose Single Direction, the ePlayer displays all selected structures in sequence, then
loops back to the first structure and redisplays the entire series until you click another ePlayer
directional button. 

If you select Oscillate, the ePlayer displays all of the selected structures in the forward direc-
tion, then in the reverse direction, and repeats this sequence until you click another ePlayer
directional button. 

9.7.2 ePlayer Options

The ePlayer Options panel provides access to controls for the ePlayer and extra actions that can
be performed during play. To open the ePlayer Options panel, choose Options from the ePlayer

menu. The panel has three sections: general options, options for superimposing structures, and
options for running a script.

Figure 9.11. The ePlayer Options panel.
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General 

You can adjust the speed at which the ePlayer moves through the specified structures by
entering a value in seconds in the Speed text box. This is the time that each structure is
displayed in the Workspace. The default is zero seconds per entry, which means that the speed
of play is limited only by the speed of rendering of the structures.

In Continuous play mode, the structures are only temporarily displayed in the Workspace. By
default, any changes in the structure are also temporary. However, you can save changes during
play by selecting Save workspace at each step. 

Superimpose Entry

One instance in which you may find the ePlayer very helpful is in superimposing entries onto
each other or onto a reference structure. For instance, when viewing ligands, you might want to
view them superimposed on a receptor. You can do this by fixing the receptor in the Workspace
but selecting only the ligands. 

If you choose On Previous Entry, each entry is superimposed on the previous entry in the
series. If you choose On Reference Entry, you must specify a reference entry, either by typing
its name in the Reference text box, or clicking the Choose button and choosing an entry from
the list. The reference entry can be any entry, but to view it during play, you must fix it in the
Workspace. 

If you choose to superimpose structures in Step mode, the project synchronization mode that
you have selected in the Preferences panel is applied. If you have chosen Automatically for the
synchronization mode, superimposing structures changes the coordinates of the structures
involved. If you do not want to save the coordinates that result from using the ePlayer, choose
Only When Specifically Requested for the synchronization mode.

In Continuous mode, coordinate changes that result from superposition are saved to the project
only if you have selected Save workspace at each step in the General section.

Run script at each step 

In addition to superimposing structures, you can execute a command script when each struc-
ture is displayed. If you choose Current Script, the script that is currently loaded in the
Command Script Editor panel is executed for each structure. You can open this panel and edit
the script by clicking Edit. If you choose From File, you can choose the file that contains the
command script you want to execute. This script is not loaded into the Command Script Editor
panel, but is stored temporarily.

Note: You should not include in your script any command that operates on all selected
entries, or that changes the inclusion state of the entries.
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9.8 Viewing Poses

The Project Table panel provides a facility for viewing ligands that are aligned to a receptor
active site, along with hydrogen bonds and contacts between the ligands and the receptor.
When you set up pose viewing, the receptor and the ligands must be part of the same entry
group, and the receptor must be the first entry in the selection (which need not include the
whole group). You can subsequently add ligands in another group, for example, as the setup is
done as a one-time action.

To start using the facility, chose View Poses from the Entry menu or the entry group shortcut
menu and then click Set Up in the Pose Viewer panel. The receptor is fixed in the Workspace,
the view is zoomed to the ligand, and a boolean property named Mark is added to the Project
Table. You can step through the entries by simply including them in the Workspace, by using
the ePlayer controls, or by using the LEFT ARROW and RIGHT ARROW keys. You can mark
entries (or clear the mark) by pressing the X key. The Mark property is then set to TRUE, and
displayed as a check mark in the Mark column. You can then select entries using this property. 

The Pose Viewer panel also allows you to turn on or off the display of nonbonded interactions
such as H-bonds and contacts, to generate counts of nonbonded interactions as Maestro proper-
ties, to set up nonbonded interactions using the Non-Bonded Interactions panel, and to display
and define per-residue interactions. The display of nonbonded interactions selected from this
panel is linked to the selection in the H-Bonds and Contacts panel, so that the selections in both
places are the same. For more information on nonbonded interactions, see Section 10.2.2 on
page 251 and Section 14.8 on page 362. For more information on viewing poses and per-
residue interactions, see Section 6.1 of the Glide User Manual.

9.9 Viewing 2D Structures

Maestro displays 3D representations of structures in the Workspace, but there are occasions
when it is more useful to see a 2D representation of the structures. The project facility provides
two ways in which you can view the 2D representation of structures, which are described in the
sections below. 

9.9.1 Displaying 2D Structures in the Project Table

You can display the 2D structure in a column of the Project Table, which allows you to asso-
ciate the structure with its properties in a more direct manner than including the structure in the
Workspace. To do so, click the 2D Structure toolbar button, or choose Property → Show →
Show 2D Structures. 
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The structures are displayed as the third column in the Project Table (or the fourth, if the Stars

column is shown), labeled 2D Structure. The structures are actually images that are generated
when they are displayed. You can change the size of the displayed structures by dragging the
row margin in the Rows column to change the row height. You can also set preferences for the
images under 2D structure in the Preferences panel—see Section 14.10 on page 368. Struc-
tures with more than a specified number of atoms (default 200) are not displayed. For protein-
ligand complexes, the ligand is displayed, with an icon in the top right to indicate that a protein
is present but not represented in 2D. The ligand is detected with the settings in the Ligand
Detection Settings dialog box—see Section 7.6.3 on page 159 for details.

If you do not want to display 2D structures as a column, but still want to be able to see them
when needed, you can set a preference to display the 2D structure in a tool tip when the pointer
pauses in the Row column—see Section 14.3.1 on page 345.

9.9.2 The 2D Viewer Panel

The second way of displaying 2D structures is to use the 2D Viewer panel. The basic function
of the 2D Viewer panel is to display 2D representations of the structures in the Project Table
and provide capabilities for selecting and including entries. 

To open this panel, click the 2D Viewer button on the toolbar or choose Table → 2D Viewer (or
click the 2D Viewer button on the Project toolbar or choose Project → 2D Viewer in the main
window).

Like the 2D structures displayed in the Project Table, the 2D structures are images that are
created when you open the panel, or when you click Update to update the panel contents from
the Project Table. There may be a short delay while the images are generated. As for the
Project Table display, images are not created for proteins or other large structures, but for
protein-ligand complexes, the ligand is displayed, with an icon in the top right to indicate that a
protein is present but not represented in 2D.

Each cell in the display area corresponds to an entry in the Project Table. The cells are arranged
in a rectangular grid. The structures for the entries are added to the grid row by row: moving
across a row and onto the next row is the same as moving down the Project Table. You can
select the number of columns displayed from the Columns menu, and you can choose which
entries are displayed from the Show option menu. 
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Figure 9.12. The 2D Viewer panel.

You can display selected properties at the bottom of each cell. By default, the title is displayed.
To select the properties that are displayed, choose Edit → Select Properties. The 2D Viewer -

Select Properties dialog box opens, in which you can select the properties that are displayed,
and choose whether to display the property names. The dialog box provides standard tools for
sorting the list of available properties and filtering it by product family or by text content. 

In this dialog box, you can also choose am atom-level property to use to label atoms instead of
the atomic symbol. All atoms, including carbon and hydrogen (if displayed) are labeled. After
choosing a property from the Atom-level annotation property option menu, you must click
Update in the 2D Viewer panel to see the chosen property on the atoms. 

You can select cells with the usual shift-click and control-click actions, and you can drag to
select cells. You can select all entries, clear the selection, and invert the selection from the
Select menu. With a single cell selected, you can step through the structures with the arrow
buttons, the arrow keys, with the N (next) and P (previous) keys, or from the Select menu. 

The selection is independent of the selection in the Project Table by default, but you can make
the panel selection and the Project Table selection the same by selecting Synchronize selection

with Project Table. Selecting entries in either panel then changes the selection in the other.
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If you have a single structure selected, you can display a larger image by selecting Single. To
return to the grid display, select Grid. You can also switch between single structure and grid
display by pressing ENTER. 

The inclusion state is always the same as in the Project Table, and is indicated by the square in
the top left of each cell. You can automatically include in the Workspace the structures that you
select in the panel by selecting Include selection in Workspace. With this option, whenever you
select a table cell, the structure is included in the Workspace. 

The images that are used to display the 2D structures can be adjusted by setting preferences in
the 2D structure group of the Preferences panel, which you can open by choosing Edit → 2D
Display Settings. See Section 14.10 on page 368 for details. 

The images can also be exported in a variety of formats, from the Export menu. Each item on
this menu opens a file selector in which you can navigate to a location and name the file.

• Export to PDF—Export the selected structures as images in a PDF file, in an array with
the same number of columns as in the panel. The properties are included in the images
with the structure. The images are exported as scalable vector graphics.

• Export to PNG—Export the selected structures to separate PNG files, named base-
NNN.png, where base is the name that you specify in the file selector, and NNN is a
serial number starting from 001. Only the 2D structure is included in the image.

• Export to HTML—Export the selected structures as PNG images included in a table in an
HTML page, with the same number of columns as in the panel. The images are exported
into a directory in the same location. If the file is named myimages.html, the image
directory is named myimages_img and the image files are named myimagesN.png,
where N is an index starting from 1. The links to the images are relative, so the file and
image directory can be moved to another location easily. The structure title is included as
alt text for the image. The properties displayed with the structure are included below the
image in the HTML file.

• Export to EPS—Export the selected structures to separate encapsulated PostScript files,
named base-NNN.png, where base is the name that you specify in the file selector, and
NNN is a serial number starting from 001. Only the 2D structure is included in the image.

You can also copy the image of the selected cell (provided only one is selected) to the clip-
board, with Edit → Copy or CTRL+C (C)

In addition, the 2D structures can be exported to a 2D SD file, by choosing Export → Export to

2D SD. The 3D structures can be exported to an SD file with a SMILES string for the structure
added as a property, by choosing Export → Export to 3D SD with SMILES. 
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There are some settings for exporting images and structures, which you can set in the 2D

Viewer - Settings dialog box by choosing Edit → Settings. 

• Scale images on export—Scale images to a uniform image size of 400×200 pixels when
they are exported. Images are always scaled when exported to a PDB file. Deselect this
option to produce images for which equivalent bonds have the same length. 

• When exporting, use transparent background—Use a transparent background when
exporting an image. The default is to use a white (opaque) background. 

• Include hydrogens when exporting to 2D SD format—Include hydrogens in the 2D struc-
ture when exporting structures to a 2D SD file. The default is not to include hydrogens. 

9.10 The Entry List Panel

The Project Table panel contains all the functionality in Maestro for access to projects and
project data. For performing basic tasks, it is not always convenient to switch between the
Workspace and the Project Table. A smaller, dockable panel that provides a basic view of the
project is also available: the Entry List panel. This panel contains a reduced view of the Project
Table, but retains many of the common capabilities, and is synchronized with the Project Table. 

By default, the Row, In, and Title columns are shown. These columns are shown so you can
include and exclude entries quickly without having to move your focus away from the Work-
space. If you want to add a property column, right click on the table heading row and choose
Show Property. A standard property selector opens, in which you can choose the property you
want to show. To remove a property column, right-click on its heading and choose Hide. 

Display of 2D structures is independent of the Project Table display, and can be done from the
shortcut menu in the heading row. 
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Figure 9.13. The Entry List panel docked into the Workspace.

Access to some of the Project Table functions is available through the shortcut menus, which
duplicate those in the Project Table panel, except for a few items. See Table 9.2, Table 9.3 and
Table 9.4 for a description of these menus. You can use the keyboard to perform functions,
such as including the next or the previous entry with the right and left arrow keys. 

A feature that is not available in the Project Table panel is the ability to filter the list of entries
shown in the Entry List panel. To filter the list by matching text, enter the text in the text box at
the top of the panel. As you type, the list is filtered to include only the entries that have a match
to the text anywhere in the title. Clicking the X button to the right clears the text and the filter.

You can also apply a filter based on the entry properties. Click the arrow next to the Filter

button and choose from the menu that is displayed: Included to show only included entries,
Selected to show only selected entries, or Filter to define a filter or choose a standard filter.
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When you choose Filter, the Entry Selection dialog box opens (see Section 9.5.2 on page 198),
and you can set up and name a filter or choose an already named filter. The filter that you
choose remains in effect (the Filter button is indented) until you click the button again. You can
reapply the most recent filter that you selected by clicking the button: you do not need to select
the item from the menu again. Both filters can be applied at the same time, and the filters are
reapplied whenever the Project Table changes. 

If you select multiple entries from a filtered list (with shift-click, for example), only the entries
that are shown are selected. Any intervening entries that have been filtered out are not selected.
The same applies to including entries in the Workspace from a filtered list: only the entries that
are visible in the list are included in the Workspace.

Information on the entries in the project and the list is shown below the list: the number of
entries and groups, the filter that is in effect and the number of entries shown after filtering on
properties. A list of suggestions for the use of the panel is displayed at the bottom of the panel. 

9.11 Entry Properties

Maestro supports incorporation and display of properties and calculated data for project
entries. You can display, delete, sort, and filter entries based on property values. You can select
a subset of properties to view, and you can add, delete, copy, and rename properties. Some
properties of structures can be calculated by Maestro, such as the molecular weight, number of
residues, and statistics of structural features. You can export properties to and import properties
from a spreadsheet file. See Section 3.3 on page 57 and Section 3.4 on page 58 for information
on exporting and importing properties.

Properties are displayed in columns in the Project Table. The property name is displayed in the
column heading. If the property has units, these are displayed in the tool tip for the column
heading, along with the property names (display name and internal name, see Appendix E).

Properties are classified into primary properties and secondary properties. These classifications
are defined for each application that produces properties, but you can change the classifica-
tions. Only the primary properties are shown in the Project Table by default, but you can
specify which properties are shown when adding entries by setting a preference—see
Section 14.3.1 on page 345.

Most of the operations you can perform on properties are available from the Property menu.
Others, such as plotting, importing, and exporting, are available from the Table menu.
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9.11.1 The Stars and Mark Properties

Maestro provides two special properties that you can use to rank and mark entries. One is the
Stars property. This property allows you to give a ranking from zero to three stars to any entry.
The property is displayed by default as the second column of the table. To set the number of
stars, click on one of the stars. To clear the stars setting, click on the rightmost star that is set.
(Each star behaves as a toggle.) You can also choose the number of stars from the Entry menu
or the Entry shortcut menu, or use the 0, 1, 2, and 3 keys to set the number of stars for the
selected entries. For a single (target) entry in the Workspace, you can use the * key in the Work-
space to cycle through the number of stars. The Stars property is an integer property with
values from 0 to 3. 

The other special property is the Mark property, which is a Boolean property. This property is
set for the target entry when you press X, either in the Workspace or in the Project Table panel,
or by choosing Entry → Mark → Target Entry. If the property does not exist, it is created. A
check box is displayed in the Mark column for marked entries. The Entry → Mark submenu
also allows you to mark the selected entries (Selected), the included entries (Included), and all
entries (All); it also allows you to clear the mark for all entries (None) or to invert the marking
of the selected entries, or all entries if there is no selection (Invert).

The target entry is the entry that is included in the Workspace that meets one of the following
conditions:

• It is the only entry included in the Workspace
• It is the only entry included in the Workspace that is not fixed
• It is the only entry included in the Workspace that is selected

If you have single-entry feedback displayed in the Workspace, the target entry is the entry for
which feedback is shown. 

9.11.2 The Date Added and Date Modified Properties

When an entry is added to the project, two properties are added with it that record a time
stamp: Date added and Date modified. The times are given in the local time in the form YYYY-
MM-DD HH:MM:SS, and are stored as strings. The Date modified property is updated when
changes to an entry are written to the project database. If you undo changes to the entry, the
Date modified is also reverted to the previous value. When merging properties, the Date added

property is set to the time of the merge.
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9.11.3 Creating New Properties

Apart from incorporating results from a calculation and importing data from a spreadsheet,
there are some ways in which you can create new properties. One is to add a property column
and insert values into it manually. Another is to copy an existing property and modify the prop-
erty values. A third is to calculate one of a selection of new properties. A fourth is to calculate
a new property from existing properties. 

9.11.3.1 Adding Properties with a Default Value

To add a property column to the Project Table, choose Add from the Property menu. In the Add
Property panel, you can specify the name, the type, and the initial value of the new property
(see Figure 9.14). When you add the property, all selected entries are assigned this property
value. If you don’t specify a value, the property is created but no values are assigned. For real-
valued properties, you can set the precision to which the value is displayed. The default preci-
sion is set as a preference—see Section 14.3.1 on page 345 for more information.

Figure 9.14. The Add Property panel.

9.11.3.2 Adding Properties by Copying

To create a new property by copying an existing property, choose Property → Copy to open the
Copy Property panel. In this panel, select the property in the From list, select <Add New Prop-

erty> in the To list, provide a property name in the New Property Name text box, then click All

Entries or Selected Entries. A new property column is created, and the values are copied for all
entries or for the selected entries. See Section 9.11.5 on page 233 for more information on
copying properties. 

9.11.3.3 Calculating Properties from Structural Data

Maestro provides a selection of properties that can be calculated for entries from the structure
itself. These calculations are done from the Calculate Properties panel, which you open by
selecting Property → Calculate. 
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Figure 9.15. The Calculate Properties panel.

The available properties, given in the Property list at the top of the panel, are:

For some properties, there are options or settings that must be made in order to calculate the
property, such as a restriction on the number of atoms. These are presented in the Property

Options dialog box, which opens when you click the button to calculate properties. To calculate
properties, select them in the Property list, then click All Entries or Selected Entries under
Calculate N properties for.

Chiral centers AlogP 

Molecular charge Hydrogen bond acceptors 

Molecular formula Hydrogen bond donors 

Molecular weight Number of rotatable bonds 

Number of atoms Polar surface area 

Number of heavy atoms Molar refractivity 

Number of molecules Polarizability 

Number of residues Substructure 

Spin multiplicity Total surface area 

Secondary structure content Sequential index 
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Figure 9.16. The Property Options dialog box.

If you have previously calculated the properties for some entries and want to calculate them for
other entries, you can choose to recalculate the existing values by selecting Recalculate
existing values. 

The Chiral Centers property choice calculates the number of chiral centers for ligand-sized
molecules and adds the chirality properties used by LigPrep. These properties are calculated
only for entries that contain a single ligand-sized molecule.

The Secondary structure content property is actually three properties: percentage of helices,
percentage of beta strands, and percentage of random coils. 

The Substructure property is the number of occurrences in each entry of the substructure that
you provide (as a SMARTS pattern). You can specify the SMARTS pattern in the Property

Options dialog box, either by typing or pasting it in, or by picking atoms in the Workspace and
creating a pattern from the selection with the Get from Workspace Selection button. (You can
set preferences for some of the notational elements in the generated SMARTS pattern—see
Section 14.15 on page 382.) You can also specify the property name.

The Total surface area property choice generates up to four properties, Total Surface Area,
Hydrophobic SA, Buried SA, and Buried Hydrophobic SA. There are two options in the Property

Options dialog box for the type of surface that is used: Extended radius or Molecular. These are
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the same as the surfaces available from the Surfaces submenu of the Workspace menu (see
Section 12.1.2 on page 299 and Section 12.1.3 on page 300 for details). For each surface type,
a probe radius must be given in the Probe radius text box. The default value of 1.4 Å is the
value for water. For molecular surfaces you can also specify the grid spacing. Which surface
area properties are generated depends on the options selected: 

• Hydrophobic surface area—calculates the hydrophobic surface area of the molecule.
Selecting this option produces the Hydrophobic SA property. Hydrophobic atoms are
defined in the same way as for Phase hydrophobic features. 

• Buried surface area—calculates the buried surface area of the selected entries when a
receptor is present. Selecting this option requires you to choose a receptor, and produces
the Hydrophobic SA property.

• Buried hydrophobic surface area— calculates the buried surface area of a receptor when a
ligand is present. Selecting this option requires you to choose a receptor, and produces the
Buried Hydrophobic SA property.

For meaningful values of the buried surface areas, the entries that you calculate the property
for should be docked to the receptor. The buried surface area is the area that is not solvent-
accessible when the receptor is present. 

When calculating buried surface areas, the Receptor controls enable you to choose a receptor.
You can either pick a receptor in the Workspace, if Pick to define receptor is selected, or click
Choose to choose an entry for the receptor. 

For the Sequential index property, you can select an option to index the selected entries sepa-
rately for each group. By default the index runs over all entries, regardless of grouping. You
can also name the property.

9.11.3.4 Calculating Properties from Other Properties

In the Project Table Calculator Panel, you can construct formulas from arithmetic properties
(real or integer), and use these formulas to construct new properties. The calculator provides
the usual arithmetic operations and a range of mathematical functions and units conversions, as
well as the ability to group expressions with parentheses to create complex formulas. The
expression can be applied to multiple entries to create properties. To open the panel, choose
Table → Calculator or click the Calculator toolbar button.
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Figure 9.17. The Project Table Calculator panel.

A formula can refer to any number of existing properties and functions, including mathemat-
ical functions. Formulae are assembled by using the operator buttons ˘–, +, *, /, **, the paren-
theses buttons, the lists of properties and functions, and constants. Each time you click a
button, a token is added to the formula, and the availability of the buttons is updated to reflect
the valid choices for the next token. 

• To add a property to the formula, click Properties. A dialog box opens that lists the avail-
able real or integer properties. Select the property, then click OK. 

• To add a mathematical function to the formula, click Functions. A dialog box opens that
lists the available functions. Select the function, then click OK. 

• To add a constant to the formula, type the value in the Constant text box and press
ENTER.

• To remove the last addition from the formula, click Undo. You can click this button multi-
ple times to undo multiple additions to the formula. 

The entire formula can be cleared by clicking Clear. There is no way to directly edit the
formula.

When the formula is in a complete state the Execute button becomes available. This button
evaluates the formula for all the rows in the current project, or if Selected Rows Only is
selected then the formula is evaluated for only the selected rows in the Project Table.

Example: Calculating GlideScore divided by molecular weight.

1. Calculate the molecular weight property:

a. Choose Property → Calculate in the Project Table panel.

b. Select Molecular weight from the Property list.

c. Click Calculate, then click Close.

2. Enter glidescoremw in the Create text box.
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3. Select the GlideScore property:

a. Click Properties.

b. Select docking score from the list.

c. Click OK.

4. Click the / button.

5. Select the Molecular weight property.

Use the same procedure as in Step 3. The formula is now complete and can be evaluated.

6. Click Execute.

The property is created and the values entered into the table.

9.11.4 Editing Properties

To edit the contents of an individual Project Table cell, click the cell, edit the contents, then
press ENTER or click elsewhere in the Project Table. If the cell is not in a selected entry, the
entry it is in is selected and all others are deselected. 

To set the value of a property to a particular value for the selected entries, click one of the cells,
edit the contents, then press CTRL+ENTER. The new value is copied to all selected entries. 

You can copy and paste property values using the mouse. To copy a value from the Project
Table, click in the cell, then drag over the value you want to copy. To paste the value, click in
the cell you want to copy the value to, then middle-click to paste the value into the cell. The
value you copy does not need to come from Maestro—you can obtain it from any location.

For properties that store the name of a file (which is shown as a hyperlink), clicking in the cell
shows a shortcut menu, from which you can choose Edit Text to enter edit mode and edit the
text of the file name.

9.11.5 Copying Properties

You can copy values from one property to another in the Copy Property panel, which you open
by selecting Copy from the Property menu. To copy values, specify the source property (From)
and the destination property (To), then click All Rows or Selected Rows to copy the values. 

The source and destination properties do not need to have the same data type. The result of the
copy operation depends on the characteristics of the data. An entry must always have values for
Title, Entry ID, Entry Name, In, Surf, Hyp, Vib, and Selected (the selection state). These prop-
erty values cannot be deleted. The Entry ID, Surf, Hyp, and Vib properties cannot be over-
written. The Entry Name can only be replaced by a legal entry name. The Title can be made
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empty, but the property itself cannot be deleted. If the source value is missing or the conversion
fails when copying to the In or Selected properties, these properties are set to false. 

Figure 9.18. The Copy Property panel.

The following conditions determine what happens when the destination is not one of the
special properties:

• If the destination property does not exist, it is created using the data type of the source
property and the source data is copied into it.

• If the destination property does exist and is of the same type as the source, the destination
property values are replaced.

• If the destination property exists and is of a different type, an attempt is made to convert
the data type to that of the destination. If the conversion fails, the destination property is
deleted. If it succeeds, the converted data replaces the original data.

• If fields in the source property column are empty, the corresponding fields in the destina-
tion property column are deleted.

Note that the row number is not a property of the entry. However, it can be copied to a property,
by selecting Row in the From section. The From section also has an option for the group title,
which you can copy to a property. 
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See Section 9.6.6 on page 206 for information on copying a range of properties from one entry
to other entries.

You can also copy and paste values for individual properties in edit mode, which you enter by
clicking in the table cell (see Section 9.11.4 on page 233). To copy use CTRL+C; to paste use
CTRL+V; or use the shortcut menu for the cell. For properties that store the name of a file,
clicking in the cell shows a shortcut menu, from which you can choose Copy Text to copy the
file name, and Edit Text to enter edit mode and paste text. 

9.11.6 Merging Properties

You can merge the values in one or more property columns into an existing property or a new
property in the Merge Properties panel, which you open from the Properties menu. The desti-
nation property must be a string property, because the merged property is a list of the selected
properties, separated by a delimiter. The source properties can be any kind or property, but they
are converted to a string on merging.

Figure 9.19. The Merge Properties panel.

To merge properties: 

1. Select the desired properties from the Available properties list, 

2. Click the right arrow to move them to the Properties to merge list.

3. Select the destination property from the Destination property list.

4. (Optional) Enter a separator in the Separator text box.
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5. Click All Rows or Selected Rows to perform the merge.

Both property lists have tools that you can use to restrict the list to a given family, filter the list,
or sort the list. The order of the source properties in the destination property is the order in
which they are sorted in the Available properties list. The merged property is appended to the
destination property.

To create a new property, select <Create New Property> in the Destination property list, and
enter a name in the New property name text box. The name can include spaces. You can
specify a multi-character separator (including spaces) in the Separator text box. Click All Rows

or Selected Rows to complete the operation.

9.11.7 Setting the Number of Decimals and the Notation for a Real 
Property

You can change the number of decimal places displayed for a given property, by choosing
Property → Columns → Decimal Places or choosing Decimal Places from the Columns button
menu on the Property toolbar. 

The Set Decimal Places dialog box is displayed, in which you can select one or more proper-
ties and set the number of decimal places to display. The default number of decimals is set as a
preference—see Section 14.3.1 on page 345 for more information.

You can also select Use E notation, to display the property in exponential notation, e.g. 1.0e-02
instead of fixed- point notation, e.g. 0.01. The properties that you select are shown in the
Project Table in E notation, with the specified number of decimal places, when you click Set. 

9.11.8 File Name Properties

Some properties store the name of a file, such as the input or output file from a calculation.
These properties are shown in blue underlined text, as is common in hyperlinks to web pages.
The full path to the file is stored in the property, so that the file can be located by Maestro, and
the property is registered with Maestro as a file name property for this purpose. 

When you click on this property, a shortcut menu is shown. You can edit the text of the file
name by choosing Edit Text from the shortcut menu, and you can copy the text of the file name
by choosing Copy Text from the shortcut menu. You can view the contents of the file, if it is a
text file, by choosing View from the shortcut menu. A read-only text viewer opens (named
View File filename), which displays the file name and the file contents. You cannot edit the
contents, but you can select and copy text from the contents to paste somewhere else. 
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9.11.9 Renaming Properties

You can rename properties other than the fixed properties, Entry ID, In, Title, Stars, and Entry
Name. 

Figure 9.20. The Edit Property Name/Type panel.

To rename a property, choose Property → Columns → Edit Name/Type, or choose Edit Name/

Type from the Property shortcut menu or the Columns button menu on the Property toolbar. 

You can then edit the name in the Edit Property Name/Type panel.

Properties have a “display name” or “visible name” and an “internal name” (see Appendix E).
You can change both names in this panel. Normally you should not need to edit the internal
name, but if you want to change it, select Change internal name. If you change the prefix that
specifies the property type, the property values are converted to the new type. If any property
value is not converted, a warning is posted so you can revert the change. Otherwise, the values
on which the conversion fails are left blank. The name that you choose (either visible or
internal) must be unique within the project.
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9.11.10 Deleting Properties

You can delete properties other than the fixed properties, Entry ID, In, Title, Stars, and Entry
Name. 

To delete a single property, right-click on the column heading and choose Delete, or right-click
on the property in the Property Tree panel, and choose Delete Property.

To delete one or more properties, you can choose Property → Delete, which opens the Delete
Properties panel. Select the properties in the list and click Delete Selected Properties. You can
select multiple properties with shift-click and control-click. 

Figure 9.21. The Delete Properties panel.

To find the properties you want to delete, you can show a subset of properties, filter the proper-
ties, or sort the properties using the property selection tools. 

You can select all the properties shown in the list by clicking All. Only the shown properties are
selected. You can select the properties for which none of the entries have a value by clicking All

Empty. This action selects from all the properties in the project, regardless of the filter. 

To clear the selection, click None. 

9.11.11 Clearing Property Values

You can clear the values of all or selected properties, so that the properties have no value for
those entries. To do this, choose Property → Clear Values, select the properties and the target
entries (All or Selected) in the Clear Property Values dialog box and click Clear. 
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9.11.12 Showing and Hiding Properties

The Property menu has several choices for selecting the properties that are shown in the Project
Table. The choices on the Show submenu are also available from the Show toolbar button.

The Property shortcut menu (displayed when you right-click on a column heading) has several
choices for showing and hiding properties—see Table 9.2 on page 188. 

You can also show and hide properties and property families from the tree view of the proper-
ties, which you display by clicking the Tree toolbar button.

You can set a preference to control whether new properties are automatically added to the
display when entries are added to the Project Table, under Project Table – Properties in the
Preferences panel—see Section 14.3.1 on page 345.

As well as reducing the amount of data displayed in the Project Table, limiting the displayed
properties can be used to limit the properties that are exported to a structure file or a spread-
sheet file. 

9.11.12.1 Using the Properties Menu

The main ways of selecting the properties using the menu are as follows:

• You can select the properties to show in the Show Property dialog box, which you open
by choosing Property → Show → Select. You can select multiple properties in the Avail-

able properties list by shift-clicking and control-clicking the list items. 

The list can be restricted to primary properties, a property family or its primary proper-
ties, or the shown properties by selecting from the Subset option menu, and it can be
filtered by entering the text to match in the Filter text box. This text can include wildcard
characters: * to match any number of characters, ? to match a single character; and it can
include character sets enclosed in square brackets, such as [a-z]. You can also sort the
list alphabetically or by the order of the Project Table.

When you have selected the desired properties, click the right arrow button or press the
RIGHT ARROW key to transfer them to the Properties to show list. If you want to hide
properties, select them in the Properties to show list and remove them from the list by
clicking the left arrow button or pressing the LEFT ARROW key.
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Figure 9.22. The Show Properties dialog box.

When you have chosen the properties, click Show to change the Project Table display.

• You can display all properties by choosing Property → Show → All.

• You can display only the primary properties by choosing Property → Show → Primary

Only.

• If you want to display all the properties or the primary properties for a given family and
hide all other properties, you can choose from the Show Only Family submenu of the
Properties menu.

• If you want to hide the properties from a given family, you can select the family from the
Hide Family submenu of the Property menu.

• You can hide all properties by choosing Property → Show → None.

• The 2D structure can be shown or hidden separately. It has its own item on the Property

menu, and a toolbar button. 

• You can limit the properties to those for which the selected entries have at least one value
defined, by choosing Property → Show → For Selected Entries. This choice removes col-
umns from the display that are empty for the selected entries, allowing you to focus on
those that have values. 

9.11.12.2 Using the Property Tree

The property tree lists all the properties in the Project Table. Each property has a check box
that you can use to show or hide the property. The tree is organized by families, with one node
for each family, and nodes underneath it for the primary and secondary properties, with proper-
ties sorted alphabetically under each node. 
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To view the properties for a family, click the turner (node). Click the turner again to hide the
properties in the tree. If you want to expand or collapse all branches of the tree, right-click on
any family (but not on a node) and choose Expand All or Collapse All. 

The properties that are shown in the tree can be filtered, by entering the text you want to match
in the search text box. This text can include wildcard characters: * to match any number of
characters, ? to match a single character; and it can include character sets enclosed in square
brackets, such as [a-z]. Filtering is done as you type, and the tree displays only the nodes that
contain properties that match the filter. To show the full tree again, click the clear (X) button at
the right side of the text box.

Figure 9.23. The Property Tree panel.

To show or hide any property or any group of properties (a property family, or the primary or
secondary properties of a family), click the appropriate check box. If a group of properties has
some but not all of its properties shown (checked), the check mark is gray, to indicate that the
group is incompletely shown. 

Since properties can belong to more than one family, when you select a property or a group of
properties to be shown, other groups or properties can be selected. For example, selecting the
secondary family for Glide also selects the Glide Residue Interactions family, because this
family is a subset of Glide secondary properties (see Figure 9.23).

To scroll a particular property into view in the Project Table, right-click on a property and
choose Scroll into View.

9.11.13 Creating and Editing Custom Property Families

You can create and edit your own property families in the Manage Custom Property Families

panel, which you open from the Property menu. You can create new families, copy families,
rename families, edit families, and delete families. You can also redefine the primary property
families that are defined for each application. Property family definitions are stored in the file
custom_property_groups in the profile directory for the current profile, and primary prop-
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erty families are stored in custom.primary.properties, in the same location. Thus, they
are not tied to a particular project, but are part of your Maestro customization. 

Figure 9.24. The Manage Custom Property Families panel.

Some procedures are given below for creating and editing custom property families. Changes
that you make to a property family are applied immediately: there is no confirmation for
changes to the properties included, or for deleting a family. You should therefore take care to
make a copy of any family that you do not want to change or delete accidentally. You can also
edit the resource files for these families—see Section 13.5.6 on page 329.

The list of available properties can be limited to an existing family, which you can choose from
the Subset option menu, or it can be filtered, by entering an expression in the Filter text box.
The expression can include wildcard characters: * to match any number of characters, ? to
match a single character; and it can include character sets enclosed in square brackets, such as
[a-z]. The beginning and end of the expression have implicit * wildcard characters.

To create a new property family from scratch:

1. Click New.

The New Family dialog box opens.

2. Enter a name for the property family and click OK.

The dialog box closes and the family name is shown in the Custom property families list.
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3. Select the properties that you want to add to the family in the Available properties list.

To select the properties, you can use shift-click and control-click as usual; you can choose
a subset of the properties from the Subset option menu; and you can filter them by enter-
ing an expression in the Filter text box.

4. Click the arrow button that points to the right (the upper one) or press the RIGHT ARROW
key.

The properties you selected are transferred to the Properties in family list.

5. Repeat the selection and transfer steps until you have all the properties you want in the
family.

To create a new property family from an existing family:

1. Select the existing family in the Custom property families list.

2. Click Copy.

The Copy Family dialog box opens. 

3. Enter a name for the property family and click OK.

The dialog box closes and the name is displayed in the Custom property families list.

4. Select the properties that you want to add to the family in the Available properties list, and
click the right arrow button or press the RIGHT ARROW key.

5. Select the properties that you want to remove from the family in the Properties in family

list, and click the left arrow button or press the LEFT ARROW key.

To change an existing property family:

1. Select the existing family in the Custom property families list.

2. Select the properties that you want to add to the family in the Available properties list, and
click the right arrow button.

3. Select the properties that you want to remove from the family in the Properties in family
list and click the left arrow button or press the LEFT ARROW key.

Note that the changes to the family are immediate: there is no confirmation.

To delete a property family: 

1. Choose the family in the Custom property families list.

2. Click Delete.

The family is deleted immediately.
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To delete all custom property families:

• Click Reset All.

All families are deleted, and any customization of the primary families is reverted.

To restore the primary property families to their defaults:

• Click Reset Primary Families.

You can also customize the primary property families from the Tree view of the properties, by
dragging properties between the primary and secondary sets within a family. To display the
tree view, choose Property → Tree or click the Tree button.

9.11.14 Coloring Table Cells By Property Value

You can define how the cells in property columns are colored, using the numerical values of
the property. The property must have real or integer values. The properties for which a cell
color scheme is applied can be selected, and the color schemes for the cells can be set up,
modified, applied, and saved as preferences, in the Color By Property dialog box. To open this
dialog box, choose Entry → Color → By Entry Property, or choose By Entry Property from the
Color toolbar button.

To apply a color scheme to a property column in the Project Table:

1. Select the property in the Available properties list.

You can restrict the range of properties shown with the Subset option menu, filter them
by entering a string in the Filter text box that the property name must include, or sort them
by choosing a sort option.

2. Click Add.

The property is transferred to the Colored properties list, selected, and is listed in the
Property text box. The range of property values is reported below the Property text box. If
the property has previously had color settings, these settings are restored. Otherwise,
standard default values are set. 

3. Select the desired options for coloring the property, and set the value thresholds and
choose the colors (see below). 
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4. Click Apply to apply the scheme and continue on to color another property, or click OK to
apply the scheme and close the dialog box.

Figure 9.25. The Color By Property dialog box.

To remove a color scheme:

1. Select the property in the Colored properties list.

2. Click Remove.

The property is transferred to the Available properties list. The coloring is turned off, but
the scheme is still available if you decide to reapply coloring.

To change a color:

1. Click the color button.

A standard color selector opens.

2. Pick the color or specify its numerical values (HSV or RGB).

3. Click OK.

The new color is displayed on the color button.

The color scheme is defined by the options in the lower part of the panel, with their controls.
Maestro 10.2 User Manual 245



Chapter 9: Projects

246
• Color below—Select this option to color property values that are below the specified
threshold. The threshold is a strict inequality (value < threshold) You can enter the thresh-
old in the text box. 

• Color above—Select this option to color property values that are above the specified
threshold. The threshold is a strict inequality (value > threshold) You can enter the thresh-
old in the text box.

• Color between—Select this option to color property values that are between the Color

below and Color above thresholds. There are two options:

• Solid: Use a single color between the two thresholds. 

• Interpolate colors in N steps: Interpolate the colors between the Color below and
Color above colors in the given number of steps. The range of values between the
two thresholds is partitioned into steps of the same size. 

• Color exact match—Select this option to color property values that are equal to the speci-
fied value (value = target) You can enter the target value in the text box. 

The range of property values for the selected property is reported above these options. You can
set the limits in the Color below and Color above text boxes to the minimum and maximum
values of the property by clicking Set Limits to Range. 

If you want to save the property color schemes for use in other projects, click Save as Prefer-
ences when you have finished defining the color schemes. The schemes are saved in your
Maestro user resources directory. These preferences are read and applied to properties in any
project, not just the current project, and are used as the default colors. The property color
schemes are stored in the project by default, and are used whenever the project is opened. 

9.11.15 Moving, Reordering, and Resizing Property Columns

There are several ways of moving individual property columns and multiple columns.

You can move and resize individual columns in the Project Table with the mouse. Dragging a
column border resizes the column. Dragging the column heading moves the column. You can
only move columns that are in the scrollable area.

More options for moving an individual column are available from the Property shortcut menu,
which is displayed when you right-click in a column heading. The following options are avail-
able from the Move To submenu: 

• First—Move the property to the first (leftmost) position in the scrolling area of the table.

• Before—Move the property to the position before the property that you choose in the
property selector that opens.
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• Left—Move the property one place to the left.

• Right—Move the property one place to the right.

• After—Move the property to the position after the property that you choose in the prop-
erty selector that opens.

• Last—Move the property to the last (rightmost) position in the scrolling area of the table.

• Fixed Area—Move the property to the fixed area of the table. The property is added after
the standard fixed properties, and cannot be moved to a position to the left of any of these
properties.

• Scrolling Area—Move the property to the scrolling area of the table. This can only be
done for properties that you moved from the scrolling area. The property is placed in the
first position of the scrolling area.

If you want to rearrange multiple columns, use the Reorder Properties dialog box, which you
open by choosing Property → Reorder. In addition to reordering the properties, you can select
properties to show or hide, and create new property families. Properties can be reordered by
selecting them in the Properties list, and moving them to their desired new location in the list. 

Figure 9.26. The Reorder Properties dialog box.
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To choose the scope of reordering, select All or Shown. The Properties list is updated to reflect
the choice, and the count of properties at the top of the panel is updated. If you display all
properties, the properties that are currently hidden are listed in italics. You can show or hide
properties in the list by selecting them and clicking Show Only, Show, or Hide. The font is
changed to reflect the new status. If Shown is selected, and you click Hide, the properties are
hidden. The visibility of the properties in the Project Table is not changed until you click OK.

You can select properties in the list with the usual click, shift-click and control-click in the list,
or with the tools in the Select section of the panel. In this section, you can select by family or
by using a filter, then click Add to add to the selection or click Replace to replace the selection.

To move properties in the list, you can drag them to the new location, or use the four arrow
buttons to the right of the list. If the list does not display hidden properties, the moved proper-
ties are placed above any hidden properties that are above the insertion point.

If you want to create a custom family, you can select properties in the list, then click Create

Family. When you enter a name and click OK in the Create Custom Property Family dialog box,
the family is created and added to the Family option menu. It can then be used for selection of
properties.

Properties can also be reordered alphabetically or by family. To do so, choose the appropriate
option from the Order all option menu, and click Apply. When properties are ordered by family,
the families are arranged alphabetically, but the order of the properties within the families is
not changed. Properties that are not in families or in the scope of the option chosen are placed
at the end of the list, in their current order. 

You can resize all columns to fit the width of the data, to fit the width of the data and the
heading, or to a fixed width by choosing the appropriate item from the Columns button menu
or the Columns submenu of the Table menu. 

9.11.16 Exporting and Importing Data

Maestro does not provide full spreadsheet capabilities. However, you can export data to a
spreadsheet file, operate on the properties, and re-import the modified data. These capabilities
are available from the Import and Export submenus of the Table menu, and are discussed in
detail in Section 3.3 on page 57 and Section 3.4 on page 58. You can also export data along
with structures to Canvas—see Section 3.5 on page 60.
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Maestro is equipped with tools for investigating and changing the properties of structures in the
Workspace. While some of these tools, such as plotting (Chapter 11) are discussed elsewhere,
most of the tools are discussed here. The tools are available on the Tools menu.

10.1 Displaying Markers

Maestro uses markers to mark atom selections in the Workspace. These markers provide visual
confirmation that atoms have been successfully selected, or that an analysis task or operation
has been performed.

For most operations, you can choose whether or not to display markers. To display the markers
for a particular operation, select Show markers or Markers in the panel used to perform the
operation. When you are no longer using a property represented by a set of markers, you can
hide the markers so that the Workspace does not become cluttered. The atom sets remain
defined, so that you can redisplay the markers later.

Most panels display markers by default, and hide their associated markers when you close the
panel. The exception is measurement markers, which are displayed even if the Measurements

panel is hidden. You must delete these markers explicitly.

The color of some markers can be changed. If there is a colored button or a color patch and an
Edit button next to the Show markers or Markers option, you can click the button and select a
color for the marker in the color selector that opens. The color is shown in the color patch. 

10.2 Displaying Measurements in the Workspace

The Measurements panel (see Figure 10.1 on page 250) provides tools to determine the
geometric relationships between atoms in the Workspace, and other geometry-dependent prop-
erties, and display them in the Workspace. These tools are contained in four tabs—Distances,
Angles, Dihedrals, and 1H NMR Coupling. 

The Non-Bonded Interactions panel (see Figure 10.2 on page 251) provides tools for displaying
hydrogen bonds, halogen bonds, contacts, and pi interactions between atoms that are not
directly bonded. Nonbonded interactions are considered measurements even though no
measurement is explicitly made, because there are specific value ranges of atom distances and
angles that must be satisfied.
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To open the Measurements panel at a particular tab, choose the tab name from the Measure-

ments submenu of the Tools menu. This panel is a dockable panel. Measurements can also be
made from the Labels toolbar. To open the Non-Bonded Interactions panel, use the Tools menu.

Settings that affect the display of measurements and nonbonded interactions can be made in
the Preferences panel (see Section 14.7 on page 361 and Section 14.8 on page 362).

10.2.1 Measuring Distances, Angles, Dihedrals, and NMR Coupling

The controls for Distances, Angles, Dihedrals, and 1H NMR Coupling are very similar, as are
the actual measurement procedures for these quantities. To measure a distance, you need to
specify only two atoms or one bond, for an angle you must specify three atoms or two bonds,
and for dihedrals you must specify four atoms or three bonds.

Figure 10.1. The Dihedrals tab of the Measurements panel.

To select atoms for measurement, select the Add mode, then choose Atoms or Bonds from the
Pick option menu in the Define atoms for measurement section, and select the atoms or bonds
in the Workspace. When you have selected the requisite number of atoms, the measurement is
made and entered into the measurement list. If Markers is selected, a dashed line indicating the
atom locations and the numerical value obtained from the measurement is displayed in the
Workspace. Distances are marked in purple, angles in green, and dihedrals in red, but you can
change the color by clicking Edit and choosing a new color in the color selector.

Once you have defined atoms for a measurement, those atoms remain defined until you delete
the atom set or remove the structure from the Workspace. If you only temporarily want to
undisplay the results of your measurements, deselect Markers. However, if you no longer need
the measurement value itself, you can remove it by selecting the corresponding list item and
clicking Delete. To delete all of the atom sets currently defined for a particular type of
measurement, click Delete All. 
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You can make measurements with the Measure toolbar button. 

To make a measurement, choose Distance, Angle, Dihedral, or 1H NMR Coupling from the
button menu, then click the atoms in the Workspace. The measurement is made, and any
options that are set in the Measurements panel are applied: for example, if Create property for

selected entries is selected, the property is created. 

10.2.2 Displaying Nonbonded Interactions

Nonbonded interactions, such as hydrogen bonds, halogen bonds, contacts, pi-pi stacking
interactions, and pi-cation interactions, can be displayed using the Non-Bonded Interactions
panel, which you can open with any of three items on the tools menu: H-Bonds and Halogen

Bonds, Contacts, and Pi Interactions. (Hydrogen and halogen “bonds” are considered
nonbonded interactions, as they are not covalent bonds.)

Figure 10.2. The Non-Bonded Interactions panel.
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To mark any of the three main types of interactions in the Workspace, select the Display option
in the section for that interaction type. To choose which interactions of the three types you wan
to display, select the option for that interaction. The color of the markers can be changed by
clicking the color button and choosing a new color in the color selector that opens.

The criteria for defining hydrogen bonds or contacts can be changed in the Preferences panel—
see Section 14.8.1 on page 362. 

All nonbonded interactions that are found within or between the specified atom sets are
displayed. You can choose these atom sets from the option menu in the section for each inter-
action type. The predefined sets are Ligand-receptor, which displays interactions between any
ligand and any receptor in the Workspace; Intra-ligand, which displays interactions within any
ligand in the Workspace, and All, which displays all interactions for all the Workspace atoms.

You can also choose Other to define the atom sets for the interactions. The Edit interaction
Definition dialog box opens, and an Edit button is placed next to the option menu in the Non-

Bonded Interactions panel. To define atom sets, use the atom selection tools—see Section 6.3
on page 121 for a description of these tools. If you define only Atom set 1, the interactions are
displayed within that set. If you define both Atom set 1 and Atom set 2, the interactions are
displayed between the two sets.

You can also display interactions from the Measurements toolbar. There are three buttons, one
for each interaction type. The buttons have menus that offer the same choices for display and
atom set definition as in the panel (and are kept in sync). 

10.2.3 Displaying H-H NMR Coupling Constants

NMR spin-spin coupling constants can be estimated for vicinial hydrogen atoms using a modi-
fied Karplus-type calculation (Haasnoot et al. Tetrahedron 1980, 36, 2783). To display the esti-
mated coupling constants, you must select two hydrogen atoms that are bonded to two carbon
atoms, and these carbon atoms must be bonded to each other. The controls are the same as for
distance measurements. You can also display coupling constants from the toolbar, using the
Measurements button. 
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10.2.4 Storing the Results of Measurements

You can include measurements as properties in the Project Table, and you can export measure-
ments to a tab-delimited or comma-delimited file. 

To create properties for measurements, select Create property for selected entries before you
define the measurements. The properties are added to the selected entries in the Project Table.
Each distance, angle, or dihedral becomes a separate property, and is labeled with the name
Distance, Angle, or Dihedral and the atom numbers that define the geometric quantity. 

To create properties for nonbonded interactions, click Create Property in the Non-Bonded

Interactions panel. A dialog box opens, in which you can choose the type of interaction to
create properties for. The properties are the number of interactions of each type.

Each tab in the Measurements panel has a Write button, which allows you to write a file
containing the measurements. The Write button opens a panel in which you can specify a
delimiter for the file and a file name. If you specify a name or a relative path in the File text
box, the file is written relative to the Maestro working directory. If you click Write To, a dialog
box is displayed in which you can navigate to the desired directory and select a file or enter a
file name.

The file consists of a header line, a blank line, then lines containing the data, one line for each
measurement. The data written is as follows:

• For distances and angles, the atom numbers are listed, followed by the measurement
value. 

• For dihedrals, the residue number is listed first, then a label that consists of the element
and atom number for each atom, separated by hyphens, then the atom numbers, then the
dihedral angle. 

• For hydrogen bonds, the hydrogen atom is listed first, as element(atom#), followed by the
acceptor atom in the same format, then the A-H distance, the D-H-A (donor heavy atom–
donor hydrogen–acceptor) angle, and the H-A-B (donor hydrogen–acceptor–atom
attached to the acceptor) angle. The header also lists the current criteria for H-bond
acceptance.

• For contacts, the two atoms are listed first in the format element(atom#), followed by the
distance, the contact cutoff ratio, and the type (Good, Bad, or Ugly). 
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10.2.5 Defining Dummy Atoms for Measurements

Dummy atoms can be useful for making measurements. For example, you can measure the
distance between the centroids of two ring systems by placing dummy atoms at the centroids.
You can place dummy atoms in two ways:

1. Use the Centroid panel to define a centroid atom.

A dummy atom is placed at the mean position of the picked atoms. 

2. Use the Draw button on the Build toolbar to place an atom in the Workspace, then retype it
with the appropriate MacroModel atom type.

Several kinds of dummy atoms are defined in the Atom Type (Macromodel) list in the
Atom Properties tab of the Build panel. If you attach the dummy atom to your structure,
you can adjust its position using the Adjust panel.

10.2.6 Positioning and Formatting Measurement Labels

The formatting and the position of the text label that displays the measurement values can be
changed. The number of decimal places, the color, and the font used are set as preferences, in
the Measurements tab of the Preferences panel—see Section 14.7 on page 361. The font size
can also be adjusted with the font buttons on the Labels toolbar.

The position of each label can be adjusted by dragging the label to its desired location.

10.3 Superimposing and Aligning Structures

If you want to determine the similarity of structures such as a set of conformers or a family of
ligands docked by Glide, you can use two tools on the Tools menu: Superposition, and Flexible

Ligand Alignment. There is also a Phase command-line utility, rmsdcalc, that can calculate and
minimize the RMSD of a set of structures with respect to a reference structure. 

Protein structures can be aligned with the protein structure alignment program, which has two
panels for performing the alignment: Align Binding Sites, and Protein Structure Alignment. The
second of these is the more general tool. 
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10.3.1 The Superposition Panel

You can use the Superposition panel to rigidly superimpose a set of structures and evaluate the
differences in the atom positions. Each structure must be in a separate project entry. To open
the Superposition panel, choose Superposition from the Tools menu.

The atoms are aligned to the first entry in the Project Table that is being used in the superposi-
tion (the reference entry). After superimposing atoms, the results of the operation are displayed
in the RMSD text box near the bottom of the panel. The results include the molecule numbers,
the RMS deviation of the atoms from those of the first structure, and the maximum difference
between superimposed atom positions. The results accumulate as you perform superpositions,
so you can click Clear to clear them.

There are two choices for the entries that are used for the superposition: the included entries
(those in the Workspace), or the selected entries (those selected in the Project table). This
choice is available under Entries to superimpose. If you choose Selected entries, you must
have at least one entry displayed in the Workspace to be able to pick atoms for superposition. 

Figure 10.3. The Superposition panel, showing the Atom Pairs and the SMARTS tabs.
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There are four choices for the method of superposition, displayed in four tabs:

• Atom pairs—To compare two structures, you can select the atoms to superimpose in each
structure in pairs. To define the atom pairs, select Pick atom pairs, then pick the atom
pairs. You must pick one atom from each entry, and you must pick the first atom from the
same entry each time. The atom pairs are displayed in the Superimpose by atom pairs text
box as you pick them. If Show markers is selected, the atom pairs are connected by
dashed lines. Once you have picked the first pair, Superimpose Atom Pairs, Delete, and
Delete All are activated. If you need to delete a pair, select the pair in the list and click
Delete. To delete all pairs, click Delete All. After all the atom pairs are selected, click
Superimpose Atom Pairs to superimpose the two structures. If you picked only one pair, a
simple translation is done to superimpose the atoms; if you picked two pairs, the vectors
between the two picked atoms in the second structure is superimposed on that of the first.
Otherwise the superposition is performed to minimize the RMSD for the atom pairs.

• ASL—To superimpose the displayed or selected structures based on all the atoms in the
structures, click All in the ASL tab. The superposition is done using the atom numbers.
This option is useful if each entry has the same number of atoms and is numbered the
same way, which usually requires that the entries be conformers. When you click All, the
superposition is done with the maximum use of local symmetry. You can also type all in
the text box, or make a selection from the Atom Selection button, but the superposition
does not use symmetry in this case. 

If the structures you want to compare are not conformers, or if you only want to compare
part of the structure, you can select the atoms to superimpose by making a selection in the
Workspace and clicking Selection, or by clicking Select and using the Atom Selection

dialog box to select the atoms, or by entering the ASL expression in the text box. For
example, to use only carbon atoms for the superposition operation, type atom.e C and
press ENTER. For more information on the Atom Specification Language, see the Mae-
stro Command Reference Manual.

• SMARTS—To superimpose atoms defined by a SMARTS pattern, you can enter the pat-
tern in the Superimpose by SMARTS text box, or you can create a SMARTS pattern from
the atoms that are selected in the Workspace. This method is useful if you want to super-
impose structures in which the atom numbering of key parts of the molecule is different,
such as conformers that do not have the same atom numbering.

To select the Workspace atoms and create a SMARTS pattern from them, first use the
Select atoms toolbar button to select the atoms. Once you have selected the desired
atoms, click Get From Selection. The SMARTS pattern corresponding to the selected
atoms is entered in the Superimpose by SMARTS text box. You can set preferences for
some of the notational elements in the SMARTS pattern—see Section 14.15 on page 382.
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• C-alpha—To superimpose proteins by their alpha carbon atoms, click Choose to choose
the entry that you want to superimpose to, then click Superimpose. The entry you choose
must be one of the entries you are superimposing. This tab simply uses a particular choice
of ASL to do the superposition, but provides a convenient way of superimposing proteins
without regard to residue identity. It is mainly useful for similar proteins, such as mutants
of a parent protein. See Section 10.3.4 on page 259 for more protein alignment tools.

The default action when superimposing structures is to apply a transformation to the entries,
then calculate the RMS difference in coordinates. If you want to preserve the coordinates of the
superimposed structures, select Calculate ‘in place’ (no transformation). The RMS difference is
then calculated without moving the structures. This is a convenient way of obtaining RMS
differences for ligand poses in a receptor, for example. 

If you do not use the calculate in place option, you can separate the superimposed entries by
choosing Edit → Undo. 

You can store the RMS deviation as a property for each entry that was superimposed. To create
a property, select Create RMSD property before you perform the superposition. The property is
labeled RMSD entry-ID or RMSD In Place entry-ID, depending on how you performed the
superposition. The reference entry has a value of zero for this property. The reference entry ID
is used for entry-ID in the label. If you change the details of the superposition but do not
change the reference entry, the property values are replaced. You can always rename the prop-
erty if you want to keep it and perform other superpositions with the same reference entry. See
Section 9.11.9 on page 237 for information on renaming properties.

10.3.2 The Flexible Ligand Alignment Panel

The Flexible Ligand Alignment panel allows you to perform a flexible alignment of the entries
that are selected in the Project Table, in which dihedral angles are varied but bond lengths and
angles are kept fixed. To open the Flexible Ligand Alignment panel, choose Tools → Flexible

Ligand Alignment.

The first selected entry is used as a template, and is kept as is. The remaining ligands are then
aligned to this template. The conformation of the structure changes, so you should ensure that
you copy the original structures if you want to keep them. 
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Figure 10.4. The Flexible Ligand Alignment panel.

There are two methods you can choose for the alignment:

• Flexible shape-based alignment—a ligand torsional search is performed with ConfGen
(see the ConfGen User Manual for details). The conformers generated by ConfGen are
then aligned in turn to the reference ligand, and the conformer that has the best overlap
with the reference ligand is chosen.

• Common scaffold alignment—common scaffolds among the ligands are detected, and the
ligands are aligned on the scaffold, with conformational variation of the side chains. This
option requires a Phase license, as the alignment is done with the phase_align_core
utility. Ligands with no scaffold in common with the template are not aligned. 

There are three choices for determining the common scaffold:

• Largest common Bemis-Murcko scaffold—Use the largest common scaffold that
contains complete ring systems and the linkers that join them. You can select Use

fuzzy matching to treat all non-hydrogen atoms as equivalent, but distinguish bond
types (single, double, triple, aromatic); otherwise exact matching is done.

• Maximum common substructure—Use the largest common substructure found in all
the ligands. This is more general than the Bemis-Murcko scaffold, as it is not
restricted to rings and linkers. A Canvas license is required for this option.

• SMARTS—Use the specified SMARTS pattern. You can type or paste the SMARTS
pattern into the text box, or generate a SMARTS pattern from the Workspace atom
selection by clicking Get from Selection. 

The structures must include hydrogens—implicit hydrogens are not permitted—and should be
well-minimized structures. 
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To align the ligands click Align Selected Entries. The alignment can take 1–2 seconds per entry. 

For more options to align the molecules, including the use of a flexible template, you can use
the flex_align utility, which is distributed as part of Phase (and requires a Phase license).
See Section C.9 of the Phase User Manual for details.

10.3.3 Aligning Centers of Mass

If you want to align the centers of mass of several structures (which are in separate entries),
you can do so as follows:

1. Include the entries in the Workspace

2. Select the atoms in each structure to use for calculating the center of mass. 

3. Right-click in the Workspace and choose Align Centers of Mass.

The structures are translated so that the centers of mass coincide with that of the reference
structure, which is the entry with the lowest row number in the Project Table. There is no rota-
tion of the structures to align the principal axes. 

10.3.4 Aligning Proteins

If you want to bring two or more proteins into a common frame of reference by structurally
aligning (superimposing) them, you can use the Protein Structure Alignment panel or the Align

Binding Sites panel, both of which you open from the Tools menu. For information on these
panels, see Chapter 7 of the Prime User Manual or the online help for the panel.

10.4 Using Atom Sets

Sets are groups of atoms that can be used in a variety of Maestro operations. The Sets panel is
used to define these atom groups for subsequent operations, and can be used to save and read
set definitions. Set definitions are automatically saved with the current project and are included
when the project is copied or merged with another project.

To open the Sets panel, choose Tools → Sets. This panel is dockable.
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Figure 10.5. The Sets panel.

10.4.1 Creating and Deleting Sets

To create a new set, click the New button. In the dialog box that appears, enter a name for the
set and click OK. This name is used to identify the set in later operations. The name is added to
the list at the top of the Sets panel.

To delete a set, select the set name in the set list and click Delete.

10.4.2 Selecting Atoms for a Set

To define the atoms that make up a set, select the set from the set list, then use the tools in the
Atoms For Set section to select the atoms. You can pick the atoms using the picking tools, enter
an ASL expression in the text box, or click the Atom Selection button to select predefined atom
groups or open the Atom Selection dialog box. The Atom Selection dialog box has a Create Set

button, which you can use to create a set at any time, not just from the Sets panel. You can also
select sets in the Atom Selection dialog box and perform logical operations on them to
construct a new set.

If you select Markers, the atoms in the set are marked with green markers. If the markers
obscure part of the structure that you want to see, you can move them slightly by selecting
Apply marker offset. This option is selected by default. 

For more information on ASL, see the Maestro Command Reference Manual, Chapter 3. For
more information on the Atom Selection dialog box, see Section 6.5 on page 125. 
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10.4.3 Reading and Writing Sets

You can save set definitions to disk for use with multiple projects. Click Write to open the Write
Set Files panel. In this panel, navigate to the directory in which you wish to save the set defini-
tions, and enter a name for your sets definition file. The extension .set is automatically
appended to the file name. Click Write to save the file and dismiss the panel. 

To read an existing sets definition file, click Read in the Sets panel, then navigate to the
desired directory and select the file in the Read Set Files panel, and click Read.

10.4.4 Selecting Atoms in the Workspace that Match a Set

You can use the sets that you have defined to select atoms in the Workspace. Select the set you
want to apply to the Workspace in the sets list, then click one of the buttons in the Workspace

selection section:

• Replace—Replace the current Workspace selection with the selection of atoms that
match the set. 

• Add—Add the atoms that match the current set to the Workspace selection.

• Subtract—Remove any atoms that match the current set from the Workspace selection.

10.5 Ligand Analysis Tools

The Tools menu contains several ligand-related tools. This section describes two tools that can
be used to analyze ligands in terms of a scaffold, to which side chains have been added, and
examine properties of the ligands based on this analysis.

10.5.1 R-Group Analysis

The R-group analysis tool analyzes properties of a set of ligands in terms of a common scaf-
fold, or core, and its side chains, or attachments, which are the R groups. The analysis is repre-
sented in terms of the set of R groups at each attachment site. A full description of this tool is
given in the document R-Group Analysis.
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10.5.2 Scaffold Decomposition

One way of finding common structural features in a set of structures is to decompose each
structure into a set of scaffolds, then make a list for each scaffold of the structures that contain
that scaffold. You can perform this scaffold decomposition in the Scaffold Decomposition

panel, which you open from the Tools menu.

Figure 10.6. The Scaffold Decomposition panel.

To run a scaffold decomposition, select Analyze structures from and choose the source of struc-
tures from the option menu. If you choose a file, specify the file name or click Browse to locate
the file. 

The decomposition is done by first removing side chains from all ring systems, to define the
largest scaffold in the structure. This structure is then split into all possible subscaffolds by
breaking bonds and removing linkers between rings, other than those in fused rings. The list of
scaffolds is collated, and then for each scaffold, the structures that contain that scaffold are
located and added to a list. 

When finding the structures that contain a scaffold, you can choose to match scaffolds to a
fused ring system in a structure that contains the scaffold. This is called an “embedded match”,
and you can allow them by selecting Allow embedded matches. For example, if the list of scaf-
folds contains imidazole and benzimidazole, a structure that contains benzimidazole is
included in the list of structures that contain the imidazole scaffold, if embedded matches are
allowed. Identifying embedded matches takes substantially more time than not doing so. 

If you want to view the results as soon as the job finishes, select Wait for results. Otherwise,
you can view the results at a later time by selecting Restore results from previous run,
supplying the file name for that run, jobname_scaffolds.dat, and clicking Restore. In
either case, the Scaffold Decomposition of jobname panel opens.
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Figure 10.7. The Scaffold Decomposition of jobname panel.

The Scaffold Decomposition of jobname panel shows the 2D structures of the scaffolds in a
table. The scaffolds can be classified by the number of rings in each scaffold, or by the number
of ring systems. The scaffolds for a given classification are shown on the same table row. You
can select scaffolds in the table, and limit the display to show only those scaffolds. Each time
you limit the display (or remove the limits), that view of the table is stored, and you can use the
arrow buttons to step through these views. If you want to see all the subscaffolds or superscaf-
folds of a particular scaffold, right-click in its table cell and choose the appropriate command.

The table also shows the property distribution of the structures that contain each scaffold, for a
property that you can choose from the Property option menu. The average, standard deviation,
minimum, and maximum values of the property are displayed to the right of the option menu.
The property distribution is displayed for each scaffold as a “stick spectrum” in a bar that
represents the full range of the property. For each structure there is a vertical line at the prop-
erty value for that structure. The average property value is marked, and the region outside one
standard deviation from the average is colored if it contains vertical lines for property values. 
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You can export the scaffolds to a structure file. The scaffolds are stored internally as canonical
SMILES strings, so if you choose Maestro or SD format for the file, they are exported as 2D
structures without hydrogens, except where the hydrogens are part of the SMILES string. 

Figure 10.8. The Source Structures panel.

If you want to see the source structures for a set of scaffolds, select them in the table and click
Show Source Structures. The Source Structures panel opens, and displays the structures for
those scaffolds, arranged in rows with the same classification as for the scaffolds, and
including the property distribution display. You can export selected structures or all structures
to a file. You can run an R-group analysis on the selected structures or on all structures in the
panel. If the structures have more than one scaffold in common, you are prompted to choose
the scaffold you want to use for R-group analysis.
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10.6 Protein Tools

Maestro has tools for a number of operations on proteins: aligning and splicing protein struc-
tures, assigning secondary structures, reporting on protein properties, generating Ramachan-
dran plots, and generating interaction energies for rotamers and ligand torsions in a complex. 

10.6.1 Assigning Protein Secondary Structure

The Assign Secondary Structure command on the Tools menu provides a way of assigning
secondary structure labels to a protein. The assignment occurs in two stages. First, all inter-
backbone hydrogen bonds are identified. Second, a search is made for hydrogen-bonding
patterns representing helices and strands. The assignment is used for the display of ribbons, the
use of some color schemes, and for the Workspace sequence viewer.

10.6.2 Viewing Reports on Protein Properties

Reports on various properties of the protein that is in the Workspace are presented in the
Protein Reports panel, which you open by choosing Tools → Protein Reports. The Display
option menu lists the various protein properties for which reports can be generated. When you
choose an item from the menu, the table is updated with the relevant report.

Figure 10.9. The Protein Reports panel.

The table displays the label for each residue or residue pair in the report in the first column,
and the report data in the remaining columns. Clicking a row marks the residue or the relevant
part of the residue in the Workspace, and zooms in on the residue. Clicking a column heading
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sorts the table by the data in the column. Repeated clicking cycles through ascending order,
descending order, and original order.

G-factors are calculated by binning the dihedral angles from a collection of high-resolution
structures into 10-degree ranges, and calculating the probability of a pair of angles lying in a
given range. The G-factor is the logarithm of this probability. If there are no values in a given
range, the G-factor is reported as “disallowed”. 

Table 10.1. Display menu items in the Protein Reports panel

Item Description

Steric Clashes Ratio of the interatomic distances to the sum of the atomic (van der 
Waals) radii from the force field. The threshold is 0.85. 

Bond Length Deviations Deviation from the ideal value derived from Engh and Huber. The 
RMSD is reported at the bottom.

Bond Angle Deviations Deviation from the ideal value derived from Engh and Huber. The 
RMSD is reported at the bottom.

Backbone Dihedrals G-factors for backbone dihedrals (see below for definition), along with 
dihedral angles. Less negative (closer to zero) means that the combina-
tion of angles is more probable. 

Sidechain Dihedrals G-factors for side-chain dihedrals (see below for definition), along with 
dihedral angles. Less negative (closer to zero) means that the combina-
tion of angles is more probable. 

G-Factor Summary G-factors for backbone dihedrals, side-chain dihedrals, and the sum of 
the two. 

Average B-Factors Average B-factors (temperature factors) for the backbone and the side 
chain for each residue, and their standard deviations. 

Gamma-Atom B-Factor B-factor for the gamma atom in each residue. 

Peptide Planarity RMSD of the atoms in the peptide linkage from the plane that minimizes 
the RMSD. 

Sidechain Planarity For side chains that have nominally planar groups, RMSD of the atoms 
in the planar groups from the plane that minimizes the RMSD. 

Improper Torsions For side chain atoms that are nominally planar, RMSD of the improper 
torsion for these atoms. 

C-alpha Stereochemistry Stereochemistry of the C-alpha atoms. 

Missing Atoms  Residues for which atoms are missing from the structure. 
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10.6.3 Protein Reliability Reports

The Protein Reliability Report panel displays a simple graphical representation of various
metrics that indicate the reliability or quality of a protein structure, and in particular, X-ray
structures of proteins. To open the panel, choose Tools → Protein Reliability Report. 

Figure 10.10. The Protein Reliability Report panel.

To analyze a protein for reliability, you must first display it in the Workspace. If a report has
already been generated for a protein, and it is displayed in the Workspace, the report is
displayed immediately. 

Next, choose which part of the protein to analyze, from the Analyze option menu: 

• Entire structure—Analyze the entire structure that is in the Workspace.

• Region around ligand—Analyze the region that includes the ligand and all residues that
have atoms within a specified distance of the ligand. 
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When you choose this option, a text box, a Pick ligand option, and a Shell text box are dis-
played to the left of the menu. To identify the ligand, select the Pick ligand option and
pick a ligand atom in the Workspace. The identity of the ligand is displayed in the text
box. To set the distance, use the Shell text box.The default distance is 10 Å. 

• Custom region—Analyze the region that includes a custom selection of residues. 

When you choose this option, a text box and a Select button are displayed to the left of
the menu. To select the residues for the region, click Select and use the tools in the Atom

Selection dialog box. The ASL expression for these residues is displayed in the text box.

If you want to include X-ray diffraction data in the analysis, select Use diffraction data and
click Browse. A file selector opens, in which you can locate and select the file that contains the
diffraction data. The file name is displayed in the text box. You can also type the full file name
into the text box. The X-ray data are used to calculate real-space R-factors and correlation
coefficients. 

When you have finished defining the input and the analysis region, click Run to generate the
report. After the job finishes, the results are displayed in the display area. 

This area displays a visual representation of the metrics for protein reliability. For each metric
a circle is drawn that represents the quality of that metric. It is colored red if the deviation from
acceptable values is larger than a threshold, and green if the deviation is smaller. The radius of
the circle indicates the magnitude of the metric. Circles are still drawn for metrics that were not
calculated, but they are not colored. For large deviations, the circles can overlap other circles.
The intention of the display is to provide a quick means of determining if the protein structure
is reliable, and which aspects of the structure deviate from acceptable values.

The metrics that are used to assess the quality of the protein structure are described in
Table 10.2, with the threshold values for marking a problem. Some metrics require X-ray
reflection data for their evaluation. Some apply to the entire protein, others apply to the region
that is analyzed. 

Table 10.2. Protein reliability metrics.

Metric Description Cutoff

Average B-factors Number of residues in the analyzed region whose average B-factor 
is larger than 100. 

100

Backbone dihedrals Number of abnormal backbone dihedrals in the analyzed region 
(those in the disallowed region of a Ramachandran plot). 

1

Binding site pack-
ing 

Number of residues in sequences of three or more consecutive resi-
dues in the binding site that have Z-scores less than • 4.0. 

0
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Binding site RSCC Real-space correlation coefficient for the binding site. Can help to 
identify cases where the binding site is poorly built. 

0.9

Bond angle 
deviations 

Number of bond angles in the analyzed region that deviate by more 
than 4 standard deviations from standard bond angles. 

1

Bond length 
deviations 

Number of bond lengths in the analyzed region that deviate by more 
than 4 standard deviations from standard bond lengths. 

1

Buried unsatisfied 
acceptor 

Number of buried H-bond acceptors in the analyzed region that do 
not have hydrogen bonds. Most acceptors buried in a protein are part 
of a hydrogen-bonding network. 

1

Buried unsatisfied 
donor 

Number of buried H-bond donors in the analyzed region that do not 
have hydrogen bonds. Most donors buried in a protein are part of a 
hydrogen-bonding network 

1

Improper torsions Number of improper torsions in the analyzed region that exceed 10°. 0

Isolated water 
clusters 

Number of water clusters that are not hydrogen-bonded to anything 
else. 

0

Ligand RSCC Real-space correlation coefficient for the ligand. Can help to iden-
tify cases where the ligand is poorly built or the density does not 
support ligand placement. 

0.9

Missing atoms Number of atoms missing from the analyzed region. 0

Missing loops Number of loops missing from the entire structure. 0

Non-binding-site 
packing 

Number of residues that are not in the binding site in which the Z-
scores are less than • 4.0 in sequences of three or more residues. 

0

PDB resolution X-ray structure resolution. 2.5 Å

Peptide planarity Number of peptide dihedrals that are greater than 20°. 0

Protein packing Average packing environment of the protein, measured by the aver-
age Z-score of all residues in the protein. A problem is flagged if the 
Z-score is more negative than the threshold. High-quality structures 
have a uniform distribution of atoms in the core of the protein.

• 1.2

The presence of holes in the core can be an indicator of poorly built 
side chains or backbone, or incorrect threading of the sequence 
through the density. 

Side-chain dihe-
drals 

Number of dihedral angles in the side chains that are in the disal-
lowed region of a Ramachandran plot. 

0

Table 10.2. Protein reliability metrics. (Continued)

Metric Description Cutoff
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The results of the analysis can be displayed for each chain separately, or for the entire protein.
Use the Display results for chain option menu to select the chain or the entire protein (All). 

If you click on the title of a metric, the values for that metric are displayed in a table, to the
right. For metrics whose values lie outside acceptable ranges, the unacceptable values are
displayed in the table. The section is blank initially, and is cleared if you choose a metric
whose values are all acceptable. 

Below the display area an informational message on metrics whose values lie outside the
acceptable range is shown, when you click on the metric in the display area. It specifies the
cutoff for acceptable values, and suggests possible reasons that the values might lie outside the
range. 

You can save a copy of the report in a text file (.txt), by clicking Save Report. The report lists
metrics and their values. You can also save an image of the display area to a file, in PNG,
JPEG, or TIFF format. The Save Image button opens a file selector, in which you can choose
the image format and save the file. 

10.6.4 Ramachandran Plots

The Ramachandran Plot panel displays a plot of the dihedral angles φ and ψ for each residue in
the protein that is displayed in the Workspace. To open the panel, choose Tools → Ramachan-

dran Plot. This panel is useful for identifying residues that fall in disallowed regions of protein
dihedrals, so that adjustments can be made to the protein geometry. After adjusting the geom-
etry, click Refresh to redisplay the plot. You can only display a plot for one entry at a time.

The plot area displays a plot of protein dihedrals for all residues in the protein. The plot is
organized as follows:

• Glycine is plotted as triangles, proline is plotted as squares, all other residues are plotted
as circles.

• The orange regions are the “favored” regions, the yellow regions are the “allowed”
regions, and the white regions are the “disallowed” regions.

Side-chain planarity Number of side chains that are expected to be planar whose RMSD 
to the ideal plane exceeds 0.5Å. 

0

Steric clashes Number of abnormally short interatomic distances. 1

Waters with no HB 
partners 

Number of waters that do not form hydrogen bonds at all. 0

Table 10.2. Protein reliability metrics. (Continued)

Metric Description Cutoff
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The following actions can be performed on the plot:

• Clicking on a point zooms the Workspace image in to that residue. The point is displayed
as an outline instead of solid black. The residue information is displayed at the top of the
panel and the residue is highlighted in the Workspace and the sequence viewer. 

• Pausing the pointer over a point displays information for that residue at the top of the
panel, and highlights the residue in the Workspace and the sequence viewer. When you
move the pointer off the point, the display returns to that of the selected point, if there is
one.

The size of the points on the plot can be adjusted using the Point size slider.

Figure 10.11. The Ramachandran Plot panel.
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The panel has a toolbar that you can use to configure the plot or to save an image of the plot.
The toolbar buttons are described below.

10.6.5 Energy Profiles of Torsional and Rotamer States

The Rapid Torsion Scan panel enables you to scan the orientations around a ligand bond or
rotamer states of a selected protein residue and see a breakdown of the energy for each orienta-
tion or state. 

To open the Rapid Torsion Scan panel, choose Tools → Rapid Torsion Scan.

The panel has two options for selecting the torsional states to sample:

• Pick ligand bond to rotate—Select this option and pick a bond in the Workspace to define
the bond to rotate around. You should pick the bond nearer to the end of the bond that is

Reset 
Reset the plot to the original pan and zoom settings.

Back 
Display the previous view of the plot in the view history

Next 
Display the next view of the plot in the view history

Pan/zoom 
Pan the plot by dragging with the left mouse button, zoom by dragging with the right mouse 
button. 

Zoom to rectangle 
Drag out a rectangle on the plot to zoom in to that rectangle.

Configure subplots 
Configure the margins and spacing of each plot in the panel.

Edit axis and curve parameters 
Make settings for the title, range, labeling, and scale of the axes; the color, style, and width of 
lines; and the color, style, and size of markers.

Save image
Save an image of the plot to file. Opens a file selector in which you can browse to a location, 
select the image format, and name the image.

Copy to clipboard 
Copy an image of the plot to the clipboard. You can then paste it into another application. This 
button is only available in some panels. 
Schrödinger Software Release 2015-2 



Chapter 10: Tools
rotated. The bond is scanned by default at 30° intervals, but you can adjust the interval
with the Angle increment slider, which sets the angle interval to integer divisors of 360°
from 1° to 30°. The number of states generated is reported in the Number of rotamers text
box. If you subsequently change the angle increment, click Recalculate to regenerate the
rotamer states.

• Pick standard protein residue to sample—Select this option and pick a protein residue for
which you want to see energetic information on the rotamer states. 

Figure 10.12. The Rapid Torsion Scan panel.

When you pick the ligand bond or the residue, a calculation with the OPLS_2005 force field is
performed to evaluate the interaction energy for each rotamer or torsional angle, and the results
are presented in the Rotamer states table. As well as the total energy, the contributions from
the electrostatic component and van der Waals plus internal components are presented.
Rotamer states are identified by their probability, and the bond or residue is identified above
the table. The original rotamer state does not have an associated probability, because the prob-
ability is derived from a data set of rotamer states and this state might not be in the data set.
The table can be sorted by clicking in a column header.

If you select Select state with lowest energy, the lowest energy state is selected in the table and
displayed in the Workspace. Selecting a row in the table also displays the state in the Work-
space. The structure in the Workspace is changed, and so the corresponding project entry will
also be changed. The original state is the first state in the table, which you can select to return
to the initial state. 
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To see a plot of the rotamer states as a function of the angle (for ligands) or rotamer state
number (for protein residues), click Plot, which opens the 1D Plot panel with a display of the
plot. For more information on this panel, see Section 11.2 on page 292.

10.6.6 Ligand Interaction Diagrams

The Ligand Interaction Diagram panel allows you to generate and display a 2D diagram of the
interactions between a ligand and various protein residues.

To open the Ligand Interaction Diagram panel, choose Tools → Ligand Interaction Diagram, or
click the Lig. Int. button on the Project toolbar.

The diagram is generated automatically from the structures in the Workspace. If you have more
than one ligand in the Workspace, the first is used, and you can choose any of the other ligands
from the Ligand option menu. 

Figure 10.13. The Ligand Interaction Diagram panel.
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The orientation of the ligand can be chosen to match the Workspace orientation, or to give the
best 2D representation. To match the Workspace orientation, select Sync with 3D. When you
rotate the structure in the Workspace, the diagram is redrawn to match the Workspace orienta-
tion. To give the best 2D orientation, click the Best 2D View button on the toolbar. 

You can also change the orientation by using the toolbar buttons. These perform the same func-
tions as those on the 2D Sketcher toolbar—see Section 5.5.2 on page 90 for details.

The set of residues that appear in the diagram is determined by the cutoff specified in the Cutoff

text box. All residues that have any atom within the specified distance of any ligand atom are
included in the diagram. If you change this value, the diagram is regenerated with the new set. 

In the diagram, residues are represented as colored spheres, labeled with the residue name and
residue number. The colors indicate the residue (or species) type:

• red—acidic (Asp, Glu)
• green—hydrophobic (Ala, Val, Ile, Leu, Tyr, Phe, Trp, Met, Cys, Pro)
• purple—basic (Hip, Lys, Arg)
• blue—polar (Ser, Thr, Gln, Asn, His, Hie, Hid)
• light gray—other (Gly, water)
• darker gray—metal atoms

Interactions with the protein are marked with lines between ligand atoms and protein residues:

• Solid pink—H-bonds to the protein backbone
• Dotted pink—H-bonds to protein side chains
• Green—pi-pi stacking interactions
• Orange—pi-cation interactions

Ligand atoms that are exposed to solvent are marked with gray spheres. The protein “pocket”
is displayed with a line around the ligand, colored with the color of the nearest protein residue.
The gap in the line shows the opening of the pocket.

The details of the representation can be displayed in the panel, by choosing View → LID

Legend. Likewise, the title of the ligand entry can be displayed by choosing View → Scene

Title. You can control aspects of the formatting, such as the sphere radii, the font size, the line
widths, residue by choosing Edit → Preferences, and making settings in the panel that opens.

If you want to save the diagram in an image file, choose File → Save Screenshot, or press
CTRL+ALT+P (P). A file selector opens, so you can browse to a location and name the file.
The image can be saved in PNG or EPS format, and you can specify the size of the image in
pixels or the size and resolution of the document in inches and pixels/inch (dpi). 
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You can also generate diagrams from the command line as an image file—see Section 4.4 of
the General Utilities manual.

10.6.7 Protein Splicing

The Protein Splicing tool can be used to take a segment of one protein (the source) and replace
a segment of another protein with the source segment. The proteins are aligned temporarily if
they are not already aligned, so that the segment can be simply transferred between the source
and the destination. The regions around the attachment points are minimized, but otherwise no
change is made to the spliced segment. This is intended to be a quick means of transferring
residues from one protein to another.

Figure 10.14. The Protein Splicing panel.

Prior to splicing a segment of a protein into another protein, you may want to perform a struc-
tural alignment of the two proteins, so that the termini of the desired source and destination
segments are aligned to each other. This gives you more control over the alignment than the
automatic global alignment done as part of the procedure.

Once the source segment is defined, possible attachment points on the (aligned) destination
protein are identified. The attachment atoms are the carbonyl carbon on the C-terminus end
and the nitrogen on the N-terminus end. Any attachment atoms in the destination that are
within 8 Å of the attachment atoms of the source segment are considered as potential attach-
ment points. Of these, the default is selected to preserve the residue numbering if possible,
otherwise the attachment atom that forms the shortest peptide bond with the segment is taken.
The preservation of the numbering assumes that the splicing is being done between two
different structures of the same (or similar) protein, with the same residue numbering.

The splicing is done by temporarily aligning the source protein to the destination if necessary;
extracting the source segment and deleting the destination segment (between the attachment
points); assigning the destination chain ID to the spliced segment and renumbering the residues
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to continue from the N-terminal attachment residue numbering. If a duplicate residue number
is found, the residue in the spliced segment is assigned a number that is higher than any found
in the destination chain. The new segment is attached at the attachment points (or point, for a
terminal attachment), and all atoms within 6 bonds of the attachment points are minimized. A
new project entry is created for the modified protein.

Apart from the minimization around the attachment points, no attempt is made to relieve strain
or clashes with the rest of the target protein. Once the splicing is done, you should run a refine-
ment on the spliced segment and its local environment.

To splice a segment of one protein (the source) into another protein (the destination):

1. Include both proteins in the Workspace.

You can include more than one protein in the Workspace, but only one protein can be
selected as the destination. You might want to do this to identify variable and conserved
regions in a set of related proteins, to guide the selection of the segment to splice.

2. If the proteins are already aligned, select Proteins are already structurally aligned to each

other.

This should be done before defining the source segment: once it is defined, the proteins
are aligned temporarily if they aren't already.

3. Select a contiguous set of residues in the source protein.

It is probably easiest to do this in the sequence viewer, which is displayed automatically
when you open the panel. If you make the selection in the Workspace, it is filled out to
entire resides. You must make sure the residues are attached in a continuous chain.

Once the residues are selected, the segment selected is reported in the top part of the
panel, and the option menus are filled in with the list of possible destination proteins and
the residues on the destination to which the splicing could be done.

4. Choose the destination protein, if you have more than two proteins in the Workspace.

5. Change the selection of the attachment residues, if necessary.

If you need to identify the residues, you should be careful not to select a residue in the
Workspace, as this will change the source segment. You can identify the residues by
using atom feedback: pause the pointer over an atom in the Workspace, and its identity,
including the residue number, is displayed in the status bar. 

If you want to splice the tail of a protein onto another protein, you can choose None as an
attachment residue on the C- or the N-terminal end. You should only do this for one
attachment point: setting both to None results in an error message.
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6. Click Splice.

The segment is spliced into the destination protein, and the new protein is added to the project
as a new entry and replaces the Workspace. The panel then closes.

10.6.8 The Multiple Sequence Viewer

The Multiple Sequence Viewer panel is an alignment, visualization, and manipulation toolkit
for multiple sequences. It is described in a separate document, Multiple Sequence Viewer.

To open the Multiple Sequence Viewer panel, choose Tools → Multiple Sequence Viewer.

10.7 Assigning Bond Orders and Partial Charges

The Assign Bond Orders command on the Tools menu assigns bond orders to structures that do
not have the correct bond orders, as follows: 

• If you have a Workspace selection that is 300 atoms or less, bond orders are assigned for
all the selected atoms. 

• If the selection has more than 300 atoms, bond orders are assigned for all residues in the
selection that do not have multiple bonds.

• If there is no selection, bond orders are assigned for all residues in the Workspace that do
not have multiple bonds.

The assignment is based on a range of factors, including connectivity, bond length, bond angles
and dihedral angles. Occasionally the bond order cannot be assigned, or is assigned incorrectly.
You should always check your structure after using this command, especially for bonds that are
unusual in any way. If you find any errors, you can correct them with the Build toolbar
buttons—see Section 5.7 on page 96. 

If you have built a structure using Draw mode in the Build panel, you should change the bond
orders manually, because the structure is unlikely to meet the criteria for bond lengths, angles
and dihedrals required for successful bond order assignment.

Assignment of bond orders is a necessary preliminary to hydrogen addition. If the bond orders
are incorrect, hydrogen addition will place too many or too few hydrogen atoms. 

The Assign Partial Charges command on the Tools menu assigns partial charges to the struc-
tures in the Workspace, based on the OPLS_2005 force field. These partial charges can be used
for many purposes, such as coloring a surface by partial charge and displaying the dipole
moment of the molecule. If the structure does not have explicit hydrogens, the partial charges
for the implicit hydrogens are added to the partial charge for the heavy atom to which they are
implicitly attached.
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10.8 Ligand Filtering

If you want to filter a set of ligands based on their properties, you can do so in the Ligand

Filtering panel. This panel allows you to set up filtering criteria for a set of structures, which are
represented as a set of conditions on Maestro properties, certain predefined feature counts, or
counts of SMARTS patterns for functional groups. When you have set up the criteria, you can
run a job to apply the criteria to the structures and return those that match or that do not match. 

Although this panel is entitled Ligand Filtering and is primarily intended for filtering ligands,
you can also use it to filter protein structures, for example by the percent_strand, percent_helix,
and percent_loop attributes.

To open the Ligand Filtering panel, choose Tools → Ligand Filtering. A brief description of the
procedure is given here, with details in the subsections below.

Figure 10.15. The Ligand Filtering panel.
Maestro 10.2 User Manual 279



Chapter 10: Tools

280
To filter a set of structures by various structural attributes:

1. Select a structure source from the Use structures from option menu. If you choose a file,
specify the file name or browse to locate it.

2. Choose how matching is defined under Ligand matches if.

3. Choose what to do with the ligands that match, using the Matching ligands options. 

4. If you want to mark the ligands that match in the output, select Set boolean property and
provide a property name.

5. Select a property, general attribute, or functional group from the lists in one of the tabs,
and construct a criterion using the text boxes and option menus.

You can define upper and lower limits on a property value by using both text boxes and
option menus and a boolean operator to connect the two limits.

6. Click Add to add the criterion to the Filtering definitions and criteria list.

7. Repeat the last two steps to add as many criteria as you like.

8. Click Start to set up and start the job.

The job runs the ligfilter utility, described in Section 2.4 of the General Utilities manual.

If you want to start again or create a new filter, click Reset, to clear the entire panel. If you
want to write the criteria file without running a job, click Write. In the dialog box that opens,
enter a name for the file, which is written to the current directory with the extension .lff.

10.8.1 Selecting a Structure Source 

The Use structures from option menu allows you to choose from three structure sources:

• Workspace—Filter the structures that are included in the Workspace. These structures are
written to an input file, by entry.

• Project Table—Filter the structures that are selected in the Project Table. These structures
are written to an input file, by entry.

• File—Filter the structures in the file specified in the Input file text box. You can click
Browse to navigate to the desired file. When you have selected or entered a file, the file is
scanned for properties to list in the Properties tab. If you want to stop this scan, click Stop

scanning. 
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10.8.2 Defining the Matching Method

There are several choices for how the matching is done. First, you can choose whether the
ligand must meet all criteria or only one criterion. This choice is made with the Ligand

matches if options:

• All criteria are satisfied—The ligand must match all criteria. This choice corresponds to
connecting each criterion by a logical AND operator.

• At least one criterion is satisfied—The ligand must match one of the criteria. This choice
corresponds to connecting each criterion by a logical OR operator.

Once you have decided how to match the criteria, you must decide whether to keep the ligands
that match, discard them, or mark them. This you can do with the Matching ligands options:

• Retain—Write the ligands that match to the output structure file. Ligands that do not
match are not written out. 

• Remove—Write the ligands that do not match to the output structure file. Ligands that
match are not written out.

• Set boolean property—Write all ligands to the output structure file, and for each ligand,
set a Boolean property that indicates whether it matched or not. 

You can name the Boolean property in the Property name text box. This name is the name
that is displayed in the Project Table. By default the name is matched, and can be filtered
with the ligfilter family of properties. The property name cannot contain spaces. When the
visible name is displayed, any underscores are replaced with spaces for display purposes.

10.8.3 Defining Matching Criteria

The center section of the panel has three tabs, for setting up criteria using different classes of
structural attributes. Each tab has the following common features:

List of structural attributes—This list contains the available structural attributes (properties,
general attributes, or functional groups). You can select a single item from this list. The
selected item is displayed in the first text box below the list, which is labeled with the structural
attribute class. In the Properties tab, there is a Show family option menu below the list. You can
use this menu to limit what is shown in the list to a single property family (e.g. QikProp). 

Criterion specification text boxes and option menus—Below the list is a set of text boxes
and option menus that you use to construct a criterion. The first text box lists the structural
attribute selected from the list. To define a condition on the structural attribute, choose a rela-
tional operator from the leftmost option menu and enter a value in the text box immediately to
the right of it. If you want to define two conditions, choose a Boolean operator (AND or OR)
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from the next option menu, then choose a relational operator from the option menu and enter a
value in the text box that are to the right of the Boolean operator. 

Add button—This button adds the criterion to the filter. The criterion is displayed in the
Filtering definitions and criteria text area. 

Below the tabs is the Filtering definitions and criteria text area, which lists the criteria from all
tabs that make up the filter, one per line. Property criteria are given in terms of their internal
names in this list, rather than the external names as they are in the Select a property list. If you
want to delete one or more criteria, select them in this text area and click Delete.

You can read an existing file of criteria by clicking Read criteria file, and navigating to the file
in the file selector that is displayed. The file has the extension .lff. The contents of this file
replaces the contents of the Filtering definitions and criteria. Once the criteria are loaded, you
can add to them, or delete them.

10.8.4 Defining New Matching Patterns

In the Functional Group Counts tab, you can define new functional groups that can be used to
match the ligands. The functional groups are defined by SMARTS patterns. Here we use a
broad definition of a functional group that encompasses any set of atoms that is defined by
some atom type and connectivity pattern. 

You can set up a new functional group in the Add Definition dialog box, which you open by
clicking New.

Each pattern that is added to the definition can either be “included” in the definition or
“excluded” from the definition. For a chemical feature to match the definition, it must match
all of the included patterns, and it must not match any of the excluded patterns. So, for
example, if you wanted to match all oxygen atoms that were not in alcohols, you could include
O, and exclude Alcohols.

To add an existing pattern to the definition, select the pattern in the list and click Include or
Exclude. The pattern name is displayed in the SMARTS expression or pattern name text box
when you select it. If you want to view the definition of an existing pattern, click View. The
SMARTS string for the pattern is displayed in a dialog box.

To add a SMARTS pattern, enter the SMARTS expression in the text box above the list, and
click Include or Exclude. You can also select atoms in the Workspace, then click Get From

Selection to add a SMARTS pattern for the selected atoms to the text box.
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Figure 10.16. The Add Definition dialog box.

When you click Include, the pattern is added to the list in the lower part of the panel, preceded
by a + sign. Likewise, when you click Exclude, the pattern is added to the list in the lower part
of the panel, preceded by a − sign. You can delete patterns from this list by selecting them and
clicking Delete, and you can clear the list by clicking Delete All.

Before you click Add to add the new definition, ensure that you have named it in the Name of

new functional group text box.

10.8.5 Eliminating Duplicate Ligands

Another task that is related to filtering is the elimination of duplicate ligands. This task can be
done in the Merge Duplicates panel, which you open with Tools → Merge Duplicates. The
elimination is done by comparing SMILES strings, and the output is either a SMILES file or a
2D SD file; in either case the output contains no 3D information other than chirality properties.
This tool is therefore most useful when you plan to prepare the structures for modeling with
LigPrep, either directly or as part of another workflow. You can neutralize and desalt the struc-
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tures in the process of merging, and you can merge property values into a string, where a given
property has a value for more than one of the duplicates. 

10.9 Minimizing Structures

For a quick minimization of a structure or part of a structure, the Tools menu offers a few
choices. The Minimize option menu provides for minimization of the selected atoms, all atoms,
or the ligand. The Structure Sculpting tool enters a mode in which you can move individual
atoms and the environment of the atom is minimized after the move. These tools are described
in more detail in Section 5.9.5 and Section 5.9.6 on page 107.

10.10 Visualization Tools

Maestro includes a range of visualization tools for various kinds of data—in addition, of
course, to the display of structures in the Workspace. These tools are listed below, with refer-
ences to the location of their descriptions. Descriptions are also given in the help. 

• Plotting. The plotting tools enable you to plot data associated with project entries. These
tools are described in Chapter 11.

• Surfaces. Maestro can generate surfaces and display surfaces generated by various com-
putational programs. Generation and display of surfaces is described in Chapter 12.

• Vibrational animation. Vibrational frequencies generated by Jaguar can be animated in
the Workspace, via the Project Table. The animation tool is described in Section 3.9.4 of
the Jaguar User Manual.

• Ramachandran plots. The tool for generating and displaying Ramachandran plots of
protein dihedrals is described in Section 10.6.4 on page 270. 

• Ligand Interaction Diagram. This tool displays a simplified representation of protein-
ligand interaction, and is described in Section 10.6.6 on page 274.

• Coordinate Scan Plots. These panels display plots of energy as a function of one or two
coordinates, and are described in Section 11.2 on page 292. MacroModel and Jaguar can
generate information for plotting in these panels. 

• Force Field Viewer. This tool displays the interactions generated from the various force-
field terms in a MacroModel calculation, and is described in Section 5.4 of the Macro-
Model User Manual.

• Trajectories. The Trajectory panel allows you to display trajectories (animated) from MD
simulations that were generated by Desmond or Impact. The viewer is described in
Section 5.1 of the Desmond User Manual.
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Maestro’s Plot facility allows you to generate scatter plots from data in the Project Table. Each
plot can consist of multiple data sets, and each data set can represent up to four properties, by
use of location, color, and plot symbol size to represent the property values. The plots interact
with the Project Table selection and inclusion, so that you can use the plot to select entries and
include them in the Workspace. Plots are stored in the project. 

For coordinate scans in one or two coordinates, such as generated by MacroModel or Jaguar,
Maestro provides special plotting capabilities, in the Plot of One-Coordinate Scan panel and
Plot of Two-Coordinate Scan panel. 

11.1 Scatter Plots

Scatter plots are generated from data in the Project Table for the selected entries. The plots are
managed in the Manage Plots panel. From this interface you can add, edit, view and delete
plots. Scatter plots can also be generated from applications such as Strike and Phase, to display
predictions against the experimental data.

11.1.1 Managing Plots

The Manage Plots panel is used to add, edit, view, and delete plots. To open the Manage Plots
panel, choose Table → Plot, or click the Plot button on the toolbar. 

This panel lists the plots that are stored in the project. You can select multiple plots in this list,
and apply the following actions to them:

• Delete—delete the selected plots.
• Show—display the plot panels for the selected plots. Double-clicking a single plot shows

that plot.
• Hide—close the plot panels for the selected plots 

To rename a plot, select it in the list, click Rename, then enter the new name in the dialog box
that opens and click OK. This is the name that appears in the title bar of the Scatter Plot panel.
You can use spaces in the name. 
Maestro 10.2 User Manual 285



Chapter 11: Plotting

286
Figure 11.1. The Manage Plots panel.

11.1.2 Creating Plots 

Plots are created from property data in the Project Table. To plot data, you must therefore have
at least one entry in the Project Table. The following instructions create a simple scatter plot of
two properties.

To create a simple scatter plot: 

1. Select the entries in the Project Table whose data you want to plot.

2. Choose Table → Plot or click the Plot button on the toolbar. 

The Manage Plots panel opens. 

3. Click New Scatter Plot. 

A new scatter plot panel opens, with a blank plotting area. 

4. Choose the property for the x axis and the y axis.

You can make the choice from the option menus, or click Select to open a property selec-
tor, in which you can restrict the list of properties by family or by filtering. 

When you have chosen properties for both axes, data points appear in the plotting area. 

From here you can continue on to make further plot settings. These settings are described in
Section 11.1.3 on page 287.

There are several other possibilities offered for creating more complex plots:

• You can represent a third property by coloring the plot symbols with a color map. To do
so, choose the property from the Color by option menu (or click Select), then choose a
map from the Color map option menu. 
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• You can represent a fourth property by the size of the plot symbols. To do so, choose the
property from the Symbol size by option menu (or click Select).

• You can add data sets to the plot by clicking New Data Set. When you do so, a new tab is
displayed with the same controls as the first tab. You can then select the properties you
want to display in the same way as you did for the first data set. To delete data sets, dis-
play the tab for the data set you want to delete, and click Delete Data Set.

Figure 11.2. A Scatter Plot panel with four properties represented.

11.1.3 Changing Plot Settings 

The settings that govern the appearance of the plot itself can be made in the tab for the data set.
Settings for the axes and the color bar can be made in the Axis Settings dialog box.

Each data set has its attribute settings in a tab on the right of the panel. These settings fall into
several classes: the properties that are represented, the plot symbols and line style used, and the
display of additional lines that are related to the data. These controls can be hidden by clicking
Hide Controls on the toolbar, and redisplayed by clicking Show Controls. 

11.1.3.1 Changing the Plotted Properties

The properties that are plotted on the two axes can be changed from the X-Axis and Y-Axis
option menus, or by clicking the corresponding Select button and choosing the property in the
property selector that is displayed. The property selector allows you to show properties from a
given property family and to filter the properties by matching a text string that can include
wildcard characters.
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Two more properties can be represented on the plot, by using the color of the plot symbols and
their size. To change the property that is represented by color, choose the property from the
Color by option menu (or click Select to use a property selector), then choose a map from the
Color map option menu. To change the property that is represented by symbol size, choose the
property from the Symbol size by option menu (or click Select).

11.1.3.2 Changing the Plot Symbols and Lines

The color of the plot symbols, their point size, and the shape of the symbol can be changed by
choosing from the Color, Size, and Symbol option menus. If you choose a property to color the
symbols by, the Color option menu is not available. Likewise, if you choose a property to map
to the symbol size, the Size option menu is not available. 

The line style, width, and color can be changed by choosing from the Style, Width, and Color

option menus to the right of the Line label. If you do not want a line connecting the points,
choose None from the Style option menu. 

To display the line of best fit, select Best fit line. The line is drawn, and the equation of the line
and the value of R2 is displayed in the text box to the right. As well as the line of best fit, you
can display the line of perfect correlation or perfect anticorrelation by selecting Diagonal line

with slope, and choosing 1 or -1 from the option menu.

11.1.3.3 Changing the Axis and Color Scale Settings

By default, the axes and color scale are labeled with the last selected property, and the axis and
color scale range and tick marks are placed automatically. The color scale shows the distribu-
tion of colors in the color map. It can be displayed by selecting Color scale.

To change these settings, click Axis Settings, and make the changes in the Axis Settings dialog
box. The Axis Settings dialog box has three tabs: X, Y, and Color Scale. These tabs have the
same controls, with one exception noted below. 

Axis labels: To change the label, enter the label to be used for the axis or color bar in the Axis

label text box. The default is the property name. To change the font size for the label, choose
the point size from the Label font size option menu. The default is 10. 

Axis limits: In the Axis limits section you can select an option for determining the axis limits.
This section is not included in the Color Scale tab. The two options are:

• Automatic—Determine the axis limits from the range of values for the axis. Some round-
ing is done to decrease the number of significant digits in the end points.

• Manual—Set the axis limits in the Minimum and Maximum text box. The defaults are the
automatically determined limits. If you choose values that are smaller than the actual
range, some points will not appear on the plot. 
Schrödinger Software Release 2015-2 



Chapter 11: Plotting
Figure 11.3. The X and Color Scale tabs of the Axis Settings dialog box.

You can also enforce the axis ranges to be the same by selecting Equalize axis range in the
Scatter Plot panel. This option should only be used when the properties on the two axes have
approximately the same range of values, such as in an experimental versus predicted value
scatter plot. Otherwise, the plot points will not occupy much of the plot area.

Axis tick marks: You can set the number of tick marks on the axis, the number of decimal
places used on the numerical labels for the tick marks, and the font size for the tick marks. In
the Axis ticks section you can select one of the following options for determining the number of
tick marks on the axis: 

• Automatic—Determine the number of tick marks from the axis range to give a reasonable
appearance.

• Number of ticks—Specify the number of tick marks to use, including the ends of the
range. The axis range is divided by this number minus one to determine the increment.

• Tick increment—Specify the increment to use for the tick marks. The number of ticks is
determined by the range and the increment.

In the Tick label decimal places section, you can choose from the following options:

• Automatic—Determine the number of decimal places from the tick increment.
• Manual—Set the number of decimal places in the text box.
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The point size for the tick label font can be chosen from the Tick label font size option menu.
The default is 8. 

11.1.3.4 Changing the Plot Shape and Area

There are two ways in which you can change the shape of the area used to plot points. 

• You can place the axes on the same scale by selecting Equal aspect. The shape of the plot
area is changed so that the scales on the axes are the same. This option is useful only
when the range of values covered by the axes is approximately the same. 

• You can adjust the sides of the plot area by clicking the Configure plot toolbar button.

The Plot Configuration panel opens. In this panel, you can adjust the position of each of
the four sides of the plot. To close the panel, use the window controls.

The size and shape of the plot area is also adjusted when you resize the panel or when you hide
the controls for the plot. 

11.1.3.5 Adding a Title and a Legend

To add a title above the plot, select Plot Title, and enter the title text in the text box. This title is
not the same as the plot name, by which the plot is identified in the project.

To display a legend for the points, which shows the plot symbol for each series and the prop-
erty chosen for the y axis, choose the legend location from the Legend option menu. The
legend is placed inside the plot area. 

11.1.3.6 Labeling Plot Points

You can label the plot points with the value of a property, or view the value of a property for
plot points, by using the Label points toolbar button.

When you click this button, a property selector opens, in which you can choose the property
that you want to use for the labels or view. Once you have chosen the property, you can view
the property value by pausing the pointer over a plot point. The value appears in a tooltip, with
an arrow pointing to the point. To label the point with this value, click the point, then move the
pointer to the location in the plot area where you want to place the label, and click again. The
label moves with its arrow as you move the pointer. To delete the label, click the point again. 
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You can add labels for multiple properties, but the property name is not included in the label.
Only one label can be added to each point. 

11.1.4 Changing the View of a Plot

The toolbar in the Scatter Plot panel has tools for changing the view of the plot. These tools
can be used to pan the plot and zoom in or out. Each time you zoom or pan, the settings for the
new view are stored in the view history. You can then step through the different views of the
plot, and you can reset the view to the original state. The buttons for the view operations are
described below.

11.1.5 Interacting with the Project Table

The toolbar contains buttons for operations on the selected plot that interact with the Project
Table: selecting and deselecting entries associated with data points, and including and
excluding entries associated with data points. If the Project Table panel is not open, you can
open it by clicking the Open Project Table toolbar button:

Clicking the Pick to select entries button enters a mode in which you can select entries in the
Project Table by selecting points in the plot.

Reset view 
Reset the plot to the original pan and zoom settings.

Previous view 
Display the previous view of the plot in the view history

Next view 
Display the next view of the plot in the view history

Pan and zoom 
Pan the plot with the left mouse button; zoom in and out with the mouse wheel or the right 
mouse button. Using the mouse wheel preserves the aspect ratio. With the right mouse button, 
the magnitude of the zoom for each axis is determined by the direction in which you drag. 

Zoom to rectangle 
Drag out a rectangle on the plot to zoom in to that rectangle.
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Clicking the Pick to include entries button enters a mode in which you can include entries in the
Project Table by selecting points in the plot.

For both of these modes, you can select points with the following actions:

• Click on a data point to select a single point and deselect all others. 

• Shift-click on a data point to add that point to the selection. 

• Control-click on a data point to change the selection of that point without affecting the
selection of other points. 

• Drag over points to select all of those points and deselect all others.

• Hold down SHIFT and drag over points to add points to the selection. Points that are
already selected remain selected, so you can drag over a mix of selected and unselected
points to add the latter to the selection.

• Hold down CTRL and drag over points to change their selection without affecting the
selection of other points. When you do this, the points in the region you drag out that
were already selected are deselected, and the points that were not selected are selected. 

• Click in a blank area of the plot to clear the selection of points.

11.1.6 Saving Plot Images

You can save an image of the plot area with the Save plot image toolbar button.

When you click this button, a file selector opens, in which you can choose the image format,
navigate to the desired location, and name and save the file. 

11.2 Plotting Coordinate Scan Results

You can display the results of a scan of one or two coordinates in the Plot of One-Coordinate

Scan panel or the Plot of Two-Coordinate Scan panel in Maestro. Scans can be generated by
MacroModel or Jaguar. The data from these scans is stored in .grd files, which must be
opened from the panel. To open a .grd file, click the Open button, navigate to the file, select it,
and click Open. The panels and their use is described below. Since there are many common
features of these panels, the general features are described first. 
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To open the Plot of One-Coordinate Scan panel, choose Tools → Plot Coordinate Scan → One

Coordinate. To open the Plot of Two-Coordinate Scan panel, choose Tools → Plot Coordinate
Scan → Two Coordinates.

11.2.1 General Features of Coordinate Scan Plot Panels

Each panel consists of a toolbar, a plot area on the right and a set of controls on the left. The
common controls are described below; the controls specific to a given plot are described in
later sections. 

Minimum energy, Maximum energy

These text boxes allow you to set the energy range for the plot.

Full Scale

Restores a plot whose range has been altered to its full scale.

Energy Units

These options allow you to display data in either kJ/mol or kcal/mol energy units.

Energy Scale

These options allow you to display the energy as either an absolute or a relative value. The
Relative option is useful for estimating rotational barriers.

Show legend

Show a legend for the plot. 

Decimal places

Specify the number of decimal places to be displayed for the values on the x and y axes.

The panel has a toolbar that you can use to configure the plot or to save an image of the plot.
The toolbar buttons are described below.

Reset 
Reset the plot to the original pan and zoom settings.

Back 
Display the previous view of the plot in the view history

Next 
Display the next view of the plot in the view history
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11.2.2 The Plot of One-Coordinate Scan Panel

After a scan calculation with a single geometric parameter has been successfully completed,
the resulting .grd file can be displayed graphically using this panel. To open a .grd file, click
the Open button, navigate to the file, select it, and click Open. The data from the .grd file is
displayed in the plot area. The corresponding structures are read into Maestro as a scratch
entry, and one of the structures is displayed in the Workspace.

The appearance of a displayed plot can be changed using the controls on the left side of the
panel and the controls in the Plot Settings - One-Coordinate Scan panel, which is opened by
the Plot Settings button. 

• The ranges of the axes can be changed by entering values in the Minimum coordinate,
Maximum coordinate, Minimum energy and Maximum energy text boxes. 

• The symbol shape, color, and size and the curve style, color, and width are all controlled
from the Plot Settings - One-Coordinate Scan panel. To change these attributes, select the
data set in the list at the top of the panel, then choose the attributes from the option
menus. 

You can display multiple plots from .grd files in the Plot of One-Coordinate Scan panel. Each
plot is added by clicking the Open button and selecting the .grd file. The data sets are listed in
the Plot Settings - One-Coordinate Scan panel. You can delete a plot by selecting it in the list
and clicking Delete. 

Pan/zoom 
Pan the plot by dragging with the left mouse button, zoom by dragging with the right mouse 
button. 

Zoom to rectangle 
Drag out a rectangle on the plot to zoom in to that rectangle.

Configure subplots 
Configure the margins and spacing of each plot in the panel.

Edit axis and curve parameters 
Make settings for the title, range, labeling, and scale of the axes; the color, style, and width of 
lines; and the color, style, and size of markers.

Save image
Save an image of the plot to file. Opens a file selector in which you can browse to a location, 
select the image format, and name the image.

Copy to clipboard 
Copy an image of the plot to the clipboard. You can then paste it into another application. This 
button is only available in some panels. 
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Figure 11.4. The Plot of One-Coordinate Scan panel.

Figure 11.5. The Plot Settings - One-Coordinate Scan panel.
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To create a comma-separated file that can be read by a spreadsheet, click Export to CSV. A file
selector opens, in which you can navigate to a location and name the file. The data for all avail-
able plots is written to this file. 

11.2.3 The Plot of Two-Coordinate Scan Panel

For two-dimensional scans, the data from the .grd file is displayed in the plot area as a
contour map. Only one .grd file can be displayed at any given time. Reading in a second file
clears the data from the first.

Figure 11.6. The Plot of Two-Coordinate Scan panel.

The appearance of a displayed plot can be changed using the controls on the left side of the
panel. You can set the number of contour lines with the Number of Contours option menu, the
line thickness with the Contour Width option menu, and use dashed lines for negative contour
values by selecting Negative Dashed. You can choose the color map used to display the
contours from the Color map option menu. You cannot, however, change the range of coordi-
nates displayed. 

To determine the contour intervals, Maestro divides the range of energy values specified in the
Minimum Energy and Maximum Energy text boxes (or the maximum and minimum values in
the file) by n+1, where n is the specified number of contour lines. This means that the
maximum and minimum energy values are not represented by contour lines. 
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Chapter 12: Surfaces
The Maestro surface facility allows you to create and visualize molecular structure surfaces,
extended radius surfaces, van der Waals surfaces, electrostatic potential surfaces, and maps of
active sites in receptor molecules; to import surfaces; to display crystallographic density maps;
and to display surfaces generated by Jaguar, QSite and the Semiempirical NDDO package,
such as electrostatic potential surfaces, density surfaces, and molecular orbitals.

Some surfaces are constructed directly as a set of surface elements. Other surfaces are derived
from data for a function on a three-dimensional grid. This data is called a volume. The surface
is created by selecting a value for the function and displaying the surface that corresponds to
that value. The value is called an isovalue, and the surface is called an isosurface. Volumes can
also be rendered as a function of the data value in the Workspace by defining a map of the data
values to the opacity and to color ramps. 

Generated surfaces are incorporated into the Project Table and are displayed in the Workspace
by default when the associated entry is included. Surface data for any entry can be viewed
using the Manage Surfaces panel. From this panel, you can change surface display properties,
such as transparency, display style, and color, and edit the volume map.

12.1 Generating Surfaces

From the Surface submenu of the Workspace menu in the main menu bar, you can generate
three kinds of surfaces that have similar characteristics: molecular surfaces (Connolly
surfaces), van der Waals surfaces, and extended radius surfaces. The panels for these surfaces
are docked into the Workspace by default. 

Surfaces can only be generated for project entries. If you try to generate a surface for the
scratch entry, you will be prompted to create a project entry from the scratch entry. Each
surface is associated with only one entry, but an entry may have zero or more surfaces. 

12.1.1 Surface Generation Controls

Most of the surface-generation settings are common to the Molecular Surface panel, the
Extended Radius Surface panel, and the VDW Surface panel. All the settings are discussed
below.
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Figure 12.1. The Molecular Surface panel.

Atoms for surface display 

The surface is displayed only for the atoms specified in the Atoms for surface display section of
the panel. You can select atoms by picking in the Workspace, by entering an ASL expression in
the ASL text box, by clicking All, or by clicking the Atom Selection button and choosing an
atom selection item or clicking Select to open the Atom Selection dialog box. If you want to
reset the atom selection, click the Clear button. If you have Markers selected, the atoms you
select are marked in the Workspace. 

Boolean operation

In the Molecular Surface panel, you can create surfaces that are formed by Boolean operations
on two surfaces. The operations are:

• None—Create a single surface. This is the default.

• Union—Create a surface that encloses the volume occupied by either of the two surfaces
(Boolean OR). 

• Intersection—Create a surface that encloses the common volume of the two sur-
faces(Boolean AND). 

• Difference—Create a surface that encloses the volumes that are unique to each sur-
face(Boolean XOR).

The atoms for the second surface are specified in the Atoms for surface boolean operation

section, which is displayed when you choose an operation other than None. The controls are
the same as in the Atoms for surface display section.
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Surface context 

The surface is actually generated for the atoms chosen from the Surface context option menu,
but only the portion of the surface defined by the Atoms for surface display is displayed. If you
choose Entry or Molecule, the surface is generated for the entries or molecules of which the
atoms selected for surface display are a part. If you choose Selected atoms, the surface is
generated only for the atoms selected for surface display, and appears as a complete surface.

You can also limit the surface dynamically once it is created, using the Limit Surface dialog
box. See Section 12.4.1 on page 309 for details. 

Surface resolution 

You can set the quality of the image to Low, Medium, or High with this option menu. These
controls set the grid spacing for surface generation. You can also choose Custom and enter a
grid spacing in the text box. The grid spacing values for the other three choices are displayed in
this text box. The high quality surface is smoother but takes longer to generate.

Probe radius 

This setting appears only on the Molecular Surface panel and the Extended Radius Surface
panel. Since the van der Waals surface is, by definition, built directly on the van der Waals
spheres, a probe radius setting is not needed for this panel.

The value in the Probe radius text box controls the radius of the probe sphere that is “rolled
over” the van der Waals surface of the molecule. The default probe radius of 1.4 Å corresponds
to water.

VDW radius scale

This setting allows you to scale the van der Waals radius before the probe is used to generate
the surface.

Create Surface

To start the surface generation, click Create Surface. During this time Maestro is inoperative
and no user interaction is possible. For large surfaces and high quality, surface generation can
be time consuming. 

12.1.2 Molecular Surfaces

In the Molecular Surface panel, you can generate a surface that follows the molecular surface,
but is smoother than the CPK surface. The best known type of molecular surface is the
Connolly surface. Imagine rolling a ball, representing a solvent molecule, over the assembly of
spheres constituting the van der Waals surface. Where the outside of the ball contacts the van
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der Waals spheres, the surfaces coincide. Where two van der Waals spheres intersect, the
Connolly surface follows the surface of the solvent sphere, producing fillets rather than cusps.
Changing the solvent sphere (probe radius) affects the size and shape of the surface. Reducing
the grid spacing improves the accuracy of the surface, but increases the calculation time. 

You can also generate a surface by performing a Boolean operation on two surfaces—see the
previous section for details on how to do this. 

To open the Molecular Surface panel, choose Workspace → Surface → Molecular Surface.
Instructions for using the settings in the Molecular Surface panel are described in
Section 12.1.1 on page 297. The default surface context is Selected atoms.

When you display a molecular surface, the surface color can be darkened according to cavity
depth. This feature highlights the shape of the surface, providing an effect similar to shadows.
You can turn this effect on or off with the Darken colors by cavity depth option, under Surfaces

– Appearance in the Preferences panel.

12.1.3 Extended Radius Surfaces

In the Extended Radius Surface panel, you can generate a surface constructed on van der
Waals spheres in a similar way to a Connolly surface. In an extended radius surface, the point
that corresponds to the center of the probe is used to generate the surface, rather than the point
representing the closest contact of the probe with the surface. An extended radius surface
therefore shows roughly the surface that the centroid of a solvent or a ligand cannot penetrate.
Thus, looking at bound ligands with wire bond representation, the ligands would “hug” but not
penetrate the extended-radius surface. 

To open the Extended Radius Surface panel, choose Workspace → Surface → Extended

Radius. Instructions for using the settings in the Extended Radius Surface panel are described
in Section 12.1.1 on page 297.

Figure 12.2. The Extended Radius Surface panel.
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12.1.4 Van der Waals Surfaces

The VDW Surface panel is used to generate a van der Waals surface. This surface is identical to
the CPK molecular representation with the percentage set to 100. 

To open the VDW Surface panel, choose Workspace → Surface → Van der Waals. Instructions
for using the settings in the VDW Surface panel are described in Section 12.1.1 on page 297.

Figure 12.3. The VDW Surface panel (right).

12.1.5 Electrostatic Potential Surfaces

The Electrostatic Potential panel is used to generate a volume that contains values of the elec-
trostatic potential. To open the Electrostatic Potential panel, choose Workspace → Surface →
Poisson-Boltzmann Electrostatic. 

Figure 12.4. The Electrostatic Potential Surface panel.
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The electrostatic potential is derived from the partial atomic charges by solving the Poisson-
Boltzmann equation on a 3D grid of points, and is evaluated with a continuum solvation model.
By default, the calculation is done for the entire Workspace, but you can limit it to the region
around a particular set of atoms (for example, a ligand in a complex), by selecting the atoms
with the Atoms for electrostatic potential grid picking tools. If you limit the grid, the electro-
static potential is still evaluated with respect to the entire Workspace, but is only represented on
the grid you define.

Some of the parameters for the Poisson-Boltzmann solver can be set. You can change the
internal dielectric constant of the solute, and you can set the dielectric constant and radius of
the solvent. The default values are set for water. You can run the calculation at different
temperatures. 

The output from this panel can be mapped onto a molecular surface (which is generated if this
feature is requested), and it can be represented as a pair of isosurfaces, one for each sign of the
potential. If you choose to map onto a molecular surface, the same image quality controls as in
the Molecular Surface panel are available. The color scheme for the surface mapping can be set
in the Surface Display Options dialog box. If you choose to create isosurfaces, you can set the
initial isosurface value. Using the isosurfaces is a way to identify regions of large positive or
negative electrostatic potential. 

Electrostatic potential surfaces can also be generated by Jaguar, from the electron density. See
Section 3.10 of the Jaguar User Manual for details.

12.2 Hydrophobic/philic Surfaces

Maestro provides a tool that is designed to help you to visualize the preferred locations of
ligand atoms in a receptor site. Using the Hydrophobic/philic Surfaces panel, you can generate a
surface that displays hydrophobic and hydrophilic regions within the active site of a protein. To
open the Hydrophobic/philic Surfaces panel, choose Hydrophobic/philic from the Surface

submenu of the Workspace menu. 
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Figure 12.5. The Hydrophobic/philic Surfaces panel.

12.2.1 Background

Given a receptor structure, the accessible space in the active site is partitioned into three types
of regions:

1. Hydrophobic—regions that are favorable for occupancy by hydrophobic ligand groups

2. Hydrophilic—regions that are favorable for occupancy by hydrophilic ligand groups

3. Neither hydrophobic nor hydrophilic—regions that are of mixed character or that are
far enough from the receptor surface to be similar to bulk water, where to a first approxi-
mation any group could reside with little effect on the binding affinity. 

Hydrophobic and hydrophilic regions are marked by surface contours that enclose the region.
The “neither” regions are implicit; these are simply regions that are accessible to the ligand but
are not marked as being either hydrophobic or hydrophilic.

By revealing “targets of opportunity”—e.g., hydrophobic regions that have room to accommo-
date a larger hydrophobic group—active site maps can aid in the design of new ligands. Alter-
natively, by showing the degree to which poses produced by a program like Glide display or
violate proper complementarity to the receptor site, site maps can aid in the evaluation of
docking hits. The “neither” regions are also important because they are regions in which the
physical properties of the ligand can be changed, for example to make the ligand more or less
soluble, with minimal expected effect on the binding affinity. 

The active-site mapping procedure operates in a manner analogous to Goodford’s GRID algo-
rithm (P. Goodford, J. Med. Chem. 1985, 28, 849). Hydrophilic and hydrophobic regions are
defined in a way that considers both spatial proximity to the receptor and suitability for occu-
pancy by solvent water. A putative van der Waals energy and the magnitude and direction of
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the electric field (calculated using a distance-dependent dielectric formulation) are computed
for a probe centered at each grid point by considering interactions with all atoms of the
receptor site within a defined cutoff distance. In contrast to techniques that color-code the
receptor surface to represent hydrophilicity or hydrophobicity, these maps depend on more
than the character of the nearest receptor atom. Moreover, the maps explicitly show the shape
and extent of hydrophilic and hydrophobic regions, something a receptor-surface display
cannot do. The maps behave rather like an “extraradius” surface in that the atoms of a wire
frame representation of the ligand can approach but should not penetrate the map surface
(except in hydrogen bonding regions, where internuclear distances are expected to be smaller
than normal contact van der Waals distances).

Hydrophilic Map: The hydrophilicity is defined by adding an “electric-field reward” term to
the vdW energy: 

Grid_philic = vdW_energy + oriented-dipole_energy (1)

where the oriented-dipole energy is necessarily negative. Hydrophilic regions are those within
which the sum of the two terms is sufficiently negative, and are displayed by contouring the
hydrophilic grid at a prescribed negative isovalue, typically –6 kcal mol–1.

Hydrophobic Map: The quantity representing hydrophobicity is constructed by adding an
oppositely signed (positive) “electric-field penalty” term to the vdW term: 

Grid_phobic = vdW_energy – 0.15 * oriented-dipole_energy (2)

Hydrophobic regions are those for which the favorable van der Waals term is not too strongly
degraded by the positive electric-field penalty. Qualitatively, hydrophobic regions are those
that lie suitably close to the surface of the receptor but for which the water-dipole-orienting
electric field produced by the receptor is sufficiently small. In short, these are regions where
something would like to be, but water would not. Hydrophobic regions are displayed by
contouring the hydrophobic grid at a suitably negative isovalue, typically –0.5 kcal mol–1. 

12.2.2 Mapping Algorithm

The first step is to define a rectilinear box that contains an active site and to define grid points
with a typical grid spacing of 1 Å within the box. 

Next, van der Waals energies and x, y, and z electrostatic field components are computed at
each of the grid points. Receptor atom partial charges and van der Waals parameters are taken
from the OPLS-AA force field. A probe is represented by a van der Waals sphere of radius
1.5 Å, well depth 0.2 kcal mol–1, and point dipole moment 2.3 Debye. The probe’s point dipole
is oriented along the electric field to give a minimum (negative) electrostatic energy and is
offset from the vdW body (which is located at the grid point and represents the oxygen atom of
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a water molecule) toward the center of an optimally oriented O–H bond. A smoothing proce-
dure is applied during the calculation of the receptor’s electric field to avoid artificial singular-
ities. The hydrophilic and hydrophobic grid values are then determined from Eqs. 1 and 2. 

Finally, the hydrophilic and hydrophobic grids are read by Maestro, which contours the grids at
the empirically selected default isovalues cited above (–6 and –0.5 kcal mol–1) and displays the
corresponding hydrophilic and hydrophobic volumes as surfaces. 

12.2.3 Specifying a Structure to Be Mapped 

To create a map of a receptor structure, you must first include the structure in the Workspace.
The structure must belong to an entry in the current project: you cannot map structures from
more than one entry or from a scratch entry. 

Once you have displayed the structure, specify the part of the structure to be mapped with the
tools in the Part of structure to map section. You can pick atoms in the Workspace, enter an
ASL expression, click All, or click the Atom Selection button to choose from a range of
predefined atom groups or open the Atom Selection dialog box and select atoms. If Markers is
selected, a dark pink trace is superimposed on the selected atoms and bonds. 

To clear the atom selection, click the Clear button. Clearing the selection does not delete
existing maps.

12.2.4 Defining the Mapping Box

In addition to specifying the structure for which a map is to be generated, you must also set the
location and size of the “box” of atoms to be mapped, using the tools in the Bounding Box

section. You can pick atoms in the Workspace, enter an ASL expression, click All, or click
Select to open the Atom Selection dialog box and select atoms. Mapping box atoms must be
associated with a project entry; they cannot be part of the scratch entry. If Markers is selected,
an orange box is displayed in the Workspace to mark the mapping box region.

The box margin provides a buffer around the minimal defined mapping box enclosure. Adding
a buffer region may be useful if you are investigating modification of the ligand to obtain a
better fit in the active site, and would like to generate a surface large enough to show how
modified or added atoms would interact.

To alter the box margin, enter a value into the Box Margin text box. If you have defined the
mapping box region using fillres in an ASL expression, you may want to set the box margin
value to zero.
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12.2.5 Running the Job 

In contrast to the generation of other types of surfaces, mapping of an active site is run as a job.
After you have configured the Hydrophobic/philic Map panel settings, you can choose to either
run the job or to simply write out the job files so that you can run the calculation later. 

To write the job files without running the job, click the Write button. You can use these files to
subsequently launch the calculation from the command line.

To set up and run the calculation, click Start, make settings in the Start dialog box, and click
Start to launch the job. This job is not run at reduced priority if it is run locally, unlike most
local jobs.

When the job finishes, the surface data is incorporated into the project and an S button is added
to the Title column for the entry, which you can click to open the Manage Surfaces panel and
view the data associated with this surface.

12.2.6 Viewing the Surface

The site map is displayed as a pair of isosurfaces generated from the hydrophilic and hydro-
phobic grids. The default isovalues can be changed in the Surfaces panel if more expansive or
more restrictive philic and phobic volumes are appropriate in a given application. If you need
to see inside these surfaces, you can display them as Mesh surfaces, or if you display them as
Solid surfaces (the default), you can increase the transparency. 

12.3 Importing Surface or Volume Files

You can import surfaces or volumes from one or more files into the Maestro project and asso-
ciate these surfaces or volumes with a project entry. The file formats that are recognized by
Maestro are given in Table 12.1. 

Table 12.1. Surface file formats.

File Extension Format description

.vis Schrödinger format. Files in this format are created by Jaguar, QSite, Semiempiri-
cal NDDO, SiteMap, and hppmap. 

.plt Obsolete Jaguar format. 

.cns, .map CNS electron density map format. Used by PrimeX.

.ccp4 CCP4 electron density map format. Used by PrimeX.
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To import a file, choose Display → Surface → Import, or click the Import button in the Manage

Surfaces panel. Browse for the desired files and click Import. The data must be associated with
a project entry, so once you have selected the files, the Choose Entry dialog box opens. In this
dialog box, choose the entry to which the surface or volume data belong. Once you have asso-
ciated the data, it becomes a part of the Maestro project. It can be displayed by clicking the S
button in the Title column of the Project Table or by clicking in the In column of the surface
table in the Manage Surfaces panel.

If you are importing an electron density map, the Map Type dialog box is displayed after
choosing the entry, so that you can select the map type from among the common types.
Selecting the map type is important for PrimeX operations that expect a particular type of map.

When you import surface or volume files, the surfaces and volumes are already named. To
change the name of the displayed surface or volume, edit the name in the Surface Name field
in the surfaces table. 

A .vis file can contain volumes, surfaces, or both. A volume contains all of the data values for
each of the points on the grid. Once the file is imported into Maestro, one or more surfaces can
be created. In addition, if the .vis file still contains the original volume data used to generate
an imported surface, you can change the isovalue in Maestro and generate new surfaces using
different isovalues. If a Maestro .vis file contains only surfaces, then it contains only a
description of the surface and not the original volume data from which it came. You cannot
change the isovalue for such a surface in Maestro. 

Jaguar-generated .vis files always contain volume data—3D grids with data values at each
point. They may contain orbital, electron density, spin density, or electrostatic potential infor-
mation. These files are created using the appropriate keywords in the gen section in the Jaguar
input file. See Section 3.10 of the Jaguar User Manual for details. Likewise, surfaces gener-
ated by SiteMap, WaterMap, and hydrophobic/philic maps contain volume data. The surface
and volume data from all these applications is automatically incorporated into the project and
displayed.

12.4 The Manage Surfaces Panel

The Manage Surfaces panel is used to import, modify, and view surfaces and their properties.
The panel consists of a table of surfaces for all entries that are included in the Workspace, and
a set of controls below the table. 

To open the Manage Surfaces panel, choose Workspace → Surface → Manage Surfaces, or
click the S button in the Title column of the Project Table panel. 
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Figure 12.6. The Manage Surfaces panel.

The columns of the surface table are described in Table 12.2. Scratch entries are not part of a
project and thus cannot be used for surfaces.

• To display a single surface in the Workspace, click in the In column for the desired sur-
face. 

• To display multiple surfaces, click the first and shift-click the last in the In column. 

Table 12.2. Surface table columns.

Column Purpose

In Displays or undisplays the surface for that entry in the Workspace.

Limit If limits are set for this entry, a checkbox appears. You can then check or uncheck 
the box to turn limits on or off. To add or edit limits, click the Limit button.

Entry Lists the entry ID and the title of the entry that contains the surface. 

Volume Name Lists the name of the volume from which the isosurface was created.

Vol Displays or undisplays the volume for that entry in the Workspace.

Surface Name Edit this field to create a unique surface name within each entry.

Comments Edit this field to add your own comments. Jaguar fills this field in with molecular 
orbital names.

Surface Type Lists the type of surface to be displayed: molecular surface, Van der Waals, 
extended radius, density, potential, orbital, spin, hydrophobic, or hydrophilic.

Isovalue Lists the value that was used to create the surface. To change this value, use the 
Isovalue slider at the bottom of the panel or enter a value in the text box next to it. 
For regular surfaces, this field is blank. 

Area Lists the surface area of the limited surface (summation of all polygons).

Sigma (PrimeX only) Sigma value used to generate the map.
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• To display or undisplay individual surfaces, use control-click or middle-click in the In
column. 

• To change the name of a surface, enter a new name in the Surface Name column

• To arrange the surfaces in a rectangular grid, choose View → Tile → Tile by Surface fol-
lowed by View → Tile Workspace (or use the Tile button on the View toolbar).

Below the table are buttons for importing, duplicating, deleting, and limiting surfaces, as well
as controlling the display of surfaces and volumes and for setting surface-related preferences.
You can adjust the isovalue of a volume with the slider or the text box. These controls and
buttons are described in the following sections.

12.4.1 Importing, Modifying, and Deleting Surfaces 

Importing surfaces 

You can import surfaces from a file into the Manage Surfaces panel. To do so, click Import,
browse to select the desired surface file, and click Import. You can also import surfaces by
choosing Workspace → Surface → Import in the main window. More information is given in
Section 12.3 on page 306.

Changing isovalues 

The isovalue is the current value of the property that was used to create the surface. Surfaces
generated by Jaguar and hydrophilic/phobic surfaces have volume data for which an isovalue is
specified. Molecular surfaces, van der Waals surfaces, and extended radius surfaces do not
have volume data. 

You can change the isovalue for a surface that has an associated volume: either enter a new
number in the Isovalue text box at the bottom of the panel or use the slider to adjust the
isovalue. The surface is redisplayed with the new isovalue. For PrimeX, the fraction of Sigma
is also displayed.

To create a new isovalue for a surface, select the surface in the table and click the Duplicate

button at the bottom of the panel. Then you can change the isovalue for the new surface.

Limiting the display volume of surfaces

You can limit the visible portion of the surface to the portion that is within a specified distance
from a selection of atoms. Click Limit to open the Limit panel. Select the atoms using the
picking tools in the Limit to ASL section, enter a value in the Distance text box, and click Apply.
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The limit is applied to the surface. You can change the atom selection, or click OK to accept the
limit. To remove the limit, click the square in the Limit column of the surfaces table.

Figure 12.7. The Limit panel.

You can also limit surfaces by only displaying the surface within a cube of a specified volume.
To do so, select Display at most, and enter a volume in the text box. 

Splitting paired surfaces

Surfaces calculated from volume data that have both positive and negative values are displayed
as paired surfaces: one for the positive values and one for the negative values. Examples of
such surfaces are molecular orbitals, electrostatic potentials, and crystallographic density
difference maps (Fo-Fc). You can display just the positive or the negative surface, by selecting
the surface in the table and clicking Split. Two new surfaces are created, one for the positive
surface and one for the negative surface, with suffixes _positive and _negative. 

Deleting surfaces 

To delete a surface, select it in the surfaces table and click Delete. 

12.4.2 Changing the Appearance of the Surface 

You can adjust various characteristics of the surface’s appearance using the controls in the
Surface Display Options dialog box. Many of these controls are available from the shortcut
menu, which opens when you right-click on a row in the table. This menu allows you to change
the style and transparency, and color with a constant color or by the value of a property.

In addition, there are preferences for the display of surfaces that can be set in the Surfaces tab
of the Preferences panel—see Section 14.9 on page 365 for details. 
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Figure 12.8. The Surface Display Options dialog box.

12.4.2.1 Style and Transparency 

Surfaces can be displayed in three styles: Solid, Mesh, and Dot. The transparency of Solid

surfaces can be changed using the Transparency sliders. Mesh and Dot surfaces are opaque
unless the Transparency slider is set to 100%, when they become invisible.

You can adjust the transparency of the front and back of the surface independently, with the
Front surface and Back surface sliders and text boxes. By default, these controls are linked. To
allow them to be adjusted independently, deselect Adjust together. The default values of the
transparency can be set in the Surfaces tab of the Preferences panel.

You can also use the shortcut menu to choose from several preset transparency values: 0%,
25%, 50%, and 75% transparency for both front and back, and Front Face 100% (with 0% for
the back), which makes the front face completely transparent. 

The transparency can be made to vary across the surface, according to the angle the surface
normal makes with the plane of the screen. The transparency is a minimum when the normal is
perpendicular to the screen, and a maximum when it is parallel to the screen. This gives an
effect like looking through a balloon, where the color is darker toward the edges of the view
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and lighter in the middle. This effect is controlled by the Angle-dependent transparency prefer-
ence, under Surfaces – Viewing in the Preferences panel—see Section 14.9.1 on page 365. The
transparency slider in the Surface Display Options panel sets the maximum transparency used.

Note: Angle-dependent transparency is only available with an OpenGL graphics level of 2.1.

12.4.2.2 Color Scheme

You can color a surface using the following options in the Color Scheme section of the panel: 

• Property—each part of the surface is colored according to the value of the property on the
nearest atom to that part of the surface. Choose a property from the Property option
menu. The properties include such things as Entry and Molecule Number, as well as
numerical properties like Electrostatic Potential and Residue Charge. Atom Color and CA

Atom Color use the color of these atoms to color the surface.

The Partial Charge and Electrostatic Potential schemes require partial charges, which you
can generate with a MacroModel, Impact, Prime, or Jaguar calculation. You can also gen-
erate partial charges by choosing Assign Partial Charges from the Tools menu. If partial
charges are not available, the surface appears completely white.

For the Electrostatic Potential color scheme, you can choose a color ramp from the Color

ramp option menu. By default, the range of colors is determined by the range of property
values. You can set minimum and maximum property values for the ends of the color
ramp in the Minimum and Maximum text boxes. The colors for property values outside the
minimum and maximum are set to the colors at the appropriate end of the ramp.

• Constant—the entire surface is colored with the same color, which you can choose from
the Color option menu. You can make this the default surface color by clicking Set

Default Color. 

When a surface has both positive and negative portions (a “split” surface, such as a
molecular orbital), the Negative color option menu is active and you can select the color
in which the negative surface is displayed. 

• Map values from volume data—the surface is colored based on the value of the volume on
the surface, which you select in the list.

The color fades between the colors selected in the Color ramp option menu according to
the value of the volume property on the surface. By default, the range of colors is deter-
mined by the range of values in the volume. You can set the minimum and maximum
volume property values represented by the color ramp in the Minimum and Maximum text
boxes, and revert to the default by clicking Reset Full Range. You can also display a leg-
end in the Workspace that shows the color ramp and value range used. The legend is
labeled with the volume name.
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This scheme can be used, for example, to display the values of the electrostatic potential
obtained from a Jaguar calculation on the van der Waals surface, as shown in Figure 12.9.
You can also create your own color ramp (see Section 13.5.4 on page 327 for
instructions).

Figure 12.9. Example of color ramp: electrostatic potential of benzene from Jaguar 
mapped to van der Waals surface.

12.4.2.3 Depth Perception

If you want to enhance the perception of the depth of the cavities in a surface, select Darken
colors by cavity depth. This option determines the depth of a cavity in the surface relative to a
smooth surface that covers the cavity, and changes the color shade according to the depth of the
cavity. For new surfaces, this option is set by a preference—see Section 14.9.1 on page 365.

Another depth perception feature is the use of depth-enhancing contours, which are outlines on
the surface that are drawn when the features behind it are more than a certain distance away.
This feature, including controls for the distance, the thickness of the contour, and the blending
with the background, is available in the Preferences panel—see Section 14.9.1 on page 365.

12.4.3 Displaying Volumes

Volume data can be displayed as a continuous function of the data value, rather than just at a
particular value (the isovalue). The display is created by setting the opacity and the color of the
surface as a function of the data values. To display a volume in this way, select its Vol column.

The function is set up graphically in the Volume Color Map Editor panel, which you open by
clicking Volume Editor. 
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Figure 12.10. The Volume Color Map Editor panel.

The opacity and color are set up in a graphical manner, by adding points to the opacity chart at
particular values of the property and the opacity, and with a particular color value. These points
can be dragged around to change the shape of the opacity curve. The color is interpolated
linearly between points, and the logarithm of the opacity is interpolated linearly between
points. You can also define “peaks” which consist of a point at some opacity and property
value, and two points on either side at zero opacity. Peaks can be moved and their width
changed. An initial curve is loaded when you open the editor for a particular volume, taken
from information stored with the volume. 

The basic actions for defining the points are as follows:

• To add a point: click on the chart.
• To remove a point: right-click on the point.
• To move a point: drag it to its new location.
• To move a point vertically: shift-drag it to its new location.
• To change the color: double-click on a point.
• To add a peak: control-click on the chart.
• To move a peak: control-drag it to its new location.
• To change a peak width: use the scroll wheel; add SHIFT for finer control.

For detailed control, you can use the Active color point section to change the data value, the
opacity, and the color for the current point. 
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You can change the range of values used in the map by editing the text boxes for the minimum
and maximum values. To reset the range to the default, click Reset Range.

If the data values span many orders of magnitude, and the details of interest occur at different
orders, you can use the logarithm of the data values rather than the values themselves. The data
values should all have the same sign. An example is the electron density. 

The panel also has some display options, for increasing the quality of the rendering, and for
displaying the box inside which the volume is defined. 

Note: This feature is only available with an OpenGL graphics level of 2.1 or higher.

12.4.4 Exporting Surfaces

PrimeX maps can be exported in CNS (formatted or unformatted) or CCP4 format. To do so,
select the map in the Surface Table, then click Export to Map. A file selector opens, in which
you can choose the format, navigate to the desired location, and save the file. 
Maestro 10.2 User Manual 315



316
 Schrödinger Software Release 2015-2



Maestro User Manual
Chapter 13
Chapter 13: Customizing Maestro
Many aspects of the Maestro interface can be customized from within Maestro. This chapter
describes customizing the panel layout, menus, keyboard shortcuts, mouse actions, and
profiles, all of which can be done from Maestro. It also describes the resource files used for
customization, which you can change by editing. Customization of the toolbars is described in
Section 2.4 on page 17 and customization of color schemes is described in Section 7.2.4 on
page 138. Setting preferences is described in Chapter 14, and other customization tasks that
can be performed using scripts are described in Chapter 15.

The customizations described in this chapter can be saved explicitly, so that they are preserved
in subsequent Maestro sessions. Customizations are stored separately for each profile, in the
subdirectory (folder) for the profile in your user profiles directory, which is: 

Here, vv is the two-digit Maestro version number (99 for this release). For Windows,
%APPDATA% is  C:\Users\username\AppData\Roaming (the location of shared application
data).

For Mac, $HOME is usually /Users/username, while on Linux it is usually /home/username.
The subdirectory where the data is actually stored is referred to here as the profile. 

Other changes can be preserved only by creating a startup script that issues the Maestro
commands necessary to generate the desired changes when Maestro is launched. For more
information on startup scripts, see Section 15.4 on page 390.

13.1 Changing and Saving Panel Layout

Although effort has been made to optimize the default window positions and dimensions, you
may want to change them. Resizing and repositioning windows is done in the normal way by
dragging a corner, a side, or the title bar of the panel. Here, “windows” means panels, dialog
boxes, and the main window. You can also close all panels (except the main window), reopen
the panels you had open, raise all panels, and arrange the panels in a cascade, from upper right
to lower left, by choosing the corresponding items from the Window menu. 

UNIX, Mac:  $HOME/.schrodinger/maestrovv/profiles 

Windows:  %APPDATA%\Schrodinger\maestrovv\profiles 
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You can save the size and location changes in a layout file, by choosing Save Layout from the
Window menu in the main window. Maestro immediately saves your panel settings to the file
named layout.res in your profile. If you want to return the panels to their default sizes and
locations, delete the layout.res file. If you change the panel size and location during a
session and want to revert to the last saved layout, choose Restore Layout from the Window
menu. You can also raise one or all open panels from the Window menu.

If you start Maestro and display it to a monitor with a lower resolution, or if you have fewer
screens, some windows might not open in your display area. To fix this problem, quit Maestro,
edit the coordinates of these windows in the layout.res file, or delete this file to reset the
locations, and restart Maestro. 

When you upgrade to a new version of Maestro, the panel layouts you saved in a previous
version are not accessible in the new version. The reason for this is that, in the new release,
panels are often upgraded and their elements rearranged. Using an old panel layout may hide
important features of the panel. Once you have installed the new version of Maestro, start the
program, arrange the panels the way you want them, and save the panel layouts. Maestro will
use the new panel layouts for all subsequent sessions.

13.2 Customizing the Menus and Keyboard Shortcuts

The Maestro menus provide access to all the features of Maestro, organized mainly by func-
tion. You might want to rearrange the menu items, or even remove or rename menus and menu
items, to suit your own needs. Along with changing the menu items, you can also change the
mnemonics for the menus and the keyboard shortcuts. 

Figure 13.1. The Customize Menus panel.
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The menus are defined in a resource file, which you can edit directly. This file is described in
Section 13.5.7 on page 329. However, you can easily customize the menus by using the
Customize Menus panel, which you open from the Maestro menu in the main window for
customizing main window menus, and from the Table menu in the Project Table panel, for
customizing Project Table menus.

The Menu option menu lists all the available menus in the panel, including the menu bar itself.
When you make a choice from this option menu, the items on the chosen menu are listed in the
table. You can then make changes to the menu: change the name, the mnemonic, the shortcut
key, and the help text; add and delete items, add separators and submenus. You can add the
same menu item (function) to more than one menu. 

To change the item name and mnemonic:

1. Click in the table cell to edit it.

The cell is outlined in blue to indicate that it is in edit mode.

2. Enter the new name and mnemonic.

The mnemonic is the letter that follows the ampersand (&) and is the keyboard key that
can be used with the ALT key to open the menu or select the menu item. 

To add or to change a shortcut key:

1. Click in the table cell to edit it.

The cell is outlined in blue to indicate that it is in edit mode.

2. Press the shortcut key that you want to use.

To remove a shortcut key:

1. Click in the table cell to edit it.

The cell is outlined in blue to indicate that it is in edit mode.

2. Right-click and choose Delete from the shortcut menu.

To change the help text:

1. Click in the table cell to edit it.

The cell is outlined in blue to indicate that it is in edit mode.

2. Type in the new text.

The help text is the text that is displayed in the Auto-Help bar at the bottom of the panel
when you pause the pointer over the menu item.
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To move an item:

1. Select the item.

2. Drag it to its new location.

To delete menus or menu items:

1. Select the table rows.

2. Click Delete.

To add a menu item:

1. Select the table row above which you want to add the menu item, or clear the table selec-
tion to add the item at the end of the list.

2. Choose an item type from the Add item of type option menu.

3. Click Add.

Subsequent steps depend on the item type:

• Existing item—the Add Existing Item dialog box opens.

a. Choose the item from the tree of the existing menus and items that are available in
the current panel. 

b. If you want to remove the item from its current location when it is added to the new
location, select Remove from current location. Otherwise the item is duplicated in
the new location.

c. Click OK.

The menu item is added to the menu with the existing name, mnemonic and shortcut.

• Python script—the Add Python Script dialog box opens.

a. Specify a name for the menu item in the Name text box

b. If you want to use a mnemonic, add an ampersand in the name before the mnemonic
letter.

c. Specify the Python function that it runs.

The function is executed with the pythonrun command. 

d. Click OK. 

• Submenu—the Add Submenu dialog box opens.

a. Specify a name for the submenu in the Name text box
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b. If you want to use a mnemonic, add an ampersand in the name before the mnemonic
letter.

• Separator—a separator is added immediately. 

If you want to revert any of your changes to the defaults, choose the scope of the reversion
from the Reset to defaults for option menu, then click Reset. Choosing All menus resets all
items to the defaults for the panel. Choosing Current menu resets all items for the current menu
and its submenus. Choosing Selected items resets the name, mnemonic, shortcut, and help text
only: it has no effect on any submenus. 

To assist you in choosing shortcuts, you can view all the shortcuts defined in the panel by
clicking View Defined Shortcuts. The Defined Shortcuts panel opens, showing a list of all menu
items and their shortcuts. You can change the shortcut in this panel by editing the table cell and
pressing the keys for the new shortcut.

When you have made changes, you can check whether the changes conflict with other menu
items by clicking Check for Conflicts. This tool checks for conflicts and shows a panel that
reports on the following items:

• Conflicts between mnemonics on the current menu.
• Missing mnemonics on any menu.
• A list of available mnemonic letters.
• Conflicts between shortcuts used for any menu item in the panel.

Not having a mnemonic is not strictly an error, but it means that you will not be able to choose
the menu item from the keyboard.

13.3 Customizing Mouse Actions

If you want to change the Workspace actions that are associated with the mouse buttons or
trackpad gestures, you can do so in the Customize Mouse Actions panel, which you open with
Maestro → Customize→ Mouse Actions.

Figure 13.2. The Customize Mouse Actions panel.
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First, choose the kind of device that you are using from the Customize actions for option menu.
The choices include a mouse with 2 or 3 buttons, with or without a scroll wheel, or a trackpad.
Button 1 is the left button, button 2 is the middle button (if present), button 3 is the right button.
The table is filled in with the default actions assigned to each combination of modifier keys and
mouse controls for the chosen device type. There is also a special PyMOL customization.

To change the action for a particular combination, click in a table cell. An option menu is
displayed, from which you can select the action to use for that particular combination. Not all
actions are available for each combination. You can assign the same action to multiple key/
mouse combinations. The available actions are listed in Table 13.1.

Table 13.1. Actions that can be assigned to key/mouse combinations.

Action Description

No action The mouse gesture is not assigned any Maestro action.

Rotate Rotate around the axis that is perpendicular to the direction of movement of 
the pointer.

X or Y rotate 
(gesture-based) 

Rotate around the x axis or the y axis, depending on the direction of the initial 
pointer movement (perpendicular to the rotation axis).

X rotate Rotate around the x axis.

Y rotate Rotate around the y axis.

Z rotate Rotate around the z axis.

Translate (& spot 
center) 

Translate in the xy plane in the direction of the pointer movement, spot-center 
with click (if relevant).

X or Y translate 
(gesture-based) 

Translate in the x or the y direction, depending on the direction of the initial 
pointer movement.

X translate Translate in the x direction.

Y translate Translate in the y direction.

Z translate Translate in the z direction

Zoom Zoom in or out.

Clipping (forward/
back) 

Move the clipping planes forward (out of the screen) or back (into the 
screen).

Clipping (together/
apart) 

Move the clipping planes closer together or further apart.

PrimeX Isovalue 
(inc/dec) 

Increase or decrease the Isovalue on PrimeX maps.
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If you want to swap the actions in the table to use different mouse buttons, click one of the
Swap buttons buttons. For example, clicking 1 & 2 would swap the assignments for Button 1
with those for Button 2, and swap the assignments for Button 1& 3 with those for Button 2& 3.

The default mouse actions are stored in the file default.mouseactions in the Maestro
resources directory. If you customize actions, the file is written to your profile.

13.4 Customizing Profiles

When you save any information that customizes Maestro, it is stored in your user profiles
directory under the name of the profile you are using. This profile is in one way a custom
profile, because it differs from the profile settings stored in the installation. If you want to
customize Maestro in more than one way, you can create named custom profiles from one of
the existing standard profiles. These profiles are also stored in your user profiles directory, with
the name that you give it. 

You can create custom profiles in the Customize Profiles panel, which you open by choosing
Maestro → Customize → Profiles. A custom profile can only be created from the current
profile. To create the profile, click New, and enter a name in the dialog box that opens. The
name is case-sensitive, and should not contain spaces. The new name is listed under Available

Profiles. The files for the current profile are copied to the new profile. Custom profiles always
have a “parent” profile, which is the standard profile from which they originated. Some
customization (including display of online help) is dependent on the parent profile. 

Pick only Pick atoms to create a new Workspace selection. Each pick clears the previ-
ous Workspace selection.

Pick add Pick atoms to add to the Workspace selection. Does not affect other selected 
atoms.

Pick invert Pick atoms to change their selection state. Does not affect other selected 
atoms.

Pick or Rotate Pick atoms with click; rotate the Workspace with click and hold.

Rotate (Virtual 
Trackball) 

Rotate around the x or y axis if the pointer is in a circle (virtual trackball) in 
the center of the Workspace, rotate around the z axis if the pointer is outside 
this circle, with a smooth change in behavior over the boundary. The circle 
diameter is about 80% of the shortest Workspace dimension.

Pick or Rotate 
(Virtual Trackball) 

Pick atoms with click; rotate the Workspace with click and hold using a vir-
tual trackball (see previous item).

Table 13.1. Actions that can be assigned to key/mouse combinations.

Action Description
Maestro 10.2 User Manual 323



Chapter 13: Customizing Maestro

324
Figure 13.3. The Customize Profiles panel.

13.5 Customization by Editing Resource Files

Maestro uses resource and configuration files to make settings for various parts of its opera-
tion, for example, for the display of colors and fonts. The default versions of the resource files
are stored in subdirectories of $SCHRODINGER/maestro-vversion/data. General resources
are in the res subdirectory, which will be referred to as the Maestro resources directory. The
default versions of project configuration files, rotamer resource files, and other resources are
stored in $SCHRODINGER/mmshare-vversion/data, which will be referred to as the installa-
tion resources directory. 

You can customize resources by copying the resource or configuration files to the relevant
profile directory (folder) in your user profiles directory: 

where vv is the 2-digit Maestro version, and then editing them. Instructions for editing these
files are given in the subsections below.

When Maestro is started, resources and configurations are initialized from the Maestro
resources directory, then resources that are set in the profile directory are read, and replace
those read from the distribution. The resource files in the profile directory for a new release are
copied from the profile directory for the previous release. 

You can also change the standard resources and configurations by editing these files in the
Maestro resources directory. If you do, the resources are changed for all users. 

UNIX, Mac:  $HOME/.schrodinger/maestrovv/profiles 

Windows:  %APPDATA%\Schrodinger\maestrovv\profiles 
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13.5.1 Visual Style Resources

To customize visual style resources, such as fonts and colors, you can copy the file
maestro.sty from the Maestro resources directory into your profile directory as
maestro_user.sty. The styles in the copy supersede the default styles, so you can remove
lines from maestro_user.sty that you do not want to change from their defaults. This file is
a QT style sheet, which is described in detail at http://doc.qt.digia.com/4.4/stylesheet.html. 

The style sheet syntax has many similarities to the HTML cascading style sheets (CSS). To set
the font used throughout Maestro to Arial normal 10px, for example, you would add the
following lines to the style file:

*{
font-family: "Arial";
font-size: 10px;
font-weight: normal;
}

The font family, size, and weight for panel text can be set under General – Application fonts in
the Preferences panel—see Section 14.1.5 on page 338. For Workspace text, it can be set
under Workspace – Fonts in the Preferences panel—see Section 14.4.9 on page 352.

13.5.2 Color Definitions

Many of the places where color is used in Maestro use the RGB color values directly, rather
than the Maestro color palette. The color palette is used for named colors. The default color
palette is defined in the file colors.res in the installation resources directory (given above).
When Maestro starts, it looks for a colors.res file in your profile directory and uses that
copy in preference to the one from the installation resources subdirectory. 

Maestro supports 256 colors in its color palette. Colors 1–128 are used by various parts of
Maestro. Colors 129–256 are user-defined colors: these colors can be used for new color
schemes and color ramps, for example. All of the colors are editable.

To customize the colors from Maestro, click the color button in the Bond Color tab of the Atom

and Bond Coloring panel or in the Atom Labels tab of the Preferences panel. A color palette is
displayed. Click Advanced, to open the Choose Color dialog box, then choose a color and click
Edit to change the color. When you click OK, a colors.res file that contains the new color is
written to your profile directory. To restore the default colors from the mmshare data subdirec-
tory, click Restore Defaults in the Choose Color dialog box. This action removes the
colors.res file from your profile directory.

You can edit the colors.res file directly with a text editor. Lines beginning with # are
comment lines. Blank lines are ignored. Each line that defines a color has an index number, a
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triplet of RGB color values in decimal format, and a color name. There must be no spaces after
the name. If you change the resource file in the installation, the colors for all users are changed.

13.5.3 Color Schemes

Each of the standard color schemes is defined in a separate file in the schemes subdirectory of
the Maestro resources directory. By convention, color scheme files end with .sch. The
schemes are called by Maestro using the file scheme.res, which is in the Maestro resources
directory. Color schemes can be created from Maestro—see Section 7.2.4 on page 138for
details. Instructions for creating color schemes by editing the files are given below.

To define your own color schemes:

1. Create a scheme.res file in your profile directory, or copy scheme.res from the Mae-
stro resources directory and edit it. 

2. Create a schemes subdirectory in your profile directory.

3. Create color scheme files scheme.sch in the schemes subdirectory, or copy the .sch
files from the schemes subdirectory of the Maestro resources subdirectory and edit them.

13.5.3.1 The scheme.res File

The scheme.res file contains a three-line description of each scheme. The three lines contain
the following information:

• The short name of the color scheme
• The long name of the color scheme. This is the name used in the Atom Coloring panel.
• The name of the file that contains the scheme definition 

Lines beginning with a # are comment lines. Either the short name or the long name can be
used to refer to the color scheme when using the colorscheme scheme=scheme-name
command in Maestro. 

13.5.3.2 Color Scheme Files

The color scheme files contain a number of rules, one rule per line, which are applied in the
order they appear in the file. Each rule consists of the name of a color as it appears in the
colors.res file or the 6-digit hexadecimal code for the RGB color; an ASL specification that
describes which atoms are to have that color; and an optional description. Color names must be
a single token (there must be no spaces). If the color names do have an embedded space, they
must be quoted (for example, "spring green").

The following is an example of a possible color scheme:
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white atom.ele *
blue atom.ele N
red atom.ele O

This scheme first sets all atoms to white, then colors all the nitrogen atoms blue and the oxygen
atoms red. Any number of such rules can be included in color scheme files.

13.5.4 Color Ramps

Color ramps are used in Maestro to map volume data onto a surface. In addition to the default
color ramps provided with Maestro, you can also create your own color ramps. Like color
schemes, each of the standard color ramps is defined in a separate file. These ramp files are
stored in the in the ramps subdirectory of the Maestro resources subdirectory.

By convention, color ramp files end with .rmp. The color ramps are called by Maestro using
the file ramp.res, which is stored in the Maestro resources subdirectory.

To define your own color ramps:

1. Create a ramp.res file in your Maestro user resources directory, or copy ramp.res
from the Maestro resources subdirectory and edit it. 

2. Create a ramps subdirectory in your Maestro user resources directory.

3. Create color ramp files ramp.sch in the ramps subdirectory, or copy the .sch files from
the ramps subdirectory of the Maestro resources subdirectory and edit them.

13.5.4.1 The ramp.res File

The ramp.res file contains a three-line description of each ramp. The three lines contain the
following information:

• The short name of the color ramp (used in Maestro commands) 
• The long name of the color ramp (used in the Display Options dialog box of the Manage

Surfaces panel)
• The name of the file that contains the ramp definition 

Lines beginning with a # are comment lines. Only the short name can be used to refer to the
color ramp when using the surfacescheme colorramp=ramp-name command in Maestro. 

13.5.4.2 Color Ramp Files

The color ramp files contain a list of color names, in the order that they will be used in the
color ramp. The names of the colors must be taken from the colors.res file. Color names
must be a single token (there must be no spaces). If the color names do have an embedded
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space, they must be quoted (for example, "spring green"). Lines beginning with a # are
comment lines. The following example defines a simple 5-color ramp:

# Number of colors
# 5
# Color names for all colors of this color ramp
red
orange
yellow
green
blue

When a color ramp is applied, the range of values that define the ramp is divided evenly
between the colors. The first color on the list is applied to the most negative value, the last
color to the most positive. If you want to extend the range of values mapped to a single color,
you can duplicate the color in the list. For example, to extend the range for the endpoints in the
above example, you could duplicate red and blue, as follows:

# Number of colors
# 7
# Color names for all colors of this color ramp
red
red
orange
yellow
green
blue
blue

13.5.5 Column Data in the Project Table

Several attributes of the property data and columns in the Project Table can be set in configura-
tion files. The default precision to which real properties are displayed and the default units can
be set in the file m2io.ini. The default initial column width in characters can be set in the file
mmproj.ini; Boolean properties have a 2-character default width, and other properties have a
4-character default width. Since the column width and precision can be changed, these two
values are only initial values. The two configuration files are stored in $SCHRODINGER/
mmshare-vversion/data. 

You can copy and edit these files to set the precision, units, and initial column width. The
syntax for the files is given at the top of the file. You might want to set these values for proper-
ties that you use frequently and that are not generated from Schrödinger software. For
example, you might want to specify the precision for properties read from an SD file; the name
to use is r_sd_SD-property. 
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13.5.6 Property Families

When you create a custom property family (which you can do in the Manage Custom Property
Families dialog box, see Section 9.11.13 on page 241), the definition is stored in your profile
directory in the file custom_property_groups. Each custom family is defined on a single
line as a comma-separated list, with the format

family-name, property1, property2, ... 

Wildcard characters can be used to specify multiple properties. 

Each built-in family has a set of default primary properties, which are essentially custom fami-
lies, and are listed in the file default.primary.properties in the Maestro resources
directory, with the same format as above. If you modify these primary properties, this file is
copied to your profile directory as custom.primary.properties with the changes inserted.
Primary properties are the properties that are shown by default in the Project Table. There is no
interrace for defining primary properties for custom families. To define primary properties for
a custom property family, you can edit the custom.primary.properties file (or copy the
default.primary.properties file to your profile directory and add the definition for the
custom property family).

A given property can be present in multiple families. When the property is present, all families
that contain the property are shown in lists of families: for example, many families include
PDB ID as a property. To ensure that families are listed only if one of a set of key properties is
present in the project, a key properties file can be defined, with the same format as for custom
families. If one of the key properties are present, the family is considered to be present. If a
family does not have key properties defined, the primary properties are used instead: if a
primary property is present, the family is present. If primary properties are not defined, the
family is present if one of its properties is present. The default key properties are stored in the
default.key.properties file in the Maestro resources directory. There is no interface for
setting key properties, so you must edit the file to change or add key properties, and write it as
custom.key.properties to your profile directory. 

13.5.7 Maestro Menus

The items that appear on menu bars and their menus are determined by the contents of a
configuration file. The default configuration file is named default.menu and is stored in the
Maestro resources directory. When you customize the menus from Maestro, the customizations
are saved in the file custom.menu in your profile directory.

The menu file uses Json syntax to define the menu bars, the menus and submenus, and the
items on the menus and submenus. Briefly, Json syntax defines objects using key-value pairs,
in which the key is separated from the value by a colon, and pairs are separated by commas.
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The key is a string, given in quotes. The value can be a string (in quotes), an object (in braces
{}) or an array (in square brackets []). Objects are lists of key-value pairs; arrays are lists of
values. 

Each menu bar, menu, or submenu is specified by a key-value pair in which the key is the
unique identifier for the menu bar, menu, or submenu, and the value is an object. The object
contains two key-value pairs: 

• The type key defines the type of object, with the value menubar or menu. There is no
distinction between a menu and a submenu: a submenu is just a menu that is on another
menu rather than a menu bar.

The deleted_standard_ids type is used for a list of standard items that have been
deleted from the menus. It is written when you customize the menus using the Customize

Menus panel.

• The second key-value pair defines the contents of the menu or menu bar. If the object
defines a menu bar, then the key is menus; if the object defines a menu, then the key is
items. The value is an array that lists the menus or menu items (actions). For menus,
separators can also be defined. Each element of the array is an object. 

The menu and menu item objects have a number of keys that are common: name, shortcut,
and status_help. The value for the name key is the name that is shown on the menu, and can
include a mnemonic. It is required in all menu and menu item objects. In the example below
for the Maestro main menu bar (truncated), the mnemonic is indicated by an ampersand
preceding the mnemonic letter. 

   "main_window" : {
      "menus" : [
         {
            "id" : "main_maestro",
            "name" : "&Maestro",
            "shortcut" : ""
         },
...
         {
            "id" : "main_help",
            "name" : "&Help",
            "shortcut" : ""
         }
      ],
      "type" : "menubar"
   },

The shortcut key value defines the key stroke for the item, and is usually only defined for
menu items rather than menus. Shortcut keys are defined in the example below for the Maestro
menu of the Maestro profile:
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   "main_maestro" : {
      "items" : [
         {
            "action" : "maestro_preferences",
            "name" : "Pre&ferences...",
            "shortcut" : "Ctrl+,"
         },
..
         {
            "name" : "separator"
         },
         {
            "action" : "maestro_quit",
            "name" : "&Quit...",
            "shortcut" : "Ctrl+Q"
         }
      ],
      "type" : "menu"
   },

This example shows a separator item, which only has a name key whose value is separator.
This item adds a horizontal line to the menu.

Menu objects have an id key that defines the unique identifier for the menu. Menu item
objects have an action key that is also a unique identifier, for the action to be performed by
the menu item. The action can refer to an standard Maestro action, or it can refer to a Python
script. An example of both types of action is given below: 

   "Homology Modeling" : {
      "items" : [
         {
            "action" : "homology_model_simple_gui.panel",
            "name" : "Simple Homology Modeling...",
            "pyfunc" : "homology_model_simple_gui.panel",
            "shortcut" : ""
         },
         {
            "action" : "tasks_homology_modeling",
            "name" : "Advanced Homology Modeling...",
            "shortcut" : ""
         }
      ],
      "type" : "menu"
   },

The first of these is a Python action, and the action key is the same as the pyfunc key. The
pyfunc key defines the Python function that is executed to perform the action with the
pyfunc Maestro command, in the form module.function. Python actions allow you to add
your own Python scripts to the menus. Although, strictly speaking, you could define the
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action key any way you like for a Python action, you should not modify the action key for
any of the built-in Python scripts (other than defining aliases), as this key is used for other
purposes in Maestro, to locate information on the action.

The second item in the example above is a standard Maestro action, i.e. one that is defined in
the Maestro code. Standard Maestro actions have defined identifiers, which can represent
opening a panel, or performing some operation in the Workspace, for example.

The definition of each standard Maestro action is required to be unique. If you want to use an
action on more than one menu, you can use an alias for the action key, and point to the real
action with the std_action key, as in the example below. This menu contains both menu
items and a menu:

   "QSAR" : {
      "items" : [
         {
            "action" : "phase_qsar_alias_1",
            "name" : "Atom-Based &QSAR...",
            "shortcut" : "",
            "std_action" : "phase_qsar"
         },
         {
            "action" : "phase_fieldqsar_alias_1",
            "name" : "Field-Based &QSAR...",
            "shortcut" : "",
            "std_action" : "phase_fieldqsar"
         },
         {
            "id" : "Property-Based",
            "name" : "&Property-Based...",
            "shortcut" : ""
         }
      ],
      "type" : "menu"
   },

The action alias is formed by appending _alias_n to the standard action identifier, where n is
an integer starting with 1. The action key must be unique, so the value of n should be incre-
mented for each new alias. Aliases can also be used for Python actions, but the std_action
key is not used because the action is performed using the pyfunc key value.

The name and  shortcut keys for a standard Maestro action have default values, which are
replaced if you specify them in the menu file. There are no defaults for Python actions. 

Table 13.2 lists the available keys for a menu or menu item object.  
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If you copy an action for a Python script to another location, you must change the action
value by appending _alias_n to define an alias as well as changing the name value, if you
want to use a different name. 

The pyfunc key is intended for common scripts. When this key is used, Maestro searches for
the Python module in the following locations:

• the directory specified by the environment variable SCHRODINGER_SCRIPTS,
• the common Python directory in the software installation, $SCHRODINGER/mmshare-

vversion/python/common, for scripts available to all users. 

The pyfuncuser key is intended for user scripts. When this key is used, Maestro searches for
the Python module in the current directory or in the scripts subdirectory (folder) of your
Maestro user resources directory.

If you delete standard Maestro actions from your menus in the Customize Menus panel, they
are stored in a block with the type deleted_standard_ids (this is also the name of the

Table 13.2. Keys used in specifying menus or menu items.

Key Value 

id Menu or submenu. The value must be the unique identifier of a menu object. 

action Unique identifier of the action to be performed by Maestro when the menu item is 
chosen. It can be a standard Maestro action, or a name that you choose to be asso-
ciated with a Python script, or it can be an alias. If it is an alias to a standard action, 
the std_action key must be given. 

std_action Unique identifier of a standard Maestro action, used when the action is an alias. 
Aliases are needed when the data associated with the action is modified for use in 
another menu. 

name Display name for the menu or menu item. The value is the name that appears on 
the menu bar or the menu. Append an ellipsis (three dots) to the name if the action 
is not completed by clicking on the menu item. Include an ampersand before the 
mnemonic letter, if needed. A special case of the value is separator, which 
includes a horizontal line on the menu. 

pyfunc,
pyfuncuser 

Python function to be called when the action is performed, usually in the form 
scriptname.method. This key must be included if the action key for the menu 
item is not a standard Maestro action. Use pyfunc for Python scripts in the instal-
lation, and pyfuncuser for Python scripts installed in your user area. 

shortcut Shortcut key sequence for the action, such as CTRL+O. 

type Type of object. This key identifies whether the object is a menu or a menu bar. 
Allowed values are menu or menubar. 
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object). This block preserves the information on the deleted items, and makes it easy to restore
them. 

There are some items that cannot be configured by this mechanism. One of these is the Scripts

menu, which is configured from the Manage Scripts panel. The others are the Quit item on the
Maestro menu and the Undo item on the Edit menu. These items cannot be removed, and
consequently the Maestro and Edit menus cannot be removed (though they can be renamed).

To make use of a customized menu that is not saved in your profile, you must start Maestro
with the option -u menu-file-name. On Windows, you can add this option to your Maestro
shortcut as follows:

1. Right-click on the shortcut and choose Properties.

2. In the Target text box, append -u "path-to-menu-file" to the text.

13.5.8 Rotamers

The rotamers that can be selected in the Rotamers dialog box are defined in a resource file,
rotamer.res, which is stored in the installation resources directory. For each rotamer, the file
lists the residue name, its frequency of occurrence (percentage), and the chi angles for the
rotamer. You can copy this file to your Maestro user resources directory and edit it, if you want
to make changes that apply to your own use of Maestro, or edit the copy in the installation
resources directory if you want to change it for all users. If you want to add rotamers for a new
residue type, check whether the residue type and its dihedrals are defined in the file
chidef.res, and if not, add the appropriate definitions. This file is also in the installation
resources directory.
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Maestro has an extensive set of options for the default settings in various panels and the default
behavior of Maestro. These options can be set in the Preferences panel. To open the Prefer-
ences panel, choose Maestro → Preferences, or type CTRL+, in the main window. You can
also open the Preferences panel with the relevant preferences displayed from the Project Table

panel (Table → Preferences), the Manage Surfaces panel (click Preferences), and several
other panels.

Figure 14.1. The Preferences panel.

The preferences are collected into major groups, and in each of these there are collections of
settings, or subgroups (described in the sections below). This classification is represented by a
tree structure in the left of the panel, with turners to open and close the groups. Clicking on one
of the “leaves” displays the collection of settings in the right of the panel, each of which
contains controls for modifying Maestro’s default behavior. Some settings are in more than one
collection, because they can be classified in several ways. 

To find a preference, you can search for text that is in the tree text, the preference and heading
text, or the preference tool tip text. Enter the desired text in the Search text box above the tree.
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As you type, the tree is pruned to show only the leaves in which the text is found. To show the
full tree again, clear the text box by clicking the clear button at the right.

Changes made to settings in the Preferences panel are persistent: they define Maestro’s default
behavior until you modify them. A file called prefer.cmd, which contains all of your Maestro
preferences, is created and saved to your profile. You should not edit this file directly, because
Maestro overwrites it. If you want to add custom preferences that are not settable from
Maestro, you should add them to a maestro.cmd file in your profile. This file is executed
when Maestro starts, and takes precedence over prefer.cmd.

14.1 General Preferences

14.1.1 History

Command history

These options can be used to limit the number of Maestro commands stored, and therefore the
number that is available in the Command Script Editor panel. Select Unlimited to keep all
commands; select Limited and enter a value in the text box to limit the number of commands to
the specified number.

Recently used list

The most recently used projects and the most recently imported files are listed on the Project

menu for quick opening. This text box allows you to specify how many items are listed on each
list. 

Log project operations to the annotations file

Keep a record of operations on the project in the project annotations file. The record of opera-
tions is displayed in the Project Summary panel.

14.1.2 Directories

The Maestro current working directory is the directory to which file, directory, and project
selectors open by default, and to which job files are written. The default initial working direc-
tory on Linux is the Maestro startup directory, and on Windows and Mac is the Schrodinger
folder in your Documents folder. By changing the settings in the Directory tab of the Prefer-
ences panel, you can specify a default current working directory. 

You can choose from Maestro’s current working directory, Project directory, Parent of project
directory, Project jobs directory, and Other. These options are also in the Jobs–Directories

section of the Preferences panel. See Section 14.13.4 on page 376 for details of the options.
Schrödinger Software Release 2015-2 



Chapter 14: Setting Preferences
You can provide a custom directory that is linked to the Custom icon in the file, directory, and
project selectors. 

You can choose from two standard locations as well as your own location. 

• Maestro installation directory—Set the custom directory to the directory in the installation
that contains the Maestro software and resources. The actual path is displayed in the tool
tip for this option.

• Maestro launch directory—Set the custom directory to the directory from which Maestro
was started, on Linux, or the Schrodinger folder in your documents folder on Windows
and Mac. The actual path is displayed in the tool tip for this option.

• Other (specify below)—Specify the directory in the Directory text box.

Maestro stores scratch projects in a temporary location, which you can specify in the Tempo-

rary project location text box, or click Browse and navigate to the desired location. The location
should be large enough for your temporary projects, and for efficiency should be on a local file
system. This location will be used for temporary projects the next time you start Maestro. You
can also set the temporary location in the SCHRODINGER_TEMP_PROJECT environment vari-
able. This value overrides the preference specified here. 

In the absence of any specification, the TMPDIR environment variable is used for the location,
followed by the default Schrödinger temporary directory, which is 

On Windows, LOCALAPPDATA is set to C:\Users\username\AppData\Local.

See Appendix A of the Installation Guide for instructions on setting environment variables. If
space is limited on TMPDIR or your home file system, you should consider setting the tempo-
rary location for projects. 

14.1.3 File extensions

In this section you can change the default file extensions that are used when Maestro exports
structures to a file. These extensions are appended to file names when you export structures
from the Export dialog box if they do not already have an extension. They do not include exten-
sions for file formats converted by Babel. 

Linux, Mac:  $HOME/.schrodinger/tmp 

Windows:  %LOCALAPPDATA%\Schrodinger\tmp 
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Extensions for compressed formats can be set for Maestro and SD files. On Unix, it can be
useful to use the extensions mae.gz and sdf.gz, so that the files can be recognized by appli-
cations such as gunzip. On Windows, use of maegz and sdfgz ensures that the files can be
associated with Maestro as the default application for opening them, whereas files ending in
.gz are recognized as archives. 

14.1.4 Appearance

Show tooltips

When the pointer is paused over a control, show information about the control in a box near the
control after a short delay. The box is hidden after a period of time, or when the pointer is
moved. This information in a box is known as a tool tip or balloon help. 

Main title bar information

Show the selected information in the title bar of the main window, after the application name
(Maestro). The version number is shown next to the application name, followed by the current
working directory, if both are selected.

Set all toolbar styles to

Set the style for the toolbar buttons, by clicking the appropriate button. The style is applied
immediately. The buttons can be displayed as icons, text, or both, with text beside or under the
icon. Click the button for the style that you want to use. The Default button places text under
icons for all toolbars except the Fragments toolbar (main window) and the ePlayer toolbar
(Project Table panel).

14.1.5 Application Fonts

These font selection tools allow you to set the fonts for text in various parts of Maestro. You
can choose the font type, the size, and the style. The text types you can set the font for are:

• Regular (text in all panels except for the items below)
• Text editing
• Project Table headers
• Project Table cells
• Toolbar buttons

An example of the font size is given below each set of font selection tools. You must restart
Maestro to apply the new font size. The font size is stored in the file maestro_user.sty in
your Maestro user resources directory (see Section 13.5 on page 324).
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14.1.6 Panels

Allow docking of panels

This option allows panels to be docked into the Workspace (main window) or into a “floating
window” named Docked Panels, which is positioned to the right of the main window by
default. You can choose where the panels are docked by selecting one of the Location options.
Most of the panels other than those on the Applications and Workflows menu are dockable. This
option is selected by default. If it is not selected, when you open these panels, they are opened
outside the Workspace and cannot be attached to the Workspace (docked).

Show dialog boxes at the position of the pointer

When a dialog box opens, center it on the current pointer position. If you turn this option off,
the dialog box is displayed at its last displayed location (or its default location if it has not been
displayed).

Always show panels on top of main window

Show all panels in front of the main window, and ensure that they do not go behind the main
window. 

Default homology modeling interface

Select the default interface to use for homology modeling, when choosing Tasks → Homology

Modeling or Applications → Prime → Homology Modeling. The options are:

• Multiple Sequence Viewer—Use the Multiple Sequence Viewer panel for homology mod-
eling.

• Structure Prediction Wizard—Use the Prime Structure Prediction panel for homology
modeling.

• User choice—Open the Homology Modeling dialog box to present the choice between the
two interfaces each time.

14.1.7 Quitting Maestro

Select the information that is shown or saved when Maestro quits.

Warn when quitting Maestro

Display the Quit panel when quitting Maestro, which provides an opportunity to cancel the quit
operation. 
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Warn if PyMOL is running when quitting

Display a warning if a PyMOL session launched from Maestro is still running when quitting
Maestro. Quitting Maestro also forces termination of this PyMOL session, so the warning
enables you to save any work done in PyMOL before Maestro quits and closes PyMOL. 

Save panel layout 

Save the panels layout (size, location) of all panels that have been opened in a Maestro session
in a resource file when Maestro quits. The layout is read the next time Maestro is started. You
can also save the layout by choosing Window → Save Layout. 

Write command log file 

Write a log of commands used in the Maestro session to the log file specified in the text box.
The log file is written to Maestro’s working directory. This information can be useful to
Schrödinger support staff when responding to any problem you report. 

14.2 Project Preferences

These preferences govern opening and closing of projects, properties, Project Table display,
and saving modifications of a Workspace structure to the corresponding project entry.

14.2.1 Opening and Closing Projects

Open last project on startup 

You can choose to open the last project you were working on when you start Maestro. This
feature is particularly useful if you are working on one project over a period of time. You can
always open a specific project when you start Maestro under UNIX by using the -p option. See
Section 2.1 on page 11 for more information on Maestro options. 

Show Project Table

Display the Project Table when you open a named project. This is the default behavior, but it
does not apply to the scratch project. 

Show Entry List

Display the Entry List when you open a named project. This is the default behavior, but it does
not apply to the scratch project. 
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Warn before closing a scratch project

When closing a scratch project, show the Save Scratch Project dialog box, which gives you the
choice of saving the project with a name, discarding it, or canceling the operation that closes
the project. This dialog box is shown if you explicitly close the project (Project → Close), open
another project, or quit Maestro with a scratch project open. 

Turn off Workspace Style Reapply when closing a project

When closing a project, turn off the Reapply button on the Style toolbar, so that the current
style is not changed when the Workspace changes. 

14.2.2 Backups

These settings can be used to make a daily automatic backup of the project that is open in your
Maestro session, to control the number of backups (either automatic or manual), and to receive
notification of the status of a backup. 

For more information on project backups, see Section 9.1.3 on page 176.

Automatic daily backup 

Select this option to request an automatic daily backup of the current project. The following
options can be set for the backup:

Schedule for 

Schedule the backup for the specified hour (on a 24-hour clock). 

Post-backup check 

Choose an option for checking on the success of the backup. The options are:

• None—Do not do any checking.
• Project exists—Check that the backup project exists.
• Required files exist—Check for the existence of files inside the project that are required

for a valid project.
• Count entries and properties—Check that the number of entries, number of included

entries, number of properties, and other counts match.
• Entry structure files exist—Check that the structure files for each entry exist and are valid.

This option unzips the project temporarily, so it requires as much disk space as the full
project.
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Send EMail notifications 

Select this option if you want e-mail notification with details of the backup. If you select this
option, you must fill in the information in the following fields:

• SMTP server —Full name of the SMTP mail server used to send e-mail notification. 
• Port—Port to use for the SMTP mail server. 
• Security—Type of security to use for e-mail. Choose from None, STARTTLS, or SSL/

TLS. 
• From—Full e-mail address of the user account from which e-mail notification is sent. 
• Password—If sending e-mail requires a password, specify it in this text box. 
• To—Full e-mail address of the user account to which e-mail notification is sent. 

Limit the number of backups 

Select this option to limit the number of backups.

Save at most N backups 

Specify the maximum number of backups to save. This option is only available if you choose
to limit the number of backups. When the number of backups exceeds this limit, the oldest
backup is removed. This means that you must have space for one more backup than the number
set, as the new backup is written before the oldest backup is removed. 

Display dialog 

Select an option for when to display a notification dialog box after a backup finishes. The
choices are Never, Only when an error occurs, and Always. 

Alternate backup location

Specify an alternate location for backups, by clicking Browse and navigating to the desired
location. The location is shown in the text box when you click Choose in the directory selector
that opens. When you first set an alternate backup location, the Alternate backup location

option under Store new backups in is automatically selected, so that the new backup location is
used. 

Store new backups in

Specify where to store new backups. You can choose from Same directory as project (the
default), or Alternate backup location, to use the location you specified. 
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14.2.3 Entry Changes

Save workspace changes 

When you include an entry in the Workspace, you are working with a copy of the structures in
that entry. By default, Maestro saves, or synchronizes, changes in the Workspace version of the
structure to the entry with which it is associated when you make the changes. The other two
preferences allow you to dictate what changes are saved to the project. If you select When

approved, you are prompted to save Workspace changes when you attempt to exclude that
entry from the Workspace. If you choose not to save, your changes are lost. If you select Only

when specifically requested, Maestro does not prompt you to save changes made to Workspace
structures: you must click the disk icon in the status bar to save any changes, or choose Project
→ Save Workspace Changes. 

14.2.4 Importing Structures

Import associated data files

If the structure file has other data associated with it, the data can be imported into the project
and associated with the relevant entries, by selecting this option. The mapping of the data to
the entries is done in a file with the suffix .smap. This option is selected by default.

For Desmond files, import only first structure

If you want to import only the first structure from a Desmond CMS file, select this option.

For PDB files, read alternate locations

If the PDB file contains alternate positions, you can read them by selecting this option. If this
option is not selected, the coordinates for the atoms with the highest occupancy are read, and
the rest are ignored. You can display alternate positions from the Workspace menu. 

Open Protein Preparation Wizard after importing PDB file

If you are importing a PDB file, you can select this option to open the Protein Preparation
Wizard panel automatically when the structure is imported, so that you can prepare the protein
for use in various applications.

For PDB files, color by conversion status

When importing a PDB file, color the structure by the status of the conversion. The color
scheme is described in Table 3.2 on page 50.
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For pose viewer files, turn on pose viewing

If a pose viewer file is imported, you can perform the setup in the Project Table automatically
by selecting this option. You can then immediately start viewing poses—see Section 6.1 of the
Glide User Manual for more information. This option is selected by default.

For SD files, create titles from

SD files often do not have a title property, so you must choose one to display in the project
from the options under this heading. The default is SD molecule name. To specify an alterna-
tive property for the title, select SD property and enter the property name in the text box. 

Replace Workspace

If this option is selected (the default setting), Maestro automatically clears existing structures
from the Workspace. To import new structures without removing the Workspace contents,
deselect this option. 

Fit to Workspace following import

Structures that are imported are not necessarily centered on the coordinate origin, and might
not be visible even though displayed. To ensure that the view is centered on the structures and
zoomed to display all atoms upon import, select this option. (This setting is persistent between
Maestro sessions.) 

Include in Workspace

To specify which structures are to be included in the Workspace, choose one of the options
from this option menu: No Imported Structures, First Imported Structure, or All Imported Struc-
tures. The default is First Imported Structure. If you choose No Imported Structures and
Replace Workspace is selected, the Workspace is cleared.

Create groups for

Structures can be added to the Project Table as single entries or as groups. You can control how
the entries are grouped on import by selecting an item from this option menu. By default,
groups are created for files with multiple structures. The groups are named after the files,
minus the extension. You can also create a single group for all structures from all imported
files, and provide a name in the Group name text box.

Map SD properties to existing non-SD properties

Select this option if you want to map properties in an imported SD file to existing properties in
the project other than SD properties. You can also choose whether to modify the mapping each
time you import an SD file (Always) or not to use a mapping (Never). Choosing Never is the
same as deselecting the main option. If you choose Always, to modify the mapping, the Map
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Properties dialog box opens on import of an SD file. In this dialog box you can select a prop-
erty from the project for each property in the input file (in the first structure). The property
mapping is applied when the file is imported. The dialog box also allows you to save and load
property mappings, so you can use different mappings for different files or projects.

14.3 Project Table Preferences

14.3.1 Properties

These options affect the display of properties and editing of properties.

Show Entry Name

This option controls whether the Entry Name property is shown in the table. It is hidden by
default. 

Show Stars in new projects

This option controls whether the Stars column is shown when a project is created. To control
the visibility of this column thereafter, use the Properties menu of the Project Table panel.

Show 2D structure in new projects

This option controls whether the 2D structure is shown by default when you create a new
project (including a scratch project). Thereafter, the visibility of the Stars column can be
controlled from the Properties menu of the Project Table panel. 

Warn when editing properties

When this option is selected, a warning dialog box is displayed when you edit a property value,
and you must confirm the change to the property.

When new entries are added

These options control which new properties are shown in the Project Table when new entries
are added. 

• Show all properties—Show all new properties when entries are added.

• Show only primary properties—Of the new properties that are added to the Project Table,
show only the primary properties. The exception is properties imported from an SD file,
all of which are shown by default.

• Do not show any new properties—Hide properties that are not already displayed in the
Project Table when entries are added. This option is useful if you have a particular set of
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properties displayed that you are interested in and don’t want the set to change when you
add entries.

Justification

These options determine how numeric and textual values are justified in the table cells. The
options for each type of data are Left, Center, and Right. By default, numeric values are right-
justified, which is equivalent to aligning numbers on the decimal point, because real properties
are generally displayed with a fixed number of decimal places. Text is aligned left by default. 

Sort string values

These options affect the order in which sorting is done when the property used to sort the table
is a string. This preference applies to other tables and lists in Maestro as well as the Project
Table.

• Alphanumerically—Sort strings with upper-case letters before lower-case letters and
lower-case letters before numbers. A sequence of digits is treated as a single number for
the purpose of the sort. This allows a sequence of strings that have increasing values of
the numerical part to be sorted in ascending numerical sequence, while the rest is treated
as a string. For example, if the sequence of strings was ligandn, where n ran from 1 to
100, ligand10 would follow ligand9, and ligand100 would follow ligand99. In
ordinary string sorting, ligand10 would follow ligand1, and ligand100 would fol-
low ligand10.

• Alphabetically—Sort strings in case-insensitive alphabetic order, with numbers preceding
letters (“dictionary order”). No special treatment is given to sequences of digits.

Default precision for properties

Real-valued properties are displayed in the project table to a set number of decimal places
(precision). Some properties have predefined precision. You can set the number of decimals
used for properties that don’t have a defined precision in this text box. This value is used as the
default for new properties and properties that are imported and don’t have a predefined preci-
sion. This setting affects only the display precision, not the value of the property itself.

You can set the number of decimal places for individual properties, and also choose to use E
notation, in the Set Decimal Places dialog box—see Section 9.11.7 on page 236.

Show 2D image in Row column tooltip

When the pointer pauses in the Row column, show the structure as a 2D image in a tool tip. 
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Add N pixels of padding when fitting column width to data

Add padding of the specified number of pixels to either side of the column when using the
commands that fit the columns to the data (Table → Columns → Fit to Data).

Scroll bar

The scroll bar in the Project Table can be placed on either side of the table. These two options
allow you to choose which side to place it on. 

14.3.2 Colors

These settings control the colors used in the Project Table. Each of the color settings show the
color and have an Edit button to change the color. Some of the colors are optional, others are
always applied. The optional colors are only applied in place of the default color.

Default

Set the color for unselected rows. 

Selected entries

Set the color used for selected entries (rows), both inside and outside entry groups. 

Partially selected groups

Set the color used for the group row when some but not all of its entries are selected. 

Fully selected groups

Set the color used for the group row when all of its entries are selected. 

Standard fixed area

Set the color used for the standard (default) columns in the fixed area. The color is only applied
if this option is selected. 

Nonstandard fixed area

Set the color used for the nonstandard columns in the fixed area (columns that you move to the
fixed area). The color is only applied if this option is selected. 

Row numbers

Set the color used for the row number column (Row). The color is only applied if this option is
selected. 
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Column headers

Set the color used for the column heading row (Row). The color is only applied if this option is
selected. 

Highlight alternating rows 

Select this option to use different shades of the colors for odd and even rows in the table. 

Show row borders

Draw a horizontal line at the bottom of each row to mark the boundary between rows.

Reset to 

These buttons reset the colors. Default sets the colors to the default values. Classic sets the
colors to those used in Suite 2011 (Maestro 9.2) and earlier. 

14.3.3 Groups

These settings control behavior related to entry groups. 

Warn when deleting entry groups 

Post a warning dialog box when an empty group is about to be deleted. The default is not to
post the warning.

14.4 Workspace Preferences

These preferences control the behavior of actions and appearance of objects in the Workspace.

14.4.1 Picking

These settings affect the appearance and behavior of picking actions in the Workspace (click or
right-click). 

Beep when picking

Select this option to make the system beep for each successful pick in the Workspace. 

Picking cursor size

Choose a small, medium, or large picking cursor. The sizes are in pixels. 
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Show Workspace menu on right-click-and-hold

Select this option to display a shortcut (context-sensitive) menu when you right-click in the
Workspace. You can set the time-delay for displaying this menu by entering a value in the
Delay before showing menu text box. Right-clicking and dragging is used for translation of a
structure. If the delay is too short, the menu might be displayed before you start dragging. 

Ignore Workspace click when giving focus to main window

Ignore any click in the Workspace when the main window does not have focus, and you are
clicking on it to give it focus. Setting this preference prevents an unintended action from taking
place when you happen to click in the Workspace to get focus in the main window. This prefer-
ence is on by default. If the focus policy of your window manager puts focus in the main
window without clicking (follows mouse), you might want to turn this option off. 

14.4.2 View Animation

Animate view changes

This option enables animation of changes in the view: the structure changes from one view to
another over a period of time, rather than instantly. View animation is done when an automatic
change in view is made, such as spot centering, resetting the view, and fitting to Workspace.
The duration of the animation can be controlled by entering a value in the Duration text box.

Animation can be turned off if the distance over which the structure moves is greater than a
given threshold, by selecting Limit animation distance, and entering the distance threshold in
the Maximum distance text box. The default threshold is 10 Å.

By default, the animation has a constant speed (linear). If you select Non-linear animation, the
animation starts slowly, speeds up in the middle, then slows down at the end.If you are using
animation for a smooth change between multiple views, linear animation may be preferable.

14.4.3 Translation

Keep center of rotation fixed while translating

This option keeps the center of rotation at its current position in the Workspace when the struc-
ture is being translated. When the option is deselected, the center of rotation moves with the
structure when it is translated. The default location for the center of rotation is the center of the
Workspace. The center of rotation is updated by spot-centering and by a fit-to-Workspace.
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Keep electron density centered while translating 

When translating the Workspace structure, selecting this option ensures that the cube in which
the electron density is displayed remains at the same place relative to the Workspace view. The
effect is that the structure with its electron density appears to move through the cube. The size
of the cube is set in the Manage Surfaces panel—see page 309.

14.4.4 Rotation

Sensitivity in rotation

Use the slider to set mouse sensitivity for rotation. Larger values result in faster rotation. 

Keep center of rotation fixed while translating

This option keeps the center of rotation at its current position in the Workspace when the struc-
ture is being translated. When the option is deselected, the center of rotation moves with the
structure when it is translated. The default location for the center of rotation is the center of the
Workspace. The center of rotation is updated by spot-centering and by a fit-to-Workspace.

Display center of rotation

Display a marker at the center of rotation. The marker is a set of three circles perpendicular to
each other that indicate the orientation of the view. 

Smoother local rotation 

This option makes local rotation appear to happen smoothly. Turning it off can result in more
jerky rotation, but may prevent rotation from continuing after the mouse has stopped moving.

14.4.5 Trackpad

The Trackpad section is only visible if you have a multi-touch trackpad. 

Pinch gesture sensitivity for zoom

This slider controls the rate at which zooming is done as you pinch.

14.4.6 Transformations

Keep center of rotation fixed while translating

This option keeps the center of rotation at its current position in the Workspace when the struc-
ture is being translated. When the option is deselected, the center of rotation moves with the
structure when it is translated. The default location for the center of rotation is the center of the
Workspace. The center of rotation is updated by spot-centering and by a fit-to-Workspace.
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Display center of rotation

Display a marker at the center of rotation. The marker is a set of three circles perpendicular to
each other that indicate the orientation of the view. 

Keep electron density centered while translating 

When translating the Workspace structure, selecting this option ensures that the cube in which
the electron density is displayed remains at the same place relative to the Workspace view. The
effect is that the structure with its electron density appears to move through the cube. The size
of the cube is set in the Manage Surfaces panel—see page 309.

Include alternate positions in local transformations

When performing a local transformation on a set of atoms that include atoms with alternate
positions, transform the coordinates for both alternatives. Deselect this option to transform the
displayed location and not the alternate. 

14.4.7 Dipole Moment

Choose options for the display of an arrow in the Workspace to represent the dipole moment. 

• Show disk on positive end of arrow—Show a disk around the positive end of the arrow.

• Show positive and negative colors—Color the arrow with a color gradient from blue (neg-
ative) to red (positive).

• Show arrow from positive to negative—Show the arrow pointing from positive to negative
(“chemists’ convention”). Deselect this option to show the arrow pointing from negative
to positive (“physicists’ convention”).

14.4.8 Clipping Planes

These options affect the adjustment of the clipping planes (the planes between which objects
are displayed, and outside of which objects are hidden). 

Adjust clipping planes when focusing on a substructure 

When zooming in to a set of atoms that has been selected by one of the processes listed below,
adjust the clipping planes to within the distance specified in the Clip to within text box.

• Selecting a residue in the residues table of the Density Fit panel (PrimeX).
• Selecting a rotamer in the Residues table of the Rotamers dialog box.
• Middle-clicking a residue in the Workspace sequence viewer (to zoom in to it).
• Finding any set of atoms using the Find toolbar.
• Fitting a ligand to the Workspace.
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Zoom clipping planes with Workspace

Select this option to adjust the clipping at the same time as zooming in or out. The image in
clipping planes window changes size when zooming, to reflect the new clipping planes
settings. If this option is deselected, the clipping planes are not adjusted when zooming, and
the image in the clipping planes window stays the same size. This option is off by default.

Clip increment

Specify the increment by which the clipping planes are moved when you move them forward,
backward, together, or apart (View → Move Clipping Planes). The increment is a percentage of
the current width of the region between the clipping planes. 

14.4.9 Fonts

These settings control the fonts used for text that is displayed in the Workspace: atom labels,
measurements, adjustments, and single-entry feedback. It does not include caption or highlight
text, for which there are separate font controls. You can choose the font type, the point size,
and the style (bold or italic) using the option menus and buttons.

14.4.10 Fitting

Fit to Workspace for these actions 

These options control when an automatic fit to the Workspace is performed. The fitting only
applies when you include entries in the Workspace: it does not apply to entry exclusion or to
the results of job incorporation. 

• Single entry inclusion—fit to the Workspace when the Workspace contents are replaced
by the inclusion of a single entry from the Project Table or Entry List (Entry → Include or
Entry → Include Only, click the In column). 

• Stepping through entries (ePlayer)—fit to the Workspace when using the ePlayer or the
left and right arrow keys to step through a set of entries, including only one entry per step.
This does not include using the arrow keys to simultaneously include multiple entries.

• File import—fit to the Workspace when entries are added to or replace the Workspace
when importing structures from a file. 

• Other entry inclusions—fit to the Workspace when entries are included in other circum-
stances from the Project Table or Entry List. This option covers inclusion of multiple
entries in the same operation. 
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Fit target

Select an option for the atoms that should be fitted to the Workspace when an automatic fit is
done, from All atoms or Ligands. If you have multiple ligands, all ligands are included in the
fitting procedure. The fitting itself is done to the displayed atoms of the selected target, and
does not include undisplayed atoms. 

Zoom clipping planes with Workspace

Select this option to adjust the clipping at the same time as zooming in or out. The image in
clipping planes window changes size when zooming, to reflect the new clipping planes
settings. If this option is deselected, the clipping planes are not adjusted when zooming, and
the image in the clipping planes window stays the same size. This option is off by default.

Fit to Workspace when growing

When you are building a structure in Grow mode, Maestro fits the structure to the Workspace
after each fragment addition by default. To prevent the fitting, deselect this option.

Enhance fog

Enhance the fogging depth cues when fitting to the Workspace.

Fit margin

Specify the margin in angstroms around the structures or selected atoms when fitting them to
the Workspace. 

14.4.11 Zooming

These settings affect the display when zooming in and out in the Workspace.

Zoom clipping planes with Workspace

Select this option to adjust the clipping at the same time as zooming in or out. The image in
clipping planes window changes size when zooming, to reflect the new clipping planes
settings. If this option is deselected, the clipping planes are not adjusted when zooming, and
the image in the clipping planes window stays the same size. This option is off by default.

Minimum size of Workspace for automatic zooming

Set the minimum size of the Workspace in angstroms for automatic zooming, that is, zooming
in that is performed as a result of other actions rather than user-initiated zooming. When this
setting is on, zooming in stops when the distance across the Workspace either horizontally or
vertically reaches the specified value. This option essentially imposes a maximum zoom level,
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so that there is a limit to the displayed length of bonds, and a single atom will (in general)
never fill the screen. It guarantees that a defined amount of context will always be visible in the
Workspace when zooming in. The context is also affected by the Fit margin setting—see above.

14.4.12 Depth View 

These options control the enhancement of the depth view using approximate ambient occlu-
sion, which takes into account the ambient lighting blocked by nearby atoms. It is applied only
to atoms in the CPK representation.

Enhanced depth view 

Turn on or off the enhancement of depth viewing. This can also be done from the View menu in
the main window or by pressing D when the pointer is in the Workspace. 

Depth factor

Use this slider to change the amount of depth enhancement applied. 

Cutoff slider

Adjust the grid size for the ambient occlusion calculations. A larger grid includes more atoms,
which is desirable when there are large pockets in a protein structure, for example. However,
this also makes the calculation slower. 

Restore Defaults 

Restore the default values for the depth factor and cutoff. 

14.4.13 Changes

These settings control how changes in the Workspace are saved to the project.

• Automatically—Maestro automatically saves any changes to entries in the Workspace to
the project.

• When approved—Maestro determines when changes will be lost if they are not saved,
and prompts you to save the changes. You must make a choice before proceeding.

• Only when specifically requested—Maestro never determines that changes must be saved.
You must explicitly synchronize changes or they will be lost. To synchronize changes,
click the exclamation point in the status bar of the main window.
Schrödinger Software Release 2015-2 



Chapter 14: Setting Preferences
14.4.14 Periodicity

These settings control the display of markers for periodic structures in the Workspace.

Unit cell

Make settings for the display of the unit cell in the Workspace. 

Show 

Choose an option to display the unit cell boundaries, the lattice vectors, or both.

Line width

Adjust the width of the lines in the unit cell boundaries and the lattice vectors with this slider.

You can set the color of the lines using the color button, which opens a color selector. 

Polyhedrons

Make settings for the display of polyhedrons

Polyhedron color

Set the color of the polyhedrons. Clicking the button opens a color selector. The current color
is displayed on the button.

Opacity

Set the opacity of the polyhedrons. 

14.4.15 Crystal Mates

Rename crystal mate chains

If you want to generate unique chain names for the crystal mates, select this option. By default
the crystallographically related copies have the same chain name as the original. 

14.4.16 Graphics

The setting in this section control features that relate to the graphics card or graphics libraries.

Requested OpenGL level 

These options select the OpenGL library version that is used to draw objects in the Workspace.
Two versions are available: 1.2 and 2.1. OpenGL 2.1 has features that are used to provide
higher quality and improved performance of the rendering when using hardware graphics.
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If you use -SGL when starting Maestro, the performance with OpenGL 2.1 is much slower than
that of 1.2, because hardware acceleration is not being used. However, if you want a high-
quality single image, for example, you can select 2.1.

The Best option selects the best available OpenGL level. OpenGL 2.1 is used if you have an
NVIDIA or an ATI graphics card with proper driver support. OpenGL 1.2 is used if Maestro is
started with the -SGL option, if Maestro is run over a network, or if OpenGL 2.1 is not avail-
able or is not adequately supported (as is the case for some graphics cards that claim OpenGL
2.1 support). The version actually used is displayed below the options. 

You must restart Maestro for the changes in the OpenGL level to take effect.

Full scene antialiasing 

Turn on full-scene antialiasing, which smooths the appearance of objects in the Workspace. 

Quality 

The settings in this section control the quality of the molecular representation. The settings
depend on the OpenGL level set in Workspace – Graphics (see Section 14.4.16 on page 355).
The OpenGL 2.1 implementation is usually much faster than the OpenGL 1.2 implementation,
so settings for OpenGL 1.2 are not needed for OpenGL 2.1.

For OpenGL 1.2, the following settings can be made:

Use simplified representation when moving 

When a structure is being moved in the Workspace, display it at lower resolution than when it
is at rest, and in a simplified representation. This speeds up the operation on the structure. This
option is off by default, but is turned on when you select the Performance rendering option on
the Style toolbar. 

Use thick lines for tubes when rotating

In the simplified representation, use thick lines (of the same thickness as the tubes) when
rotating. This makes the simplified representation look a bit more like the normal representa-
tion. The default is to use wire frame representation for bonds in the simplified representation. 

Moving resolution 

Specify the resolution to use for the structure when it is moving, on a scale from 1 to 50. Lower
numbers mean lower resolution (lower quality). 
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Resting resolution 

Specify the resolution to use for the structure when it is at rest, on a scale from 1 to 50. Lower
numbers mean lower resolution (lower quality). 

For OpenGL 2.1, the following setting can be made:

Use faster sphere-drawing method 

Use the faster method for drawing spheres. This method provides up to 20% speedup when
there are many spheres in the Workspaces, such as for a protein in CPK representation. It is not
used when perspective is enabled. 

14.4.17 Sequence Viewer

These settings control how sequences are displayed in the sequence viewer. The options are
also available on the Sequence viewer shortcut menu.

Wrap sequences

Wrap the sequence display so that long sequences are displayed across multiple lines with
vertical scrolling rather than on a single line with horizontal scrolling. 

Display SSA

Show the secondary structure assignment for the sequence. 

Align by residue number

Align the sequences in the sequence viewer by residue number. (Does not affect the alignment
of the structures.) This option enables gaps to be displayed in the sequence viewer. 

Display non-protein molecules

Display non-protein molecules in the sequence viewer. Three lines are used, for ligands,
waters, and ions.

Proximity cutoff 

Set the distance cutoff for the sequence viewer proximity color scheme.

14.4.18 Display/Undisplay Atoms

Display Within includes nonpolar hydrogens

When displaying residues within a given distance of the currently displayed atoms, select this
option to display nonpolar hydrogens. By default only polar hydrogens are displayed.
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14.5 Feedback Preferences

14.5.1 Atom

These settings control the atom information that is shown in the status bar when you pause the
pointer over an atom. By default, the changes you make apply only to the current project, and
are stored with the project. You can also store the settings as preferences for all projects, by
clicking Save Preferences.

Show atom feedback in Status Bar

This option enables the display of selected properties in the status bar when the pointer pauses
over an atom in the Workspace. The last property in the list can be selected from the Property

field list. The default for this property is the entry title. See Section 2.5 on page 23 for more
information about what is displayed.

Show index of object to pick

When picking in the Workspace, show the index of the object that is being picked (atom, mole-
cule, ...) as the first item in the Status Bar, in the format Pick: index.

Show property 

This noneditable text box shows the property that is displayed. To choose the property, click
Select to open a property selector. This is the last property in the atom feedback. The default
for this property is the entry title.

Save Preferences 

Click this button to save the settings in this panel as preferences that apply to all projects. The
default is that the settings apply only to the current project. 

14.5.2 Properties

These settings control the properties that are displayed in the Workspace for a target entry. 

Show properties in Workspace

Display project properties for a single entry, termed the “target” entry, in the top left corner of
the Workspace. The target entry is the entry defined by the following conditions:

• Only one entry is included in the Workspace
• More than one entry is included in the Workspace, but only one is not fixed
• More than one entry is included in the Workspace, but only one is selected
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If none of these conditions is met, there is no target entry, and no feedback is displayed. The
symbol in the In column of the Project Table is red for the target entry.

Include property names 

Select this option to include the names of the properties along with the property value, in the
form name:value. 

Font

Choose a combination of font, size, and weight for the text shown in the Workspace from the
option menus. The available fonts are those installed on your system. 

Color

Set the color for the text shown in the Workspace by clicking on the button and choosing a
color. The button displays the current color. 

Properties to show

List of properties to display in the Workspace for the target entry. You can select properties in
the list to delete with the Delete button. To add properties to the list, click Add and select the
properties in the property selector dialog box that opens. The default properties displayed are
the entry title and the PDB ID.

Save Preferences 

Click this button to save the list of properties as preferences that apply to all projects. By
default, the property selection applies only to the current project. 

14.5.3 Job

Show job status feedback in Workspace

Show the status of the last job submitted from the current project in the top left corner of the
Workspace, in the format jobname:status.
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14.6 Atom/Bond Labels Preferences

These preferences control the appearance and the location of atom labels. Changes made in the
label preferences are immediately applied to existing labels.

Font

Choose the font type, size, and style for atom and bond labels and Phase feature labels.

Field separator 

By default, the label fields are separated by a space. To add a separator such as a colon, semi-
colon, or vertical bar, type the character in this text box.

Display headings in labels

If you select this option, the label includes the descriptions of the label fields. For example, if
you selected Molecule Number, the label is molnum=n instead of simply n, where n is the
number of the molecule.

Display one-letter residue names in labels

If you select this option, the one-letter residue names are displayed instead of the usual three-
letter or four-letter names. Only the common (naturally occurring) residues have one-letter
names; the rest are labeled “X”. 

Display H isotopes for element labels

When displaying element labels, use the isotope symbols for hydrogen (H, D, T). This option
is on by default.

X-offset and Y-offset 

To reposition labels, enter new values in these text boxes. The offsets define the location of the
lower left corner of the label relative to the atom position or bond midpoint. 

Show label when atom hides

Display labels for atoms that are hidden. Labels for hidden (undisplayed) atoms are shown in
the Workspace, but do not appear to be associated with an atom. Undisplaying atoms is not the
same as excluding entries from the Workspace. Labels, like ribbons, can only be shown for
included atoms; however, these atoms need not be displayed.

Color atom labels by

Select an option to control the color of the atom labels. 
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• Atom color— color the labels with the color of the labeled atom.
• Constant color—color all atom labels with the color shown. Click the color square to dis-

play a color palette, then select the color, or click Advanced to open the Choose Color
dialog box in which you can choose from a wider range of colors.

Color bond labels

Color bond labels with the color shown. Click the color square to display a color palette, then
select the color, or click Advanced to open the Choose Color dialog box in which you can
choose from a wider range of colors.

14.7 Measurements Preferences

The Measurements tab contains settings for the precision and appearance of measurement text
in the Workspace.

Display Precision

In this section you can set the number of places after the decimal point that are displayed for
measurements. You can set the values for distances, angles, and dihedrals separately. 

Text

In this section you can make settings for the font and border for the display of measurements in
the Workspace.

Font

Choose a font, a point size, and make the font bold or italic (or both). 

Draw background-colored border around text

Select this option to draw a border around the measurement text in the background color. The
default is to use a transparent background (no border). 

Color

These settings control the color of the measurement markers. The color buttons open a color
selector, which you can use to select a new color for the marker type. 

Line Width

The Line width slider and text box allow you to set the width of the lines drawn to represent
measurements, in pixels. 
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14.8 Non-Bonded Interactions Preferences

This group of settings controls the display of hydrogen bonds, halogen bonds, contacts, and pi
interactions in the Workspace. See Section 10.2.2 on page 251 for more information.

14.8.1 Criteria

These settings are used to set the criteria for defining hydrogen bonds, halogen bonds, and
contacts.

14.8.1.1 H-Bonds

These settings control the cutoffs that define a hydrogen bond (H-bond). For display purposes,
hydrogen bonds are defined by relations between four atoms: the donor hydrogen atom (H), the
donor atom (D) bonded to H, the acceptor atom (A), and another neighbor atom (B) bonded to
the acceptor atom A. The bond can be represented as D–H...A–B. The following relations must
be satisfied for a valid hydrogen bond:

• The H...A distance must be less than a specified maximum distance.
• The D–H...A angle must be greater than a specified minimum value.
• The H...A–B angle must be greater than a specified minimum value.

Hydrogen bonds are not shown unless the structure has explicit hydrogen atoms. 

The default values used by Glide and those used in Maestro are different. 

Maximum distance

Specify the maximum distance from the H atom to the acceptor atom (H...A) for an H-bond to
be identified. The Maestro default is 2.8 Å, the Glide default is 2.5 Å.

Donor minimum angle

Specify the minimum D–H...A angle for an H-bond to be identified. The Maestro default is
120°, the Glide default is 90°.

Acceptor minimum angle

Specify the minimum H...A-B angle for an H-bond to be identified. The Maestro default is 90°,
the Glide default is 60°.

Set default criteria for 

Click Glide or Maestro to set the defaults for the three criteria to those for Glide or Maestro. 
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14.8.1.2 Halogen bonds

These settings control the cutoffs that define a halogen bond. Halogens can act as donors or
acceptors. As an acceptor it interacts with a hydrogen, so it is like a hydrogen bond but with its
own characteristics. As a donor it interacts with an electronegative element in a similar way to
hydrogen, but again with some differences.

Halogen bonds in which the halogen acts as donor are defined in a similar way to hydrogen
bonds, by relations between four atoms: the donor halogen atom (X), the donor atom (D)
bonded to it, the acceptor atom (A), and another neighbor atom (B) bonded to A, represented
as D–X...A–B. The following must be true for a valid donor halogen bond:

• The X...A distance must be less than a specified maximum distance (2.8 Å, by default)
• The D–X...A angle must be greater than the minimum donor angle (120°, by default)
• The X...A–B angle must be greater than the minimum acceptor angle (90°, by default)

Halogen acceptor bonds likewise have relations between the donor H atom (H) and the atom
bonded to it (D), the halogen acceptor (X) and the atom bonded to it (B), D-H...X-A. The
following must be true for a valid acceptor halogen bond:

• The H...X distance must be less than a specified maximum distance 
• The D–H...X angle must be greater than the minimum donor angle 
• The H...X–A angle must be greater than the minimum acceptor angle 
• The H...X–A angle must be less than the maximum acceptor angle 

Maximum distance

Specify the maximum distance from the halogen atom to the other atom for a halogen bond to
be identified. This value is independent of whether the halogen atom acts as an acceptor or a
donor. 

Donor minimum angle

Specify the minimum D–X...A angle or D–H...X angle for a halogen bond to be identified.
This angle can be set independently for halogens as donors and halogens as acceptors. 

Acceptor minimum angle

Specify the minimum X...A–B or H...X–A angle for a halogen bond to be identified. This
angle can be set independently for halogens as donors and halogens as acceptors. 

Acceptor maximum angle

Specify the maximum H...X–A angle for a halogen bond to be identified when the halogen acts
as an acceptor. 
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14.8.1.3 Contacts 

These settings define the distance ratios for contacts and allow the exclusion of certain types of
contacts from consideration as contacts. 

Contacts are classified into three types: good, bad, and ugly. The ranges for which contacts are
so classified are defined by a ratio C, given by the following formula:

C = D12 / ( R1 + R2)

where D12 is the distance between atoms 1 and 2, and R1 and R2 are the van der Waals radii of
atoms 1 and 2. The contacts are classified into good, bad, and ugly based on this ratio. C must
be monotonically increasing for each of the contact types, that is C(ugly) < C(bad) < C(good).
The default values are:

• Good: 1.30 > C > 0.89
• Bad: 0.89 > C > 0.75
• Ugly: C < 0.75

Contacts essentially only consider the overlap of the outer parts of a charge distribution, and
take no account of electrostatics. A “bad” contact could therefore be favorable if the atoms
have the opposite partial charge. Some of these, such as H-bonds and 1,4 interactions, can be
excluded from consideration as contacts.

Cutoff ratios 

These text boxes specify the cutoff ratios C for contacts to be considered Good, Bad, or Ugly.
Distances for which the ratio is smaller than the cutoff (but larger than any cutoff that is
smaller) are included in the contact category defined by that cutoff. Any distance ratio larger
than the Good cutoff is not considered a contact.

Exclude 

These options control whether certain atom pairs are considered to be in contact or not.

• H-bonds—Do not consider the hydrogen and the acceptor atom in a hydrogen bond to be
in contact. This option is on by default.

• 1,4 interactions—Do not consider pairs of atoms that are connected by a sequence of 3
bonds to be in contact. Intra-ring contacts are always excluded. This option is off by
default.
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14.8.2 Display

These settings control the color and line width of the nonbonded interaction markers, whether
any interactions are displayed while adjusting or transforming structures, and if so, which
interactions are displayed. 

Colors 

The colors of the markers for nonbonded interactions can be changed by clicking on the color
button and choosing a new color in the color selector that opens. 

Line width 

This slider and text box allow you to set the width of the lines drawn to represent nonbonded
interactions, in pixels. 

Display interactions while adjusting or transforming structures 

Select this option to display specified interactions while adjusting structures or transforming
structures. The interactions are updated dynamically as you perform the adjustment or trans-
formation. The interactions to display can be specified by selecting from the options given
below this option. 

14.9 Surfaces Preferences

The Surfaces section has three tabs, Creation, Viewing, and Performance. These tabs contain
settings for the appearance and behavior of surfaces in the Workspace.

14.9.1 Creation

These options set the default appearance for new surfaces, which includes surfaces created
directly in Maestro, and surfaces created on import of volume data into Maestro that have no
information on appearance settings. These settings are the ones shown by default in the Surface

Display Options dialog box.

Transparency

Set the default transparency of the front and back surfaces, and choose whether to link the two
transparency values so that they are adjusted together.

Style

Set the default surface style: Solid, Mesh, or Dot. The default style is not applied to surfaces
that have a predefined style (such as PrimeX and SiteMap).
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Colors, by surface type

Set the default colors of surfaces, by the surface type. Paired surfaces are surfaces like molec-
ular orbitals. 

Darken colors by cavity depth

Darken the colors of molecular surfaces according to the distance from an iteratively
smoothed, convex surface. The darkening enhances the depth perception of surface cavities.
This preference applies to new surfaces. The effect can be controlled for individual surfaces
from the Surface Display Options panel—see Section 12.4.2 on page 310.

Intensity 

Specify the intensity of the darkening effect, on a scale from 0.0 to 1.0, where 1.0 applies the
full effect, and 0.0 is equivalent to turning off the effect. Setting this value is useful when the
cavities are deep. 

Show surface manager when surfaces are created

Open the Manage Surfaces panel when surfaces are created. 

14.9.2 Viewing

These options affect the appearance and behavior of all surfaces or surfaces of a particular
type. 

Keep electron density centered while translating 

When translating the Workspace structure, selecting this option ensures that the cube in which
the electron density is displayed remains at the same place relative to the Workspace view. The
effect is that the structure with its electron density appears to move through the cube. The size
of the cube is set in the Manage Surfaces panel—see page 309.

Scale mesh width

When zooming in and out, selecting this option allows the width of the lines in the mesh repre-
sentation to be scaled appropriately. The Min and Max text boxes provide the means to specify
the minimum and maximum scaling factor that should be used for the mesh. The scaling factor
is applied to the mesh width set with the Mesh width slider. 

Mesh width (pixels)

Set the width in pixels of the lines in the mesh representation of the surface. Scaling of the
mesh width is applied to this value. 
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Angle-dependent transparency

Vary the transparency across the surface, according to the angle the surface normal makes with
the plane of the screen. The transparency is a minimum when the normal is perpendicular to
the screen, and a maximum when it is parallel to the screen. Only available with OpenGL 2.1.

Global contour settings

These settings are only available with an OpenGL graphics level of at least 2.1. 

Depth-enhancing contours 

Draw depth-enhancing contours on the edges of surfaces and when an edge is in front of
another part of the surface by more than a defined distance. 

Thickness

Set the thickness of the contour (in angstroms). 

Depth difference at least

Set the minimum distance that an edge of the surface must be in front of other parts of the
surface for the contour to be drawn. 

Color

Set the color of the contour, by clicking the Edit button, and the intensity of the contour color,
with the Intensity slider and text box. The intensity is the fraction of the contour color that is
mixed with the surface color when drawing the contour. 

14.9.3 Performance

When rotating, draw solid surfaces as

These three options (Solid, Mesh, Dot) control how surfaces are drawn while they are being
rotated. Choosing mesh or dot surfaces may result in quicker rotation. 

Use low quality transparency for surfaces

These three options (When rotating, Always, Never) allow you to choose when low-quality
transparency is used for display of surfaces. Low-quality transparency speeds up the redisplay
of surfaces after rotation, at the expense of surface display quality.

Use random patterns for low quality transparency

These three options (When in interlaced stereo, Always, Never) allow you to choose when to
use a random pattern for low-quality transparency. The regular pattern does not produce good
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results for interlaced stereo. This option is primarily intended for use with interlaced stereo to
improve the appearance of transparent surfaces.

14.10 2D Structure Preferences

These preferences control the display of 2D structures in the Project Table and the 2D Viewer. 

Maximum number of atoms

To ensure that the displayed structure is not too small, a limit on the maximum number of
atoms in any structure that is displayed can be set in the Maximum number of atoms text box.
For entries that have more than this number of atoms, a message is displayed in the 2D Struc-

ture column about the size limit, instead of the structure. 

Maximum scale factor

The structure images that are generated are much larger than the table cells, and are scaled
down to fit. Structures are scaled down by at least the amount specified in the Maximum scale
factor text box, and may be scaled down further if they are large. Setting a small value of this
factor ensures that small molecules are not displayed on a larger scale than large molecules: the
benzene ring doesn’t look bigger than the rings in a steroid, for example. 

Font size

This slider allows you to adjust the point size of the font that is used for text (such as atom
symbols) in the generation of the original image (before it is scaled). 

Label margin

Scaling factor for distance between atom symbols and bond lines.

Bond line width

Width of the bond lines in pixels, for image generation.

Hash spacing

Width of the wedge bonds in pixels, for image generation.

Bond spacing

Spacing between bond lines for multiple bonds in pixels, for image generation.

Use color in 2D images

Color the atoms by element in the 2D images. 
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Show all hydrogens

Show all hydrogens, rather than leaving them implicit. Hydrogens on non-carbon atoms are
always displayed.

Label all carbons

Display a C for each carbon atom, rather than leaving them implicit.

14.11 LIgand Detection Preferences

These settings define what is classed as a ligand in Maestro; in particular they define the ligand
ASL expression.

Ligand molecules

In this section you can set size limits on the ligand molecule, by specifying the minimum and
maximum number of atoms that a ligand molecule can have. There are two options for small
ions and small peptides, which are excluded from consideration as ligand molecules by default.

Minimum atom count

Enter the minimum number of atoms that a valid ligand molecule can have in this text box.
Default: 5. 

Maximum atom count

Enter the maximum number of atoms that a valid ligand molecule can have in this text box.
Default: 130. 

Allow molecules that are small ions 

Select this option to allow molecules that are small ions (less than 10 atoms) to be considered
as ligands. This option is deselected by default. 

Allow molecules containing only amino acids 

Select this option to allow molecules that consist only of amino acids to be considered as
ligands. This option is selected by default. 

Excluded residues 

In this tab you can select from a list of molecules that commonly appear in biological systems,
to exclude them from consideration as ligands. The molecules are identified by their residue
code, which is usually 3 letters, but can be any length from 1 to 4 letters. The tab contains a
table, whose columns are described below, and tools to add and delete residues. 
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Exclude

This column contains a checkbox for each residue. When the box is checked, the residue is
excluded from consideration as a ligand. By default all residues are excluded. 

Residue 

This column lists the residue code for various common residues, such as cofactors and ions.
The column is noneditable. 

Description 

This column lists a description for each residue. The column is noneditable. 

Residue to add 

In this text box, enter the residue code of a residue that you want to add to the table. 

Add

Click this button to add the residue entered in the Residue to add text box to the table. An error
is posted if the residue name is more than 4 characters long. 

Delete

Click this button to delete the selected residues from the table. 

Included residues

In this tab you can specify residues that may validly be part of a ligand. Molecules that contain
any of the listed residues are considered ligands. The residue codes are usually 3 letters, but
can be any length from 1 to 4 letters. The tab contains a table and tools to add and delete resi-
dues. The table is empty by default.

Include 

This column contains a checkbox for each residue. When the box is checked, the residue is
permitted to be part of a ligand. 

Residue 

This column lists the residue code for residues to be included as allowed in ligands. The code
must correspond to a known residue code: there is no facility for defining custom residues. 

Description 

This column lists a description for each residue. The column is noneditable. 
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Residue to add 

In this text box, enter the residue code of a residue that you want to add to the table. 

Add 

Click this button to add the residue entered in the Residue to add text box to the table. An error
is posted if the residue name is more than 4 characters long. 

Delete 

Click this button to delete the selected residues from the table. 

Restore Defaults 

This button resets the settings to the defaults. It removes any residue codes added to the table
and restores any default residue codes as well as redoing the settings. 

14.12 Builder Preferences

In the Builder tab you can set options to control the use of united atoms, automatic adjustment
of bond lengths, removal of hydrogens to maintain valence during build operations, and dele-
tion of terminal atoms. The options are persistent between Maestro sessions, and are selected
by default. 

14.12.1 Behavior

Allow united atom types while building

The use of united atom types can cause problems for users (especially Jaguar users) who do not
want implicit hydrogen atoms in their structures. United atom types with implicit hydrogens
are assigned by default when hydrogens are deleted from heavy atoms. If this option is dese-
lected, united atom types are never assigned when atoms and bonds are explicitly deleted,
atoms are retyped, or structures are drawn freehand. Instead, the atom types remain unchanged,
or explicit radical types are assigned if they are available. 

United atom types are used regardless of this option if a hydrogen treatment that requires
united atom types is applied, or when reading in a structure file (such as a PDB file) that does
not have explicit hydrogens present.

Adjust bond length when atom type is changed 

When atom types are changed, bond lengths are automatically adjusted to give a “reasonable”
bond length. This behavior is undesirable if the geometry is already correct (such as from a
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crystal structure) and it is only necessary to change the atom types. Deselecting this option
prevents the adjustment of bond lengths.

Adjust number of hydrogens during build operations

The number of hydrogen atoms is adjusted by default to maintain a normal valence during
formal charge, bond order, or retyping changes. This behavior is not always desirable, and can
be prevented by deselecting this option.

Delete terminal atoms 

When you delete an atom, the terminal atoms that are attached to this atom can be deleted, or
they can be left in place. Terminal atoms are atoms that are bonded only to that atom, such as
hydrogen or a halogen. Deleting terminal atoms would not, for example, delete a methyl group
attached to the deleted atom. 

Fit to Workspace when growing

When you are building a structure in Grow mode, Maestro fits the structure to the Workspace
after each fragment addition by default. To prevent the fitting, deselect this option.

Include alternate positions in local transformations

When performing a local transformation on a set of atoms that include atoms with alternate
positions, transform the coordinates for both alternatives. Deselect this option to transform the
displayed location and not the alternate. 

Include zero-order bonds when defining molecules

When determining which atoms are bonded together to form molecules, consider atoms that
are joined by zero-order bonds to belong to the same molecule. This option is selected by
default.

14.12.2 Geometry cleanup 

These preferences specify how geometry cleanup is done. You can clean up the geometry by
pressing U in the Workspace or by choosing Edit → Build → Clean Up Geometry. 

Geometry cleanup method

Specify the method used to clean up the geometry. There are two choices:

• Built-in—Use the built-in minimizer with the OPLS_2005 force field. This method is
faster and supports larger structures, but is limited to the elements supported by
OPLS_2005.
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• UFF—Use the Universal Force Field with the associated minimizer. This method is
slower, but covers a much wider range of elements. It supports up to about 5000 atoms.

This preference can also be set from the Clean Up button menu on the Build toolbar.

Freeze unselected atoms during geometry cleanup

Select this option to freeze the atoms that are not selected during geometry cleanup with the
built-in minimizer. By default, atoms within 5 Å of the selected atoms are restrained with a
moderate restraint, and atoms within 5 Å of these atoms are restrained with a much tighter
restraint, while the rest of the atoms are frozen. This option does not affect cleanup with the
UFF minimizer. 

14.13 Job Preferences

These preferences specify the conditions under which jobs are monitored and are incorporated
when they finish, whether the job name is kept, whether warnings about proteins are issued,
and whether to keep job files from the wizard-like workflows. 

14.13.1 Starting

Minimize disruption from jobs

The effect of job incorporation and monitoring on the Workspace and the Project table can also
be controlled with the Minimize disruption from jobs option. When this option is selected,
changes to the Workspace and the Project Table selection from job monitoring and incorpora-
tion are minimized. This means that the Workspace is only updated when an entry that is
already in the Workspace is replaced in the Project Table, and the selection of entries in the
Project Table is not changed. Structure monitoring is off, but monitoring and display of the
Monitor panel are controlled by the preferences listed above.

For more information on job monitoring, see Section 3.2 of the Job Control Guide.

Warn about use of unprepared proteins

If you start a job (such as a Glide grid generation) that uses a protein from the project, Maestro
checks whether the protein has been prepared by the Protein Preparation Wizard. If it does not
appear to have been prepared (as indicated by the prepared property), a dialog box is displayed
in which you can mark the protein as prepared and continue, or cancel the job. Proteins that
have been prepared earlier than Suite 2009 do not have this property by default, and so are
treated as not prepared. To prevent the display of this dialog box, deselect the option Warn
about use of unprepared proteins. Proteins will then be accepted regardless of their prepara-
tion, but will not be marked as prepared.
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Warn before overwriting existing job files

Display a warning dialog box when a job name is reused and job files will be overwritten if the
job is run or the job files are written. If this option is off, no warning is displayed, and the files
are overwritten. However, if the existing job is still running, the files will not be overwritten,
regardless of this setting, and a warning is displayed.

Allow use of web server for BLAST searches

Allow Prime to use the BLAST web site to perform a BLAST search. This option allows you
to run Prime Structure Prediction without having a local copy of the BLAST database. If your
query structures are proprietary, you should not select this option. (The option is stored in the
file web_blast in your user resources directory as a single word, allow or deny.)

Always run driver on remote host

When running jobs on a remote host, run the driver for that job on the remote host as well. This
option is useful if you are running on the Cloud, as the driver must run on the remote host.
Note that some jobs, such as Glide, Prime MM-GBSA, and Induced Fit Docking, rely on the
driver running locally and using the local file system (-LOCAL) to ensure that jobs are restart-
able. Running these jobs on the remote host will prevent restarting. 

Enable job debug output (-DDBEUG)

When the job is run, print debugging output. This option is useful when running jobs for anal-
ysis by Schrödinger technical support. It is not stored between Maestro sessions. 

14.13.2 Monitoring

When starting jobs

Monitoring behavior when a job is started can be controlled with two options:

• Start monitoring—Start monitoring jobs when they are submitted. If this option is dese-
lected, jobs will not be monitored, but they will be incorporated if your preference for
incorporation does not include monitoring. 

• Open Monitor panel—Open the Monitor panel when a job is started. This option applies
only to jobs that are not started from wizard-like workflows, where the job status button
can be used to open the Monitor panel. By default, the Monitor panel is not opened when
a job is started. 
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Update Monitor panel every N seconds

Update the job status and related information for unfinished jobs that are listed in the Monitor
panel at the specified frequency. If you have chosen to incorporate jobs automatically or when
approved, jobs that are not being monitored may be incorporated during the status update, if
their status changes to “completed”. 

Update monitored job's status every N seconds

Set the interval at which the status of a monitored job is updated, by clicking one of the arrow
buttons, or specifying a time interval in the text box. This is the frequency with which informa-
tion on the monitored job is updated, not the frequency with which status information is
updated in the Monitor panel. 

Update application panels job toolbar and Workspace status bar every N seconds

Update the job status information shown on the Job toolbar for application panels and the Jobs

button on the status bar in the Workspace at the specified frequency. 

Show job status in Workspace status bar

Show the job status as a button on the right end of the Workspace status bar. The button shows
the number of active jobs in the project and the total number of active jobs. The tool tip for the
button gives information on various job categories, listing up to three in each category.
Clicking the button opens the Monitor panel. The frequency with which this status is updated
can be specified in the Update every N seconds text box. 

14.13.3 Incorporation

These settings control what happens to jobs and files when the jobs finish. See Section 2.9 of
the Job Control Guide for more information on job incorporation.

Incorporate completed jobs

Set options for the incorporation of jobs that have finished and are ready for incorporation:

• Only when monitored—Jobs are only incorporated when you monitor them in the Monitor
panel.

• When approved—You are prompted to incorporate a job when it finishes and is ready for
incorporation. If you choose not to incorporate, you must monitor the job to incorporate
it. If you subsequently select another option, you must restart Maestro for the option to
take effect on jobs that you chose not to incorporate.

• Automatically—Jobs that are ready for incorporation are incorporated automatically. Mae-
stro is unavailable while the job incorporates. This is the default behavior.
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A progress dialog box is displayed while jobs are incorporated, and you must wait until incor-
poration finishes before doing anything in Maestro. Incorporation is only done for jobs from
the current project. If you change projects, the option you select applies to the new project.

Keep workflow job files for 

For the products that have wizard-like workflows, you can set options for the retention of job
files. By default, these files are deleted on incorporation of the results. 

The options for the three products are:

• CombiGlide—Keep job files for the Combinatorial Screening workflow.
• Phase—Keep job files for the Develop Common Pharmacophore Hypotheses workflow.
• Prime—Keep job files for the Structure Prediction workflow.

14.13.4 Directory

These settings affect the directories used when running jobs. The last two set job options: see
Section 2.3 of the Job Control Guide for more information on the options.

Default directory for job startup and file i/o

These settings determine the location that Maestro uses for creating job files and the location
that Maestro initially uses for file input and output. This location is called Maestro's current
working directory, also the job launch directory or the I/O directory. 

When you choose one of the options below, the current working directory is set to the specified
location, and the option you select is stored as a preference. The current working directory is
then set to this location when you start Maestro again. In the descriptions below, the directory
is called the default directory. For more information on changing the current working directory,
see Section 1.4 on page 7.

Note: If you choose a default directory that is inside the project, you should wait until any
jobs launched from that project finish before you rename the project, or save the
project if it is a scratch project (which renames it to a named project). 

• Maestro’s current working directory—Set the default directory to the Maestro startup
directory. Jobs running with this setting are not lost if the project is renamed.

• Parent of project directory—Set the default directory to the parent directory of the current
project (the directory that the project is in). Opening a different project or closing a proj-
ect (which opens a scratch project) changes this directory. For zipped projects, the parent
directory is the directory that contains the .prjzip file, rather than the temporary direc-
tory into which the zipped project is extracted. Jobs running with this setting are not lost
if the project is renamed.
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• Project directory option—Set the default directory to the top-level directory of the current
project. This is the project-name.prj directory. This directory changes when a new proj-
ect is opened, and therefore the current working directory changes. Jobs running in this
directory will fail if the project is renamed. This includes saving scratch projects.

• Project jobs directory—Set the default directory to the project's jobs subdirectory (proj-
ect-name.prj/jobs). This directory changes when a new project is opened, and there-
fore the current working directory changes. Jobs running in this directory will fail if the
project is renamed. This includes saving scratch projects.

• Other (specify below) option—Use the specified directory as the default directory. You
must enter the desired directory name in the Directory text box.

Copy archived job directory to the launch directory when job finishes (-SAVE) 

When a job finishes, create a zip file of the temporary directory that the job used to write files
needed for the job (the job directory), and copy it back to the job launch directory. The zip file
is not automatically unzipped. This option can be useful if you need to debug a job that fails,
and keep the files, or to use the files for some other purpose. Normally, these files (“scratch
files”) are deleted and the directory is removed when the job finishes. 

This option sends the -SAVE option to Job Control. It is not saved across Maestro sessions, but
it is initialized from the SCHRODINGER_SAVE_JOBDIR environment variable.

Run the job in the launch directory and keep all files (-LOCAL) 

When a job is run, use the launch directory as the location to write temporary files needed for
the job, and leave the files in place when the job finishes. If the job launches subjobs, the
subjobs might not use this directory for their working directory: the behavior depends on the
application. If the subjobs do not write to the launch directory, you can set the Copy archived

job directory to the launch directory when job finishes option to copy back the subjob temporary
directories. Note that in this case, the files that are local already are not archived in a zip file.

This option sends the -LOCAL option to Job Control. It is not saved across Maestro sessions.
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14.14 Molecular Representation Preferences

These preferences affect how atoms, bonds, and ribbons are displayed in the Workspace,.

14.14.1 Atoms and Bonds 

These options control the default representation of atoms and bonds. There are three sections,
and two general options which are described first. 

Default representation

This option menu allows you to set the default representation to one of the five representations:
Wire, Thin tube, Tube, Ball & Stick, or CPK. Selecting one of these choices from the menu sets
the representation used for new atoms that are built or imported. If you import a file in Maestro
format and it includes graphical information, the representation saved in the file is used rather
than the defaults. 

Default color scheme

This option menu allows you to set a default color scheme for atoms and bonds. For some color
schemes (which usually include the word Custom), a color option menu is displayed below the
schemes option menu, so that you can choose the custom color. This option menu has a list of
allowed colors. For a description of the standard color schemes, see Section 7.2.3 on page 135.

Restore defaults

Restore the default values for the atom and bond representation. This button is below the
settings for the different representations.

Wire settings

Scale wire width

If you want the wire width to scale as you zoom in, select this option. You can adjust the
minimum and maximum wire (line) width in the Min and Max text boxes. The values are given
in pixels, and there are limits on how much you can change these values that are determined by
the OpenGL implementation on your computer.

Wire width 

This slider you to determine the width of wire (in pixels) in the Wire representation. 
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Style

These options control how color is applied to bonds.

• Split—The bonds are split, and each half is colored with the color of the nearest atom.
• Blend—The color is progressively changed along the bond from the color of one atom to

the color of the other. Selecting Blend can improve graphics performance.

Show bond orders

These options control when bond orders are displayed. Multiple bonds are displayed as
multiple lines, and zero-order bonds are displayed as dashed lines.

The Automatically option displays bond orders at high zoom, when the portion of the displayed
structure that is visible in the Workspace is less than 30 Å across. If you zoom out, bond order
display is turned off; if you zoom in again, bond order display is turned on again when the
display meets the criterion given. 

The threshold for the display of bond orders can be changed with the Maestro command
repall borderscale=value. 

Smoothing

These options request smoothing of the lines or tubes that represent bonds. Smoothing wire
bonds especially enhances the viewing of larger structures. When Show bond orders is on,
those bonds that are drawn with widths greater than one are not smoothed. 

Tube/Stick/CPK settings

This section has settings for the display of bond orders and the sizes of the tubes and spheres
used in these representations.

Show bond orders 

These options control when bond orders are displayed. Multiple bonds are displayed as
multiple tubes, and zero-order bonds are displayed as tube segments.

The Automatically option displays bond orders at high zoom, when the portion of the displayed
structure that is visible in the Workspace is less than 30 Å across. If you zoom out, bond order
display is turned off; if you zoom in again, bond order display is turned on again when the
display meets the criterion given. 

Thin tube radius 

Tube radius 

These sliders set the radius of the tubes in angstroms for the tube representations.
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Ball percentage 

This slider sets the percentage of the van der Waals radius of the atoms that is used to deter-
mine the size of the spheres in Ball & Stick representation. 

Stick radius 

This slider sets the radius of the sticks in angstroms in Ball & Stick representation.

CPK percentage 

This slider sets the percentage of the van der Waals radius of each atom that is used to deter-
mine the size of the spheres.

14.14.2 Ribbons 

These settings control the defaults for display of ribbons. The style and the color scheme are
set when you create the ribbons. 

Quality 

Set the quality of the ribbon rendering. These options control the smoothness of the ribbons. 

Use simplified representation when moving

Use a lower-quality ribbon representation when translating, rotating, or zooming. You might
want to set this option if moving structures is slow when ribbons are displayed. 

Blend ribbon colors

Select this option to create a smooth color transition on the ribbons between residues. 

Helix interior 

Select an option for coloring the interior surface of helices (and ladders). The two options are
to use gray for the inside (Gray) or to use the same color as the exterior (Same as exterior), as
determined by the color scheme. 

Ribbon width 

Set the width of ribbons in angstroms. 

Ribbon thickness

Set the thickness of ribbons in angstroms. 
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Strand width 

Set the width of strands in angstroms. 

Strand thickness

Set the thickness of strands in angstroms. 

Thin tube width 

Set the width of thin tubes in angstroms. These tubes are used in Cartoon and Thin Tube repre-
sentation. 

Thick tube width

Set the width of thick tubes in angstroms. These tubes are used in CA Trace Tube and Thick
Tube representation. 

Ladder width

Set the width of the rungs of the ladder for DNA and RNA. The sides of the ladder are
controlled by the ribbon settings. 

Atoms to hide when ribbons are created

Select an option from this menu to determine which of the atoms that are associated with the
ribbons are displayed or hidden when a ribbon is created. This option only affects the initial
visibility; the normal atom display controls can be used to change the visibility of these atoms.
The options are:

• None—Do not hide any atoms (the default).

• All associated atoms—Hide all the atoms associated with the ribbons, so that only the rib-
bons are displayed.

• Associated backbone atoms—Hide the backbone atoms, and show the side chains.

These options do not affect atoms that are not associated with the ribbons, such as ligands,
cofactors, and water molecules.

Restore defaults

Restore the default values for the ribbon representation.
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14.15 SMARTS Generation Preferences

This group of settings controls the generation of SMARTS patterns from selected atoms. There
is one set of options, for including notational elements in the SMARTS pattern. Examples of
the notation with the option selected are given next to the label.

Charge 

Include the formal charge on an atom in the SMARTS pattern. 

Number of substituents

Include the number of substituents that are attached to each atom in the SMARTS pattern. 
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Chapter 15: Scripting in Maestro
Maestro provides several facilities for creating and using scripts. You can create Python scripts
or generate macros with the Macros panel and install them on the Scripts menu. You can also
create scripts and assign them to one of the 12 function keys on your keyboard.

15.1 The Scripts Menu

The Scripts menu in the main window is configurable and allows you to install, manage, and
run Python scripts or named macros directly from Maestro. Scripts can be installed by indi-
vidual users, using the Install Scripts panel, or they can be installed in the Schrödinger software
installation or some other suitable public directory for use by all users. Once scripts are
installed, they can be managed from the Manage Scripts panel. The software installation
contains a number of scripts that are installed on the menu by default.

15.1.1 Installing Scripts and Macros

Scripts or macros for individual use must be installed explicitly. To do so, you can use the
procedures described below. Scripts or macros that are intended for general use need only be
copied to the appropriate directory, and automatically appear on the Scripts menu. Instructions
are given below for installation of scripts for general use. 

To install a Python script:

1. From the Scripts menu, choose Install.

The Install Scripts panel opens (see Figure 15.1). 

2. Enter a directory in the Directory text box, or click Browse and navigate to the directory
that contains the scripts.

When the directory is entered, the table is populated with the available scripts. 

Note: The Install Scripts panel only displays files with a .py suffix, the standard suffix
for Python scripts, and only those files that are recognized as installable. 

3. Click in the Install column to select a script. 

The script name, the command that runs it, and a description (if available) appear in the
text boxes at the bottom of the panel. The script name is what appears on the Scripts

menu.
Maestro 10.2 User Manual 385



Chapter 15: Scripting in Maestro

386
Figure 15.1. The Install Scripts panel.

4. Click OK.

The script is added to the Scripts menu and the panel closes. If the script is already on the
menu, you are asked if you want to overwrite it.

To install a macro: 

1. Choose Manage from the Scripts menu.

The Manage Scripts panel opens (see Figure 15.2). 

2. Click Macros.

The Macros panel opens. You can also open this panel by choosing Macros from the Edit
menu.

3. Select a macro from the list. 

4. Click Install.

To install scripts or macros for all users in the installation:

1. Copy the scripts to $SCHRODINGER/mmshare-vversion/python/common on Linux or
Mac, or %SCHRODINGER%\mmshare-vversion\python\common on Windows. 
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2. Create or edit a scripts.mnu file in the same directory, and add the relevant lines to this
file for each script.

To install scripts or macros for all users in some other location:

1. Copy the scripts to a directory that is accessible to all users. 

2. Create or edit a scripts.mnu file in the same directory, and add the relevant lines to this
file for each script.

3. Set the environment variable SCHRODINGER_SCRIPTS to the directory to which the
scripts were copied. Make sure you use the full path. 

The format for the lines in the scripts.mnu file can be deduced from the user installation.
Briefly, each script should have a line containing the menu item, followed by a line containing
the pythonrun or macrorun command to run the script.

15.1.2 Managing Scripts

The Manage Scripts panel provides some ways of managing the scripts that are installed.

Figure 15.2. The Manage Scripts panel.

To change the name or command of a script or macro, edit these fields directly in the Contents

of the Scripts menu table.

You can delete or duplicate scripts and macros by using the Delete and Duplicate buttons. You
can change the order in which the items appear in the Scripts menu by selecting a script and
clicking the up and down arrow buttons.
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To create submenus in the Scripts menu, edit the script names and insert a colon to separate the
submenu name from the menu item. For example:

Color Atoms:Green

creates the submenu Color Atoms with the menu item Green.

To see the changes you have made to script names and locations, click Apply, then click on the
Scripts menu. When you are satisfied with the changes, click Close to close the Manage Scripts
panel.

To view the description of a script, first select the script in the table. If a description is avail-
able, the Description button becomes active. When you click this button, the description is
displayed in a dialog box. 

15.2 Using Python and Python Scripts

Python is a full-featured scripting language that has been embedded in Maestro to extend
scripting facilities. The Python capabilities within Maestro include access to Maestro function-
ality for dealing with chemical structures, projects, and Maestro files, in an extensive API.

The two main Python commands used in Maestro are:

• pythonrun—executes a Python module. You can also use the alias pyrun. The syntax
is:

pythonrun module.function

• pythonimport—rereads a Python file so that the next time you use the pythonrun
command, it uses the updated version of the module. (You can also use the alias pyimp.)

The distribution includes a number of Python scripts designed for interaction with the structure
in the Workspace. You can use these scripts, as well as create your own. You can also down-
load scripts from the Script Center. With the Maestro Scripts menu, you can install, manage,
and run your Python scripts directly from Maestro. For more information on the Scripts menu,
see Section 15.1 on page 385.

Python commands can be run interactively in Maestro by using the Python Shell panel, which
you open from the Window menu. This panel provides an input area where you can enter
Python code, and then execute it. This input area has a range of modules preloaded, to make it
easier to write code that interacts with Maestro:

from codeop import CommandCompiler, compile_command
from PyQt4 import QtCore, QtGui
from PyQt4.QtCore import Qt
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import pythongui_ui
import sys, os, traceback, string
import pyhelp
from schrodinger.maestro import maestro

The command output is displayed in a text area in the panel. You can import other modules
from the API for performing tasks in Maestro. 

Figure 15.3. The Python Shell panel.

For detailed information on the API for using Maestro and other Schrödinger capabilities from
Python, choose Help → Python Module Overview or Help → Python API Reference. 

15.3 Scripting and KNIME Workflows

KNIME workflows are another way of scripting a sequence of applications that pass results
from one application to the next. To create the workflows, you use the KNIME application—
see the KNIME Extensions User Manual for details. KNIME provides the pipelining frame-
work and a set of basic applications (“nodes”) that you can plug together to create a workflow.
Schrödinger provides a set of KNIME nodes for its applications (the KNIME extensions). 

Once you have created a workflow, you can generate a Python script to run the workflow. The
script includes a panel so you can set up input values for the workflow, and manages the execu-
Maestro 10.2 User Manual 389



Chapter 15: Scripting in Maestro

390
tion of KNIME in batch mode to run the workflow. These Python scripts can then be installed
on the Workflows menu so you can execute them in the much the same way as any built-in
workflow. The panels to generate a Python script are also on this submenu.

You must purchase a license to run the Schrödinger KNIME extensions, except for the
following:

• The reader and writer nodes (17 nodes)
• The file format converters (6 nodes)
• The Chemistry external tool nodes (5 nodes)
• The Python script nodes (6 nodes)

This means you can set up and run third-party applications from Maestro and make use of
Maestro’s features for processing the results without purchasing a KNIME extensions license.
You can also use the KNIME-Maestro connector, the Run Maestro node, the Run Maestro
Commands node, and the Run Canvas node without purchasing a KNIME extensions license. 

For more information, see the KNIME Extensions User Manual.

15.4 Using Command Scripts

Some Maestro interface customization options can be set for the present session, but are not
automatically retained for future sessions. To use these settings each time you launch a new
Maestro session, you can create a startup script that will make the settings for you.

You can create startup scripts even if you are not familiar with the Maestro Command
Language because most of the commands that you may want to include in a startup script can
be extracted from the Command History log in the Command Script Editor panel.

To create a startup script, use the controls on the Command Script Editor panel, and then save
the script in your preferences directory under the file name maestro.cmd. Each time you
subsequently launch Maestro, this script is used to override the system-wide startup settings
with your personal preferences.

To open the Command Script Editor panel, choose Window → Command Script Editor.
Schrödinger Software Release 2015-2 



Chapter 15: Scripting in Maestro
Figure 15.4. The Command Script Editor panel.

15.4.1 Command History

By default, most of the internal Maestro commands generated when you perform actions are
logged in the Command History list in the Command Script Editor panel (see Figure 15.4). This
written record of your commands is provided mainly to make the scripting process simpler.
Since you can perform an operation, then cut and paste the resulting command into the Script

list and save the script, it is not necessary to memorize the Maestro Command Language. 

You can control whether Workspace transformation commands are displayed by using the Hide

transformation commands option, and you can turn off command logging altogether by dese-
lecting the Log commands option.

15.4.2 Building a Command Script

To build a command script from commands logged in the Command History list, you need to
select and copy the commands of interest. Multiple commands can be selected with shift-click
and control-click and by dragging. To select all of the commands in the list, click Select All. To
deselect all the commands in the list, click Deselect All.
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Once you have selected the desired commands, copy them to the Script text area by clicking
Copy Selection To Script. If the copy operation takes more than a second or so, a progress
dialog box is displayed. You can cancel the operation in this dialog box.

The commands are copied to the location of the cursor, which is placed at the end of the text
after a copy operation. Therefore, repeated copy operations append the new command selec-
tion to the commands in the Script text area. If you want to create a new script, you must first
delete the commands from the Script text area.

The commands in the Command History list remain selected after the copy operation, and must
be explicitly deselected. 

You can also directly enter commands in the Script text area. 

15.4.3 Saving a Command Script

To save the command script displayed in the Script text area, click Save As and navigate to the
directory into which you want to place the file. Then type the name of the file to be created at
the end of the line of text in the Selection box, and click Write. You must include the .cmd
extension when specifying the file name.

Command scripts that call macros must not include the definition of the macro, or the script
will not run properly. If you send someone such a script, you should also send the macro defi-
nitions.

15.4.4 Opening Existing Command Scripts

The Command Script Editor panel provides two options for locating existing command scripts:

• Click Open Local to browse in your working directory.

• Click Open Global to browse in the maestro-vversion/data/res subdirectory of the
Schrödinger software installation.

You can then navigate to the desired directory, select a command script, and click Open to load
the script into the Script text area. If there are any commands currently in the Script text area,
you are asked whether you want to replace them with the script you are about to open.

15.4.5 Running and Stopping Scripts

After you load a script into the Script text area, you can execute it by clicking Run Script. If
Log commands is selected, the script commands are added to the Command History list, even if
the command script doesn’t perform any operations that are visible in the Workspace. 
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If the script takes more than a second or so to run, a progress dialog box is displayed. You can
stop the script in this dialog box. 

15.4.6 Copying Commands as Python Commands

If you want to use Maestro commands as part of a Python script, you can select the commands
in the Command history list, then click Copy Selection for Python. Each command is wrapped
as a Python command as 

maestro.command('maestro-command') 

and the commands are copied to the clipboard. You can then paste the commands into any
application. For example, you can paste them into the Python Shell panel to create a Python
script (see Section 15.2 on page 388). If you copy them to some other location, you must
remember to import the Maestro Python modules in your script, otherwise they will not run. 

15.4.7 Customizations You Can Perform With a Script

Some customization settings in Maestro are not persistent across sessions. You can configure
Maestro on startup according to your personal preferences by performing any of the desired
operations described below, making a script containing the resulting commands, and then
saving the script as maestro.cmd in the preferences directory.

Before you create scripts to perform the following customizations, open the Command Script

Editor panel, ensure that Log commands is selected and that all commands are shown. 

If you already have a maestro.cmd file in your preferences directory and you want to save the
commands in this file, open it in the Command Script Editor panel before you perform the new
customizations. If you no longer want to override the system-wide settings with your personal
startup preferences, delete your maestro.cmd file, or move it out of this directory.

After performing each customization, select the relevant commands in the Command Script

Editor panel and copy the resulting commands into the Script text area. When you have
completed all customizations, save the script.

To set the Workspace background color: 

1. Choose Workspace → Appearance in the main window.

2. Click the Background tab.

3. Click the Background Color button to choose a color in a color selector, or select one of
the preset colors.
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To specify a stereo viewing method:

1. Choose View → 3D Options in the main window.

2. In the Stereo tab, choose a stereo display technique from the Method option menu.

3. Adjust the Size Factor and Scale Factor if necessary.

To enable perspective:

1. Choose View → 3D Options in the main window.

2. In the Perspective tab, select Display in perspective.

3. Adjust the Perspective Scale, if needed.

To hide the command input area:

• Choose Window → Command Input Area in the main window.

Alternatively, you can type the following command into the Scripts text area, or add it directly
to your maestro.cmd file.

hidepanel cominput 

To hide the clipping planes window:

• Choose Window → Clipping Planes in the main window.

Alternatively, you can type the following command into the Scripts text area, or add it directly
to your maestro.cmd file.

hidepanel topview 

15.5 Creating Command Aliases

If you choose to use command scripts to perform operations in Maestro, you may find that
there are many that you use frequently. The controls on the Command Alias panel allow you to
assign shorter names to these commands. For example, you might want to define the alias
label for the labelatom command. You can then use these aliases in commands typed in the
command input area. 

To open the Command Aliases panel, choose Maestro → Command Aliases.
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Figure 15.5. The Command Aliases panel.

Defining a New Alias

To enter a new command alias, click New, type the abbreviation that you wish to use for the
command in the Alias name dialog box, and click OK. In the Command Aliases panel, enter the
command in the Alias definition box for the abbreviation you entered in the previous step. 

Saving Aliases

To save your aliases, click Save. The aliases are written to the file alias.cmd in your prefer-
ences directory. Once the aliases have been saved, they can be used in later Maestro sessions. If
you wish to use an alias only for the current session, it is not necessary to save the alias. 

Changing an Existing Alias

Maestro is shipped with a set of command aliases already defined, and these can be edited or
deleted. To change an alias, select the alias in the alias list, then type a new alias name or defi-
nition in the appropriate box. 

To delete an alias from the list, select it and click Delete. To delete all currently defined aliases,
click Delete All. 

15.6 Creating Macros

Maestro allows you to create two kinds of macros: named macros and function key macros.

15.6.1 Named Macros

In the Macros panel, you can create a macro, name it, and run the macro from the command
input area. To open the Macros panel, choose Maestro → Macros.
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Figure 15.6. The Macros panel.

To create a named macro, click New, enter a name for the macro and click OK. In the Definition
text box, you can either type the commands for the macro or copy and paste commands from
the Command Script Editor panel. When you have finished entering commands, click Update to
update the macro definition.

Note: Macros are automatically saved when you exit Maestro. However, it is advisable to
update the macro whenever you change the definition. This makes the updated macro
available during the Maestro session.

You can also add the macro to the Scripts menu by clicking Add to Scripts Menu. For more
information on editing the Scripts menu, see Section 15.1 on page 385.

To run the macro, enter the following in the command input area in the main window:

macrorun macro_name

If the command input area is not visible, choose Window → Command Input Area.

15.6.2 Function Key Macros

The Function Key Macros feature allows you to assign a script command, or series of
commands, to a particular keyboard function key. You can use the keys F2–F12, on their own
or with the CTRL key or SHIFT key or both. F1 is reserved for the online help. 

On Linux some of these keys are assigned by the window manager, and these assignments take
precedence over user assignments. You can usually change or remove some or all of these
assignments. If you are using the KDE window manager, go to Control Center → Regional →
Accessibility → Keyboard Shortcuts → Shortcut Schemes → Shortcut Sequences. If you are
using the Gnome window manager, go to Preferences → Keyboard Shortcuts. 
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To open the Function Key Macros panel, choose Maestro → Function Key Macros.

Figure 15.7. The Function Key Macros panel.

To assign a macro to a function key, choose the key from the Macro Key option menu, select the
desired Ctrl or Shift options, and type the command or command sequence into the text area.
You can copy and paste commands from the Command Script Editor panel into the text area of
the Function Key Macros panel. 

To test your macro, click Run. 

To save a new macro for use in subsequent Maestro sessions, click Save. Saved macros are
placed in the maestro.mac file in your preferences directory. To delete a macro, edit this file.
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Chapter 16: Saving Workspace Images
In addition to creating structure files in a variety of formats, Maestro can produce images of the
structures depicted in the Workspace. You can use the Save Image panel to create TIFF, JPEG,
and PNG images, and you can copy images into other applications. For information on writing
(exporting) structure files, see Chapter 3.

16.1 Saving Images to a File

You can save images of structures rendered in the Workspace in TIFF, JPEG, or PNG format
using the Save Image panel. To open the Save Image panel, choose Workspace → Save Image,
or click the Save Image button on the Workspace toolbar. 

The panel is a file selector that includes options for saving the image. These options are not
displayed by default, but you can display them by clicking Options.

The Save Image panel allows you to set the following options:

• Smooth—Select this option to turn on scene anti-aliasing. This creates smoother edges,
but takes longer to save the image. 

• Transparent background—Save the image with a transparent background, instead of the
Workspace background color.

• Quality—(for JPEG only) Use the slider to select a quality level from 1 to 100. The
default is 5. The higher the quality level, the longer it takes to save the image. For high
resolution images, this can take a while.

• Gamma—(for PNG only) Use the slider to select a gamma encoding level, from 0 to 1. 

• Workspace—This noneditable area displays the dimensions of the Workspace in the units
given for the image, below. 

• Image—Enter the desired width and height of the image. These proportions are con-
strained, so if you change one parameter, the other adjusts automatically. To change the
units, select either Pixels or Inches from the option menu. 
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Figure 16.1. The Save Image panel.

• DPI—Choose a resolution for the image or enter a specific value. If you choose Pixels for
the units, this option is unavailable and the specified pixels are used. 

The panel has two display areas that provide information about sizes:

• Workspace—Displays the measurement of the Workspace, not the whole main window.
These values can not be edited directly. However, if you resize the Workspace, the values
are updated automatically. The units are determined by the choice made for the image. 

• Final Image size—Displays the final resolution of the image (in pixels). This value is not
editable, but you can change it by changing the options above.

The image format can be selected from the Files of type option menu. The three supported
formats are:

• TIFF—Images in TIFF format are saved without compression, and are “lossless” (all of
the information in the original image is retained), but the file can be quite large. The TIFF
format is recommended for saving high quality Maestro images.
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• JPEG—JPEG is actually a compression method, not an image format. Maestro uses the
JPEG-based JPEG-File Interchange Format (JFIF), the most commonly used JPEG file
format. The JPEG file format specifies a means of compressing natural images that does
not severely impair the perceived image “quality”. The JPEG method is almost always
“lossy”, meaning that the reconstituted pixel data differs from that of the original. For
natural images, these differences are not generally noticeable. However, in general, the
JPEG method is not recommended for saving synthetic images like those Maestro pro-
duces, because there may be noticeable distortions in the saved image, such as subtle
color changes. This option is provided because it allows you to create extremely compact
screen shots for sending with an e-mail message or inserting in web pages.

• PNG—A bitmap image that uses lossless data compression. This format can also produce
compact images. PNG stands for Portable Network Graphics. 

When are you are ready to save an image, make sure the Workspace is unobstructed:

• Undisplay the clipping planes window by right-clicking it and choosing Hide or choose
Window → Clipping Planes. 

• Make sure there are no panels or dialog boxes overlapping the Workspace. This includes
the Save Image panel. 

Note: When saving high resolution images in wire molecular representation, you may need
to adjust the wire width so that the bonds remain visible at the higher resolution. The
automatic scaling of the wire width is used for larger images. The adjustment may take
some experimentation, depending on the purpose of the image. See Section 14.14.1 on
page 378 for information on changing the molecular representation attributes.

To save an image: 

1. Choose a format from the Files of type option menu.

2. If you want to increase the quality of a JPEG image, use the Quality slider to select the
quality level.

3. Select the units you want to use: Pixels or Inches.

4. Adjust the image size (width and height).

The Workspace size can only be adjusted by actually resizing the main Maestro window.

5. Select a resolution under DPI. (If you chose Pixels above, this option is unavailable.)

The final image resolution is displayed in pixels near the bottom of the panel.

6. Navigate to a directory, and select or enter a file name.

7. Click Save.
Maestro 10.2 User Manual 401



Chapter 16: Saving Workspace Images

402
16.2 Copying Images to Other Applications

You can copy images of the Workspace to other applications using the clipboard. To make a
copy of the image, choose Edit → Copy. The image is saved at the current screen resolution to
the clipboard both as an image and as a pixmap. You can then paste the image into another
application, such as a word-processing program. 
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Chapter 17: Using Maestro with Other Applications
As well as providing an interface to most of Schrödinger’s software, Maestro also has inter-
faces to other applications. You can transfer data from Maestro to Canvas and to PyMOL, and
you can copy structures between Maestro and applications like ChemDraw and Isis Draw. This
chapter describes the ways in which Maestro can be used with these other applications. 

17.1 Canvas

Canvas is Schrödinger’s cheminformatics program. The Canvas GUI has its own projects and
data storage that are separate from Maestro projects. You can export structures and data from
the Project Table to Canvas. This feature is described in Section 3.5 on page 60.

17.2 KNIME

KNIME is a program for graphically constructing workflows from various applications, which
are encapsulated in “nodes” that can be connected, so that the output from one application is
used as input to another. Schrödinger provides a wide range of KNIME nodes that can be used
to construct workflows. KNIME workflows can be run from Maestro rather than from the
KNIME interface or the command line, by wrapping a KNIME workflow in a Python script
and installing it on the Workflows menu. The nodes that are used to communicate structures
and data to KNIME do not require a license, so no specific license is required to run workflows
containing only third-party nodes from Maestro.

In addition to running workflows from Maestro, you can send and receive structures to a
running KNIME session from Maestro through a lightweight server that communicates with
both applications. No license is required for this feature either. 

For further information, see the KNIME Extensions User Manual.

17.3 PyMOL

For users who like to use PyMOL, Maestro provides a convenient way of transferring struc-
tures and associated data to PyMOL, via the PyMol for Maestro panel. This panel allows you to
start PyMOL, load structures from Maestro to PyMOL, and make settings for the PyMOL
scene and image. You must purchase the “incentive” version of PyMOL to use this feature,
because the components required for this feature to work are not in the free version.
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To open the PyMol for Maestro panel, choose Tools → View in PyMOL in the main window. 

Figure 17.1. The PyMOL for Maestro panel.

Maestro uses the following sources to find an installation of PyMOL to use, in the order given:

1. On Windows, the registry.

2. The PYMOL4MAESTRO environment variable. This environment variable should point to
the top directory of the PyMOL installation. This is the preferred method of specifying
the location of PyMOL.

3. A PyMOL launch script called pymol4maestro in the Schrödinger software installation.
This script must run PyMOL.

4. A PyMOL installation in $SCHRODINGER/pymol.

5. The standard PyMOL environment variable PYMOL_PATH.

6. On Windows, C:\Program files\pymol\pymol.

7. A launch script called $SCHRODINGER/pymol.

You can choose to send the Workspace structure or the selected entries to PyMOL. These struc-
tures are written to disk and then read by PyMOL, which is automatically started. You can also
start PyMOL without sending structures to it by clicking Launch, and you can then hide or
show the PyMOL panel by clicking the relevant button. 

Once you have structures in PyMOL, you can use the PyMOL for Maestro panel to perform
some of the PyMOL operations, like appending a scene to the list, stepping through scenes,
updating and deleting scenes. You can choose whether to use ray tracing or rendering for the
image, and save the current image, with the Image buttons. For the representation, you can use
the closest match to Maestro’s representation with the Closest Match option, or use PyMOL’s
representation by deselecting this option. You can also use the PyMOL or the Maestro mouse
functions, with the Remap Mouse option, and show or hide the scene buttons in PyMOL with
the Scene Buttons option. Finally, you can clear PyMOL, save a PyMOL session, and quit
PyMOL with the PyMOL buttons.
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If you are running Maestro and PyMOL on a Mac, you can use the X11 version of PyMOL
rather than the native version, by selecting Use X11 in the PyMOL for Maestro panel.

17.4 ChemDraw and ISIS/Draw

When you copy a structure in ChemDraw or ISIS/Draw, it is placed on the clipboard as an
object with an application-specific MIME type. Maestro recognizes objects with these MIME
types, so you can paste them into the Workspace. The details of how the structure is pasted are
given in Section 3.7 on page 61. You must make sure that all atoms in the structure have
explicit atom types, not generic metals (M) or organic groups (R). 

In ISIS/Draw, you must set an option to enable copying to the clipboard in the appropriate
MIME format. To do so, go to Options → Settings → General and select Copy Mol/Rxnfile to
the Clipboard. 

If you want to paste a structure from Maestro into ChemDraw, you can paste it as a SMILES
string. When you copy a structure in Maestro, it is added to the clipboard as a SMILES string,
which you can then paste into any other application that accepts a SMILES string.
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Chapter 18: Help
This chapter describes the various ways in which you can obtain information on Schrödinger’s
products. Maestro has an online help facility, automatic context-sensitive help (Auto-Help),
and tool tips (balloon help). Manuals in PDF format are included with the product distribution,
and each product has a Known Issues page on the Schrödinger web site.

18.1 The Help Menu

The Help menu in the main window provides access to various kinds of information about
Maestro and Schrödinger products. The items on this menu are described briefly below. Some
of these items are described in more detail in later sections. 

• Help—Opens the Help panel at the default help topic.

• Documentation Index—Opens the documentation index file in the Help panel. Click a
link to view a manual or other document in your PDF viewer.

• Search Manuals—Opens the full text search index for the PDF documentation in Adobe
Reader. You can then search across all the PDF documentation for words or phrases.

• Python Module Overview—Opens the top-level document that provides an overview of
the Python modules supplied for use with Schrödinger software. 

• Python API Reference—Opens the top-level document that provides access to detailed
descriptions of the Python modules supplied for use with Schrödinger software.

• Keyboard Shortcuts—Displays a help topic that describes use of the keyboard keys in
Maestro.

• Tips—Displays a help topic that provides tips for using Maestro.

• Tutorials—Opens the Tutorials panel, in which you can choose a tutorial, copy the files,
and open the relevant manual.

• New Features—Displays a file that contains information on the new features in the cur-
rent release. 

• Known Issues—Submenu with a list of products for which known issues pages are avail-
able on the Schrödinger web site. When you choose a product from the submenu, the
Known Issues page opens in your browser. If you are not logged on to the Schrödinger
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web site, you are redirected to the logon page. After logging on, the page is displayed.

• Knowledge Base—Opens the Knowledge Base page on the Schrödinger web site in your
browser.

• Diagnostics—Opens the Diagnostics panel, in which you can run licensing and installa-
tion diagnostic tests, and generate reports to send to technical support. See Section 6.8
and Section 7.10.1 of the Installation Guide for more information. 

• About Maestro—Opens a window that gives information about Maestro versions and
copyright and licensing notices.

• About Applications—Opens a help topic that gives a brief description of Schrödinger
products.

• About Utilities—Opens your PDF viewer with the quick reference sheet that describes the
utilities in $SCHRODINGER/utilities.

• Contact Technical Support—Displays a form on the Schrödinger web site that you can fill
in to create a technical support ticket.

18.2 Maestro Help

For information on performing a particular operation in Maestro, look for answers first in the
help. The help system includes descriptions of all the Maestro panels and how to use them, and
other information on performing various tasks. In addition, it has active links to other sources
of information, such as the PDF manuals and the Schrödinger web site.

The Maestro help is presented in the Help panel. You can open the help panel in the following
ways:

• Click the Help button in the lower right corner of a panel or dialog box, or press F1. The
button may have text or an icon.

A topic is displayed that gives information about the panel, dialog box, or current tab in
the panel. 

• Choose Help from the Help menu, or press CTRL+H (H) in the Workspace. A topic is
displayed that gives information about getting help.

• Choose Help from a shortcut menu in the Workspace, to open a relevant help topic. 

Most topics contains a list of contents at the top that you can click to go to the relevant section,
and a list of related topics at the end that you can click to select a new topic. 
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Figure 18.1. The Help panel.

The Help panel has a toolbar at the top, with navigation and search tools. The Previous and
Next buttons take you to the previous and the next topic or set of search results. 

The Home button displays a list of all help topics with links, in alphabetical order. 

To search for text across all topics, enter the words in the search text box, and press ENTER or
click the Search button. 

The results are displayed in the display area, and you can click the links to display the topic
that contains the words. 
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By default, the search looks for all the words you enter (implicitly inserting “and” between the
words). The search allows you to construct complex search expressions:

• Use ‘and’, ‘or’, and ‘not’ to construct conditional expressions. For example, ‘ligand prep-
aration not protein’ finds topics that contain ‘ligand’ and ‘preparation’ but not ‘protein’. 

• Use parentheses to group expressions, e.g. ‘(ligand not protein) preparation’ first looks
for topics that contain ‘ligand’ but not ‘protein’, and then looks in the results of that
search for topics that contain ‘preparation’. 

• Use double quotes to search for an exact phrase, e.g. “protein preparation”. 

To find words in a single topic, click the Find on page button. 

You can then enter the words in the search text box and press ENTER or click the Search

button. Click the arrow buttons to go to the next or the previous hit in the page. 

18.3 Context-Sensitive Help

Maestro has two other help features, which are described below.

Auto-Help

The Auto-Help text area is located at the foot of the main window. The Auto-Help facility
provides automatic context-sensitive help, usually providing information about the task to be
completed. For example, when you open the Atom Labels panel, Auto-Help prompts you to
pick an atom to label. Auto-Help is not available for all operations.

Tooltips

Tool tips (Balloon Help) consist of a floating text box containing context-sensitive help that
appears when the pointer rests on an object. The box disappears when you move the pointer.
You can temporarily disable tool tips by deselecting Show tooltips in the Appearance tab of the
Preferences panel. Tool tips are available for many but not all interface components.
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18.4 Manuals

Manuals are available in PDF format on the program DVD or the download, and are installed
into the docs folder (directory) of your software installation. Manuals can be opened via the
HTML documentation index Documentation_Index.html (Help → Documentation Index),
or via a PDF index, Manuals_Index.pdf, which you can open in your PDF viewer. On
Windows you can open the documentation index from the Start menu. 

Manuals (and the PDF index) contain links to other manuals. As not all PDF viewers treat
cross-document links correctly, we recommend the following viewers:

• Linux: okular or evince 
• Mac: Adobe Reader
• Windows: Adobe Reader.

If you have Adobe Reader installed, in a version no earlier than 6.0, you can use the search
index provided with the documentation to search the entire manual set. You do not need to load
this index to search the documentation with Adobe Reader, but it makes the search much
quicker. Choose Help → Search Manuals or open Manuals_Search.pdx in Adobe Reader,
and then do the search. This file is stored in the docs folder. The problems with Adobe Reader
on Linux not following links does not affect the links to documents in the search results. 

If you use more than one search index in Adobe Reader, you can select the Schrödinger index
by following the instructions below.

1. Click Search.

2. Click Advanced Search Options at the bottom of the panel.

3. Under Look In, choose Select Index. 

4. Navigate to and select the file schrodinger.pdx, which is in $SCHRODINGER/docs.

5. Ensure that this is the only index selected for searching.

If a document does not open when you click the link to it, the problem could be one of those
listed below.

1. The document is not installed. 

The installed documents are located in $SCHRODINGER/docs/product, where product is
maestro, for example. By default, all the documentation is installed. See the Installation
Guide for installation information. 

2. The document was copied by the application and the relative links between PDF files are
not preserved. 
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This can happen if the PDF reader is not used as a plugin in recent browsers. In some
older browsers relative links are not preserved when a PDF file is opened with a plugin.
One solution is to upgrade your browser. Another solution is to open this file directly in
your PDF reader. You can open this document directly in your PDF reader from the Mae-
stro Help menu, by choosing Documentation Index. 

3. There are issues with the PDF reader (as described above). 

18.5 Tutorials

Tutorial material is provided with most of the products, either in the User Manual or in a sepa-
rate Quick Start Guide. The tutorials come with input structures, which are kept in zip files in
$SCHRODINGER/tutorials. You can copy the input structures and open the tutorial docu-
mentation from the Tutorials panel, which you open by choosing Help → Tutorials.

Figure 18.2. The Tutorials panel.

To enable you to choose a particular kind of exercise or tutorial set, the tutorials are put into
one or more classes, and these classes are grouped under broader categories. You can choose
the category from the Show tutorials by option menu (e.g. Modeling method), and the option
menu below it is populated with the classes that belong to this category. When you make a
choice from these option menus, a list of tutorials in the chosen class is displayed in the table,
each with a title and a description. 
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For example, if you choose to show tutorials by Task, the option menu below Show tutorials by

is labeled Task, and you can choose from various tasks. If you choose Data fitting from this
option menu, for example, a list of tutorials that involve data fitting is displayed in the table,
sorted alphabetically by the tutorial title (given in the Tutorial column). 

The tutorials listed can include entire Quick Start Guides or tutorial chapters in User Manuals,
or individual exercises within one of these tutorials. You can then choose the tutorial that you
are interested in from the table.

Once you have chosen the tutorial, you can copy the input files to your working directory. You
can specify the working directory in the Copy to text box, or click Browse to navigate to the
desired directory. After specifying the directory, click Copy to copy the tutorial input files to
this directory, which is created if it does not exist.

To view the instructions for the tutorial, click View. If you have Adobe Reader installed, the
PDF document opens at the tutorial exercise that you have chosen (which for entire manuals is
the beginning of the tutorial exercises). Otherwise, the PDF document opens at the beginning,
and you can use the bookmarks or the Contents to find the tutorial exercise. The title listed in
the Tutorial column is usually the title of the section in the document that contains the instruc-
tions. 

18.6 The Schrödinger Web Site

The Schrödinger web site, http://www.schrodinger.com, contains information about all our
products. In the Support Center, you can find the manuals in PDF format and known issues
pages for each product. The manuals on the web site are the most up-to-date. The web site also
contains information about product releases and software updates. Consult the web site for the
most recent information on a product.

The web site has a knowledge base at http://www.schrodinger.com/kb that covers many
common questions and issues, including problems and workarounds, restrictions and limita-
tions, fixes to software issues, instructions for particular tasks, and information on specific
features of the software. You can search the knowledge base from this page, or you can use
your favorite search engine, and include Schrodinger in the search terms. 
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18.7 Technical Support

If you have questions that are not answered from any of the above sources, contact Schrödinger
using the information below. 

Web: http://www.schrodinger.com/supportcenter 
E-mail: help@schrodinger.com
Mail: Schrödinger, 101 SW Main Street, Suite 1300, Portland, OR 97204
Phone: +1 888 891-4701 (USA, 8am – 8pm Eastern Time)

+49 621 438-55173 (Europe, 9am – 5pm Central European Time)
Fax: +1 503 299-4532 (USA, Portland office)
FTP: ftp://ftp.schrodinger.com

Generally, using the web form is best because you can add machine output and upload files, if
necessary. You will need to include the following information: 

• All relevant user input and machine output
• Maestro purchaser (company, research institution, or individual)
• Primary Maestro user
• Installation, licensing, and machine information as described below.

The instructions below describe how to gather the required machine, licensing, and installation
information, and any other job-related or failure-related information, to send to technical
support. Where the instructions depend on the profile used for Maestro, the profile is indicated. 

For general enquiries or problems:

1. Open the Diagnostics panel.

• Maestro: Help → Diagnostics 
• Windows: Start → All Programs → Schrodinger-2015-2 → Diagnostics 
• Mac: Applications → Schrodinger2015-2 → Diagnostics 
• Command line: $SCHRODINGER/diagnostics

2. When the diagnostics have run, click Technical Support.

A dialog box opens, with instructions. You can highlight and copy the name of the file.

3. Upload the file specified in the dialog box to the support web form.

If you have already submitted a support request, use the upload link in the email response
from Schrödinger to upload the file. If you need to submit a new request, you can upload
the file when you fill in the form.
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If your job failed:

1. Open the Monitor panel, using the instructions for your profile as given below:

• Maestro/Jaguar/Elements: Tasks → Monitor Jobs
• BioLuminate/MaterialsScience: Tasks → Job Monitor

2. Select the failed job in the table, and click Postmortem.

The Postmortem panel opens.

3. If your data is not sensitive and you can send it, select Include structures and deselect
Automatically obfuscate path names. 

4. Click Create.

An archive file is created, and an information dialog box with the name and location of
the file opens. You can highlight and copy the name of the file.

5. Upload the file specified in the dialog box to the support web form. 

If you have already submitted a support request, use the upload link in the email response
from Schrödinger to upload the file. If you need to submit a new request, you can upload
the file when you fill in the form.

6. Copy and paste any log messages from the window used to start the interface or the job
into the web form (or an e-mail message), or attach them as a file. 

• Windows: Right-click in the window and choose Select All, then press ENTER to
copy the text. 

• Mac: Start the Console application (Applications → Utilities), filter on the applica-
tion that you used to start the job (Maestro, BioLuminate, Elements), copy the text.

If Maestro failed: 

1. Open the Diagnostics panel.

• Windows: Start → All Programs → Schrodinger-2015-2 → Diagnostics 
• Mac: Applications → SchrodingerSuite2015-2 → Diagnostics 
• Linux/command line: $SCHRODINGER/diagnostics

2. When the diagnostics have run, click Technical Support.

A dialog box opens, with instructions. You can highlight and copy the name of the file.

3. Upload the file specified in the dialog box to the support web form.

If you have already submitted a support request, use the upload link in the email response
from Schrödinger to upload the file. If you need to submit a new request, you can upload
the file when you fill in the form.
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4. Upload the error files to the support web form. 

The files should be in the following location:

• Windows: %LOCALAPPDATA%\Schrodinger\appcrash 
(Choose Start → Run and paste this location into the Open text box.)
Attach maestro_error_pid.txt and maestro.exe_pid_timestamp.dmp.

• Mac: $HOME/Library/Logs/CrashReporter 
(Go → Home → Library → Logs → CrashReporter)
Attach maestro_error_pid.txt and maestro_timestamp_machinename.crash.

• Linux: $HOME/.schrodinger/appcrash 
Attach maestro_error_pid.txt and crash_report_timestamp_pid.txt. 

If a Maestro panel failed to open:

1. Copy the text in the dialog box that opens. 

2. Paste the text into the support web form. 
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Appendix A: The Maestro File Format
All Schrödinger products use the Maestro file format as their primary method of storing molec-
ular structure information. The Maestro file format is extensible. That is, users and third-party
programs can add additional fields that will be accepted and retained when the files are read by
Schrödinger products. Maestro files are also self-describing; data items are named rather than
simply identified by position, and the data type (string, real number, integer and Boolean) is
included as a single-digit code letter at the beginning of each data name.

Since Maestro files can accept additional user-defined fields, it is not possible to give an all-
inclusive example of a Maestro file. Instead, this appendix gives a general overview of the
Maestro file format and describe the components used for most Schrödinger applications.

A.1 Basic File Description

Maestro format files are free-format ASCII text. All white space (spaces, tab characters, end of
lines etc.) is ignored. Schrödinger applications will write files in a consistent layout in order to
enhance human readability but the files are not, in fact, required to follow this layout. Except
for the requirement that string type data items which contain blanks be surrounded by double
quotes, there are no restrictions, such as width or precision of the numeric fields, on the data
items.

A.2 Data Blocks

The basic unit of a Maestro file is a block, a series of data items contained within a pair of
curly braces { }. For instance, the following is the first block of the example file in shown in
this appendix:

{
    s_m_m2io_version
    :::
    1.0.0
}

Most blocks in the Maestro file are proceeded by a name, for example, f_m_ct, where ‘f’
stands for ‘full’ (see below), ‘m’ generally stands for ‘Maestro’ because the data originated
from Maestro, and ‘ct’ stands for ‘CT’—short for ‘Connection Table’, which can generally be
thought of as a collection of atoms.
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Blocks can be nested within other blocks, and if a block contains a list of data values, the block
may be indexed. That is, the number of data values contained in the block can be appended to
the name. Indexed blocks are identified by having names of the form: 'name[<number of
items>]'. For example, the file shown in Section A.5 contains an indexed block of the name
m_atom[18]. In this block name, 'm' means that the data originated in Maestro, 'atom'
means that the data values included in the block belong to atoms, and '18' indicates that are
18 sets of data in the indexed block (representing 18 atoms). 

Within each block there are two sections: a list of the names corresponding to the data fields
included in each data item, and the actual data items. In the example file, the first three data
field names in the m_atom[18] block are:

The end of the first section is denoted by a separator ':::', and followed by the actual data items.
In the example file, the first three data items are:

There must be the same number of data values as there are data names, and the fields within the
data items must appear in the same order as the data names are listed. In the above example, for
instance, the first field in the first line of data ('1') is the index number. The second number
('3') is the MacroModel atom type, indicated by the data name i_m_mmod_type. Index
numbers are required in an indexed block and do not count against data names.

The end of the data item section is indicated by a second ':::' separator. A file may contain any
number of structures (CT blocks), and each structure block may contain any number of atom
and bond data items. 

    i_m_mmod_type

    r_m_x_coord

    r_m_y_coord

    1    3   0.547623    1.262401   -0.990300    1 " " X " "    2   
0.00000   0.00000 CHEX "    " "    "      6   0   0  1   ""

    2   3   -0.930177    1.296701   -1.411700    1 " " X " "    2   
0.00000   0.00000 CHEX "    " "    "     6   0   0  1   ""

    3   3   -1.821477    1.772701   -0.253300    1 " " X " "    2   
0.00000   0.00000 CHEX "    " "  c1"   6   0   0  1   ""
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A.3 Compressed Format

Files may use a compressed format, most commonly when storing information for a set of
conformers. In a compressed file, the first CT block must be a “full” block containing all the
information described above. The name of this block is 'f_m_ct'. This full block can be
followed by any number of “partial” CT blocks with the name 'p_m_ct'. The partial blocks
contain only information which is different from that in the last preceding full CT block. For
example, a file of conformers will have only one copy of the bond table (the m_bond[36]
block in the example file), and it will be stored in the full CT. Subsequent partial CT blocks
will read bond information from the preceding full CT block.

A.4 Data Item Names

The names of data items in a Maestro format file follow a convention which allows the type of
the data item and the “owner” of the data to be identified. Names have the form 't_o_d',
where t is the type descriptor, o is the “owner” and d is the actual data name. For instance, the
first data name in the m_bond[36] block is 'i_m_mmod_type'. The first character of the name
represents the data type. The acceptable types are:

Owner values indicate the application from which the data item most likely originated.
Including this field in the data name allows multiple applications to store identically titled
quantities. For instance, two applications could store data fields named “energy.” Currently,
basic geometrical and connectivity information, which is shared by most Schrödinger applica-
tions, have 'm' (for Maestro) owner fields. Data introduced by MacroModel have 'mmod'
owner fields, data introduced by QikProp have 'qp' owner fields.

In the 'i_m_mmod_type' example, 'i' indicates the value in the corresponding data field is an
integer. The letter 'm' in the owner field means that the data originated from Maestro, and
'mmod_type' is an abbreviation for “MacroModel atom type,” which is what the data field
represents.

A.5 Example Maestro File

Below is extract from a Maestro format file. The complete file is not shown. Where data has
been exempted, it has been noted with an ellipse (...). The text in italic type is provided as
annotation and is not a part of the file.

i – integer s – string value

r – real number b – Boolean value
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The first block in the file is unnamed. This contains required information that is relevant to
the whole file.

{ 

  s_m_m2io_version

  :::

  1.0.0

}

f_m_ct { The “CT” block. Each structure in the file is contained in such 
a block. This is a full block.

  s_m_title The only CT-level data name. A string value 
representing the title of this structure.

  ::: The separator between the data names and data values.

 "Cyclohexane" The value of the “title” data item.

 m_atom[18] { The start of the atom block for this CT block. There are 18 
atoms in this block.

    i_m_mmod_type The MacroModel atom type.

    r_m_x_coord The X-coordinate.

    r_m_y_coord The Y-coordinate.

    r_m_z_coord The Z-coordinate.

    i_m_residue_number The residue number.

    s_m_insertion_code The PDB insertion code.

    s_m_mmod_res The one-letter MacroModel residue code.

    s_m_chain_name The PDB chain name.

    i_m_color The color for this atom.

    r_m_charge1 The partial atomic charge.

    r_m_charge2 The partial atomic charge.

 s_m_pdb_residue_name The PDB residue name.

    s_m_pdb_atom_name The PDB atom name.
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    s_m_grow_name The name used by the Maestro structure builder.

    i_m_atomic_number The atomic number.

    i_m_formal_charg The formal charge.

    i_m_representation The representation used to draw this atom.

    i_m_visibility A flag to indicate whether this atom is
displayed in Maestro or not.

    s_m_atom_name The user-specified atom name.

    ::: The separator for the end of the data items.

Next follow the data values. The first column contains an index number that is assigned automatically. 
Remaining columns represent the data values in the same order as data names given above.

1   3   0.547623     1.262401   -0.990300    1 " " X " "     2   0.00000   
0.00000 CHEX "    " "    "      6   0   0  1   ""

2   3   -0.930177    1.296701   -1.411700    1 " " X " "     2   0.00000   
0.00000 CHEX "    " "    "     6   0   0  1   ""

3   3   -1.821477    1.772701   -0.253300    1 " " X " "     2   0.00000   
0.00000 CHEX "    " "  c1"   6   0   0  1   ""

4   3   -1.624777    0.890901    0.990300     1 " " X " "    2   0.00000    
0.00000 CHEX "    " "    "     6   0   0  1   ""

    ....

17  41  0.493223   -0.677999   0.001900   1 " " X " "   21   0.00000   0.00000 
CHEX "    " "  n3"    1  0  0   1   ""

18  41  1.817023    0.395501   0.566000    1 " " X " "   21   0.00000   
0.00000 CHEX "    " "  n2"   1   0  0  1   ""

    ::: The separator for the end of the data values.

} The end of the atoms block.

        m_bond[36] { The bond block. There are 36 bonds.

    i_m_from The atom the bond is from.

    i_m_to The atom the bond is to.

    i_m_order The bond order.

    i_m_from_rep The graphical representation for the “from” half-bond.
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    i_m_to_rep The graphical representation for the “to” half-bond.

    ::: The end of the data names for bond data.

What follows are the data items for the bond block. The first column contains an automatically 
assigned index number for each item.

    1   1    2   1 1 1

    2   1    6   1 1 1

...

    35  17   6   1 1 1

    36  18   6   1 1 1

    ::: The end of the bond data items.

  } The end of the bond block.

} The end of the CT block.
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Maestro atom types are not “hard-wired” into the program, but are read in at run-time from a
file called atom.typ, which is installed in $SCHRODINGER/mmshare-vversion/data. We
continue to use the original MacroModel atom types for most applications, but now have a
mechanism for easily adding new types. 

You can add your own atom types and supply parameters for these types in the force-field file.
The default atom.typ file is the one located in $SCHRODINGER/mmshare-vversion/data. A
local file of this name overrides the default, as does a local file whose name is filename.typ,
where filename is the stem of the filename.mae file. This system of default version with local
overrides is analogous to that used for force field and solvation files.

Currently Maestro accepts atom types up through number 300. We restrict the type numbers
that we supply to the range 0 through 199. When adding your own types, you should begin
with the number 200. Negative atom types are not accepted.

Inside Maestro you can change atoms in existing structures to new types, including user-
defined types. However, no provision is made in the current version for the builder to obtain the
geometric information it needs from the atom.typ file, which would require extensions to the
format of this file. Also, the original atom types remain “hard-wired” in Maestro. Therefore,
you should not attempt to redefine types which we supply. Instead, add new types. The
atom.typ file itself contains comments describing its format and usage.

The atom types and their equivalents in other force fields are listed in Table B.1 and Table B.2.
These atom types are defined in the atom.typ file. Note that 00 atoms are stored as type 0 in
the atom connection table, and that all current force fields require explicit hydrogens on hetero-
atoms.
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Table B.1. Atom types and equivalents. 

No. Symbol Description

Equivalencies

MM2/
MM3 Charmm Amber

 1 C1 Carbon - sp 

 2 C2 Carbon - sp2 2,3 CT,C C, C*, CA, 
CB, CC, CM, 
CF, CG, CN

 3 C3 Carbon - sp3 1 CT CT

 4 CA United atom CH - sp3 CH1E CH

 5 CB United atom CH2 - sp3 CH2E C2

 6 CC United atom CH3 - sp3 CH3E C3

 7 CD United atom CH - sp2 CR1E CD, CE, CJ, 
CP

 8 CE United atom CH2 - sp2

 9 CF United atom CH - sp

10 CM Carbanion (C–)

11 CP Carbocation (C+) 30

12 CR Carbon free radical 29

...

14 C0 Any carbon

15 O2 Oxygen - double bond 7 O O, O2

16 O3 Oxygen - single bond 6 OH1, OH2 OS, OH 

17 OA United atom OH OH1E 

18 OM O− (alkoxide, carboxylate) 47 OC 

19 OW United atom H2O OH2E

20 OP Oxonium (sp2) =[O+]–

21 OQ Oxonium (sp3) R3O
+

...

23 O0 Any oxygen

24 N1 Nitrogen - sp 10
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25 N2 Nitrogen - sp2 9 N, NR, NP, 
NH1, NH2

N, NB, NC, 
N*, N2

26 N3 Nitrogen - sp3 8 NH3 NT

27 NA United atom NH - sp3 

28 NB United atom NH2 - sp3 NH1E

29 NC United atom NH - sp2 

30 ND United atom NH2 - sp2 NH2E

31 N4 N+ - sp2 NC2 NA

32 N5 N+ - sp3 39 N3

33 NE United atom NH+ - sp3 

34 NF United atom NH2
+ - sp3 

35 NG United atom NH3
+ - sp3 NH3E

36 NH United atom NH+ - sp2 

37 NI United atom NH2
+ - sp2 NC2E

38 NM N– - sp3 

39 NP N– - sp2 

40 N0 Any nitrogen

41 H1 H-Electroneut(e.g., C,S) 5, 44 HA HC, HS

42 H2 H-O (Neutral) 21, 24 H,HC HO

43 H3 H-N (Neutral) 23, 28 H,HC H, H2

44 H4 H+ (Cation) 48 MM3 
(none in 
MM2)

H3

45 H5 H– (Anion)

...

48 H0 Any hydrogen 

49 S1 Sulfur 15,17,18 S S, SH

50 SA United atom SH SH1E

Table B.1. Atom types and equivalents.  (Continued)

No. Symbol Description

Equivalencies

MM2/
MM3 Charmm Amber
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51 SM S– (thiolate anion)

52 S0 Any Sulfur S

53 P3 Phosphorus, trivalent 25 P

54 B2 Boron - sp2 26

55 B3 Boron - sp3 27

56 F0 Fluorine 11

57 Cl Chlorine 12

58 Br Bromine 13

59 I0 Iodine 14

60 Si Silicon 19

61 Du Dummy atom for FEP

62 Z0 Special atom to be defined

63 Lp Lone electron pair LP

64 00 Any atom 0 *

65 Li Li+ Li

66 Na Na+ SOD Na

67 K0 K+ POT K0

68 Rb Rb+ Rb

69 Cs Cs+ CES

70 Ca Ca+2 CAL

71 Ba Ba+2 

72 Mg Mg+2 MG

73 M2 Mn+2 

74 M3 Mn+3 

75 M4 Mn+4 

76 M5 Mn+5 

77 M6 Mn+6 

Table B.1. Atom types and equivalents.  (Continued)

No. Symbol Description

Equivalencies

MM2/
MM3 Charmm Amber
Schrödinger Software Release 2015-2



Appendix B: Atom Types
78 M7 Mn+7 

79 f2 Fe+2 

80 f3 Fe+3 

81 o2 Co+2 

82 o3 Co+3 

83 n2 Ni+2 

84 n3 Ni+3 

85 c1 Cu+ 

86 c2 Cu+2 

87 Zn Zn+2 

88 m3 Mo+3 

89 m4 Mo+4 

90 m5 Mo+5 

91 m6 Mo+6 

92 Sr Sr+2 

93 L0 Lithium neutral

94 M0 Magnesium neutral

95 As Arsenic, pentavalent tetrahedral 
(e.g. AsO4

3–)

...

100 SP S+ 

101 S2 Sulfur - sp2 

102 Cm Cl– CLA

103 B0 Any boron

104 Fm F– 

105 Bm Br– 

106 Im I– 

Table B.1. Atom types and equivalents.  (Continued)

No. Symbol Description

Equivalencies

MM2/
MM3 Charmm Amber
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107 P5 Phosphorus, pentavalent tetra-
hedral (e.g. PO4

3–)

108 P0 Any phosphorus

109 S4 Sulfur, tetravalent

110 S6 Sulfur, hexavalent octahedral 
(e.g. SF6)

111 P4 P+, tetravalent

112 Se Selenium

113 ST Sulfur, hexavalent tetrahedral 
(e.g. SO4

2–)

114 Sm Sulfide anion, S2–

115 Om Oxide anion, O2–

...

150 PI Ligand dummy atom

Table B.1. Atom types and equivalents.  (Continued)

No. Symbol Description

Equivalencies

MM2/
MM3 Charmm Amber
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Table B.2. Generalized atom types.

No. Symbol Description

151 GA Isolated atom

152 GB Linear-single coordinate

153 GC Linear-two coordinate

154 GD Trigonal-two coordinate

155 GE Trigonal-three coordinate

156 GF Tetrahedral-three coordinate

157 GG Tetrahedral-four coordinate

158 GH Trigonal bipyramid-three coordinate

159 GI Trigonal bipyramid-four coordinate

160 GJ Trigonal bipyramid-five coordinate

161 GK Octahedral-four coordinate

162 GL Octahedral-five coordinate

163 GM Octahedral-six coordinate

164 GN Pentagonal bipyramid-seven coordinate

165 GO Twisted cube-eight coordinate

166 GP Nine coordinate

167 GQ Ten coordinate

168 GR Eleven coordinate

169 GS Icosahedron-twelve coordinate

170 GT Thirteen coordinate

171 GU Fourteen coordinate

172 GV Fifteen coordinate

173 GW Sixteen coordinate
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Appendix C: Substructure Notation
This appendix describes a linear substructure notation proprietary to Schrödinger, referred to
as mmsubs. The mmsubs notation is based on the linear substructure notation used in Macro-
Model. The implementation is independent of the MacroModel implementation, and has some
extensions over the MacroModel notation, along with a few differences. 

Both mmsubs and MacroModel notations resemble the better-known SMILES and SMARTS
notations. They all involve atom type symbols, bond symbols, and other connectivity indica-
tions, such that an arbitrary topology (including branches and rings) can always be expressed
in a linear pattern string.

An mmsubs pattern expresses a molecular substructure as a list of atoms connected by bonds.
An atom can be specified either exactly, using a symbol for a specific atom type, or loosely,
using a symbol encompassing multiple atom types. Similarly, a bond can be specified either
exactly, using a symbol for a specific bond order, or loosely, using the wildcard bond order
symbol (which covers all bond orders).

Patterns can be limited to the required atoms and bonds. In mmsubs pattern matching, only the
atoms and bonds explicitly specified are searched for. No assumption is made about anything
else that may be attached: unspecified attachments cannot disqualify a match on the explicit
pattern. Pattern matching does not include checking of valency against the specified bond
orders. This is not usually a problem, because illegal valencies will generally not be matched.

The syntax to represent connectivity differs somewhat from that used in SMILES and
SMARTS. The support for expressing structural alternatives is also different between nota-
tions. The mmsubs notation is somewhat less flexible than SMILES and SMARTS, but the
reduced flexibility rarely presents a serious problem.

C.1 Atom and Bond Types

Structures expressed in mmsubs (or MacroModel) notation use MacroModel atom type
symbols. The MacroModel atom types are listed in Appendix B. 

Every MacroModel atom type symbol is two characters long, and is case-sensitive. It can
consist of letters and numbers, so you must be careful to distinguish between O and 0 (upper-
case letter O and zero), and between l and 1 (lower-case letter L and one).
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If there are multiple atom types for an element, a wildcard symbol encompassing all of the
element’s atom types is provided. Our convention is to spell it with the usual first letter
followed by 0 (zero). For example, the wildcards to specify any carbon and any oxygen are C0
and O0, respectively. The atom type symbol 00 (two zeroes), which matches any atom type of
any element. You can use 00 in mmsubs patterns where an atom specification is needed to
define connectivity, but the specific type or element is irrelevant. 

The bond order symbols recognized in mmsubs patterns are given in Table C.1.

Zero-order bonds are used in patterns when a bond needs to be expressed, but it is not possible
to define its precise nature. Some uses of zero-order bonds are:

• When the bond is in the process of being formed or broken. One example would be in the
(physically non-realistic) situation of a FEP simulation. Another, more physically realis-
tic, example is a transition state, where the bond is actually forming or breaking.

• Representation of certain metal-ligand interactions. Bonds that are significantly ionic in
nature can’t really be considered to have a bond order in the conventional sense.

As an example, the following mmsubs pattern specifies the essential atoms of ethyl vinyl ether:

C2=C2-O3-C3-C3

C2, O3, and C3 are the MacroModel atom type symbols for sp2 carbon, non-carbonyl oxygen,
and sp3 carbon, respectively. 

Observe the use of the bond symbol = to represent a double bond, and - for single bonds. 

Thus, ethyl vinyl ether can also be specified using wildcard atom types, like this:

C0=C0-O0-C0-C0

Table C.1. Bond order symbols in mmsubs notation

Symbol Description

.   Zero-order bond (see Comment below)

-   Single bond

=   Double bond

%   Triple bond

*   Any bond order (wildcard)
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In this pattern spec, the bond orders remain explicit. If the first bond is generalized, using a
wildcard symbol,

C0*C0-O0-C0-C0

since * can match a single, double, or triple bond, this more generalized pattern can match
diethyl ether, ethyl vinyl ether, or ethoxy acetylene.

C.2 Ring closure

Ring-forming bonds are expressed as a bond symbol followed by a number, where the number
is the pattern position of the symbol for the other atom in the ring bond. For example, cyclo-
pentane can be expressed as

C0-C0-C0-C0-C0-1

The final -1 indicates that the fifth carbon has a single bond to the atom specified at position 1
in the pattern. 

Pattern positions are numbered from 1 at the leftmost atom type symbol, and increment to the
right. Bond symbols (and any other punctuation) do not affect the numbering. A ring closure
must be referred from right to left, that is, from an atom specified later in the pattern to an atom
specified earlier. The ring-closure indications themselves are not counted as positions. This
makes sense since a closure introduces no additional atom.

C.3 Chain branching

To allow specification of branched structures, mmsubs accepts parenthesized pattern sections.
An opening parenthesis initiates a branch, and the corresponding closing parenthesis ends the
branch. A bond symbol after the closing parenthesis is tied to the atom symbol just before the
opening parenthesis.

For example, methylcyclobutane could be expressed like this:

C0(-C0)-C0-C0-C0-1

The parentheses indicate that the 2nd carbon is bonded to the 1st carbon, and that the 3rd
carbon is also bonded to the 1st carbon. The 5th carbon is bonded to the 1st carbon, forming a
ring of 4 (not 5) carbons.

Branches off branches can be specified by nesting parenthesized sections. For example, isopro-
pylbenzene can be expressed as

C0=C0(-C0(-C0)-C0)-C0=C0-C0=C0-1 
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and threonine can be expressed as

N0-C0(-C0(-C0)-O0-H0)-C0=O0

Arbitrarily deep nesting of branches is allowed. 

In patterns with more complex branching, the chance of error due to unbalanced parentheses is
greater. The mmsubs software treats excess closing parentheses as erroneous, but quietly
accepts patterns with excess opening parentheses, and implicitly inserts the matching closing
parentheses at the end of the pattern. This may not be what you intended, so you should check
carefully that the parentheses match. 

C.4 Optional atoms

Optional atoms can be specified in mmsubs notation so that the substructure will match
whether or not the optional atom is found. The syntax is to put the optional atom and its
preceding bond symbol in square brackets. With this pattern

N0([-H0])-C0(-C0-O0[-H0])-C0=O0

serine would be identified whether or not the optional hydrogens were present in the structure
searched. Note that the first optional hydrogen in that pattern is also in a chain branch, but
alone. In cases like this, the parentheses should go on the outside, as above.

The square bracket syntax can only be applied to individual atoms. It cannot be applied to
chains, and the usage cannot be nested. It is not permitted to specify the first atom in a pattern
as optional.

C.5 Special Cases

The MacroModel atom type C2 needs special attention. This type covers sp2 carbon as it occurs
both in aromatic rings and in carbonyl groups. In cases where you want to match only one C2
subtype, you need to specify an atom attached to the C2, to exclude matches on the other
subtype. 

For example, if an aromatic ring pattern contains C2*C2*C2 and it is undesirable for it to
match a structure containing C2-C2(=O2)-C2 then specifying an attached atom that is not O2
will exclude the undesirable matches: for example, C2*C2(-H0)*C2 might suffice.

The most general way to exclude unwanted carbonyl matches on a C2 in an aromatic ring
pattern is to require that the C2 have a single bond to an atom of any type. In this example, the
pattern to use is C2*C2(-00)*C2.
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C.6 Examples 

In this section, some more complex examples are presented. The first is norbornane, which is a
bicyclic compound, and can be represented as follows:

C0-C0-C0-C0(-C0-1)-C0-C0-1

Two ring closures are indicated, as the compound is bicyclic. In this pattern, both closures, of
the bridge and of the main ring, refer to the same position. This is not required. For example,
these patterns are valid and equivalent to the above:

C0-C0-C0-C0-C0(-C0-2)-C0-1
C0-C0-C0-C0-C0-C0(-C0-3)-1

Now note something about branches, which is actually independent of the ring closures: If you
swap a parenthesized branch with the part after it, and then parenthesize the new front part, the
connectivity expressed is exactly the same. For example, these two forms are equivalent:

C0-C0-C0-C0-C0(-C0-2)-C0-1
C0-C0-C0-C0-C0(-C0-1)-C0-2

Norbornane also provides an opportunity to emphasize one fundamental point about linear
substructure representations. The appearance of some patterns may seem to imply geometric
properties. The norbornane patterns above, for example, imply a 6-membered ring bridged by
one atom with two bonds on either side of the ring. It is important to keep in mind that the
pattern specifies connectivity only, and not geometry.

Though it would be somewhat unconventional, it is in fact possible to specify norbornane as a
5-membered ring bridged by a chain of 2 atoms, which is topologically equivalent:

C0-C0-C0(-C0-C0-1)-C0-C0-1 
C0-C0-C0-C0(-C0-C0-1)-C0-1 
C0-C0-C0-C0(-C0-C0-2)-C0-1 
C0-C0-C0-C0-C0(-C0-C0-2)-1 
C0-C0-C0-C0-C0(-C0-C0-3)-1 

Any of these patterns will give exactly the same matching as one of the more conventional
representations. The point is that these patterns specify topology, not geometry. 

It should be clear that there can be many valid mmsubs expressions to match a single, non-
trivial substructure. The mmsubs notation does not have a canonical representation, that is,
mmsubs has no counterpart to Unique SMILES (USMILES).

The next example is of a compound containing fused heterocyclic aromatic rings. One way to
express quinoline is the following:
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N0=C0-C0=C0-C0=C0(-1)-C0=C0-C0=C0-5

In this pattern, the atom types are general and the bond orders are exact. Thus, this pattern
specifies an exact resonance form, and that is the only form it will match. 

As an alternative, atom types are often specified more exactly, to designate the atomic hybrid-
izations, and wildcard bonds are used for the connectivity. For quinoline, this kind of specifica-
tion could look like the following:

N2*C2*C2*C2*C2*C2(*1)*C2*C2*C2*C2*5

This pattern matches any resonance form of quinoline.

Each pattern indicates a simple ring closure in branch parentheses, in the middle of the pattern.
Strictly speaking, the parentheses are not needed, since the ring closure is a branch by defini-
tion. Also, since the ring closure introduces no new atom, it doesn’t really need to be shielded
from bonding association with the symbol after it. However, we recommend use of parentheses
in such cases, to keep it clear that the atoms on either side of the ring closure indication are
bonded to each other.

C.7 Formal Charge Extensions

The mmsubs notation has syntax to explicitly specify formal charge on an atom, separately
from what the atom type itself implies. This is an extension over the MacroModel notation.

Formal charges can be specified for any MacroModel atom type, but the usage makes the most
sense when applied to a wildcard atom type. The syntax is as follows:

i. Formal charges are specified using the {} braces after an atom type symbol. The symbols
“+”, “-”, and “0” are used to represent positive, negative, and no charge. Examples:

C0{+}  —  any carbon with a +1 charge
N0{-}  —  any nitrogen with a -1 charge
O0{0}  —  any neutral oxygen

ii. An integer in the range 1-9 can be used to specify the number of formal charges:

N0{1+}  —  any nitrogen with a +1 charge
S0{2+}  —  any sulfur with a +2 charge

iii. A question mark ? can be used to indicate any number (1 or more) of a particular charge
type:

N0{?+}  —  any nitrogen with any positive charge
C0{?-}  —  any carbon with any negative charge
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It is possible to create paradoxical specifications:

CP{-}  —  negatively charged CP (atom type for carbocation)
OM{+}  —  positively charged OM (type for oxygen with -1 charge)

These would not be rejected as erroneous, but it is impossible for them to ever match anything.
Formal charge syntax is especially useful in atom-typing rules.

C.8 Atom Type Equivalence Labels

The mmsubs software supports the use of atom type equivalence labels in substructure patterns.
Such labels are defined in a data file with a simple text format, for example:

# Comments begin with a "#"
CS  CA CB CC
CT  CA CB CC C3
CU  C2 CD CE
CH  CA CB CC C3 H1

The equivalence label comes first, followed by the atom types to be made equivalent, separated
by commas or spaces. Wildcard atom types are permitted, but formal charge specifiers are not.
Equivalence labels take precedence over standard atom type symbols. Equivalence labels
cannot be defined recursively.

With the assignments shown above, if an mmsubs pattern contains the equivalence label CT, it
will match an atom of type CA, CB, CC, or C3.

Some of the labels in this example collect united atom types with non-united types, for equiva-
lent treatment in mmsubs patterns. This is clearly useful in contexts where molecule connec-
tion tables might have either form. 

Any number of equivalence labels can be defined. As with standard atom type symbols, char-
acter case matters in the equivalence labels, and every label must have 2 characters. The first
character is conventionally a letter; a number may be used but is not encouraged.

The default equivalence labels are defined in a data file installed with the Schrödinger software
in 

$SCHRODINGER/mmshare-vversion/data/mmsubs.ini 

If you want to augment or override the default equivalence labels, you can copy the installed
mmsubs.ini file and edit it. To define equivalence labels for all applications, save the copy in
$HOME/.schrodinger/mmshare. To define equivalence labels for a particular application,
save the copy in the directory from which you run the application. 
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C.9 Differences between mmsubs and bmin notations

For the record, here are the known technical differences between the mmsubs and bmin nota-
tions --

• In MacroModel notation, a pattern is limited to at most 50 atoms, and a maximum of 130
characters. In mmsubs notation, there is no explicit limit on the number of atoms in a pat-
tern, though there is a limit on the pattern specification itself of about 10,000 characters. 

• In MacroModel notation, the wildcard bond order symbol * does not cover zero-order
bonds. In mmsubs notation, it does.

• The MacroModel notation has no syntax for explicitly specifying formal charges. 

• In MacroModel notation, equivalence labels are defined in force field data files. In
mmsubs notation, equivalence labels are defined in a distinct data file.

• In MacroModel, wildcard atom type symbols are not permitted on the right-hand side of
equivalence label definitions. 

C.10 Related Files

The data file that formally specifies MacroModel atom type symbols is installed in the
Schrödinger software installation at the following location:

$SCHRODINGER/mmshare-vversion/data/atom.typ

Details of the atom types are given in this file. Further information on the atom types can be
found in the atom-typing rules file, which is installed at the following location:

$SCHRODINGER/mmshare-vversion/data/mmatype.ini 

This file uses the mmsubs notation to define the rules. 

Another related file is the file that defines the default equivalence labels that can be used in
mmsubs patterns,

$SCHRODINGER/mmshare-vversion/data/mmsubs.ini

You may on occasion need to override this installed file with your own customized version.
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Schrödinger software is distributed with a number of utility programs and scripts that can be
used in conjunction with any of the computational programs. These UNIX utility programs are
installed in $SCHRODINGER/utilities (with one exception). A complete list of utilities is
given in the Schrödinger Utilities quick reference. The general-purpose utilities are described
in the General Utilities reference. This appendix lists utilities for Maestro project management.

UNIX conventions are used for the command syntax—see page xix for more information. 

D.1 project_convert 

This utility converts a project to the current version. This utility is run automatically from
Maestro, under Job Control, when you open a project from a previous release. The syntax is: 

project_convert [options] input_project output_project 

If the input and output project names are the same, the input project is overwritten. For a
description of the options, run the command with the -h option.

D.2 project_create

This utility creates a project using specified structure files. The syntax is:

$SCHRODINGER/run project_create structure-file [-t type] project.prj 
$SCHRODINGER/run project_create -f file-list [-t type] project.prj
$SCHRODINGER/run project_create -d dir [-l type] project.prj

The project name must include the .prj extension. For a description of the options, run the
command with the -h option.

D.3 project_append

This utility appends the structures in the specified structure files to a project. The syntax is:

$SCHRODINGER/run project_append structure-file [-t type] project.prj 
$SCHRODINGER/run project_append -f file-list [-t type] project.prj
$SCHRODINGER/run project_append -d dir [-l type] project.prj
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The project name must include the .prj extension. For a description of the options, run the
command with the -h option.

D.4 project_extract

This utility extracts usable data from a corrupted Maestro project. The syntax is:

project_extract -i corrupted-project.prj  -o new-project.prj 
[-e data-types]

where -i and -o specify the path to the corrupted project and the path to the new project. If -e
is not used, the utility only attempts to extract the entry data (including properties). If -e is
used, it must be followed by a quoted, comma-separated string listing the data types to attempt
to extract, from the following types:

D.5 project_version

This utility lists the Maestro version and release that could have produced a project. The syntax
is:

project_version project1 [project2 ...]

Each project is listed with the Maestro version and the release name in parentheses. If the
project has ben converted from one format to another, the version for the latest format is
reported. 

all Attempt to extract all data types

auxiliarydata Auxiliary data for entries. Includes things like trajectories, vibrations,
surfaces, Phase hypotheses, etc.

jobsdata Job-related information for applications you have run

plotxy XY plots of Project Table entry properties

primex PrimeX data

psp Prime data

phase Phase data

strike Strike data

userdata User data

vcs CombiGlide data
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Properties of entries have two names: an internal name and a display name, or visible name.
The display name is the name that is shown in the headings of the Project Table columns. Prop-
erties also belong to a “family”, and the family name is shown in menus used for property
selection.

The internal name is the name used by Maestro to identify the property, and is the name that is
written to and read from Maestro files. The internal name has the format type_author_label.
The type is a single character, which identifies the variable as an integer (i), a real number (r),
a string (s), or a Boolean (b). The author identifies the program that generated the property, or
more generally the source of the property. Finally, the label gives information about the prop-
erty itself. For example, s_m_title is the internal name of a string property generated by the
author m, which stands for Maestro, that is the title of the entry. 

When the internal name is parsed by Maestro, it is split into the three pieces. The type is used
to assign a variable internally to store the property value. The author is mapped to the “family”
name, and the label is mapped to the display name. Maestro has a table of mappings of the
author to the family names and of the label to the display names. If there is no entry for label
in the map, then the display name is constructed by replacing any underscores in label with
spaces: thus, if the label is My_property, the display name is My property. Likewise, author is
displayed as is for the family name if it has no entry in the map. A list of authors and their
mappings is given in Table E.1. The list of property names is much larger, and is not given
here. The display names are stored as part of the project. 

The display name and the internal name can both be changed within a Maestro session—see
Section 9.11.9 on page 237. The display name is used only in the project. It is the internal
name that is exported when you export structures. If you want to export a property with a new
name (for example to an SD file), you can create a new property, and copy the desired property
to the new property for export. The author for the new property in this case is user, by default.
You can change the author, but since the author and type are stripped out when exporting to an
SD file, the author is not relevant in this case.

For SD properties, you can protect the underscore characters so that they are displayed in the
Project Table by preceding them with backslash characters. 

Atom properties also have an internal name and a display name. The internal name has the
same format as the entry properties, and the display name is derived in the same way as for
entry properties that do not have a mapping, i.e. the type and the author are stripped off, and
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any remaining underscores are replaced by spaces. The display name for atom properties is
shown in option menus for selection of an atom property, for example.

Table E.1. Mappings for the author field in the internal name.

Author Family Name Author Family Name

canvas Canvas mopac MOPAC

combgen CombiGlide pdb PDB

des Desmond phase Phase

epik Epik ppw Protein Preparation Wizard

glide Glide psp Prime

glideres Glide Residue Interactions pspIFD Induced Fit

i Impact px PrimeX

ionizer Ionizer qp QikProp

j Jaguar qpld QPLD

lp LigPrep qs QSite

lsbd LSBD sd SD

m Maestro sitemap SiteMap

mcp MCPRO+ strike Strike

mmod MacroModel user Added by user
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ASD—Atom Selection dialog box.

ASL—Atom Specification Language.

button menu—The menu available from a toolbar menu button, which you open by holding
down the left mouse button. 

clipping planes—The planes that define the displayed depth of the structure. Atoms are
clipped (not displayed) if they are in front of the front clipping plane or behind the back clip-
ping plane. The position of these planes is displayed in the clipping planes window.

current working directory—the directory that is used to write job files (the job launch direc-
tory) and the directory that is used by default in file selectors for reading and writing files. Also
called the working directory.

entry—A structure or set of structures and associated properties. Entries are represented as a
row in the Project Table, and can be used as input for jobs.

ESL—Entry Specification Language.

exporting—Writing structures and their associated data from a Maestro project to a structure
file, or writing data from a Maestro project to a spreadsheet file.

filter—An ESL expression that is used to select, or filter, entries in the Project Table.

grow bond—The bond that is replaced when you add a fragment to a structure in Grow mode.
The grow bond is displayed as a green arrow in the Workspace.

importing—Reading structures and their associated data from a structure file into a Maestro
project, or reading data from a spreadsheet file into a Maestro project.

inclusion—Display of entries in the Workspace. Multiple entries can be included in the Work-
space. The inclusion state (included, excluded, or fixed) is indicated in the In column of the
Project Table.

isovalue—the value of a property that defines a surface. The property is a function of the three
spatial coordinates, and is represented as a set of points on a three-dimensional grid. 

job directory—The directory that is used to write temporary files for a job. Also known as the
temporary directory or the scratch directory for a job. This directory is created for the job and
removed at the end of the job, unless options are set to preserve it.
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launch directory—The directory that is used to write input files for a job, and to which the
output files from a job are copied when the job finishes.

ligand—(1) A small molecule that is considered capable of binding to a protein. The definition
of a ligand is determined by the ligand detection settings (see Section 7.6.3 on page 159),
which are encoded in the ‘ligand’ ASL expression. (2) A molecule that binds to a metal.
Ligands in this sense are not necessarily covered by the biochemical definition: for example,
CO is considered a metal ligand but does not match the usual ligand detection settings. 

Maestro resources directory—The directory (folder) that contains the default resource files
used by Maestro. This directory is the maestro-vversion/data/res directory of your
Schrödinger software installation.

Maestro user resources directory—the directory (folder) in which resource files for Maestro
are kept that are specific to a user, rather than for general use. This directory is defined as
follows

where vv is the two-digit Maestro version number (92 for this release). $HOME is usually set to
/home/username on Linux and /Users/username on Mac OS X. %APPDATA% is the location
of shared data on Windows, C:\Users\username\AppData\Roaming.

menu button—A toolbar button that has a menu, which you open by holding down the left
mouse button. The button has a black triangle in the lower right corner. 

option menu—A drop-down menu from which you can select an option. Clicking the button
on the menu displays the menu without having to hold down the left mouse button. 

picking—Selecting atoms in the Workspace.

profile—(1) a named set of customizations of Maestro; (2) the directory (folder) in which
resource files for Maestro are kept that are specific to a Maestro profile, for example, menu and
toolbar customization files. This directory is the profile/profile-name subdirectory of your
Maestro user resources directory.

project—A collection of related data, such as structures with their associated properties. The
project may include data that does not appear in the Project Table.

Project Table—The table that displays the contents of a project, with rows of entries and
columns of properties. The table is located in the Project Table panel. 

Linux, Mac:  $HOME/.schrodinger/maestrovv

Windows:  %APPDATA%\Schrodinger\maestrovv 

Linux, Mac:  $HOME/.schrodinger/maestrovv/profiles/profile-name 

Windows:  %APPDATA%\Schrodinger\maestrovv\profiles\profile-name 
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selection—(1) A group of atoms in the Workspace that has been picked or otherwise chosen.
The selection is highlighted by markers when the appropriate option is selected. (2) A group of
entries in the Project Table. The entries are highlighted in the table. 

shortcut menu—The menu that is displayed when you right-click and hold on a component of
a panel, such as the sequence viewer in the main window. 

startup directory—The directory from which Maestro was started, on Linux (or from the
command line on Mac). On Windows and Mac, there isn’t a concept of a startup directory for
an application, so it is set to the Schrodinger folder in your Documents folder. 

synchronization—updating the project with changes made in the Workspace. The default is to
perform synchronizations automatically. 

user profiles directory—the directory (folder) in which Maestro profiles are kept for a
specific user.

user resources directory—the directory (folder) in which resource files are kept for a specific
user.

volume—a set of data points on a three-dimensional grid for a property that is a function of the
three spatial coordinates.

working directory—see current working directory.

Workspace—The open area in the center of the Maestro main window in which structures are
displayed.

Linux, Mac:  $HOME/.schrodinger/maestrovv/profiles 

Windows:  %APPDATA%\Schrodinger\maestrovv\profiles 

Linux, Mac:  $HOME/.schrodinger 

Windows:  %APPDATA%\Schrodinger 
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Binding Site Surface Settings dialog box ....... 160
bond labels
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Bond Labels panel .......................................... 166
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bonds
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changing order of........................................ 96
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clipboard, copying to ...................................... 405
clipping planes .......................................... 72, 443
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color schemes
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surfaces..................................................... 312
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displaying ................................................. 252
displaying for adjustments........................ 100
displaying for local transformation .......... 106
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crystal mates ................................................... 152
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customization

perspective .................................................. 76
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Customize Profiles panel ................................ 324
Customize Toolbars panel................................. 18
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Delete Properties panel ................................... 238
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fog............................................................... 77
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dihedrals
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Maestro resources..................................... 324
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startup ....................................................... 445
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distances, measuring ....................................... 250
double bonds, 
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MacroModel atom type .................... 426, 428
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E
E notation........................................................ 236
Edit Color Scheme dialog box........................ 139
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surface color scheme ................................ 312

Electrostatic Potential Surface panel .............. 301
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adding properties to .................................. 228
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copying and pasting properties ................. 206
copying properties .................................... 233
creating ............................................... 29, 179
deleting ..................................................... 209
displaying in Workspace........................... 203
duplicating ................................................ 205
excluding .................................................. 203
excluding, using plots ............................... 292
filtering ............................................. 197–200
fixing and unfixing ................................... 203
groups ....................... 179, 189, 191, 194, 208
importing .................................................. 179
including................................................... 203
including, using plots ............................... 292
incorporating from job output .................. 180
marking..................................................... 220
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merging on connection or fusion................ 98
moving...................................................... 210
properties .......................................... 226–248
renaming................................................... 204
selecting............................................ 197–202
selecting from plots .................................. 291
selecting randomly ................................... 201
sorting ............................................... 185, 211
splitting by molecule ................................ 207
stepping through in Workspace ................ 203
superimposing .......................................... 254
target ................................................. 184, 358
tiling............................................................ 70
See also properties
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entry ID ........................................................... 179
Entry List panel............................................... 225
Entry Selection dialog box.............................. 198
Entry Selection Language (ESL) .................... 198
environment variables
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LOCALAPPDATA (Windows) ..................... 337
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SCHRODINGER_TEMP_PROJECT .............  337

ePlayer .................................................... 216–219
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toolbar controls......................................... 217

ePlayer Options panel ..................................... 218
error reporting, in PDB conversion................... 51
ESL—see Entry Selection Language (ESL)
excluded entries .............................................. 184
exponential notation........................................ 236
Export dialog box ............................................. 52
Export to Canvas dialog box............................. 61
Extended Radius Surface panel ...................... 300
extended radius surfaces—see surfaces
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family—see property family
feedback

atom properties ................................... 24, 358
entry properties................................. 171, 358
from picking ............................................. 348
Workspace contents .................................... 23

Feedback button.............................................. 171
file extensions, preferences for ....................... 337
file format

export, selecting.......................................... 53
import, selecting ......................................... 43
Maestro, description ................................. 417
Maestro, example ..................................... 419
recognized .................................................. 45

files
exporting data to......................................... 57
importing data from.................................... 58
importing structures from......................... 179
overwriting ................................................. 54
selecting for import .................................... 43
writing structures to.................................... 52

filters, entry..................................................... 198
Find toolbar

main window .............................................. 36
Project Table panel ................................... 196

finding atoms .................................................... 36
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Flexible Ligand Alignment panel ................... 258
fog ..................................................................... 77
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measurement labels .................................. 361
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Fragment mode, building structures in ............. 82
fragments
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specifying growth settings for .................... 86
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Function Key Macros panel ............................ 397
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displaying in sequence viewer.................... 30
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groups, entry ................................................... 179
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creating ............................................. 194, 208
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navigating ................................................. 196
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tiling Workspace by.................................... 70
title............................................................ 208
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criteria for displaying ............................... 363
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Highlights button ............................................ 168
hydrogen bonds
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displaying for adjustments ....................... 100
displaying for local transformation .......... 106
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hydrogens
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displaying .................................................... 303

Hydrophobic/philic map panel ....................... 303
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JPEG files ................................................. 401
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images
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Ligand Interaction Diagram ..................... 275
of coordinate scan plots............................ 294
of scatter plots .......................................... 292
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Import panel...................................................... 42
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pausing and resuming................................. 48
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J
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Jaguar plot files, importing ............................. 306
job directory.................................................... 443
jobs

file deletion............................................... 377
from renamed projects.............................. 175
monitoring ................................................ 375
output incorporation ......................... 180, 374
status feedback in Workspace................... 359

joining geometry, specifying............................. 86

K
KNIME

running workflows from Maestro............. 389
sending and receiving structures .............. 403
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Label All button .............................................. 165
labels

adding user text to .................................... 165
appearance ................................................ 360
applying ............................................ 164, 166
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displaying for hidden atoms ..................... 360
field descriptions in .................................. 360
moving...................................... 165, 167, 254
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updating ............................................ 164, 166

launch directory ........................................ 11, 444
ligand .............................................................. 444
ligand detection settings.................................. 370
Ligand Filtering panel..................................... 279
Ligand Interaction Diagram panel .................. 274
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local transformations............................... 104–106

exiting mode temporarily ......................... 106
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log file, Maestro .............................................. 340
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macros
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installing ................................................... 386

Macros panel................................................... 396
Maestro
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Maestro resources directory............................ 444
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Manage Highlights panel ................................ 168
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Manage Surfaces panel ................................... 308
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Mark property ................................................. 220
markers

displaying ................................................. 249
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measurement, geometric........................... 250

marking entries ............................................... 220
measurements
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creating properties for .............................. 253
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dihedrals ................................................... 250
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writing to a file ......................................... 253
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molecules
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drawing ................................................. 87–88
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See also structures
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mouse functions
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mutating residues .............................................. 85

N
navigation
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New Property dialog box .................................. 60
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displaying for adjustments........................ 100
displaying for local transformation .......... 106
displaying when viewing poses ................ 220

marker color, width .................................. 365
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finding atoms by......................................... 37
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perspective, enabling................................. 76, 394
pi interactions
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displaying ................................................. 252

Pick option menu ............................................ 123
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picking ............................................................ 444
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Plot of One-Coordinate Scan panel ................ 295
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Plot Settings - One-Coordinate Scan panel .... 295
plots
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deleting ..................................................... 285
deselecting entries from............................ 291
displaying ................................................. 285
excluding entries from.............................. 292
hiding........................................................ 285
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labeling axes ............................................. 288
labeling points .......................................... 290
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preferences
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ligand detection ........................................ 370
quitting Maestro ....................................... 339
rotations .................................................... 350
storage location........................................... 11
surfaces ..................................................... 368
synchronization ................................ 219, 340
working directory ..................................... 336

Preferences panel ............................................ 335
presentation, creating from project ................. 182
probe radius for surfaces................................. 299
profile.............................................................. 444
project entries—see entries
project selectors .............................................. 177
Project Table ................................................... 444

alignment of numbers and text ................. 346
row colors ................................................. 347

Project Table Calculator panel ........................ 232

Project Table panel...................................... 6, 183
scroll bar ................................................... 347
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project_append utility................................ 439
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projects........................................................ 6, 444

annotation ................................................. 178
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backing up ................................................ 176
Canvas ........................................................ 60
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reverting to saved state ............................. 177
saving scenes as........................................ 183
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scenes ....................................................... 181
scratch................................................... 6, 173
zipped ................................................. 12, 175

properties ................................................ 226–248
adding ....................................................... 228
coloring cells by ....................................... 195
combining mathematically ....................... 231
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creating from measurements .................... 253
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decimal places .................................. 236, 346
displaying a subset of ....................... 194, 239
displaying in Workspace .................. 171, 358
edit warning message ............................... 345
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exporting to a Canvas project ..................... 60
filtering structures by................................ 279
hiding................................................ 240, 248
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property family
creating ............................................. 241, 248
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proteins
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displaying as ribbons ................................ 143
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interaction diagram with ligand................ 274
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Python commands
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pythonimport ..................................... 388
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reading and writing................................... 261
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shortcut keys
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